Welcome

[This is preliminary documentation and subject to change.]

The Constable Authorization Engine (CAZE) is a .NET Framework class library that allows you to easily and efficiently implement complex authorization logic required for your business application.

In This Section

What's New
Describes the features that are new and/or changed in CAZE version 2.0.

Getting Started
Describes basic information to help get you started using CAZE in your projects.

Design Environment
Describes basic features of the CAZE Design Environment that allows you design, test and manage authorization policies easily and efficiently.

Licensing and Support
Information about licensing options, technical support and CAZE redistribution.

Glossary
Glossary of commonly used terms and phrases.

Send comments on this topic.

©2002-2006 LaMarvin. All Rights Reserved.


What's New

This section summarizes features that have been added or modified in the latest version 2.0 of the Constable Authorization Engine.

Design Environment

The CAZE Policy Designer is a Windows Forms application (caze.exe) that allows you to design, test and manage authorization policies in a rich, graphical environment. The Policy Designer leverages the CAZE Design Environment that can easily be embedded and customized for use in your own applications. For more information see the LaMarvin.Constable.Design namespace.

Core API Enhancements

The core AuthorizationPolicy class exposes several new events allowing you to more easily customize authorization logic without the need of subclassing. For more information see ResolveRoleMembership event, AuthorizationContextChanged event, ActionExecuting and ActionExecuted events.

The AuthorizationPolicy class now supports pre- and post-change notifications allowing you to easily detect and react to policy changes. For more information see the InstanceChanging, InstanceChanged events and the IChangeEventSource interface.

The AuthorizationPolicyLoader class now supports flexible type resolution mechanism for loading authorization policies with custom (subclassed) policy object types. The loader now supports saving and loading custom properties of the following types:
  • Strings and primitive .NET types (Boolean, Byte, SByte, Int16, UInt16, Int32, UInt32, Int64, UInt64, Char, Double, and Single - supported also in version 1.1).
  • DateTime, Guid, Decimal and custom Enum property types (new in 2.0).
For more information see the TypeResolver property and the IPolicyLoaderTypeResolver interface.

Visual Studio 2005 and .NET Framework 2.0 Support

CAZE 2.0 now supports Visual Studio .NET 2005 and .NET Framework 2.0. Sample applications are provided for both Visual Studio .NET 2003 and Visual Studio .NET 2005. For more information please see the CAZE website page.

More Licensing Options

CAZE 2.0 introduces a new site license option that allows you to install CAZE 2.0 on one hundred CPUs for the price of a few single user licensees. For more information please see the CAZE website page.


Getting Started

CAZE is a finite state machine (FSM)-based authorization engine that is driven by an application-defined authorization policy. The authorization policy is represented as a set of authorization rules associated with an application-defined business object. The authorization policy consists of Roles, States, Actions, Properties and Authorization rules. Roles are named sets of users sharing the same set of permissions with respect to the application and / or the business object. For example, "Document Authors" can create new documents (application-level permission) and they can edit their own documents (object-level permission).

States represent the different "constitutions" defined for the type of the business object, for example "waiting for approval". The usage of states in the CAZE authorization policy is optional, but at least one state has to be defined.

Actions represent the set of operations defined for the business object; typically, the set of public methods defined for the business object's class.

Properties are attributes of the business object, for example a document's title. The use of properties in the authorization policy is optional; you'll use them only if you want to control access to the business object's individual properties.

Authorization rules associate actions and properties with roles, states and a boolean "enabled" flag. For example, an authorization rule might say: "Authors can send existing documents to approval." The rule means that users in the "Author" role are allowed to execute the "Send" action on an "existing" (state) document.

The authorization policy is brought to life by means of an authorization context, which is represented by an IPrincipal object associated with the policy and used to resolve role membership and the current state of the policy.

The functionality of the CAZE authorization policy is encapsulated in the core AuthorizationPolicy class, which is the primary API you'll use in your application.

You design the authorization policy by using the Policy Designer application. The Policy Designer stores the policy in an authorization policy file (a XML file with a .caze extension). You can also populate an authorization policy in code by using the CAZE API. Nevertheless, in most cases you'll want to use the Policy Designer, because it's more comfortable and allows you to also test the policy before deployment.

After designing and testing an authorization policy you'll need to integrate it with your application's logic. First you'll need to populate an instance of the AuthorizationPolicy class by using the AuthorizationPolicyLoader class to load the previously designed authorization policy from disk, application resource or a database.

Next you'll initialize the authorization context by setting the CurrentPrincipal and the CurrentState properties.

Finally, you'll execute access checks, enumerate available actions and properties and execute actions by calling the various AuthorizationPolicy methods ( ExecuteAction, IsActionExecutable, IsPropertyChangeable ...etc).

Setting up a project for CAZE

Before using the CAZE API in your project, you'll have to add references to the following CAZE assemblies:

LaMarvin.Common.dll exposes types supporting the implementation the LaMarvin.Constable.dll assembly.

LaMarvin.Constable.dll exposes the core AuthorizationPolicy class and supporting types.

The CAZE API contains three namespaces; we'd recommend to import them in your application's source files where you'll be using CAZE functionality:

[Visual Basic]
Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

[C#]
using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;


Design Environment

CAZE 2.0 comes with a full-featured policy design environment that allows you to visually design authorization policies, simulate authorization policy runtime execution and manage authorization policy files.

The Design Environment consits of set of assemblies and the Policy Designer (caze.exe) application, which is a standalone application that can be started by going to the Start Menu -> Programs -> Constable Authorization Engine 2.0 -> Policy Designer menu item or by double-clicking a file with a .caze extension:

The following screenshot shows the main window of the Policy Designer:

Authorization Policy Designer
[Click the image for full-sized picture]

Here you can view a flash demonstration showing how is the Policy Designer used to create the document approval policy discussed in the CAZE tutorial on the web.

The Design Environment assemblies provide a rich infrastructure exposing a set of APIs and well-defined extensibility points that allow you to easily enhance the Policy Designer with custom policy object types, design and simulation views, clipboard handlers, undo engine extensions and persistence mechanisms.

You can also easily host and control the Policy Designer from within your own Windows Forms applications allowing you to expose the rich policy design experience to your application's end users.

The Samples\PolicyDesign subfolder of the CAZE installation folder contains several samples illustrating how to use and extend the Policy Designer. The Design Environment APIs are described in detail in the reference part of this documentation. All of the APIs reside in the LaMarvin.Design and LaMarvin.Constable.Design namespaces.


Sample Applications

PolicyInDatabase Sample

Please follow these steps to set up the sample:

1. Copy the PolicyDesign.zip file to the CAZE Samples directory (<CAZE Installation Directory>\Samples) and extract the files with folder names. This should create the following directory on your hard drive: <CAZE Installation Directory>\Samples\PolicyDesign\2005\PolicyInDatabase. For simplicity, I'll call this directory PolicyInDatabase directory from now on.

2. Use the SQL Server Query Analyzer tool (or the osql.exe command line tool) to execute the T-SQL script PolicyInDatabase\Scripts\PolicyDatabaseSetup.sql. The script creates a table and a couple of views and stored procedures for storing and loading authorization policies to / from the database (all the created database objects have names with the lamarvin_pdb_ prefix - see the T-SQL script for more information).

3. Open the PolicyInDatabase\VB\PolicyInDatabaseVB\PolicyInDatabaseVB.sln solution in Visual Studio 2005 (please note that currently there is only Visual Studio 2005 version of the sample available). Open the PolicyInDatabaseVB project properties, select the Debug tab and specify a correct path to the caze.exe executable to be started as an external program when debugging. The caze.exe file is located in the <CAZE Installation Directory>\bin folder. The solution has post-build commands that will copy the PolicyInDatabaseVB sample outputs to the caze.exe directory so that it will load the sample Policy Design extension allowing you to debug it in the caze.exe process.

4. Create a new caze.exe.config file in the <CAZE Installation Directory>\bin and specify the required .NET Framework version to be 2.0 (otherwise caze.exe won't load your extension) and a connection string to the database you've setup in the second step above. The configuration file should look like this:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>

  <appSettings>
    <add key="CazePolicyDatabaseConnectionString" value="server=localhost;database=cazedb;trusted_connection=true;" />
  </appSettings>

  <startup>
    <supportedRuntime version="v2.0.50727" />
  </startup>

</configuration>
Now when you run the solution, the caze.exe process should be launched with the PolicyInDatabaseVB extension loaded. You can place a breakpoint in the SqlServerPersistencePolicyDesignExtension.Initialize method, which is called as first by the Policy Designer and see how the extension installs and handles the custom commands.

Please note this is a pre-release code, so there is very little documentation and it is not yet fully debugged and tested.


Licensing and Support

For the current licensing and support options, please visit the CAZE website.

Redistributing CAZE

You have to include the following CAZE assemblies for redistribution with your compiled applications:
  • LaMarvin.Common.dll - common types and services.
  • LaMarvin.Constable.dll - the core CAZE assembly.
If your application also uses the policy design environment types and controls, you have to redistribute also the following design assemblies:
  • LaMarvin.Design.dll - common designer types and services.
  • LaMarvin.Constable.Design.dll - the CAZE Design Environment.
Note: The CAZE setup procedure places these assemblies into the Global Assembly Cache, but they're also copied to the <CAZE Installation Directory>\bin directory for easy reference.


Glossary

Action authorization rule

See authorization rule.

Action rule

See authorization rule.

Authorization check

The act of calling specific methods of the AuthorizationPolicy class to determine availability of Properties and Actions in the current authorization context.

Authorization context

The current values of the AuthorizationPolicy.CurrentPrincipal and AuthorizationPolicy.CurrentState properties, that determine the outcome of authorization checks. Also referred to as context.

Authorization policy

A set of roles, states, actions, properties and their associated action and property authorization rules contained within an instance of the AuthorizationPolicy class or stored within a XML file. The term is also used to name a specific AuthorizationPolicy class instance.

Authorization reference data

The set of roles, states, actions and properties. See also the authorization policy.

Authorization rule

An association of a protected object (an action or a property) with a given state, role and a set of association's boolean flags - IsVisible for both actions and properties, IsEnabled for properties and IsEnabled for actions. An authorization rule for actions is also called action authorization rule or simply an action rule. Similarly, an authorization rule for properties is also called property authorization rule or simply a property rule.

Property authorization rule

See authorization rule.

Property rule

See authorization rule.

RBAC

See Role-based access control.

Reference data

See authorization reference data.

Role-based access control (RBAC)

An approach to controlling access to resources by grouping users and privileges into roles.


LaMarvin.ComponentModel

Constable Authorization Engine 2.0 BETA

LaMarvin.ComponentModel Namespace

[This is preliminary documentation and subject to change.]

The namespace defines types that fall broadly into two categories:
  • Change notifications and undo/redo support.
  • Dynamic collections and the collection updater design pattern.

Changes to objects are represented by two pairs of events: the InstanceChanging event is raised before the change actually takes place; the InstanceChanged event is raised after the change has been performed. This simple mechanism along with the ChangeUndoManager class hierarchy is used to implement a flexible, reusable framework supporting rich design-time experience, including undo/redo and the Model-View-Controller (MVC) design pattern.

The collection updater design patern allows for implementation of collections that can change their behavior dynamically at runtime. The design pattern is used internally by all LaMarvin-provided code libraries.

The collection updater pattern is designed to allow collections derived from the CollectionBase class to delegate implementation of their protected virtual (CanOverride in Visual Basic) methods to the corresponding methods implemented by the associated updater object. Becaue the updater object associated with a given collection can be changed at runtime, the collection appears to change its behavior.

The updater object is defined by the ICollectionUpdater interface. The CollectionUpdaterBase class is a base class for objects implementing the ICollectionUpdater interface.

Namespace hierarchy

Classes

Class | Description
CollectionChangeEventArgs | Represents a change to a collection instance.
CollectionChangeUndoManager | Manages undo operations for IList-based collections.
CollectionUpdaterBase | Provides an abstract (MustInherit in Visual Basic) base class for an extensible ICollectionUpdater implementation.
ExpandablePropertyAttribute | Signifies a property that can be expanded in a visual representation.
ChangeableCollectionBase | The abstract (MustInherit in Visual Basic) base class for all changeable collections that implement the collection updater design pattern.
ChangeEventArgs | The base class for all change notification events.
ChangeUndoManager | Defines a contract for types that listen to change notification for the purposes of performing corresponding undo and redo operations.
OrdinalAttribute | Decorates programming elements that can be sorted.
PropertyChangeEventArgs | Represents a change to a property of an object.
PropertyChangeUndoManager | Manages undo and redo operations for property updates.
TypeInfoAttribute | Associates a class with a descriptor containing metadata that describe several aspects of the decorated class understood and used by the design-time infrastructure.
UndoEngine | Implements undo/redo services for object graphs that generate change notification events by means of the IChangeEventSource interface contract.
UndoEngine.UndoGroup | Represents a group of changes that should be handled as a unit.
UndoException | Exception signifying failures in the designer undo feature.
UndoItemCollection | Represents a collection of IUndoItem-compatible objects.

Interfaces

Interface | Description
ICollectionUpdater | Represents an object to which a collection delegates its update methods.
IChangeableCollection | Represents a collection that can be updated. Typically used in conjunction with an ICollectionUpdater implementation to customize collection's runtime behavior dynamically.
IChangeEventObserver | Defines a contract for an adapter-like object that is interested in observing change events for possibly multiple event sources.
IChangeEventPropagator | Defines a contract that should be implemented by object graphs for propagating change notification events up the owner-like relationship chain of objects
IChangeEventSource | Defines a source of change event notifications.
IUndoItem | Defines a contract representing an undoable change item.

Delegates

Delegate | Description
ChangeEventHandler | Defines a signature for change notification event handlers.

Enumerations

Enumeration | Description
CollectionChangeType | Identifies the type of change to a collection.


CollectionChangeEventArgs Class

Represents a change to a collection instance.

For a list of all members of this type, see CollectionChangeEventArgs Members.

System.Object
System.EventArgs
LaMarvin.ComponentModel.ChangeEventArgs
LaMarvin.ComponentModel.CollectionChangeEventArgs

[Visual Basic]
<Serializable>
Public Class CollectionChangeEventArgs
Inherits ChangeEventArgs
[C#]
[Serializable]
public class CollectionChangeEventArgs : ChangeEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

CollectionChangeEventArgs Members | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs Members

CollectionChangeEventArgs overview

Public Instance Constructors

CollectionChangeEventArgs Overloaded. Initializes a new instance of the CollectionChangeEventArgs class.

Public Instance Properties

ChangeType | Gets the type of the collection change.
IgnoreNestedChanges (inherited from ChangeEventArgs) | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.
Item | Gets the item that has been added to, or removed from the collection.
ItemIndex | Gets the index of the item that has been added to, or removed from the collection.

Public Instance Methods

CreateChangeUndoManager | Creates an instance of the CollectionChangeUndoManager class for managing undo operations on the associated collection instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the type name of the instance and the associated ChangeType.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs Constructor

Initializes a new instance of the CollectionChangeEventArgs class with the given CollectionChangeType

Overload List

Initializes a new instance of the CollectionChangeEventArgs class with the given CollectionChangeType

public CollectionChangeEventArgs(CollectionChangeType);

Initializes a new instance of the CollectionChangeEventArgs class with the given CollectionChangeType, the changed item index and a reference to the changed item itself.

public CollectionChangeEventArgs(CollectionChangeType,int,object);

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs Constructor (CollectionChangeType)

Initializes a new instance of the CollectionChangeEventArgs class with the given CollectionChangeType

[Visual Basic]
Overloads Public Sub New( _
ByVal changeType As CollectionChangeType _
)
[C#]
public CollectionChangeEventArgs(
CollectionChangeType changeType
);

Parameters

changeType
Indicates the type of the change.

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace | CollectionChangeEventArgs Constructor Overload List


CollectionChangeEventArgs Constructor (CollectionChangeType, Int32, Object)

Initializes a new instance of the CollectionChangeEventArgs class with the given CollectionChangeType, the changed item index and a reference to the changed item itself.

[Visual Basic]
Overloads Public Sub New( _
ByVal changeType As CollectionChangeType, _
ByVal itemIndex As Integer, _
ByVal item As Object _
)
[C#]
public CollectionChangeEventArgs(
CollectionChangeType changeType,
int itemIndex,
object item
);

Parameters

changeType
The type of the change.
itemIndex
The index of the item that has been added to or removed from the collection.
item
The item that has been added to or removed from the collection.

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace | CollectionChangeEventArgs Constructor Overload List


CollectionChangeEventArgs Properties

The properties of the CollectionChangeEventArgs class are listed below. For a complete list of CollectionChangeEventArgs class members, see the CollectionChangeEventArgs Members topic.

Public Instance Properties

ChangeType | Gets the type of the collection change.
IgnoreNestedChanges (inherited from ChangeEventArgs) | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.
Item | Gets the item that has been added to, or removed from the collection.
ItemIndex | Gets the index of the item that has been added to, or removed from the collection.

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs.ChangeType Property

Gets the type of the collection change.

[Visual Basic]
Public ReadOnly Property ChangeType As CollectionChangeType
[C#]
public CollectionChangeType ChangeType {get;}

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs.Item Property

Gets the item that has been added to, or removed from the collection.

[Visual Basic]
Public ReadOnly Property Item As Object
[C#]
public object Item {get;}

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs.ItemIndex Property

Gets the index of the item that has been added to, or removed from the collection.

[Visual Basic]
Public ReadOnly Property ItemIndex As Integer
[C#]
public int ItemIndex {get;}

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs Methods

The methods of the CollectionChangeEventArgs class are listed below. For a complete list of CollectionChangeEventArgs class members, see the CollectionChangeEventArgs Members topic.

Public Instance Methods

CreateChangeUndoManager | Creates an instance of the CollectionChangeUndoManager class for managing undo operations on the associated collection instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the type name of the instance and the associated ChangeType.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs.CreateChangeUndoManager Method

Creates an instance of the CollectionChangeUndoManager class for managing undo operations on the associated collection instance.

[Visual Basic]
Overrides Public Function CreateChangeUndoManager() As ChangeUndoManager
[C#]
public override ChangeUndoManager CreateChangeUndoManager();

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeEventArgs.ToString Method

Returns the type name of the instance and the associated ChangeType.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

CollectionChangeEventArgs Class | LaMarvin.ComponentModel Namespace


CollectionChangeType Enumeration

Identifies the type of change to a collection.

[Visual Basic]
Public Enum CollectionChangeType
[C#]
public enum CollectionChangeType

Members

Member Name | Description
Add | An item has been added to the collection. The corresponding Item and ItemIndex properties should be set to valid values.
Remove | An item has been removed from the collection. The corresponding Item and ItemIndex properties should be set to valid values.
Clear | The collection has been cleared; the Item property should be set to a null reference (Nothing in Visual Basic) and the ItemIndex property should be set to -1.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager Class

Manages undo operations for IList-based collections.

For a list of all members of this type, see CollectionChangeUndoManager Members.

System.Object
LaMarvin.ComponentModel.ChangeUndoManager
LaMarvin.ComponentModel.CollectionChangeUndoManager

[Visual Basic]
Public Class CollectionChangeUndoManager
Inherits ChangeUndoManager
[C#]
public class CollectionChangeUndoManager : ChangeUndoManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

CollectionChangeUndoManager Members | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager Members

CollectionChangeUndoManager overview

Public Instance Constructors

CollectionChangeUndoManager Constructor Initializes a new instance of the CollectionChangeUndoManager class.

Public Instance Properties

EventArgs (inherited from ChangeUndoManager) | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been initialized.
Label (inherited from ChangeUndoManager) | Gets the label of the change recorded by this instance.
Sender (inherited from ChangeUndoManager) | Gets the sender of the event notification that was specified in the call to the Initialize method.

Public Instance Methods

Commit (inherited from ChangeUndoManager) | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes the instance for the specific change notification.
Initialize (inherited from ChangeUndoManager) | Overloaded. Initializes an instance for the specified change notification.
Match (inherited from ChangeUndoManager) | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Redoes (re-applies) the associated collection change.
ToString | Returns a string representation of the object.
Undo | Undoes the associated collection change.

Protected Instance Properties

CollectionChangeEventArgs | Gets the CollectionChangeEventArgs associated with this instance.
ChangeLabel (inherited from ChangeUndoManager) | The change label that has been passed to the Initialize method call.
IsCommitted (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been committed.

Protected Instance Methods

AssertIsCommitted (inherited from ChangeUndoManager) | Asserts the instance is committed.
AssertIsInitialized (inherited from ChangeUndoManager) | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager Constructor

Initializes a new instance of the CollectionChangeUndoManager class.

[Visual Basic]
Public Sub New()
[C#]
public CollectionChangeUndoManager();

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager Properties

The properties of the CollectionChangeUndoManager class are listed below. For a complete list of CollectionChangeUndoManager class members, see the CollectionChangeUndoManager Members topic.

Public Instance Properties

EventArgs (inherited from ChangeUndoManager) | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been initialized.
Label (inherited from ChangeUndoManager) | Gets the label of the change recorded by this instance.
Sender (inherited from ChangeUndoManager) | Gets the sender of the event notification that was specified in the call to the Initialize method.

Protected Instance Properties

CollectionChangeEventArgs | Gets the CollectionChangeEventArgs associated with this instance.
ChangeLabel (inherited from ChangeUndoManager) | The change label that has been passed to the Initialize method call.
IsCommitted (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been committed.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager.CollectionChangeEventArgs Property

Gets the CollectionChangeEventArgs associated with this instance.

[Visual Basic]
Protected ReadOnly Property CollectionChangeEventArgs As CollectionChangeEventArgs
[C#]
protected CollectionChangeEventArgs CollectionChangeEventArgs {get;}

Property Value

The collection change event args.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager Methods

The methods of the CollectionChangeUndoManager class are listed below. For a complete list of CollectionChangeUndoManager class members, see the CollectionChangeUndoManager Members topic.

Public Instance Methods

Commit (inherited from ChangeUndoManager) | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes the instance for the specific change notification.
Initialize (inherited from ChangeUndoManager) | Overloaded. Initializes an instance for the specified change notification.
Match (inherited from ChangeUndoManager) | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Redoes (re-applies) the associated collection change.
ToString | Returns a string representation of the object.
Undo | Undoes the associated collection change.

Protected Instance Methods

AssertIsCommitted (inherited from ChangeUndoManager) | Asserts the instance is committed.
AssertIsInitialized (inherited from ChangeUndoManager) | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


Initialize Method

Constable Authorization Engine 2.0 BETA

CollectionChangeUndoManager.Initialize Method

[This is preliminary documentation and subject to change.]

Initializes the instance for the specific change notification.

Overload List

Inherited from ChangeUndoManager.

public bool Initialize(object,ChangeEventArgs);

Initializes the instance for the specific change notification.

public override bool Initialize(object,ChangeEventArgs,string);

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager.Initialize Method (Object, ChangeEventArgs, String)

Initializes the instance for the specific change notification.

[Visual Basic]
Overrides Overloads Public Function Initialize( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs, _
ByVal changeLabel As String _
) As Boolean
[C#]
public override bool Initialize(
object sender,
ChangeEventArgs e,
string changeLabel
);

Parameters

sender
The sender of the change notification event.
e
The ChangeEventArgs-derived instance containing the event data.
changeLabel
The change label used to describe the change to the user.

Return Value

true is the initialization was successfull; false otherwise.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace | CollectionChangeUndoManager.Initialize Overload List


CollectionChangeUndoManager.Redo Method

Redoes (re-applies) the associated collection change.

[Visual Basic]
Overrides Public Sub Redo() _
Implements IUndoItem.Redo
[C#]
public override void Redo();

Implements

IUndoItem.Redo

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager.ToString Method

Returns a string representation of the object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that represents the current object.

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionChangeUndoManager.Undo Method

Undoes the associated collection change.

[Visual Basic]
Overrides Public Sub Undo() _
Implements IUndoItem.Undo
[C#]
public override void Undo();

Implements

IUndoItem.Undo

See Also

CollectionChangeUndoManager Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase Class

Provides an abstract (MustInherit in Visual Basic) base class for an extensible ICollectionUpdater implementation.

For a list of all members of this type, see CollectionUpdaterBase Members.

System.Object
LaMarvin.ComponentModel.CollectionUpdaterBase

[Visual Basic]
<Serializable>
MustInherit Public Class CollectionUpdaterBase
Implements ICollectionUpdater, IChangeableCollection
[C#]
[Serializable]
public abstract class CollectionUpdaterBase : ICollectionUpdater, IChangeableCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The class implements the ICollectionUpdater methods as virtual (CanOverride in Visual Basic) methods that can be overriden in derived classes on as-needed basis.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

CollectionUpdaterBase Members | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase Members

CollectionUpdaterBase overview

Public Instance Properties

IsClearAllowed | Implements the IChangeableCollection.IsClearAllowed member.
IsInsertAllowed | Implements the IChangeableCollection.IsInsertAllowed member.
IsRemoveAllowed | Implements the IChangeableCollection.IsRemoveAllowed member.
IsSetAllowed | Implements the IChangeableCollection.IsSetAllowed member.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnClear | Provides a placeholder for derived classes to implement validation logic when removing all items from the associated collection.
OnClearComplete | Provides a placeholder for derived classes to add custom logic after all items have been removed from the associated collection.
OnInsert | Provides a placeholder for derived classes to implement validation logic when inserting an item into the associated collection.
OnInsertComplete | Provides a placeholder for derived classes to add custom logic after an item has been inserted into the associated collection.
OnRemove | Provides a placeholder for derived classes to implement validation logic when removing an item from the associated collection.
OnRemoveComplete | Provides a placeholder for derived classes to add custom logic after an item has been removed from the associated collection.
OnSet | Provides a placeholder for derived classes to implement validation logic when replacing an item in the associated collection.
OnSetComplete | Provides a placeholder for derived classes to implement custom logic when an item has been replaced in the associated collection.
OnValidate | Provides a placeholder for derived classes to implement custom logic when validating an item.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

CollectionUpdaterBase Constructor Initializes a new instance of an CollectionUpdaterBase-derived object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnValidateCollection | Provides a placeholder for derived classes to check the collection argument when calling the OnInsert, OnInsertComplete, OnRemove, OnRemoveComplete, OnClear, OnClearComplete and OnValidate methods.
SetClearAllowed | Sets the IsClearAllowed property to the specfied value.
SetInsertAllowed | Sets the IsInsertAllowed property to the specfied value.
SetRemoveAllowed | Sets the IsRemoveAllowed property to the specfied value.
SetSetAllowed | Sets the IsSetAllowed property to the specfied value.
ThrowMethodNotAllowedException | Overloaded. Throw a SecurityException with the specified error message.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase Constructor

Initializes a new instance of an CollectionUpdaterBase-derived object.

[Visual Basic]
Protected Sub New( _
ByVal isInsertAllowed As Boolean, _
ByVal isRemoveAllowed As Boolean, _
ByVal isClearAllowed As Boolean, _
ByVal isSetAllowed As Boolean _
)
[C#]
protected CollectionUpdaterBase(
bool isInsertAllowed,
bool isRemoveAllowed,
bool isClearAllowed,
bool isSetAllowed
);

Remarks

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase Properties

The properties of the CollectionUpdaterBase class are listed below. For a complete list of CollectionUpdaterBase class members, see the CollectionUpdaterBase Members topic.

Public Instance Properties

IsClearAllowed | Implements the IChangeableCollection.IsClearAllowed member.
IsInsertAllowed | Implements the IChangeableCollection.IsInsertAllowed member.
IsRemoveAllowed | Implements the IChangeableCollection.IsRemoveAllowed member.
IsSetAllowed | Implements the IChangeableCollection.IsSetAllowed member.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.IsClearAllowed Property

Implements the IChangeableCollection.IsClearAllowed member.

[Visual Basic]
Overridable Public ReadOnly Property IsClearAllowed As Boolean _
Implements IChangeableCollection.IsClearAllowed
[C#]
public virtual bool IsClearAllowed {get;}

Property Value

The default implementation always returns true.

Implements

IChangeableCollection.IsClearAllowed

Remarks

Notes to Inheritors: The derived class should return true if the Clear method potentially succeeds. The inheritor should return false if the collection cannot be cleared.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.IsInsertAllowed Property

Implements the IChangeableCollection.IsInsertAllowed member.

[Visual Basic]
Overridable Public ReadOnly Property IsInsertAllowed As Boolean _
Implements IChangeableCollection.IsInsertAllowed
[C#]
public virtual bool IsInsertAllowed {get;}

Property Value

The default implementation always returns true.

Implements

IChangeableCollection.IsInsertAllowed

Remarks

Notes to Inheritors: The derived class should return true if the Insert or Add operation on the associated collection potentially succeeds. The inheritor should return false if items cannot be added to the associated collection.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.IsRemoveAllowed Property

Implements the IChangeableCollection.IsRemoveAllowed member.

[Visual Basic]
Overridable Public ReadOnly Property IsRemoveAllowed As Boolean _
Implements IChangeableCollection.IsRemoveAllowed
[C#]
public virtual bool IsRemoveAllowed {get;}

Property Value

The default implementation always returns true.

Implements

IChangeableCollection.IsRemoveAllowed

Remarks

Notes to Inheritors: The derived class should return true if the Remove or RemoveAt methods on the associated collection potentially succeed. The inheritor should return false if items cannot be removed from the associated collection.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.IsSetAllowed Property

Implements the IChangeableCollection.IsSetAllowed member.

[Visual Basic]
Overridable Public ReadOnly Property IsSetAllowed As Boolean _
Implements IChangeableCollection.IsSetAllowed
[C#]
public virtual bool IsSetAllowed {get;}

Property Value

The default implementation always returns true.

Implements

IChangeableCollection.IsSetAllowed

Remarks

Notes to Inheritors: The derived class should return true if the Set operation on the associated collection potentially succeeds. The inheritor should return false if items cannot be replaced in the associated collection.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase Methods

The methods of the CollectionUpdaterBase class are listed below. For a complete list of CollectionUpdaterBase class members, see the CollectionUpdaterBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnClear | Provides a placeholder for derived classes to implement validation logic when removing all items from the associated collection.
OnClearComplete | Provides a placeholder for derived classes to add custom logic after all items have been removed from the associated collection.
OnInsert | Provides a placeholder for derived classes to implement validation logic when inserting an item into the associated collection.
OnInsertComplete | Provides a placeholder for derived classes to add custom logic after an item has been inserted into the associated collection.
OnRemove | Provides a placeholder for derived classes to implement validation logic when removing an item from the associated collection.
OnRemoveComplete | Provides a placeholder for derived classes to add custom logic after an item has been removed from the associated collection.
OnSet | Provides a placeholder for derived classes to implement validation logic when replacing an item in the associated collection.
OnSetComplete | Provides a placeholder for derived classes to implement custom logic when an item has been replaced in the associated collection.
OnValidate | Provides a placeholder for derived classes to implement custom logic when validating an item.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnValidateCollection | Provides a placeholder for derived classes to check the collection argument when calling the OnInsert, OnInsertComplete, OnRemove, OnRemoveComplete, OnClear, OnClearComplete and OnValidate methods.
SetClearAllowed | Sets the IsClearAllowed property to the specfied value.
SetInsertAllowed | Sets the IsInsertAllowed property to the specfied value.
SetRemoveAllowed | Sets the IsRemoveAllowed property to the specfied value.
SetSetAllowed | Sets the IsSetAllowed property to the specfied value.
ThrowMethodNotAllowedException | Overloaded. Throw a SecurityException with the specified error message.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnClear Method

Provides a placeholder for derived classes to implement validation logic when removing all items from the associated collection.

[Visual Basic]
Overridable Public Sub OnClear( _
ByVal collection As CollectionBase _
) _
Implements ICollectionUpdater.OnClear
[C#]
public virtual void OnClear(
CollectionBase collection
);

Parameters

collection
The collection that is associated with this updater.

Implements

ICollectionUpdater.OnClear

Remarks

Note Always call this base class method in your derived classes.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnClearComplete Method

Provides a placeholder for derived classes to add custom logic after all items have been removed from the associated collection.

[Visual Basic]
Overridable Public Sub OnClearComplete( _
ByVal collection As CollectionBase _
) _
Implements ICollectionUpdater.OnClearComplete
[C#]
public virtual void OnClearComplete(
CollectionBase collection
);

Parameters

collection
The collection that is associated with this updater.

Implements

ICollectionUpdater.OnClearComplete

Remarks

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnInsert Method

Provides a placeholder for derived classes to implement validation logic when inserting an item into the associated collection.

[Visual Basic]
Overridable Public Sub OnInsert( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
) _
Implements ICollectionUpdater.OnInsert
[C#]
public virtual void OnInsert(
CollectionBase collection,
int index,
object value
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item being inserted into the collection.
value
The item being inserted into the collection.

Implements

ICollectionUpdater.OnInsert

Remarks

Note Always call this base class method in your derived classes.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnInsertComplete Method

Provides a placeholder for derived classes to add custom logic after an item has been inserted into the associated collection.

[Visual Basic]
Overridable Public Sub OnInsertComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
) _
Implements ICollectionUpdater.OnInsertComplete
[C#]
public virtual void OnInsertComplete(
CollectionBase collection,
int index,
object value
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item that has been inserted into the collection.
value
The item that has been inserted into the collection.

Implements

ICollectionUpdater.OnInsertComplete

Remarks

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnRemove Method

Provides a placeholder for derived classes to implement validation logic when removing an item from the associated collection.

[Visual Basic]
Overridable Public Sub OnRemove( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
) _
Implements ICollectionUpdater.OnRemove
[C#]
public virtual void OnRemove(
CollectionBase collection,
int index,
object value
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item being removed from the collection.
value
The item being removed from the collection.

Implements

ICollectionUpdater.OnRemove

Remarks

Note Always call this base class method in your derived classes.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnRemoveComplete Method

Provides a placeholder for derived classes to add custom logic after an item has been removed from the associated collection.

[Visual Basic]
Overridable Public Sub OnRemoveComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
) _
Implements ICollectionUpdater.OnRemoveComplete
[C#]
public virtual void OnRemoveComplete(
CollectionBase collection,
int index,
object value
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item that has been removed from the collection.
value
The item that has been removed from the collection.

Implements

ICollectionUpdater.OnRemoveComplete

Remarks

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnSet Method

Provides a placeholder for derived classes to implement validation logic when replacing an item in the associated collection.

[Visual Basic]
Overridable Public Sub OnSet( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
) _
Implements ICollectionUpdater.OnSet
[C#]
public virtual void OnSet(
CollectionBase collection,
int index,
object oldValue,
object newValue
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item being replaced in the collection.
oldValue
The item being replaced in the collection.
newValue
The item that replaces the oldValue.

Implements

ICollectionUpdater.OnSet

Remarks

Note Always call this base class method in your derived classes.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnSetComplete Method

Provides a placeholder for derived classes to implement custom logic when an item has been replaced in the associated collection.

[Visual Basic]
Overridable Public Sub OnSetComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
) _
Implements ICollectionUpdater.OnSetComplete
[C#]
public virtual void OnSetComplete(
CollectionBase collection,
int index,
object oldValue,
object newValue
);

Parameters

collection
The collection that is associated with this updater.
index
The index of the item that was replaced in the collection.
oldValue
The item that was replaced in the collection.
newValue
The item that replaced the oldValue.

Implements

ICollectionUpdater.OnSetComplete

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnValidate Method

Provides a placeholder for derived classes to implement custom logic when validating an item.

[Visual Basic]
Overridable Public Sub OnValidate( _
ByVal collection As CollectionBase, _
ByVal value As Object _
) _
Implements ICollectionUpdater.OnValidate
[C#]
public virtual void OnValidate(
CollectionBase collection,
object value
);

Parameters

collection
The collection that is associated with this updater.
value
The item being validated.

Implements

ICollectionUpdater.OnValidate

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection or value argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.OnValidateCollection Method

Provides a placeholder for derived classes to check the collection argument when calling the OnInsert, OnInsertComplete, OnRemove, OnRemoveComplete, OnClear, OnClearComplete and OnValidate methods.

[Visual Basic]
Overridable Protected Sub OnValidateCollection( _
ByVal collection As CollectionBase _
)
[C#]
protected virtual void OnValidateCollection(
CollectionBase collection
);

Parameters

collection
The collection being validated.

Remarks

The CollectionUpdaterBase class verifies that the passed-in collection is not a null reference (Nothing in Visual Basic).

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the collection argument value.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.SetClearAllowed Method

Sets the IsClearAllowed property to the specfied value.

[Visual Basic]
Protected Sub SetClearAllowed( _
ByVal allowed As Boolean _
)
[C#]
protected void SetClearAllowed(
bool allowed
);

Parameters

allowed
true to allow clearing the associated collection. false otherwise.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.SetInsertAllowed Method

Sets the IsInsertAllowed property to the specfied value.

[Visual Basic]
Protected Sub SetInsertAllowed( _
ByVal allowed As Boolean _
)
[C#]
protected void SetInsertAllowed(
bool allowed
);

Parameters

allowed
true to allow inserts. false otherwise.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.SetRemoveAllowed Method

Sets the IsRemoveAllowed property to the specfied value.

[Visual Basic]
Protected Sub SetRemoveAllowed( _
ByVal allowed As Boolean _
)
[C#]
protected void SetRemoveAllowed(
bool allowed
);

Parameters

allowed
true to allow removes. false otherwise.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.SetSetAllowed Method

Sets the IsSetAllowed property to the specfied value.

[Visual Basic]
Protected Sub SetSetAllowed( _
ByVal allowed As Boolean _
)
[C#]
protected void SetSetAllowed(
bool allowed
);

Parameters

allowed
true to allow replacing items in the associated collection. false otherwise.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


ThrowMethodNotAllowedException Method

Constable Authorization Engine 2.0 BETA

CollectionUpdaterBase.ThrowMethodNotAllowedException Method

[This is preliminary documentation and subject to change.]

Throws a SecurityException with default error message ("The collection cannot be modified at this time.").

Overload List

Throws a SecurityException with default error message ("The collection cannot be modified at this time.").

protected void ThrowMethodNotAllowedException();

Throw a SecurityException with the specified error message.

protected virtual void ThrowMethodNotAllowedException(string);

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace


CollectionUpdaterBase.ThrowMethodNotAllowedException Method ()

Throws a SecurityException with default error message ("The collection cannot be modified at this time.").

[Visual Basic]
Overloads Protected Sub ThrowMethodNotAllowedException()
[C#]
protected void ThrowMethodNotAllowedException();

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace | CollectionUpdaterBase.ThrowMethodNotAllowedException Overload List


CollectionUpdaterBase.ThrowMethodNotAllowedException Method (String)

Throw a SecurityException with the specified error message.

[Visual Basic]
Overridable Overloads Protected Sub ThrowMethodNotAllowedException( _
ByVal message As String _
)
[C#]
protected virtual void ThrowMethodNotAllowedException(
string message
);

Parameters

message
The error message.

See Also

CollectionUpdaterBase Class | LaMarvin.ComponentModel Namespace | CollectionUpdaterBase.ThrowMethodNotAllowedException Overload List


ExpandablePropertyAttribute Class

Signifies a property that can be expanded in a visual representation.

For a list of all members of this type, see ExpandablePropertyAttribute Members.

System.Object
System.Attribute
LaMarvin.ComponentModel.ExpandablePropertyAttribute

[Visual Basic]
<Serializable>
Public Class ExpandablePropertyAttribute
Inherits Attribute
[C#]
[Serializable]
public class ExpandablePropertyAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This attribute can be used to decorate a property that can be expanded in the LaMarvin.Design.InstanceView control.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ExpandablePropertyAttribute Members | LaMarvin.ComponentModel Namespace


ExpandablePropertyAttribute Members

ExpandablePropertyAttribute overview

Public Instance Constructors

ExpandablePropertyAttribute Overloaded. Initializes a new instance of the ExpandablePropertyAttribute class.

Public Instance Properties

IsExpandable | Sets or returns a flag indicating whether the decorated property should be displayed as expandable in the LaMarvin.Design.InstanceView control.
Ordinal | Sets or returns an ordinal value indicating the relative ordering of properties of a given instance displayed in the LaMarvin.Design.InstanceView control.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace


ExpandablePropertyAttribute Constructor

Initializes a new instance of the ExpandablePropertyAttribute class with the IsExpandable property value set to true and the Ordinal property set to zero.

Overload List

Initializes a new instance of the ExpandablePropertyAttribute class with the IsExpandable property value set to true and the Ordinal property set to zero.

public ExpandablePropertyAttribute();

Initializes a new instance of the ExpandablePropertyAttribute class with the given initial value of the IsExpandable property and the Ordinal property set to zero.

public ExpandablePropertyAttribute(bool);

Initializes a new instance of the ExpandablePropertyAttribute class with the given initial values of the IsExpandable and the Ordinal properties.

public ExpandablePropertyAttribute(bool,int);

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace


ExpandablePropertyAttribute Constructor ()

Initializes a new instance of the ExpandablePropertyAttribute class with the IsExpandable property value set to true and the Ordinal property set to zero.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExpandablePropertyAttribute();

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace | ExpandablePropertyAttribute Constructor Overload List


ExpandablePropertyAttribute Constructor (Boolean)

Initializes a new instance of the ExpandablePropertyAttribute class with the given initial value of the IsExpandable property and the Ordinal property set to zero.

[Visual Basic]
Overloads Public Sub New( _
ByVal expandable As Boolean _
)
[C#]
public ExpandablePropertyAttribute(
bool expandable
);

Parameters

expandable
The initial value of the IsExpandable property.

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace | ExpandablePropertyAttribute Constructor Overload List


ExpandablePropertyAttribute Constructor (Boolean, Int32)

Initializes a new instance of the ExpandablePropertyAttribute class with the given initial values of the IsExpandable and the Ordinal properties.

[Visual Basic]
Overloads Public Sub New( _
ByVal expandable As Boolean, _
ByVal ordinal As Integer _
)
[C#]
public ExpandablePropertyAttribute(
bool expandable,
int ordinal
);

Parameters

expandable
The initial value of the IsExpandable property.
ordinal
The initial value of the Ordinal property.

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace | ExpandablePropertyAttribute Constructor Overload List


ExpandablePropertyAttribute Properties

The properties of the ExpandablePropertyAttribute class are listed below. For a complete list of ExpandablePropertyAttribute class members, see the ExpandablePropertyAttribute Members topic.

Public Instance Properties

IsExpandable | Sets or returns a flag indicating whether the decorated property should be displayed as expandable in the LaMarvin.Design.InstanceView control.
Ordinal | Sets or returns an ordinal value indicating the relative ordering of properties of a given instance displayed in the LaMarvin.Design.InstanceView control.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace


ExpandablePropertyAttribute.IsExpandable Property

Sets or returns a flag indicating whether the decorated property should be displayed as expandable in the LaMarvin.Design.InstanceView control.

[Visual Basic]
Public Property IsExpandable As Boolean
[C#]
public bool IsExpandable {get; set;}

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace


ExpandablePropertyAttribute.Ordinal Property

Sets or returns an ordinal value indicating the relative ordering of properties of a given instance displayed in the LaMarvin.Design.InstanceView control.

[Visual Basic]
Public Property Ordinal As Integer
[C#]
public int Ordinal {get; set;}

See Also

ExpandablePropertyAttribute Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase Class

The abstract (MustInherit in Visual Basic) base class for all changeable collections that implement the collection updater design pattern.

For a list of all members of this type, see ChangeableCollectionBase Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase

[Visual Basic]
<Serializable>
MustInherit Public Class ChangeableCollectionBase
Inherits CollectionBase
Implements IChangeableCollection
[C#]
[Serializable]
public abstract class ChangeableCollectionBase : CollectionBase, IChangeableCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The class delegates all calls to the inherited OnInsert, OnInsertComplete, OnRemove, OnRemoveComplete, OnClear, OnClearComplete and OnValidate methods the their counterparts defined by the ICollectionUpdater interface and implemented by the associated Updater object.

CAUTION When overriding the above mentioned methods, be sure to either call the base implementation or call the corresponding ICollectionUpdater method explicitly. Otherwise, you'd break the design pattern resulting in errant collection behaviors.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ChangeableCollectionBase Members | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase Members

ChangeableCollectionBase overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed | Gets a flag indicating whether a Set operation is currently allowed.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ChangeableCollectionBase Overloaded. Initializes a new instance of the ChangeableCollectionBase class.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
Updater | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | Calls the OnClear method implementation of the associated Updater object.
OnClearComplete | Calls the OnClearComplete method implementation of the associated Updater object.
OnInsert | Calls the OnInsert method implementation of the associated Updater object.
OnInsertComplete | Calls the OnInsertComplete method implementation of the associated Updater object.
OnRemove | Calls the OnRemove method implementation of the associated Updater object.
OnRemoveComplete | Calls the OnRemoveComplete method implementation of the associated Updater object.
OnSet | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate | Calls the OnValidate method implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase Constructor

Initializes a new instance of an ChangeableCollectionBase-derived class associating it with an instance of the FullControlCollectionUpdater.

Overload List

Initializes a new instance of an ChangeableCollectionBase-derived class associating it with an instance of the FullControlCollectionUpdater.

protected ChangeableCollectionBase();

Initializes a new instance of an ChangeableCollectionBase-derived class associating it with the given updater object.

protected ChangeableCollectionBase(ICollectionUpdater);

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase Constructor ()

Initializes a new instance of an ChangeableCollectionBase-derived class associating it with an instance of the FullControlCollectionUpdater.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected ChangeableCollectionBase();

Remarks

This default constructor sets the Updater property to an instance of the FullControlCollectionUpdater class making the collection fully changeable.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace | ChangeableCollectionBase Constructor Overload List


ChangeableCollectionBase Constructor (ICollectionUpdater)

Initializes a new instance of an ChangeableCollectionBase-derived class associating it with the given updater object.

[Visual Basic]
Overloads Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected ChangeableCollectionBase(
ICollectionUpdater updater
);

Parameters

updater
The ICollectionUpdater implementation to be associated with the collection.

Remarks

Typically, when inheriting the ChangeableCollectionBase class, the derived class exposes a public constructor that instantiates application-specific ICollectionUpdater implementation.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the updater argument value. An ChangeableCollectionBase-derived object must be associated with a valid ICollectionUpdater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace | ChangeableCollectionBase Constructor Overload List


ChangeableCollectionBase Properties

The properties of the ChangeableCollectionBase class are listed below. For a complete list of ChangeableCollectionBase class members, see the ChangeableCollectionBase Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed | Gets a flag indicating whether a Set operation is currently allowed.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
Updater | Sets or returns the associated ICollectionUpdater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.IsClearAllowed Property

Gets a flag indicating whether the Clear method is currently allowed.

[Visual Basic]
Overridable Public ReadOnly Property IsClearAllowed As Boolean _
Implements IChangeableCollection.IsClearAllowed
[C#]
public virtual bool IsClearAllowed {get;}

Property Value

Returns true if the Clear method call is allowed; otherwise false.

Implements

IChangeableCollection.IsClearAllowed

Remarks

The call is simply forwarded to the IsClearAllowed implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.IsInsertAllowed Property

Gets a flag indicating whether an Insert (or Add) operation is currently allowed.

[Visual Basic]
Overridable Public ReadOnly Property IsInsertAllowed As Boolean _
Implements IChangeableCollection.IsInsertAllowed
[C#]
public virtual bool IsInsertAllowed {get;}

Property Value

Returns true if an Insert (or Add) method call is allowed; otherwise false.

Implements

IChangeableCollection.IsInsertAllowed

Remarks

The call is simply forwarded to the IsInsertAllowed implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.IsRemoveAllowed Property

Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.

[Visual Basic]
Overridable Public ReadOnly Property IsRemoveAllowed As Boolean _
Implements IChangeableCollection.IsRemoveAllowed
[C#]
public virtual bool IsRemoveAllowed {get;}

Property Value

Returns true if a Remove operation (or the RemoveAt method call) is allowed; otherwise false.

Implements

IChangeableCollection.IsRemoveAllowed

Remarks

The call is simply forwarded to the IsRemoveAllowed implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.IsSetAllowed Property

Gets a flag indicating whether a Set operation is currently allowed.

[Visual Basic]
Overridable Public ReadOnly Property IsSetAllowed As Boolean _
Implements IChangeableCollection.IsSetAllowed
[C#]
public virtual bool IsSetAllowed {get;}

Property Value

Returns true if a Set method call is allowed; otherwise false.

Implements

IChangeableCollection.IsSetAllowed

Remarks

The call is simply forwarded to the IsSetAllowed implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.Updater Property

Sets or returns the associated ICollectionUpdater object.

[Visual Basic]
Overridable Protected Property Updater As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater Updater {get; set;}

Property Value

A reference to the associated ICollectionUpdater object.

Remarks

Notes to Inheritors: If you override this property procedure, be sure to call the base class to actually store and retrieve the associated updater reference.

Exceptions

Exception Type | Condition
ArgumentNullException | The property has been assigned a a null reference (Nothing in Visual Basic).

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase Methods

The methods of the ChangeableCollectionBase class are listed below. For a complete list of ChangeableCollectionBase class members, see the ChangeableCollectionBase Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | Calls the OnClear method implementation of the associated Updater object.
OnClearComplete | Calls the OnClearComplete method implementation of the associated Updater object.
OnInsert | Calls the OnInsert method implementation of the associated Updater object.
OnInsertComplete | Calls the OnInsertComplete method implementation of the associated Updater object.
OnRemove | Calls the OnRemove method implementation of the associated Updater object.
OnRemoveComplete | Calls the OnRemoveComplete method implementation of the associated Updater object.
OnSet | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate | Calls the OnValidate method implementation of the associated Updater object.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnClear Method

Calls the OnClear method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnClear()
[C#]
protected override void OnClear();

Remarks

For more information, see the System.Collections.CollectionBase. OnClear help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnClearComplete Method

Calls the OnClearComplete method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnClearComplete()
[C#]
protected override void OnClearComplete();

Remarks

For more information, see the System.Collections.CollectionBase. OnClearComplete help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnInsert Method

Calls the OnInsert method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnInsert( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnInsert(
int index,
object value
);

Parameters

index
The index of the item being inserted.
value
The item being inserted.

Remarks

For more information, see the System.Collections.CollectionBase. OnInsert help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnInsertComplete Method

Calls the OnInsertComplete method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnInsertComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnInsertComplete(
int index,
object value
);

Parameters

index
The index of the item that was inserted into the collection.
value
The item that was inserted into the collection.

Remarks

For more information, see the System.Collections.CollectionBase. OnInsertComplete help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnRemove Method

Calls the OnRemove method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnRemove( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnRemove(
int index,
object value
);

Parameters

index
The index of the item being removed.
value
The item being removed.

Remarks

For more information, see the System.Collections.CollectionBase. OnRemove help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnRemoveComplete Method

Calls the OnRemoveComplete method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnRemoveComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnRemoveComplete(
int index,
object value
);

Parameters

index
The index of the item removed from the collection.
value
The item removed from the collection.

Remarks

For more information, see the System.Collections.CollectionBase. OnRemoveComplete help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnSet Method

Calls the OnSet method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnSet( _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
protected override void OnSet(
int index,
object oldValue,
object newValue
);

Parameters

index
The index of the item which is being replaced.
oldValue
The item being replaced by the value of the newValue argument.
newValue
The new value of the item.

Remarks

For more information, see the System.Collections.CollectionBase. OnSet help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnSetComplete Method

Calls the OnSetComplete method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnSetComplete( _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
protected override void OnSetComplete(
int index,
object oldValue,
object newValue
);

Parameters

index
The index of the item which was replaced.
oldValue
The item that was replaced by the value of the newValue argument.
newValue
The new value of the item.

Remarks

For more information, see the System.Collections.CollectionBase. OnSetComplete help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeableCollectionBase.OnValidate Method

Calls the OnValidate method implementation of the associated Updater object.

[Visual Basic]
Overrides Protected Sub OnValidate( _
ByVal value As Object _
)
[C#]
protected override void OnValidate(
object value
);

Parameters

value
The item being validated.

Remarks

For more information, see the System.Collections.CollectionBase. OnValidate help topic.

See Also

ChangeableCollectionBase Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs Class

The base class for all change notification events.

For a list of all members of this type, see ChangeEventArgs Members.

System.Object
System.EventArgs
LaMarvin.ComponentModel.ChangeEventArgs
LaMarvin.ComponentModel.CollectionChangeEventArgs
LaMarvin.ComponentModel.PropertyChangeEventArgs

[Visual Basic]
<Serializable>
MustInherit Public Class ChangeEventArgs
Inherits EventArgs
[C#]
[Serializable]
public abstract class ChangeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ChangeEventArgs Members | LaMarvin.ComponentModel Namespace


ChangeEventArgs Members

ChangeEventArgs overview

Public Instance Properties

IgnoreNestedChanges Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

Public Instance Methods

CreateChangeUndoManager | Derived classes must override this method and return a new instance of ChangeUndoManager-derived class specific to the current ChangeEventArgs-derived instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ChangeEventArgs Constructor Initializes a new instance of the ChangeEventArgs-derived class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs Constructor

Initializes a new instance of the ChangeEventArgs-derived class.

[Visual Basic]
Protected Sub New()
[C#]
protected ChangeEventArgs();

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs Properties

The properties of the ChangeEventArgs class are listed below. For a complete list of ChangeEventArgs class members, see the ChangeEventArgs Members topic.

Public Instance Properties

IgnoreNestedChanges Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs.IgnoreNestedChanges Property

Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

[Visual Basic]
Public Property IgnoreNestedChanges As Boolean
[C#]
public bool IgnoreNestedChanges {get; set;}

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs Methods

The methods of the ChangeEventArgs class are listed below. For a complete list of ChangeEventArgs class members, see the ChangeEventArgs Members topic.

Public Instance Methods

CreateChangeUndoManager | Derived classes must override this method and return a new instance of ChangeUndoManager-derived class specific to the current ChangeEventArgs-derived instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventArgs.CreateChangeUndoManager Method

Derived classes must override this method and return a new instance of ChangeUndoManager-derived class specific to the current ChangeEventArgs-derived instance.

[Visual Basic]
MustOverride Public Function CreateChangeUndoManager() As ChangeUndoManager
[C#]
public abstract ChangeUndoManager CreateChangeUndoManager();

Return Value

See Also

ChangeEventArgs Class | LaMarvin.ComponentModel Namespace


ChangeEventHandler Delegate

Defines a signature for change notification event handlers.

[Visual Basic]
<Serializable>
Public Delegate Sub ChangeEventHandler( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
[Serializable]
public delegate void ChangeEventHandler(
object sender,
ChangeEventArgs e
);

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

LaMarvin.ComponentModel Namespace


ChangeUndoManager Class

Defines a contract for types that listen to change notification for the purposes of performing corresponding undo and redo operations.

For a list of all members of this type, see ChangeUndoManager Members.

System.Object
LaMarvin.ComponentModel.ChangeUndoManager
LaMarvin.ComponentModel.CollectionChangeUndoManager
LaMarvin.ComponentModel.PropertyChangeUndoManager

[Visual Basic]
MustInherit Public Class ChangeUndoManager
Implements IUndoItem
[C#]
public abstract class ChangeUndoManager : IUndoItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ChangeUndoManager Members | LaMarvin.ComponentModel Namespace


ChangeUndoManager Members

ChangeUndoManager overview

Public Instance Properties

EventArgs | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized | Gets a value indicating whether this instance has been initialized.
Label | Gets the label of the change recorded by this instance.
Sender | Gets the sender of the event notification that was specified in the call to the Initialize method.

Public Instance Methods

Commit | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes an instance for the specified change notification.
Match | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Derived classes should redo the change recorded by previous calls to the Initialize and Commit method on this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Derived classes should undo the change recorded by previous calls to the Initialize and Commit method on this instance.

Protected Instance Constructors

ChangeUndoManager Constructor Initializes a new instance of the ChangeUndoManager class.

Protected Instance Properties

ChangeLabel | The change label that has been passed to the Initialize method call.
IsCommitted | Gets a value indicating whether this instance has been committed.

Protected Instance Methods

AssertIsCommitted | Asserts the instance is committed.
AssertIsInitialized | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager Constructor

Initializes a new instance of the ChangeUndoManager class.

[Visual Basic]
Protected Sub New()
[C#]
protected ChangeUndoManager();

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager Properties

The properties of the ChangeUndoManager class are listed below. For a complete list of ChangeUndoManager class members, see the ChangeUndoManager Members topic.

Public Instance Properties

EventArgs | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized | Gets a value indicating whether this instance has been initialized.
Label | Gets the label of the change recorded by this instance.
Sender | Gets the sender of the event notification that was specified in the call to the Initialize method.

Protected Instance Properties

ChangeLabel | The change label that has been passed to the Initialize method call.
IsCommitted | Gets a value indicating whether this instance has been committed.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.EventArgs Property

Gets the change notification event data as specified in the call to the Initialize method.

[Visual Basic]
Public ReadOnly Property EventArgs As ChangeEventArgs
[C#]
public ChangeEventArgs EventArgs {get;}

Property Value

The change notification event data.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.ChangeLabel Property

The change label that has been passed to the Initialize method call.

[Visual Basic]
Protected ReadOnly Property ChangeLabel As String
[C#]
protected string ChangeLabel {get;}

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.IsCommitted Property

Gets a value indicating whether this instance has been committed.

[Visual Basic]
Protected ReadOnly Property IsCommitted As Boolean
[C#]
protected bool IsCommitted {get;}

Property Value

true if this instance is committed; false otherwise.

Remarks

The instance is deemed committed after the Commit method has been called on it.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.IsInitialized Property

Gets a value indicating whether this instance has been initialized.

[Visual Basic]
Public ReadOnly Property IsInitialized As Boolean
[C#]
public bool IsInitialized {get;}

Property Value

true if this instance is initialized; false otherwise.

Remarks

The instance is deemed initialized after the Initialize method has been called on it.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Label Property

Gets the label of the change recorded by this instance.

[Visual Basic]
NotOverridable Public ReadOnly Property Label As String _
Implements IUndoItem.Label
[C#]
public string Label {get;}

Property Value

The label of the change to be displayed to the user.

Implements

IUndoItem.Label

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Sender Property

Gets the sender of the event notification that was specified in the call to the Initialize method.

[Visual Basic]
Public ReadOnly Property Sender As Object
[C#]
public object Sender {get;}

Property Value

The change notification sender.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager Methods

The methods of the ChangeUndoManager class are listed below. For a complete list of ChangeUndoManager class members, see the ChangeUndoManager Members topic.

Public Instance Methods

Commit | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes an instance for the specified change notification.
Match | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Derived classes should redo the change recorded by previous calls to the Initialize and Commit method on this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Derived classes should undo the change recorded by previous calls to the Initialize and Commit method on this instance.

Protected Instance Methods

AssertIsCommitted | Asserts the instance is committed.
AssertIsInitialized | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.AssertIsCommitted Method

Asserts the instance is committed.

[Visual Basic]
Protected Sub AssertIsCommitted()
[C#]
protected void AssertIsCommitted();

Exceptions

Exception Type | Condition
InvalidOperationException | The Commit method has not been called.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.AssertIsInitialized Method

Asserts the instance is initialized.

[Visual Basic]
Protected Sub AssertIsInitialized()
[C#]
protected void AssertIsInitialized();

Exceptions

Exception Type | Condition
InvalidOperationException | The Initialize method has not been called.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Commit Method

Indicates that a change has been completed.

[Visual Basic]
Overridable Public Sub Commit()
[C#]
public virtual void Commit();

Remarks

The method is typically called as part of processing the InstanceChanged event when the actual change has been completed.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


Initialize Method

Constable Authorization Engine 2.0 BETA

ChangeUndoManager.Initialize Method

[This is preliminary documentation and subject to change.]

Initializes an instance for the specified change notification.

Overload List

Initializes an instance for the specified change notification.

public bool Initialize(object,ChangeEventArgs);

Initializes an instance for the specified change notification.

public virtual bool Initialize(object,ChangeEventArgs,string);

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Initialize Method (Object, ChangeEventArgs)

Initializes an instance for the specified change notification.

[Visual Basic]
Overloads Public Function Initialize( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
) As Boolean
[C#]
public bool Initialize(
object sender,
ChangeEventArgs e
);

Parameters

sender
The sender of the change notification.
e
The ChangeEventArgs instance containing the event data.

Return Value

true if the initialization was successfull and the manager will be able to undo the change; false otherwise.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace | ChangeUndoManager.Initialize Overload List


ChangeUndoManager.Initialize Method (Object, ChangeEventArgs, String)

Initializes an instance for the specified change notification.

[Visual Basic]
Overridable Overloads Public Function Initialize( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs, _
ByVal changeLabel As String _
) As Boolean
[C#]
public virtual bool Initialize(
object sender,
ChangeEventArgs e,
string changeLabel
);

Parameters

sender
The sender of the change notification.
e
The ChangeEventArgs instance containing the event data.
changeLabel
The optional change label to be displayed to the user.

Return Value

true if the initialization was successfull and the manager will be able to undo the change; false otherwise.

Remarks

The method is typically called as part of processing the InstanceChanging event before the actual change takes place.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace | ChangeUndoManager.Initialize Overload List


ChangeUndoManager.Match Method

Checks whether the specified arguments match the change notification recorded by this instance.

[Visual Basic]
Overridable Public Function Match( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
) As Boolean
[C#]
public virtual bool Match(
object sender,
ChangeEventArgs e
);

Parameters

sender
The sender of the change notification.
e
The ChangeEventArgs instance containing the event data.

Return Value

true is the arguments match the recorded change notification; false otherwise.

Remarks

This method is used by undo engines to match the two event notifications (InstanceChanging and InstanceChanged) that form an atomic, undoable change.

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Redo Method

Derived classes should redo the change recorded by previous calls to the Initialize and Commit method on this instance.

[Visual Basic]
MustOverride Public Sub Redo() _
Implements IUndoItem.Redo
[C#]
public abstract void Redo();

Implements

IUndoItem.Redo

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ChangeUndoManager.Undo Method

Derived classes should undo the change recorded by previous calls to the Initialize and Commit method on this instance.

[Visual Basic]
MustOverride Public Sub Undo() _
Implements IUndoItem.Undo
[C#]
public abstract void Undo();

Implements

IUndoItem.Undo

See Also

ChangeUndoManager Class | LaMarvin.ComponentModel Namespace


ICollectionUpdater Interface

Represents an object to which a collection delegates its update methods.

For a list of all members of this type, see ICollectionUpdater Members.

[Visual Basic]
Public Interface ICollectionUpdater
Implements IChangeableCollection
[C#]
public interface ICollectionUpdater : IChangeableCollection

Types that implement ICollectionUpdater

Type | Description
CollectionUpdaterBase | Provides an abstract (MustInherit in Visual Basic) base class for an extensible ICollectionUpdater implementation.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ICollectionUpdater Members | LaMarvin.ComponentModel Namespace | IChangeableCollection


ICollectionUpdater Members

ICollectionUpdater overview

Public Instance Methods

OnClear | Called by the associated collection when the collection is about to be cleared.
OnClearComplete | Called by the associated collection after the collection has been cleared.
OnInsert | Called by the associated collection as part of Add/Insert method. The implementation should carry out any validations neccessary when inserting a new element into the collection.
OnInsertComplete | Called by the associated collection after the object has been added to the associated collection.
OnRemove | Called by the associated collection when removing an element from the collection.
OnRemoveComplete | Called by the associated collection after the object has been removed from the associated collection.
OnSet | Called by the associated collection when an element is being replaced.
OnSetComplete | Called by the associated collection after an element has been replaced.
OnValidate | Called by the associated collection when the element has to be validated.

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace | IChangeableCollection


ICollectionUpdater Methods

The methods of the ICollectionUpdater interface are listed below. For a complete list of ICollectionUpdater interface members, see the ICollectionUpdater Members topic.

Public Instance Methods

OnClear | Called by the associated collection when the collection is about to be cleared.
OnClearComplete | Called by the associated collection after the collection has been cleared.
OnInsert | Called by the associated collection as part of Add/Insert method. The implementation should carry out any validations neccessary when inserting a new element into the collection.
OnInsertComplete | Called by the associated collection after the object has been added to the associated collection.
OnRemove | Called by the associated collection when removing an element from the collection.
OnRemoveComplete | Called by the associated collection after the object has been removed from the associated collection.
OnSet | Called by the associated collection when an element is being replaced.
OnSetComplete | Called by the associated collection after an element has been replaced.
OnValidate | Called by the associated collection when the element has to be validated.

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace | IChangeableCollection


ICollectionUpdater.OnClear Method

Called by the associated collection when the collection is about to be cleared.

[Visual Basic]
Sub OnClear( _
ByVal collection As CollectionBase _
)
[C#]
void OnClear(
CollectionBase collection
);

Parameters

collection

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnClearComplete Method

Called by the associated collection after the collection has been cleared.

[Visual Basic]
Sub OnClearComplete( _
ByVal collection As CollectionBase _
)
[C#]
void OnClearComplete(
CollectionBase collection
);

Parameters

collection

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnInsert Method

Called by the associated collection as part of Add/Insert method. The implementation should carry out any validations neccessary when inserting a new element into the collection.

[Visual Basic]
Sub OnInsert( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
void OnInsert(
CollectionBase collection,
int index,
object value
);

Parameters

collection
index
value

Return Value

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnInsertComplete Method

Called by the associated collection after the object has been added to the associated collection.

[Visual Basic]
Sub OnInsertComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
void OnInsertComplete(
CollectionBase collection,
int index,
object value
);

Parameters

collection
index
value

Return Value

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnRemove Method

Called by the associated collection when removing an element from the collection.

[Visual Basic]
Sub OnRemove( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
void OnRemove(
CollectionBase collection,
int index,
object value
);

Parameters

collection
index
value

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnRemoveComplete Method

Called by the associated collection after the object has been removed from the associated collection.

[Visual Basic]
Sub OnRemoveComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
void OnRemoveComplete(
CollectionBase collection,
int index,
object value
);

Parameters

collection
index
value

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnSet Method

Called by the associated collection when an element is being replaced.

[Visual Basic]
Sub OnSet( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
void OnSet(
CollectionBase collection,
int index,
object oldValue,
object newValue
);

Parameters

collection
index
oldValue
newValue

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnSetComplete Method

Called by the associated collection after an element has been replaced.

[Visual Basic]
Sub OnSetComplete( _
ByVal collection As CollectionBase, _
ByVal index As Integer, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
void OnSetComplete(
CollectionBase collection,
int index,
object oldValue,
object newValue
);

Parameters

collection
index
oldValue
newValue

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


ICollectionUpdater.OnValidate Method

Called by the associated collection when the element has to be validated.

[Visual Basic]
Sub OnValidate( _
ByVal collection As CollectionBase, _
ByVal value As Object _
)
[C#]
void OnValidate(
CollectionBase collection,
object value
);

Parameters

collection
value

See Also

ICollectionUpdater Interface | LaMarvin.ComponentModel Namespace


IChangeableCollection Interface

Represents a collection that can be updated. Typically used in conjunction with an ICollectionUpdater implementation to customize collection's runtime behavior dynamically.

For a list of all members of this type, see IChangeableCollection Members.

LaMarvin.ComponentModel.IChangeableCollection
LaMarvin.ComponentModel.ICollectionUpdater

[Visual Basic]
Public Interface IChangeableCollection
[C#]
public interface IChangeableCollection

Types that implement IChangeableCollection

Type | Description
CollectionUpdaterBase | Provides an abstract (MustInherit in Visual Basic) base class for an extensible ICollectionUpdater implementation.
ChangeableCollectionBase | The abstract (MustInherit in Visual Basic) base class for all changeable collections that implement the collection updater design pattern.
ActionCollection | Represents a collection Action objects.
ActionRuleCollection | Represents a collection of the ActionRule objects.
NamedObjectCollectionBase | Provides a base class for all concrete collection classes for descendants of the NamedObjectBase class.
ObjectCollectionBase | Represents a collection NamedObjectBase-derived objects.
PropertyCollection | Represents a collection of Property objects.
PropertyRuleCollection | Represents a collection of PropertyRule objects.
RoleCollection | Represents a collection of Role objects.
RuleCollectionBase | Provides a base class for all concrete collection classes containing descendants of the RuleBase class.
StateCollection | Represents a collection of State objects.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IChangeableCollection Members | LaMarvin.ComponentModel Namespace | ICollectionUpdater


IChangeableCollection Members

IChangeableCollection overview

Public Instance Properties

IsClearAllowed | Returns flag that determines if the collection can be cleared (i.e. all elements removed).
IsInsertAllowed | Returns flag that determines if the collection can be inserted (or added) to.
IsRemoveAllowed | Returns flag that determines if an element of the collection can be removed (either by value or by position).
IsSetAllowed | Returns flag that determines if an element in the collection can be replaced.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace | ICollectionUpdater


IChangeableCollection Properties

The properties of the IChangeableCollection interface are listed below. For a complete list of IChangeableCollection interface members, see the IChangeableCollection Members topic.

Public Instance Properties

IsClearAllowed | Returns flag that determines if the collection can be cleared (i.e. all elements removed).
IsInsertAllowed | Returns flag that determines if the collection can be inserted (or added) to.
IsRemoveAllowed | Returns flag that determines if an element of the collection can be removed (either by value or by position).
IsSetAllowed | Returns flag that determines if an element in the collection can be replaced.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace | ICollectionUpdater


IChangeableCollection.IsClearAllowed Property

Returns flag that determines if the collection can be cleared (i.e. all elements removed).

[Visual Basic]
Property IsClearAllowed As Boolean
[C#]
bool IsClearAllowed {get;}

Property Value

Returns true if the collection can be cleared; false otherwise.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace


IChangeableCollection.IsInsertAllowed Property

Returns flag that determines if the collection can be inserted (or added) to.

[Visual Basic]
Property IsInsertAllowed As Boolean
[C#]
bool IsInsertAllowed {get;}

Property Value

Returns true if the collection can be inserted to; false otherwise.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace


IChangeableCollection.IsRemoveAllowed Property

Returns flag that determines if an element of the collection can be removed (either by value or by position).

[Visual Basic]
Property IsRemoveAllowed As Boolean
[C#]
bool IsRemoveAllowed {get;}

Property Value

Returns true if an element can be removed from the collection; false otherwise.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace


IChangeableCollection.IsSetAllowed Property

Returns flag that determines if an element in the collection can be replaced.

[Visual Basic]
Property IsSetAllowed As Boolean
[C#]
bool IsSetAllowed {get;}

Property Value

Returns true if an element in the collection can be replaced; false otherwise.

See Also

IChangeableCollection Interface | LaMarvin.ComponentModel Namespace


IChangeEventObserver Interface

Defines a contract for an adapter-like object that is interested in observing change events for possibly multiple event sources.

For a list of all members of this type, see IChangeEventObserver Members.

[Visual Basic]
Public Interface IChangeEventObserver
[C#]
public interface IChangeEventObserver

Types that implement IChangeEventObserver

Type | Description
DefaultPolicyViewAdapter | [TBD]
GroupByActionPolicyViewAdapter | [TBD]
GroupByRolePolicyViewAdapter | [TBD]
GroupByRoleThenStatePolicyViewAdapter | [TBD]
GroupByStatePolicyViewAdapter | [TBD]
PolicySimulationViewAdapter | [TBD]
PolicyViewAdapter | Defines a base class for adapting AuthorizationPolicy instances to provide customized views displayed in the InstanceView control.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IChangeEventObserver Members | LaMarvin.ComponentModel Namespace


IChangeEventObserver Members

IChangeEventObserver overview

Public Instance Properties

ObservedCollectionChangeSenders | The implementation should return an array of instances whose collection change events (as defined by the CollectionChangeEventArgs event argument type) the current instance observes.
ObservedPropertyChangeSenders | The implementation should return an array of instances whose property change events (as defined by the PropertyChangeEventArgs event argument type) the current instance observes.

See Also

IChangeEventObserver Interface | LaMarvin.ComponentModel Namespace


IChangeEventObserver Properties

The properties of the IChangeEventObserver interface are listed below. For a complete list of IChangeEventObserver interface members, see the IChangeEventObserver Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | The implementation should return an array of instances whose collection change events (as defined by the CollectionChangeEventArgs event argument type) the current instance observes.
ObservedPropertyChangeSenders | The implementation should return an array of instances whose property change events (as defined by the PropertyChangeEventArgs event argument type) the current instance observes.

See Also

IChangeEventObserver Interface | LaMarvin.ComponentModel Namespace


IChangeEventObserver.ObservedCollectionChangeSenders Property

The implementation should return an array of instances whose collection change events (as defined by the CollectionChangeEventArgs event argument type) the current instance observes.

[Visual Basic]
Property ObservedCollectionChangeSenders As Object()
[C#]
object[] ObservedCollectionChangeSenders {get;}

See Also

IChangeEventObserver Interface | LaMarvin.ComponentModel Namespace


IChangeEventObserver.ObservedPropertyChangeSenders Property

The implementation should return an array of instances whose property change events (as defined by the PropertyChangeEventArgs event argument type) the current instance observes.

[Visual Basic]
Property ObservedPropertyChangeSenders As Object()
[C#]
object[] ObservedPropertyChangeSenders {get;}

See Also

IChangeEventObserver Interface | LaMarvin.ComponentModel Namespace


IChangeEventPropagator Interface

Defines a contract that should be implemented by object graphs for propagating change notification events up the owner-like relationship chain of objects

For a list of all members of this type, see IChangeEventPropagator Members.

[Visual Basic]
Public Interface IChangeEventPropagator
[C#]
public interface IChangeEventPropagator

Types that implement IChangeEventPropagator

Type | Description
AuthorizationPolicy | Encapsulates a single authorization policy and implements the core authorization functionality to be used from within your application.
FallbackAction | [TBD]
FallbackActionRule | [TBD]
FallbackPolicy | [TBD]
FallbackProperty | [TBD]
FallbackPropertyRule | [TBD]
FallbackRole | [TBD]
FallbackState | [TBD]
Action | Defines an action that can be executed by the AuthorizationPolicy.
ActionCollection | Represents a collection Action objects.
ActionRule | Defines the association of an Action with a State and a Role. The association properties represent the result (TargetState) and the visibility (IsVisible) and accessibility (IsEnabled of the associated action.
ActionRuleCollection | Represents a collection of the ActionRule objects.
ComPlusRole | Provides a role implementation that represents a role in the COM+ catalog.
DynamicRole | Provides a role implementation whose membership can be controlled programmatically by setting the IsMemberResult property.
NamedObjectBase | This is the common base class for all the classes that form the definition of an authorization model.
NamedObjectCollectionBase | Provides a base class for all concrete collection classes for descendants of the NamedObjectBase class.
ObjectBase | This is the base class for all classes comprising the AuthorizationPolicy state-based authorization model.
ObjectCollectionBase | Represents a collection NamedObjectBase-derived objects.
Property | Defines an Property that is part of an AuthorizationPolicy.
PropertyCollection | Represents a collection of Property objects.
PropertyRule | Defines the association of a property with a state, set of Roles that can access the property and the accessibility flags: IsVisible and IsEnabled.
PropertyRuleCollection | Represents a collection of PropertyRule objects.
Role | Defines a role that can act on an instance of an AuthorizationPolicy class.
RoleCollection | Represents a collection of Role objects.
RuleBase | Provides a base class for derived classes representing associations (sometimes called tuples) of a given State, role, state-dependent object and the state-dependent object's attributes. The provided ActionRule and PropertyRule classes represent built-in rule objects.
RuleCollectionBase | Provides a base class for all concrete collection classes containing descendants of the RuleBase class.
State | Defines a state in the authorization model.
StateCollection | Represents a collection of State objects.
WindowsRole | Provides a role implementation that represents a windows security group.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IChangeEventPropagator Members | LaMarvin.ComponentModel Namespace


IChangeEventPropagator Members

IChangeEventPropagator overview

Public Instance Methods

PropagateChangedEvent | Propagate the changed event to the owner.
PropagateChangingEvent | Propagate the changing event to the owner.

See Also

IChangeEventPropagator Interface | LaMarvin.ComponentModel Namespace


IChangeEventPropagator Methods

The methods of the IChangeEventPropagator interface are listed below. For a complete list of IChangeEventPropagator interface members, see the IChangeEventPropagator Members topic.

Public Instance Methods

PropagateChangedEvent | Propagate the changed event to the owner.
PropagateChangingEvent | Propagate the changing event to the owner.

See Also

IChangeEventPropagator Interface | LaMarvin.ComponentModel Namespace


IChangeEventPropagator.PropagateChangedEvent Method

Propagate the changed event to the owner.

[Visual Basic]
Sub PropagateChangedEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
void PropagateChangedEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The original sender of the event notification; the instance that has been modified.
e
The event data.

See Also

IChangeEventPropagator Interface | LaMarvin.ComponentModel Namespace


IChangeEventPropagator.PropagateChangingEvent Method

Propagate the changing event to the owner.

[Visual Basic]
Sub PropagateChangingEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
void PropagateChangingEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The original sender of the event notification; the instance being modified.
e
The event data.

See Also

IChangeEventPropagator Interface | LaMarvin.ComponentModel Namespace


IChangeEventSource Interface

Defines a source of change event notifications.

For a list of all members of this type, see IChangeEventSource Members.

[Visual Basic]
Public Interface IChangeEventSource
[C#]
public interface IChangeEventSource

Types that implement IChangeEventSource

Type | Description
AuthorizationPolicy | Encapsulates a single authorization policy and implements the core authorization functionality to be used from within your application.
FallbackPolicy | [TBD]
DefaultPolicyViewAdapter | [TBD]
GroupByActionPolicyViewAdapter | [TBD]
GroupByRolePolicyViewAdapter | [TBD]
GroupByRoleThenStatePolicyViewAdapter | [TBD]
GroupByStatePolicyViewAdapter | [TBD]
PolicySimulationViewAdapter | [TBD]
PolicyViewAdapter | Defines a base class for adapting AuthorizationPolicy instances to provide customized views displayed in the InstanceView control.

Remarks

The interface is typically implemented by classes that represent a logical root of an object graph.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IChangeEventSource Members | LaMarvin.ComponentModel Namespace


IChangeEventSource Members

IChangeEventSource overview

Public Instance Events

InstanceChanged | Raised immediately after the instance has been changed.
InstanceChanging | Raised when the instance is about to be changed.

See Also

IChangeEventSource Interface | LaMarvin.ComponentModel Namespace


IChangeEventSource Events

The events of the IChangeEventSource interface are listed below. For a complete list of IChangeEventSource interface members, see the IChangeEventSource Members topic.

Public Instance Events

InstanceChanged | Raised immediately after the instance has been changed.
InstanceChanging | Raised when the instance is about to be changed.

See Also

IChangeEventSource Interface | LaMarvin.ComponentModel Namespace


IChangeEventSource.InstanceChanged Event

Raised immediately after the instance has been changed.

[Visual Basic]
Event InstanceChanged As ChangeEventHandler
[C#]
event ChangeEventHandler InstanceChanged;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

See Also

IChangeEventSource Interface | LaMarvin.ComponentModel Namespace


IChangeEventSource.InstanceChanging Event

Raised when the instance is about to be changed.

[Visual Basic]
Event InstanceChanging As ChangeEventHandler
[C#]
event ChangeEventHandler InstanceChanging;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

See Also

IChangeEventSource Interface | LaMarvin.ComponentModel Namespace


IUndoItem Interface

Defines a contract representing an undoable change item.

For a list of all members of this type, see IUndoItem Members.

[Visual Basic]
Public Interface IUndoItem
[C#]
public interface IUndoItem

Types that implement IUndoItem

Type | Description
CollectionChangeUndoManager | Manages undo operations for IList-based collections.
ChangeUndoManager | Defines a contract for types that listen to change notification for the purposes of performing corresponding undo and redo operations.
PropertyChangeUndoManager | Manages undo and redo operations for property updates.
UndoItemCollection | Represents a collection of IUndoItem-compatible objects.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IUndoItem Members | LaMarvin.ComponentModel Namespace


IUndoItem Members

IUndoItem overview

Public Instance Properties

Label Returns the label that describes the change this instance represents.

Public Instance Methods

Redo | Implementations should redo the change this instance represents.
Undo | Implementations should undo the change this instance represents.

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


IUndoItem Properties

The properties of the IUndoItem interface are listed below. For a complete list of IUndoItem interface members, see the IUndoItem Members topic.

Public Instance Properties

Label Returns the label that describes the change this instance represents.

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


IUndoItem.Label Property

Returns the label that describes the change this instance represents.

[Visual Basic]
Property Label As String
[C#]
string Label {get;}

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


IUndoItem Methods

The methods of the IUndoItem interface are listed below. For a complete list of IUndoItem interface members, see the IUndoItem Members topic.

Public Instance Methods

Redo | Implementations should redo the change this instance represents.
Undo | Implementations should undo the change this instance represents.

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


IUndoItem.Redo Method

Implementations should redo the change this instance represents.

[Visual Basic]
Sub Redo()
[C#]
void Redo();

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


IUndoItem.Undo Method

Implementations should undo the change this instance represents.

[Visual Basic]
Sub Undo()
[C#]
void Undo();

See Also

IUndoItem Interface | LaMarvin.ComponentModel Namespace


OrdinalAttribute Class

Decorates programming elements that can be sorted.

For a list of all members of this type, see OrdinalAttribute Members.

System.Object
System.Attribute
LaMarvin.ComponentModel.OrdinalAttribute

[Visual Basic]
<Serializable>
Public Class OrdinalAttribute
Inherits Attribute
[C#]
[Serializable]
public class OrdinalAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

OrdinalAttribute Members | LaMarvin.ComponentModel Namespace


OrdinalAttribute Members

OrdinalAttribute overview

Public Instance Constructors

OrdinalAttribute Constructor Initializes an instance of the OrdinalAttribute with the given ordinal value.

Public Instance Properties

Ordinal | Sets or returns the ordinal value of the attribute.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals | Returns true if the instance is OrdinalAttribute instance with the same value of the Ordinal property; false otherwise.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute Constructor

Initializes an instance of the OrdinalAttribute with the given ordinal value.

[Visual Basic]
Public Sub New( _
ByVal ordinal As Integer _
)
[C#]
public OrdinalAttribute(
int ordinal
);

Parameters

ordinal
The initial value of the Ordinal property.

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute Properties

The properties of the OrdinalAttribute class are listed below. For a complete list of OrdinalAttribute class members, see the OrdinalAttribute Members topic.

Public Instance Properties

Ordinal | Sets or returns the ordinal value of the attribute.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute.Ordinal Property

Sets or returns the ordinal value of the attribute.

[Visual Basic]
Public Property Ordinal As Integer
[C#]
public int Ordinal {get; set;}

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute Methods

The methods of the OrdinalAttribute class are listed below. For a complete list of OrdinalAttribute class members, see the OrdinalAttribute Members topic.

Public Instance Methods

Equals | Returns true if the instance is OrdinalAttribute instance with the same value of the Ordinal property; false otherwise.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute.Equals Method

Returns true if the instance is OrdinalAttribute instance with the same value of the Ordinal property; false otherwise.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


OrdinalAttribute.GetHashCode Method

Returns the hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

Returns the value of the Ordinal property.

See Also

OrdinalAttribute Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs Class

Represents a change to a property of an object.

For a list of all members of this type, see PropertyChangeEventArgs Members.

System.Object
System.EventArgs
LaMarvin.ComponentModel.ChangeEventArgs
LaMarvin.ComponentModel.PropertyChangeEventArgs

[Visual Basic]
<Serializable>
Public Class PropertyChangeEventArgs
Inherits ChangeEventArgs
[C#]
[Serializable]
public class PropertyChangeEventArgs : ChangeEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

PropertyChangeEventArgs Members | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs Members

PropertyChangeEventArgs overview

Public Instance Constructors

PropertyChangeEventArgs Overloaded. Initializes a new instance of the PropertyChangeEventArgs class.

Public Instance Properties

IgnoreNestedChanges (inherited from ChangeEventArgs) | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.
NewValue | Gets the new value of the property after the change represented by this instance has taken place.
OldValue | Gets the old value of the property before the change represented by this instance takes place.
PropertyName | Gets the name of the property that is changed.

Public Instance Methods

CreateChangeUndoManager | Creates an instance of the PropertyChangeUndoManager class for managing the undo and redo operations for this change.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs Constructor

Initializes a new instance of the PropertyChangeEventArgs class with the given property name

Overload List

Initializes a new instance of the PropertyChangeEventArgs class with the given property name

public PropertyChangeEventArgs(string);

Initializes a new instance of the PropertyChangeEventArgs class with the given property name and property values.

public PropertyChangeEventArgs(string,object,object);

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs Constructor (String)

Initializes a new instance of the PropertyChangeEventArgs class with the given property name

[Visual Basic]
Overloads Public Sub New( _
ByVal propertyName As String _
)
[C#]
public PropertyChangeEventArgs(
string propertyName
);

Parameters

propertyName
The name of the property.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace | PropertyChangeEventArgs Constructor Overload List


PropertyChangeEventArgs Constructor (String, Object, Object)

Initializes a new instance of the PropertyChangeEventArgs class with the given property name and property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal propertyName As String, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
public PropertyChangeEventArgs(
string propertyName,
object oldValue,
object newValue
);

Parameters

propertyName
The name of the property.
oldValue
The old value of the property (before the change).
newValue
The new value of the property (after the change).

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace | PropertyChangeEventArgs Constructor Overload List


PropertyChangeEventArgs Properties

The properties of the PropertyChangeEventArgs class are listed below. For a complete list of PropertyChangeEventArgs class members, see the PropertyChangeEventArgs Members topic.

Public Instance Properties

IgnoreNestedChanges (inherited from ChangeEventArgs) | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.
NewValue | Gets the new value of the property after the change represented by this instance has taken place.
OldValue | Gets the old value of the property before the change represented by this instance takes place.
PropertyName | Gets the name of the property that is changed.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs.NewValue Property

Gets the new value of the property after the change represented by this instance has taken place.

[Visual Basic]
Public ReadOnly Property NewValue As Object
[C#]
public object NewValue {get;}

Property Value

The new value of the property.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs.OldValue Property

Gets the old value of the property before the change represented by this instance takes place.

[Visual Basic]
Public ReadOnly Property OldValue As Object
[C#]
public object OldValue {get;}

Property Value

The old value of the property.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs.PropertyName Property

Gets the name of the property that is changed.

[Visual Basic]
Public ReadOnly Property PropertyName As String
[C#]
public string PropertyName {get;}

Property Value

The name of the property.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs Methods

The methods of the PropertyChangeEventArgs class are listed below. For a complete list of PropertyChangeEventArgs class members, see the PropertyChangeEventArgs Members topic.

Public Instance Methods

CreateChangeUndoManager | Creates an instance of the PropertyChangeUndoManager class for managing the undo and redo operations for this change.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs.CreateChangeUndoManager Method

Creates an instance of the PropertyChangeUndoManager class for managing the undo and redo operations for this change.

[Visual Basic]
Overrides Public Function CreateChangeUndoManager() As ChangeUndoManager
[C#]
public override ChangeUndoManager CreateChangeUndoManager();

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeEventArgs.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that represents the current Object.

See Also

PropertyChangeEventArgs Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager Class

Manages undo and redo operations for property updates.

For a list of all members of this type, see PropertyChangeUndoManager Members.

System.Object
LaMarvin.ComponentModel.ChangeUndoManager
LaMarvin.ComponentModel.PropertyChangeUndoManager

[Visual Basic]
Public Class PropertyChangeUndoManager
Inherits ChangeUndoManager
[C#]
public class PropertyChangeUndoManager : ChangeUndoManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

PropertyChangeUndoManager Members | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager Members

PropertyChangeUndoManager overview

Public Instance Constructors

PropertyChangeUndoManager Constructor Initializes a new instance of the PropertyChangeUndoManager class.

Public Instance Properties

EventArgs (inherited from ChangeUndoManager) | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been initialized.
Label (inherited from ChangeUndoManager) | Gets the label of the change recorded by this instance.
Sender (inherited from ChangeUndoManager) | Gets the sender of the event notification that was specified in the call to the Initialize method.

Public Instance Methods

Commit (inherited from ChangeUndoManager) | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes an instance for the specified property change.
Initialize (inherited from ChangeUndoManager) | Overloaded. Initializes an instance for the specified change notification.
Match (inherited from ChangeUndoManager) | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Redoes (re-applies) the property change represented by this instance.
ToString | Returns a String that represents the current Object.
Undo | Undoes the property change represented by this instance.

Protected Instance Properties

ChangeLabel (inherited from ChangeUndoManager) | The change label that has been passed to the Initialize method call.
IsCommitted (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been committed.
PropertyDescriptor | Gets the property descriptor representing the changed property.
PropertyChangeEventArgs | Gets a reference to the PropertyChangeEventArgs instance associated with this instance.

Protected Instance Methods

AssertIsCommitted (inherited from ChangeUndoManager) | Asserts the instance is committed.
AssertIsInitialized (inherited from ChangeUndoManager) | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager Constructor

Initializes a new instance of the PropertyChangeUndoManager class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyChangeUndoManager();

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager Properties

The properties of the PropertyChangeUndoManager class are listed below. For a complete list of PropertyChangeUndoManager class members, see the PropertyChangeUndoManager Members topic.

Public Instance Properties

EventArgs (inherited from ChangeUndoManager) | Gets the change notification event data as specified in the call to the Initialize method.
IsInitialized (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been initialized.
Label (inherited from ChangeUndoManager) | Gets the label of the change recorded by this instance.
Sender (inherited from ChangeUndoManager) | Gets the sender of the event notification that was specified in the call to the Initialize method.

Protected Instance Properties

ChangeLabel (inherited from ChangeUndoManager) | The change label that has been passed to the Initialize method call.
IsCommitted (inherited from ChangeUndoManager) | Gets a value indicating whether this instance has been committed.
PropertyDescriptor | Gets the property descriptor representing the changed property.
PropertyChangeEventArgs | Gets a reference to the PropertyChangeEventArgs instance associated with this instance.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager.PropertyDescriptor Property

Gets the property descriptor representing the changed property.

[Visual Basic]
Protected ReadOnly Property PropertyDescriptor As PropertyDescriptor
[C#]
protected System.ComponentModel.PropertyDescriptor PropertyDescriptor {get;}

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager.PropertyChangeEventArgs Property

Gets a reference to the PropertyChangeEventArgs instance associated with this instance.

[Visual Basic]
Protected ReadOnly Property PropertyChangeEventArgs As PropertyChangeEventArgs
[C#]
protected PropertyChangeEventArgs PropertyChangeEventArgs {get;}

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager Methods

The methods of the PropertyChangeUndoManager class are listed below. For a complete list of PropertyChangeUndoManager class members, see the PropertyChangeUndoManager Members topic.

Public Instance Methods

Commit (inherited from ChangeUndoManager) | Indicates that a change has been completed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initializes an instance for the specified property change.
Initialize (inherited from ChangeUndoManager) | Overloaded. Initializes an instance for the specified change notification.
Match (inherited from ChangeUndoManager) | Checks whether the specified arguments match the change notification recorded by this instance.
Redo | Redoes (re-applies) the property change represented by this instance.
ToString | Returns a String that represents the current Object.
Undo | Undoes the property change represented by this instance.

Protected Instance Methods

AssertIsCommitted (inherited from ChangeUndoManager) | Asserts the instance is committed.
AssertIsInitialized (inherited from ChangeUndoManager) | Asserts the instance is initialized.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


Initialize Method

Constable Authorization Engine 2.0 BETA

PropertyChangeUndoManager.Initialize Method

[This is preliminary documentation and subject to change.]

Initializes an instance for the specified property change.

Overload List

Inherited from ChangeUndoManager.

public bool Initialize(object,ChangeEventArgs);

Initializes an instance for the specified property change.

public override bool Initialize(object,ChangeEventArgs,string);

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager.Initialize Method (Object, ChangeEventArgs, String)

Initializes an instance for the specified property change.

[Visual Basic]
Overrides Overloads Public Function Initialize( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs, _
ByVal changeLabel As String _
) As Boolean
[C#]
public override bool Initialize(
object sender,
ChangeEventArgs e,
string changeLabel
);

Parameters

sender
The sender of the change notification.
e
The PropertyChangeEventArgs instance containing the event data.
changeLabel
The optional change label to be displayed to the user.

Return Value

true if the initialization was successfull and the manager will be able to undo the change; false otherwise.

Remarks

The method is typically called as part of processing the InstanceChanging event before the actual change takes place.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace | PropertyChangeUndoManager.Initialize Overload List


PropertyChangeUndoManager.Redo Method

Redoes (re-applies) the property change represented by this instance.

[Visual Basic]
Overrides Public Sub Redo() _
Implements IUndoItem.Redo
[C#]
public override void Redo();

Implements

IUndoItem.Redo

Remarks

The redo operation sets the property to the NewValue.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that represents the current Object.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


PropertyChangeUndoManager.Undo Method

Undoes the property change represented by this instance.

[Visual Basic]
Overrides Public Sub Undo() _
Implements IUndoItem.Undo
[C#]
public override void Undo();

Implements

IUndoItem.Undo

Remarks

The undo operation sets the property to the OldValue.

See Also

PropertyChangeUndoManager Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute Class

Associates a class with a descriptor containing metadata that describe several aspects of the decorated class understood and used by the design-time infrastructure.

For a list of all members of this type, see TypeInfoAttribute Members.

System.Object
System.Attribute
LaMarvin.ComponentModel.TypeInfoAttribute

[Visual Basic]
NotInheritable Public Class TypeInfoAttribute
Inherits Attribute
[C#]
public sealed class TypeInfoAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

TypeInfoAttribute Members | LaMarvin.ComponentModel Namespace


TypeInfoAttribute Members

TypeInfoAttribute overview

Public Instance Constructors

TypeInfoAttribute Overloaded. Initializes a new instance of the TypeInfoAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.
TypeInfoTypeName | Gets the name of the type info describing type.

Public Instance Methods

Equals | Compares two instances of the TypeInfoAttribute for equality.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute Constructor

Initializes a new instance of the TypeInfoAttribute class with the given type name.

Overload List

Initializes a new instance of the TypeInfoAttribute class with the given type name.

public TypeInfoAttribute(string);

Initializes a new instance of the TypeInfoAttribute class with the given type

public TypeInfoAttribute(Type);

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute Constructor (String)

Initializes a new instance of the TypeInfoAttribute class with the given type name.

[Visual Basic]
Overloads Public Sub New( _
ByVal typeInfoTypeName As String _
)
[C#]
public TypeInfoAttribute(
string typeInfoTypeName
);

Parameters

typeInfoTypeName
The fully-qualified type name of the type info class.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace | TypeInfoAttribute Constructor Overload List


TypeInfoAttribute Constructor (Type)

Initializes a new instance of the TypeInfoAttribute class with the given type

[Visual Basic]
Overloads Public Sub New( _
ByVal typeInfoType As Type _
)
[C#]
public TypeInfoAttribute(
Type typeInfoType
);

Parameters

typeInfoType
Type of the type info descriptor class.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace | TypeInfoAttribute Constructor Overload List


TypeInfoAttribute Properties

The properties of the TypeInfoAttribute class are listed below. For a complete list of TypeInfoAttribute class members, see the TypeInfoAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.
TypeInfoTypeName | Gets the name of the type info describing type.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute.TypeInfoTypeName Property

Gets the name of the type info describing type.

[Visual Basic]
Public ReadOnly Property TypeInfoTypeName As String
[C#]
public string TypeInfoTypeName {get;}

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute Methods

The methods of the TypeInfoAttribute class are listed below. For a complete list of TypeInfoAttribute class members, see the TypeInfoAttribute Members topic.

Public Instance Methods

Equals | Compares two instances of the TypeInfoAttribute for equality.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute.Equals Method

Compares two instances of the TypeInfoAttribute for equality.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The other instance to compare this instance to.

Return Value

Returns true if this instance equals to ; false otherwise.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


TypeInfoAttribute.GetHashCode Method

Returns the hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

A 32-bit signed integer hash code.

See Also

TypeInfoAttribute Class | LaMarvin.ComponentModel Namespace


UndoEngine Class

Implements undo/redo services for object graphs that generate change notification events by means of the IChangeEventSource interface contract.

For a list of all members of this type, see UndoEngine Members.

System.Object
LaMarvin.ComponentModel.UndoEngine

[Visual Basic]
NotInheritable Public Class UndoEngine
[C#]
public sealed class UndoEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The UndoEngine class is associated with an object graph by setting the RootInstance property. After setting the property, the UndoEngine instance listens to change notification events, records them in a form of a collection of ChangeUndoManager-derived instances and allows for undoing and/or redoing the changes upon request.

The UndoEngine allows also grouping a set of individual changes to form one logical change by enclosing the set of changes within the BeginUndoGroup/CommitUndoGroup method calls.

Note The UndoEngine itself doesn't understand how to undo/redo individual changes. Instead, it asks the ChangeEventArgs-derived event arguments to create a corresponding ChangeUndoManager instance, that is stored and subsequently used to undo/redo the change.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

UndoEngine Members | LaMarvin.ComponentModel Namespace


UndoEngine Members

UndoEngine overview

Public Static (Shared) Fields

DefaultUndoLimit The default number of undo entries that the UndoEngine stores.

Public Instance Constructors

UndoEngine Overloaded. Initializes a new instance of the UndoEngine class.

Public Instance Properties

CanRedo | Gets a value indicating whether the Redo operation can be performed.
CanUndo | Gets a value indicating whether the Undo operation can be performed.
IsEnabled | Gets a value indicating whether this instance is allowed to record change notifications.
IsRecording | Gets a value indicating whether this instance is recording a change.
IsRedoing | Gets a value indicating whether this instance is currently re-doing a change.
IsUndoGroupActive | Gets a value indicating whether this instance has an active undo group.
IsUndoing | Gets a value indicating whether this instance is currently undoing a change.
IsUndoingOrRedoing | Gets a value indicating whether this instance is undoing or redoing.
Limit | Gets or sets the max. number of undo entries this instance will keep in memory.
NextChangeLabel | Gets or sets the change label that will be associated with the next recorded change notification.
RecordingExpirationInterval | Gets or sets the recording expiration interval.
RedoItems | Gets the collection of undone changes that can be redone (re-applied).
RedoLabel | Gets the label for the operation that will be re-done by calling the Redo method.
RootInstance | Gets or sets the root instance associated with the UndoEngine.
UndoItems | Gets the collection of recorded changes that can be undone.
UndoLabel | Gets the label for the operation that will be undone by calling the Undo method.

Public Instance Methods

BeginUndoGroup | Overloaded. Begins a new undo group.
Clear | Clears this instance by removing all cached undo and redo entries.
CommitUndoGroup | Overloaded. Commits the active undo group.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Redo | Re-does the most recently undoed change.
ResetRecording | Relinguishes any accumulated recording state and causes the engine to be ready to record new set of change events.
RollbackUndoGroup | Overloaded. Rollbacks the undo group.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Undoes the most recently recorded change or undo group.

Public Instance Events

RedoComplete | The event is raised after a redo operation has taken place.
UndoComplete | The event is raised after an undo operation has taken place.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine Constructor

Initializes a new instance of the UndoEngine class.

Overload List

Initializes a new instance of the UndoEngine class.

public UndoEngine();

Initializes a new instance of the UndoEngine class with the given rootInstance.

public UndoEngine(IChangeEventSource);

Initializes a new instance of the UndoEngine class with the given rootInstance and undoLimit.

public UndoEngine(IChangeEventSource,int);

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine Constructor ()

Initializes a new instance of the UndoEngine class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public UndoEngine();

Remarks

You can later associate the instance with a change event source by setting the RootInstance property.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine Constructor Overload List


UndoEngine Constructor (IChangeEventSource)

Initializes a new instance of the UndoEngine class with the given rootInstance.

[Visual Basic]
Overloads Public Sub New( _
ByVal rootInstance As IChangeEventSource _
)
[C#]
public UndoEngine(
IChangeEventSource rootInstance
);

Parameters

rootInstance
The root instance; the source of change events.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine Constructor Overload List


UndoEngine Constructor (IChangeEventSource, Int32)

Initializes a new instance of the UndoEngine class with the given rootInstance and undoLimit.

[Visual Basic]
Overloads Public Sub New( _
ByVal rootInstance As IChangeEventSource, _
ByVal undoLimit As Integer _
)
[C#]
public UndoEngine(
IChangeEventSource rootInstance,
int undoLimit
);

Parameters

rootInstance
The root instance; the source of change events.
undoLimit
The undo limit.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine Constructor Overload List


UndoEngine Fields

The fields of the UndoEngine class are listed below. For a complete list of UndoEngine class members, see the UndoEngine Members topic.

Public Static (Shared) Fields

DefaultUndoLimit The default number of undo entries that the UndoEngine stores.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.DefaultUndoLimit Field

The default number of undo entries that the UndoEngine stores.

[Visual Basic]
Public Const DefaultUndoLimit As Integer = 1000
[C#]
public const int DefaultUndoLimit = 1000;

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine Properties

The properties of the UndoEngine class are listed below. For a complete list of UndoEngine class members, see the UndoEngine Members topic.

Public Instance Properties

CanRedo | Gets a value indicating whether the Redo operation can be performed.
CanUndo | Gets a value indicating whether the Undo operation can be performed.
IsEnabled | Gets a value indicating whether this instance is allowed to record change notifications.
IsRecording | Gets a value indicating whether this instance is recording a change.
IsRedoing | Gets a value indicating whether this instance is currently re-doing a change.
IsUndoGroupActive | Gets a value indicating whether this instance has an active undo group.
IsUndoing | Gets a value indicating whether this instance is currently undoing a change.
IsUndoingOrRedoing | Gets a value indicating whether this instance is undoing or redoing.
Limit | Gets or sets the max. number of undo entries this instance will keep in memory.
NextChangeLabel | Gets or sets the change label that will be associated with the next recorded change notification.
RecordingExpirationInterval | Gets or sets the recording expiration interval.
RedoItems | Gets the collection of undone changes that can be redone (re-applied).
RedoLabel | Gets the label for the operation that will be re-done by calling the Redo method.
RootInstance | Gets or sets the root instance associated with the UndoEngine.
UndoItems | Gets the collection of recorded changes that can be undone.
UndoLabel | Gets the label for the operation that will be undone by calling the Undo method.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.CanRedo Property

Gets a value indicating whether the Redo operation can be performed.

[Visual Basic]
Public ReadOnly Property CanRedo As Boolean
[C#]
public bool CanRedo {get;}

Property Value

true if the Redo operation can be performed; otherwise false.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.CanUndo Property

Gets a value indicating whether the Undo operation can be performed.

[Visual Basic]
Public ReadOnly Property CanUndo As Boolean
[C#]
public bool CanUndo {get;}

Property Value

true if the Undo operation can be performed; otherwise false.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsEnabled Property

Gets a value indicating whether this instance is allowed to record change notifications.

[Visual Basic]
Public Property IsEnabled As Boolean
[C#]
public bool IsEnabled {get; set;}

Property Value

true if this instance records changes; otherwisefalse .

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsRecording Property

Gets a value indicating whether this instance is recording a change.

[Visual Basic]
Public ReadOnly Property IsRecording As Boolean
[C#]
public bool IsRecording {get;}

Property Value

true if this instance is recording a change; otherwisefalse .

Remarks

When the UndoEngine catches the InstanceChanging event generated by the associated RootInstance, it remains in the 'recording' state until the engine catches the corresponding InstanceChanged event, until the RecordingExpirationInterval has not elapsed or util the ResetRecording method isn't called.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsRedoing Property

Gets a value indicating whether this instance is currently re-doing a change.

[Visual Basic]
Public ReadOnly Property IsRedoing As Boolean
[C#]
public bool IsRedoing {get;}

Property Value

true if this instance is redoing; otherwisefalse .

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsUndoGroupActive Property

Gets a value indicating whether this instance has an active undo group.

[Visual Basic]
Public ReadOnly Property IsUndoGroupActive As Boolean
[C#]
public bool IsUndoGroupActive {get;}

Property Value

true if this instance has an active undo group; otherwisefalse .

Remarks

An undo group is activated by calling the BeginUndoGroup method and deactivated by calling the CommitUndoGroup, RollbackUndoGroup or Clear methods, or by associating the UndoEngine with a new change event source by setting the RootInstance property.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsUndoing Property

Gets a value indicating whether this instance is currently undoing a change.

[Visual Basic]
Public ReadOnly Property IsUndoing As Boolean
[C#]
public bool IsUndoing {get;}

Property Value

true if this instance is undoing; otherwisefalse .

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.IsUndoingOrRedoing Property

Gets a value indicating whether this instance is undoing or redoing.

[Visual Basic]
Public ReadOnly Property IsUndoingOrRedoing As Boolean
[C#]
public bool IsUndoingOrRedoing {get;}

Property Value

true if this instance is undoing or redoing changes; otherwisefalse .

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.Limit Property

Gets or sets the max. number of undo entries this instance will keep in memory.

[Visual Basic]
Public Property Limit As Integer
[C#]
public int Limit {get; set;}

Property Value

The undo limit.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.NextChangeLabel Property

Gets or sets the change label that will be associated with the next recorded change notification.

[Visual Basic]
Public Property NextChangeLabel As String
[C#]
public string NextChangeLabel {get; set;}

Property Value

The next change label.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RecordingExpirationInterval Property

Gets or sets the recording expiration interval.

[Visual Basic]
Public Property RecordingExpirationInterval As TimeSpan
[C#]
public System.TimeSpan RecordingExpirationInterval {get; set;}

Property Value

The recording expiration interval.

Remarks

Recording expiration interval specifies the duration for which the UndoEngine maintains state for the recorded InstanceChanging event. If no InstanceChanged event is recorded within the RecordingExpirationInterval, the InstanceChanging state is relinguished and the UndoEngine is ready to record new change events.

The recording expiration feature is useful in cases where change events aren't raised in pairs ( for instance the InstanceChanging is raised but an exception is thrown later causing the corresponding InstanceChanged event to be missing).

The initial value for the property is set to 1.5 second that should be feasible for most user generated change events.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RedoItems Property

Gets the collection of undone changes that can be redone (re-applied).

[Visual Basic]
Public ReadOnly Property RedoItems As UndoItemCollection
[C#]
public UndoItemCollection RedoItems {get;}

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RedoLabel Property

Gets the label for the operation that will be re-done by calling the Redo method.

[Visual Basic]
Public ReadOnly Property RedoLabel As String
[C#]
public string RedoLabel {get;}

Property Value

The redo label.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RootInstance Property

Gets or sets the root instance associated with the UndoEngine.

[Visual Basic]
Public Property RootInstance As IChangeEventSource
[C#]
public IChangeEventSource RootInstance {get; set;}

Property Value

The root instance.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoItems Property

Gets the collection of recorded changes that can be undone.

[Visual Basic]
Public ReadOnly Property UndoItems As UndoItemCollection
[C#]
public UndoItemCollection UndoItems {get;}

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoLabel Property

Gets the label for the operation that will be undone by calling the Undo method.

[Visual Basic]
Public ReadOnly Property UndoLabel As String
[C#]
public string UndoLabel {get;}

Property Value

The undo label.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine Methods

The methods of the UndoEngine class are listed below. For a complete list of UndoEngine class members, see the UndoEngine Members topic.

Public Instance Methods

BeginUndoGroup | Overloaded. Begins a new undo group.
Clear | Clears this instance by removing all cached undo and redo entries.
CommitUndoGroup | Overloaded. Commits the active undo group.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Redo | Re-does the most recently undoed change.
ResetRecording | Relinguishes any accumulated recording state and causes the engine to be ready to record new set of change events.
RollbackUndoGroup | Overloaded. Rollbacks the undo group.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Undoes the most recently recorded change or undo group.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


BeginUndoGroup Method

Constable Authorization Engine 2.0 BETA

UndoEngine.BeginUndoGroup Method

[This is preliminary documentation and subject to change.]

Begins a new undo group.

Overload List

Begins a new undo group.

public UndoGroup BeginUndoGroup();

Begins a new undo group with the given label.

public UndoGroup BeginUndoGroup(string);

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.BeginUndoGroup Method ()

Begins a new undo group.

[Visual Basic]
Overloads Public Function BeginUndoGroup() As UndoGroup
[C#]
public UndoGroup BeginUndoGroup();

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.BeginUndoGroup Overload List


UndoEngine.BeginUndoGroup Method (String)

Begins a new undo group with the given label.

[Visual Basic]
Overloads Public Function BeginUndoGroup( _
ByVal label As String _
) As UndoGroup
[C#]
public UndoGroup BeginUndoGroup(
string label
);

Parameters

label
The label of the undo group.

Return Value

A reference to a UndoEngine.UndoGroup instance that represents the undo group.

Exceptions

Exception Type | Condition
UndoException | An undo group is already active. Undo groups cannot be nested; you have to first close the active undo group before you can activate another.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.BeginUndoGroup Overload List


UndoEngine.Clear Method

Clears this instance by removing all cached undo and redo entries.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

Remarks

If the UndoEngine has been inside an undo group, the undo group context is cleared as well. If you've cached a reference to the UndoEngine.UndoGroup instance, the instance is disposed.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


CommitUndoGroup Method

Constable Authorization Engine 2.0 BETA

UndoEngine.CommitUndoGroup Method

[This is preliminary documentation and subject to change.]

Commits the active undo group.

Overload List

Commits the active undo group.

public void CommitUndoGroup();

Commits the given undo group.

public void CommitUndoGroup(UndoGroup);

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.CommitUndoGroup Method ()

Commits the active undo group.

[Visual Basic]
Overloads Public Sub CommitUndoGroup()
[C#]
public void CommitUndoGroup();

Remarks

Commiting the active undo group stores it as a unit that can be later undone by a single call to the Undo method.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.CommitUndoGroup Overload List


UndoEngine.CommitUndoGroup Method (UndoGroup)

Commits the given undo group.

[Visual Basic]
Overloads Public Sub CommitUndoGroup( _
ByVal group As UndoGroup _
)
[C#]
public void CommitUndoGroup(
UndoGroup group
);

Remarks

Commiting the active undo group stores it as a unit that can be later undone by a single call to the Undo method.

Exceptions

Exception Type | Condition
UndoException | The specified undo group doesn't belong to this UndoEngine.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.CommitUndoGroup Overload List


UndoEngine.Redo Method

Re-does the most recently undoed change.

[Visual Basic]
Public Sub Redo()
[C#]
public void Redo();

Exceptions

Exception Type | Condition
UndoException | The redo operation cannot be performed, for example because there are no changes to be redone, or the UndoEngine is currently in the process of recording a change.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.ResetRecording Method

Relinguishes any accumulated recording state and causes the engine to be ready to record new set of change events.

[Visual Basic]
Public Function ResetRecording() As Boolean
[C#]
public bool ResetRecording();

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


RollbackUndoGroup Method

Constable Authorization Engine 2.0 BETA

UndoEngine.RollbackUndoGroup Method

[This is preliminary documentation and subject to change.]

Rollbacks the active undo group.

Overload List

Rollbacks the active undo group.

public bool RollbackUndoGroup();

Rollbacks the undo group.

public bool RollbackUndoGroup(UndoGroup);

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RollbackUndoGroup Method ()

Rollbacks the active undo group.

[Visual Basic]
Overloads Public Function RollbackUndoGroup() As Boolean
[C#]
public bool RollbackUndoGroup();

Remarks

For more information please see the overloaded RollbackUndoGroup method documentation.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.RollbackUndoGroup Overload List


UndoEngine.RollbackUndoGroup Method (UndoGroup)

Rollbacks the undo group.

[Visual Basic]
Overloads Public Function RollbackUndoGroup( _
ByVal group As UndoGroup _
) As Boolean
[C#]
public bool RollbackUndoGroup(
UndoGroup group
);

Parameters

group
The undo group reference previously returned by a call to the BeginUndoGroup method.

Return Value

true if there were an active undo group and it has been rolled back; otherwise false.

Remarks

This method never raises an exception. This makes it feasible to call the method in finally or using blocks to ensure undo groups aren't abandoned when an exception is thrown during recording the changes for the undo group.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace | UndoEngine.RollbackUndoGroup Overload List


UndoEngine.Undo Method

Undoes the most recently recorded change or undo group.

[Visual Basic]
Public Sub Undo()
[C#]
public void Undo();

Exceptions

Exception Type | Condition
UndoException | The undo operation cannot be performed, for example because there are no changes to be undone, or the UndoEngine is currently in the process of recording a change.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine Events

The events of the UndoEngine class are listed below. For a complete list of UndoEngine class members, see the UndoEngine Members topic.

Public Instance Events

RedoComplete | The event is raised after a redo operation has taken place.
UndoComplete | The event is raised after an undo operation has taken place.

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.RedoComplete Event

The event is raised after a redo operation has taken place.

[Visual Basic]
Public Event RedoComplete As EventHandler
[C#]
public event EventHandler RedoComplete;

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoComplete Event

The event is raised after an undo operation has taken place.

[Visual Basic]
Public Event UndoComplete As EventHandler
[C#]
public event EventHandler UndoComplete;

See Also

UndoEngine Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup Class

Represents a group of changes that should be handled as a unit.

For a list of all members of this type, see UndoEngine.UndoGroup Members.

System.Object
LaMarvin.ComponentModel.UndoEngine.UndoGroup

[Visual Basic]
NotInheritable Public Class UndoEngine.UndoGroup
Implements IDisposable
[C#]
public sealed class UndoEngine.UndoGroup : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

UndoEngine.UndoGroup Members | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup Members

UndoEngine.UndoGroup overview

Public Instance Properties

IsDisposed | Gets a value indicating whether this instance is disposed.
Label | The label describing the changes encompassed by this undo group to the user.

Public Instance Methods

Commit | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Rollback | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
ToString | Returns a String that represents the current Object.

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup Properties

The properties of the UndoEngine.UndoGroup class are listed below. For a complete list of UndoEngine.UndoGroup class members, see the UndoEngine.UndoGroup Members topic.

Public Instance Properties

IsDisposed | Gets a value indicating whether this instance is disposed.
Label | The label describing the changes encompassed by this undo group to the user.

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup.IsDisposed Property

Gets a value indicating whether this instance is disposed.

[Visual Basic]
Public ReadOnly Property IsDisposed As Boolean
[C#]
public bool IsDisposed {get;}

Property Value

true if this instance is disposed; otherwise false.

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup.Label Property

The label describing the changes encompassed by this undo group to the user.

[Visual Basic]
Public ReadOnly Property Label As String
[C#]
public string Label {get;}

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup Methods

The methods of the UndoEngine.UndoGroup class are listed below. For a complete list of UndoEngine.UndoGroup class members, see the UndoEngine.UndoGroup Members topic.

Public Instance Methods

Commit | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Rollback | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
ToString | Returns a String that represents the current Object.

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup.Commit Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Sub Commit()
[C#]
public void Commit();

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup.Rollback Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Function Rollback() As Boolean
[C#]
public bool Rollback();

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoEngine.UndoGroup.ToString Method

Returns a String that represents the current Object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A String that represents the current Object.

See Also

UndoEngine.UndoGroup Class | LaMarvin.ComponentModel Namespace


UndoException Class

Exception signifying failures in the designer undo feature.

For a list of all members of this type, see UndoException Members.

System.Object
System.Exception
LaMarvin.ComponentModel.UndoException

[Visual Basic]
<Serializable>
Public Class UndoException
Inherits Exception
[C#]
[Serializable]
public class UndoException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

UndoException Members | LaMarvin.ComponentModel Namespace


UndoException Members

UndoException overview

Public Instance Constructors

UndoException Overloaded. Initializes a new instance of the UndoException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

UndoException Overloaded. Initializes a new instance of the UndoException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UndoException Class | LaMarvin.ComponentModel Namespace


UndoException Constructor

Initializes a new instance of the UndoException class.

Overload List

Initializes a new instance of the UndoException class.

public UndoException();

Initializes a new instance of the UndoException class for deserialization.

protected UndoException(SerializationInfo,StreamingContext);

Initializes a new instance of the UndoException class with the given message.

public UndoException(string);

Initializes a new instance of the UndoException class with the given message and an inner Exception.

public UndoException(string,Exception);

See Also

UndoException Class | LaMarvin.ComponentModel Namespace


UndoException Constructor ()

Initializes a new instance of the UndoException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public UndoException();

See Also

UndoException Class | LaMarvin.ComponentModel Namespace | UndoException Constructor Overload List


UndoException Constructor (String)

Initializes a new instance of the UndoException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public UndoException(
string message
);

See Also

UndoException Class | LaMarvin.ComponentModel Namespace | UndoException Constructor Overload List


UndoException Constructor (String, Exception)

Initializes a new instance of the UndoException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public UndoException(
string message,
Exception innerException
);

See Also

UndoException Class | LaMarvin.ComponentModel Namespace | UndoException Constructor Overload List


UndoException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the UndoException class for deserialization.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected UndoException(
SerializationInfo info,
StreamingContext context
);

See Also

UndoException Class | LaMarvin.ComponentModel Namespace | UndoException Constructor Overload List


UndoItemCollection Class

Represents a collection of IUndoItem-compatible objects.

For a list of all members of this type, see UndoItemCollection Members.

System.Object
LaMarvin.ComponentModel.UndoItemCollection

[Visual Basic]
NotInheritable Public Class UndoItemCollection
Implements IEnumerable, IUndoItem
[C#]
public sealed class UndoItemCollection : IEnumerable, IUndoItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.ComponentModel

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

UndoItemCollection Members | LaMarvin.ComponentModel Namespace


UndoItemCollection Members

UndoItemCollection overview

Public Instance Constructors

UndoItemCollection Overloaded. Initializes a new instance of the UndoItemCollection class.

Public Instance Properties

Count | Returns the number of items in the collection.
Item | Gets the IUndoItem reference with the specified index
Label | Gets the label that descibes the group of changes represented by this collection.
Last | Returns a reference to the last item in the collection, or a null reference (Nothing in Visual Basic) if the collection is empty.
Limit | Gets or sets the maximum number of item this collection can contain.

Public Instance Methods

Add | Adds the specified item to the end of the collection.
Clear | Removes all items from the collection.
Contains | Determines whether this collection contains the specified IUndoItem.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an IEnumerator that can iterate over all items currently in the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Redo | Redoes the set of changes represented by this collection.
RemoveLast | Removes the last item from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Undoes the set of changes represented by this collection.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection Constructor

Initializes a new instance of the UndoItemCollection class with the Limit property set to DefaultUndoLimit

Overload List

Initializes a new instance of the UndoItemCollection class with the Limit property set to DefaultUndoLimit

public UndoItemCollection();

Initializes a new instance of the UndoItemCollection class with the given limit.

public UndoItemCollection(int);

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection Constructor ()

Initializes a new instance of the UndoItemCollection class with the Limit property set to DefaultUndoLimit

[Visual Basic]
Overloads Public Sub New()
[C#]
public UndoItemCollection();

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace | UndoItemCollection Constructor Overload List


UndoItemCollection Constructor (Int32)

Initializes a new instance of the UndoItemCollection class with the given limit.

[Visual Basic]
Overloads Public Sub New( _
ByVal limit As Integer _
)
[C#]
public UndoItemCollection(
int limit
);

Parameters

limit
The maximum number of items this collection can contain.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace | UndoItemCollection Constructor Overload List


UndoItemCollection Properties

The properties of the UndoItemCollection class are listed below. For a complete list of UndoItemCollection class members, see the UndoItemCollection Members topic.

Public Instance Properties

Count | Returns the number of items in the collection.
Item | Gets the IUndoItem reference with the specified index
Label | Gets the label that descibes the group of changes represented by this collection.
Last | Returns a reference to the last item in the collection, or a null reference (Nothing in Visual Basic) if the collection is empty.
Limit | Gets or sets the maximum number of item this collection can contain.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Count Property

Returns the number of items in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Item Property

Gets the IUndoItem reference with the specified index

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As IUndoItem
[C#]
public IUndoItem this[
int index
] {get;}

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Label Property

Gets the label that descibes the group of changes represented by this collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Label As String _
Implements IUndoItem.Label
[C#]
public string Label {get;}

Implements

IUndoItem.Label

Remarks

The implementation returns the value of the Label property of the first item in the collection. If the collection is empty, an empty string is returned.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Last Property

Returns a reference to the last item in the collection, or a null reference (Nothing in Visual Basic) if the collection is empty.

[Visual Basic]
Public ReadOnly Property Last As IUndoItem
[C#]
public IUndoItem Last {get;}

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Limit Property

Gets or sets the maximum number of item this collection can contain.

[Visual Basic]
Public Property Limit As Integer
[C#]
public int Limit {get; set;}

Remarks

If the Add operation would get over the limit, the first item in the collection is discarded before the new item is added to the end of the collection.

Exceptions

Exception Type | Condition
ArgumentException | An attempt was made to set the property to a negative value.

Example

The following code demostrates the effects of setting the Limit property to one.

[Visual Basic]
Imports System
Imports System.Diagnostics

Imports LaMarvin.ComponentModel

Public Class UndoItemCollectionLimit
  Public Shared Sub Main()
    ' Create the collection.
    Dim managers As UndoItemCollection = New UndoItemCollection
    Debug.Assert(UndoEngine.DefaultUndoLimit = managers.Limit)

    ' Set the limit to one - only the last item will be kept in the collection.
    managers.Limit = 1

    ' Add an IUndoItem-compatible item.
    managers.Add(New PropertyChangeUndoManager)
    Debug.Assert(managers.Count = 1)

    ' newManager replaces the previous one.
    Dim NewManager As PropertyChangeUndoManager = New PropertyChangeUndoManager
    managers.Add(NewManager)
    Debug.Assert(managers.Count = 1)
    Debug.Assert(NewManager.Equals(managers.Last))
    Debug.Assert(NewManager.Equals(managers(0)))
  End Sub
End Class

[C#]
using System;
using System.Diagnostics;

using LaMarvin.ComponentModel;

public sealed class UndoItemCollectionLimit
{
  public static void Main()
  {
    // Create the collection.
    UndoItemCollection managers = new UndoItemCollection();
    Debug.Assert(UndoEngine.DefaultUndoLimit == managers.Limit);

    // Set the limit to one - only the last item will be kept in the collection.
    managers.Limit = 1;

    // Add an IUndoItem-compatible item.
    managers.Add(new PropertyChangeUndoManager());
    Debug.Assert(managers.Count == 1);

    // newManager replaces the previous one.
    PropertyChangeUndoManager newManager = new PropertyChangeUndoManager();
    managers.Add(newManager);
    Debug.Assert(managers.Count == 1);
    Debug.Assert(newManager == managers.Last);
    Debug.Assert(newManager == managers[0]);
  }
}

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection Methods

The methods of the UndoItemCollection class are listed below. For a complete list of UndoItemCollection class members, see the UndoItemCollection Members topic.

Public Instance Methods

Add | Adds the specified item to the end of the collection.
Clear | Removes all items from the collection.
Contains | Determines whether this collection contains the specified IUndoItem.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an IEnumerator that can iterate over all items currently in the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Redo | Redoes the set of changes represented by this collection.
RemoveLast | Removes the last item from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.
Undo | Undoes the set of changes represented by this collection.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Add Method

Adds the specified item to the end of the collection.

[Visual Basic]
Public Function Add( _
ByVal item As IUndoItem _
) As Integer
[C#]
public int Add(
IUndoItem item
);

Parameters

item
The item reference.

Return Value

The index of the added item.

Remarks

If the Add operation would exceed the Limit, the first collection item is discarded.

For an example, please see the Limit property documentation page.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Clear Method

Removes all items from the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Contains Method

Determines whether this collection contains the specified IUndoItem.

[Visual Basic]
Public Function Contains( _
ByVal item As IUndoItem _
) As Boolean
[C#]
public bool Contains(
IUndoItem item
);

Parameters

item
The item reference.

Return Value

true if the collection contains the item; otherwise false.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.GetEnumerator Method

Returns an IEnumerator that can iterate over all items currently in the collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Redo Method

Redoes the set of changes represented by this collection.

[Visual Basic]
NotOverridable Public Sub Redo() _
Implements IUndoItem.Redo
[C#]
public void Redo();

Implements

IUndoItem.Redo

Remarks

The implementation simply calls the Redo method sequentially for all items in the collection.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.RemoveLast Method

Removes the last item from the collection.

[Visual Basic]
Public Sub RemoveLast()
[C#]
public void RemoveLast();

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The collection is empty.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


UndoItemCollection.Undo Method

Undoes the set of changes represented by this collection.

[Visual Basic]
NotOverridable Public Sub Undo() _
Implements IUndoItem.Undo
[C#]
public void Undo();

Implements

IUndoItem.Undo

Remarks

The implementation simply calls the Undo method sequentially for all items in the collection.

See Also

UndoItemCollection Class | LaMarvin.ComponentModel Namespace


LaMarvin.Constable

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable Namespace

[This is preliminary documentation and subject to change.]

The LaMarvin.Constable namespace contains the core AuthorizationPolicy class and supporting types.

Namespace hierarchy

Classes

Class | Description
ActionExecutionEventArgs | Defines arguments for the ActionExecuting and ActionExecuted events.
AuthorizationPolicy | Encapsulates a single authorization policy and implements the core authorization functionality to be used from within your application.
AuthorizationPolicyLoader | Provides methods for saving and loading authorization policys to/from various media types.
AuthorizationPolicyLoader.XmlElementNames | Defines the names of XML elements that comprise the definition of an authorization policy stored in a XML file.
ConstableException | The base class for all exceptions generated by the CAZE library.
DuplicateAuthorizationRuleException | The exception that is thrown by an AuthorizationPolicy when attempting to add a duplicate authorization rule to the ActionRules or PropertyRules collections.
NonDeterministicModelException | The exception that is thrown by the ExecuteAction method when attempting to execute a non-deterministic action.
PermissionDeniedException | The exception that is thrown by the ExecuteAction method when attempting to execute a disabled action.
ResolveRoleMembershipEventArgs | Defines arguments for the ResolveRoleMembership event.

Delegates

Delegate | Description
ActionExecutionEventHandler | Defines a signature for methods that can handle the ActionExecuting and ActionExecuted events.
ResolveRoleMembershipEventHandler | The signature for methods that can handle the ResolveRoleMembership event.

Enumerations

Enumeration | Description
EnabledOption | Specifies the required value of the IsEnabled property for rules to be returned from the GetDefinedActionRules and GetDefinedPropertyRules methods.
VisibleOption | Specifies the required value of the IsVisible property for rules to be returned from the GetDefinedActionRules and GetDefinedPropertyRules methods.


ActionExecutionEventArgs Class

Defines arguments for the ActionExecuting and ActionExecuted events.

For a list of all members of this type, see ActionExecutionEventArgs Members.

System.Object
System.EventArgs
LaMarvin.Constable.ActionExecutionEventArgs

[Visual Basic]
<Serializable>
Public Class ActionExecutionEventArgs
Inherits EventArgs
[C#]
[Serializable]
public class ActionExecutionEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ActionExecutionEventArgs Members | LaMarvin.Constable Namespace


ActionExecutionEventArgs Members

ActionExecutionEventArgs overview

Public Instance Constructors

ActionExecutionEventArgs Constructor Initializes a new instance of the ActionExecutionEventArgs class with the given ActionRule.

Public Instance Properties

ActionRule Returns the ActionRule for the action being executed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActionExecutionEventArgs Class | LaMarvin.Constable Namespace


ActionExecutionEventArgs Constructor

Initializes a new instance of the ActionExecutionEventArgs class with the given ActionRule.

[Visual Basic]
Public Sub New( _
ByVal rule As ActionRule _
)
[C#]
public ActionExecutionEventArgs(
ActionRule rule
);

Parameters

rule
The ActionRule whose Action is being executed.

See Also

ActionExecutionEventArgs Class | LaMarvin.Constable Namespace


ActionExecutionEventArgs Properties

The properties of the ActionExecutionEventArgs class are listed below. For a complete list of ActionExecutionEventArgs class members, see the ActionExecutionEventArgs Members topic.

Public Instance Properties

ActionRule Returns the ActionRule for the action being executed.

See Also

ActionExecutionEventArgs Class | LaMarvin.Constable Namespace


ActionExecutionEventArgs.ActionRule Property

Returns the ActionRule for the action being executed.

[Visual Basic]
Public ReadOnly Property ActionRule As ActionRule
[C#]
public Model.ActionRule ActionRule {get;}

See Also

ActionExecutionEventArgs Class | LaMarvin.Constable Namespace


ActionExecutionEventHandler Delegate

Defines a signature for methods that can handle the ActionExecuting and ActionExecuted events.

[Visual Basic]
<Serializable>
Public Delegate Sub ActionExecutionEventHandler( _
ByVal sender As Object, _
ByVal e As ActionExecutionEventArgs _
)
[C#]
[Serializable]
public delegate void ActionExecutionEventHandler(
object sender,
ActionExecutionEventArgs e
);

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

LaMarvin.Constable Namespace


AuthorizationPolicy Class

Encapsulates a single authorization policy and implements the core authorization functionality to be used from within your application.

For a list of all members of this type, see AuthorizationPolicy Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.AuthorizationPolicy
LaMarvin.Constable.Design.Fallback.FallbackPolicy

[Visual Basic]
<Serializable>
Public Class AuthorizationPolicy
Inherits NamedObjectBase
Implements IChangeEventSource
[C#]
[Serializable]
public class AuthorizationPolicy : NamedObjectBase, IChangeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The methods of the class can be divided into the following categories:

Category | Description
Authorization policy definition and manipulation. | Methods in this category are used to populate and modify the authorization policy. That is, to define Roles, States, Actions, Properties and the associated ActionRules and PropertyRules.
Authorization context definition and manipulation. | You'll use properties in this category to set and retrieve the CurrentPrincipal and the CurrentState that are used for authorization checks.
Authorization checking and querying the authorization policy. | Methods in this category take into account the current authorization context to query the authorization policy for authorization rules (IsActionExecutable, GetExecutableActionRules, GetChangeablePropertyRules) and to actually ExecuteActions.

Example

The following example defines a simple authorization policy and then performs some authorization queries based on the policy:

[Visual Basic]
' Instantiate a simple authorization policy.
Dim policy As New AuthorizationPolicy

' At least one state has to be specified.
policy.States.AddNew("Default")

' Use WindowsRoles that map to the local Users and Administrators Windows group membership.
policy.Roles.Add(New WindowsRole("User", "BUILTIN\Users"))
policy.Roles.Add(New WindowsRole("Admin", "BUILTIN\Administrators"))

' Define two sample actions for both the User and Admin roles.
policy.Actions.AddNew("Logoff")
policy.Actions.AddNew("Shutdown")

' Now define the authorization rules - User can execute Logoff, Admin both actions.
policy.ActionRules.AddNew("Logoff", "User")
policy.ActionRules.AddNew("Logoff", "Admin")
policy.ActionRules.AddNew("Shutdown", "Admin")

' Associate the current Windows user with the policy.
policy.CurrentPrincipal = New WindowsPrincipal(WindowsIdentity.GetCurrent())

' If the user is an Admin, we can execute the "Shutdown" action.
If policy.Roles("Admin").IsMember(policy.CurrentPrincipal) Then
  Debug.Assert(policy.IsActionExecutable("Shutdown"))
  policy.ExecuteAction("Shutdown")
End If

' If the user is at least in the User role, she can execute Logoff.
If policy.Roles("User").IsMember(policy.CurrentPrincipal) Then
  Debug.Assert(policy.IsActionExecutable("Logoff"))
  policy.ExecuteAction("Logoff")
End If

' If there are no executable action rules for the user, she is neither an User, nor an Admin.
If policy.GetExecutableActionRules().Count = 0 Then
  Debug.Assert(Not policy.Roles("User").IsMember(policy.CurrentPrincipal))
  Debug.Assert(Not policy.Roles("Admin").IsMember(policy.CurrentPrincipal))
End If

[C#]
Instantiate a simple authorization policy.
AuthorizationPolicy policy = new AuthorizationPolicy();

// At least one state has to be specified.
policy.States.AddNew("Default");

// Use WindowsRoles that map to the local Users and Administrators Windows group membership.
policy.Roles.Add(new WindowsRole("User", @"BUILTIN\Users"));
policy.Roles.Add(new WindowsRole("Admin", @"BUILTIN\Administrators"));

// Define two sample actions for both the User and Admin roles.
policy.Actions.AddNew("Logoff");
policy.Actions.AddNew("Shutdown");

// Now define the authorization rules - User can execute Logoff, Admin both actions.
policy.ActionRules.AddNew("Logoff", "User");
policy.ActionRules.AddNew("Logoff", "Admin");
policy.ActionRules.AddNew("Shutdown", "Admin");

// Associate the current Windows user with the policy.
policy.CurrentPrincipal = new WindowsPrincipal(WindowsIdentity.GetCurrent());

// If the user is an Admin, we can execute the "Shutdown" action.
if (policy.Roles["Admin"].IsMember(policy.CurrentPrincipal))
{
  Debug.Assert(policy.IsActionExecutable("Shutdown"));
  policy.ExecuteAction("Shutdown");
}

// If the user is at least in the User role, she can execute Logoff.
if (policy.Roles["User"].IsMember(policy.CurrentPrincipal))
{
  Debug.Assert(policy.IsActionExecutable("Logoff"));
  policy.ExecuteAction("Logoff");
}

// If there are no executable action rules for the user, she is neither an User, nor an Admin.
if (policy.GetExecutableActionRules().Count == 0)
{
  Debug.Assert(!policy.Roles["User"].IsMember(policy.CurrentPrincipal));
  Debug.Assert(!policy.Roles["Admin"].IsMember(policy.CurrentPrincipal));
}

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

AuthorizationPolicy Members | LaMarvin.Constable Namespace


AuthorizationPolicy Members

AuthorizationPolicy overview

Public Instance Constructors

AuthorizationPolicy Overloaded. Initializes a new instance of the AuthorizationPolicy class.

Public Instance Properties

ActionRules | Gets the collection of all the ActionRule objects defined for the instance.
Actions | Gets the collection of all the Action objects defined for the instance.
CurrentPrincipal | Sets or returns the IPrincipal implementation used to resolve role membership.
CurrentState | Sets or returns the current state of the authorization policy.
Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Properties | Gets the collection of all the Property objects defined for the instance.
PropertyRules | Gets the collection of all the PropertyRule objects defined for the instance.
Roles | Gets the collection of all the Role objects defined for the instance.
States | Gets the collection of all the State objects defined for the instance.

Public Instance Methods

Clear | Clears the whole authorization policy contained within this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteAction | Overloaded. Executes the Action associated with the given action authorization rule.
GetDefinedActionRules | Returns all the ActionRule objects defined for the current authorization context.
GetDefinedPropertyRules | Returns all PropertyRule objects defined for the current authorization context.
GetExecutableActionRules | Returns all the ActionRule objects for actions that are executable in the current authorization context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChangeablePropertyRules | Return all PropertyRule objects that are changeable in the current authorization context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsActionExecutable | Overloaded. Returns a value specifying if the action associated with the given rule is executable in the current authorization context.
IsNewRuleValid | This member supports the component' s implementation and is not intended to be used directly from your code.
IsPropertyChangeable | Overloaded. Returns a value specifying if the Property associated with the given rule is changeable in the current authorization context.
RaiseAuthorizationContextChangedEvent | Overloaded. Raises the AuthorizationContextChanged event.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Public Instance Events

ActionExecuted | Occurs after an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
ActionExecuting | Occurs before an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
AuthorizationContextChanged | The event is raised whenever the authorization context of the policy is changed.
InstanceChanged | The event is raised after a policy object has been changed.
InstanceChanging | The event is raised before a policy object is changed.
ResolveRoleMembership | The event is raised as part of the role resolution process.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

CreateAction | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRule | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRuleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateProperty | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRule | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRuleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRole | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRoleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRoleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateState | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateStateCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateStateCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureActionCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureActionRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewObjectPolicyOwnershipConsistency | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleConsistency | This member supports the component' s implementation and is not intended to be used directly from your code.
EnsurePropertyCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsurePropertyRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureRoleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureStateCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ExecuteActionInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAuthorizedRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetDistinctProtectedObjects | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetExecutableActionRulesInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetResolvedActionRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetResolvedPropertyRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
HasDistinctTargetStates | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsOwnedObject | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRoleMember | Determines if the given principal is member of the given role.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnActionExecuted | Raises the ActionExecuted event.
OnActionExecuting | Raises the ActionExecuting event.
OnInstanceChanged | Raises the InstanceChanged event.
OnInstanceChanging | Raises the InstanceChanging event.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PropagateChangingEvent | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
RemoveRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveConflictingEnabledRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveExecutableActionRules | Resolves the available authorization rules and fills the output resolvedRules with ActionRule objects associated with executable actions.
ResolveProtectedObjectRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveRulesRoleMembership | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy Constructor

Initializes a new instance of the AuthorizationPolicy class.

Overload List

Initializes a new instance of the AuthorizationPolicy class.

public AuthorizationPolicy();

Initializes a new instance of the AuthorizationPolicy class with the given id.

public AuthorizationPolicy(string);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy Constructor ()

Initializes a new instance of the AuthorizationPolicy class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AuthorizationPolicy();

Remarks

The properties of the instance are initialized as follows:

Property | Value
Roles, States, Actions, ActionRules, Properties, PropertyRules | Empty collections
Id, Name, Description | Empty strings
CurrentState | a null reference (Nothing in Visual Basic)
CurrentPrincipal | CurrentPrincipal

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy Constructor Overload List


AuthorizationPolicy Constructor (String)

Initializes a new instance of the AuthorizationPolicy class with the given id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public AuthorizationPolicy(
string id
);

Parameters

id
The initial value of the Id property of the new instance.

Remarks

See the AuthorizationPolicy default constructor for information about default property values.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy Constructor Overload List


AuthorizationPolicy Properties

The properties of the AuthorizationPolicy class are listed below. For a complete list of AuthorizationPolicy class members, see the AuthorizationPolicy Members topic.

Public Instance Properties

ActionRules | Gets the collection of all the ActionRule objects defined for the instance.
Actions | Gets the collection of all the Action objects defined for the instance.
CurrentPrincipal | Sets or returns the IPrincipal implementation used to resolve role membership.
CurrentState | Sets or returns the current state of the authorization policy.
Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Properties | Gets the collection of all the Property objects defined for the instance.
PropertyRules | Gets the collection of all the PropertyRule objects defined for the instance.
Roles | Gets the collection of all the Role objects defined for the instance.
States | Gets the collection of all the State objects defined for the instance.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ActionRules Property

Gets the collection of all the ActionRule objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property ActionRules As ActionRuleCollection
[C#]
public virtual Model.ActionRuleCollection ActionRules {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.Actions Property

Gets the collection of all the Action objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property Actions As ActionCollection
[C#]
public virtual Model.ActionCollection Actions {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CurrentPrincipal Property

Sets or returns the IPrincipal implementation used to resolve role membership.

[Visual Basic]
Overridable Public Property CurrentPrincipal As IPrincipal
[C#]
public virtual System.Security.Principal.IPrincipal CurrentPrincipal {get; set;}

Remarks

If you don't set this property explicitly, the AuthorizationPolicy instance will return the System.Threading.Thread. CurrentPrincipal reference. However, once you set the property, the assigned value will be used even if you set it to a null reference (Nothing in Visual Basic).

Note If you set the property to a a null reference (Nothing in Visual Basic), no authorization rules will be enabled for the given AuthorizationPolicy instance. That is, all calls to IsActionExecutable and IsPropertyChangeable will return false and the ExecuteAction will always throw PermissionDeniedException.
This is logical if you realize that a a null reference (Nothing in Visual Basic) principal cannot be member of any role.

Example

The following example initializes a new instance of the AuthorizationPolicy class and sets the authorization context to a GenericPrincipal that is member of an "Author" role.

[Visual Basic]
Dim policy As New AuthorizationPolicy
policy.CurrentPrincipal = New GenericPrincipal( _
  New GenericIdentity("Default User"), _
  New String() {"Author"})
Debug.Assert(policy.CurrentPrincipal.IsInRole("Author"))

[C#]
AuthorizationPolicy policy = new AuthorizationPolicy();
AuthorizationPolicy.CurrentPrincipal = new GenericPrincipal(
  new GenericIdentity("Default User"),
  new string[] {"Author"});
Debug.Assert(policy.CurrentPrincipel.IsInRole("Author"));

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CurrentState Property

Sets or returns the current state of the authorization policy.

[Visual Basic]
Overridable Public Property CurrentState As State
[C#]
public virtual Model.State CurrentState {get; set;}

Remarks

You can set the property to reference any State object that is contained in the States collection of this instance.

If you set the property to a null reference (Nothing in Visual Basic), by definition, all the authorization rules will be disabled (you cannot define an authorization rule that is not associated with a valid State).

Exceptions

Exception Type | Condition
ConstableException | You've attempted to set the property to a State object that is not contained in the States collection of this instance.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.Properties Property

Gets the collection of all the Property objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property Properties As PropertyCollection
[C#]
public virtual Model.PropertyCollection Properties {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.PropertyRules Property

Gets the collection of all the PropertyRule objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property PropertyRules As PropertyRuleCollection
[C#]
public virtual Model.PropertyRuleCollection PropertyRules {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.Roles Property

Gets the collection of all the Role objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property Roles As RoleCollection
[C#]
public virtual Model.RoleCollection Roles {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.States Property

Gets the collection of all the State objects defined for the instance.

[Visual Basic]
Overridable Public ReadOnly Property States As StateCollection
[C#]
public virtual Model.StateCollection States {get;}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy Methods

The methods of the AuthorizationPolicy class are listed below. For a complete list of AuthorizationPolicy class members, see the AuthorizationPolicy Members topic.

Public Instance Methods

Clear | Clears the whole authorization policy contained within this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteAction | Overloaded. Executes the Action associated with the given action authorization rule.
GetDefinedActionRules | Returns all the ActionRule objects defined for the current authorization context.
GetDefinedPropertyRules | Returns all PropertyRule objects defined for the current authorization context.
GetExecutableActionRules | Returns all the ActionRule objects for actions that are executable in the current authorization context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChangeablePropertyRules | Return all PropertyRule objects that are changeable in the current authorization context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsActionExecutable | Overloaded. Returns a value specifying if the action associated with the given rule is executable in the current authorization context.
IsNewRuleValid | This member supports the component' s implementation and is not intended to be used directly from your code.
IsPropertyChangeable | Overloaded. Returns a value specifying if the Property associated with the given rule is changeable in the current authorization context.
RaiseAuthorizationContextChangedEvent | Overloaded. Raises the AuthorizationContextChanged event.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

CreateAction | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRule | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRuleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateProperty | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRule | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRuleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRole | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRoleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRoleCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateState | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateStateCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateStateCollectionUpdater | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureActionCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureActionRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewObjectPolicyOwnershipConsistency | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleConsistency | This member supports the component' s implementation and is not intended to be used directly from your code.
EnsurePropertyCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsurePropertyRuleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureRoleCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureStateCollection | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ExecuteActionInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetAuthorizedRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetDistinctProtectedObjects | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetExecutableActionRulesInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetResolvedActionRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetResolvedPropertyRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
HasDistinctTargetStates | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsOwnedObject | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRoleMember | Determines if the given principal is member of the given role.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnActionExecuted | Raises the ActionExecuted event.
OnActionExecuting | Raises the ActionExecuting event.
OnInstanceChanged | Raises the InstanceChanged event.
OnInstanceChanging | Raises the InstanceChanging event.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PropagateChangingEvent | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
RemoveRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveConflictingEnabledRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveExecutableActionRules | Resolves the available authorization rules and fills the output resolvedRules with ActionRule objects associated with executable actions.
ResolveProtectedObjectRules | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
ResolveRulesRoleMembership | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.Clear Method

Clears the whole authorization policy contained within this instance.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();

Remarks

Removes all Roles, States, Actions, Properties and the associated ActionRules and PropertyRules.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateAction Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateAction( _
ByVal id As String _
) As Action
[C#]
protected virtual Action CreateAction(
string id
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateActionCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateActionCollection() As ActionCollection
[C#]
protected virtual ActionCollection CreateActionCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateActionCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateActionCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreateActionCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateActionRule Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateActionRule( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
) As ActionRule
[C#]
protected virtual ActionRule CreateActionRule(
Action action,
Role role,
State state,
State targetState,
bool isVisible,
bool isEnabled
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateActionRuleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateActionRuleCollection() As ActionRuleCollection
[C#]
protected virtual ActionRuleCollection CreateActionRuleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateActionRuleCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateActionRuleCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreateActionRuleCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateProperty Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateProperty( _
ByVal id As String _
) As Property
[C#]
protected virtual Property CreateProperty(
string id
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreatePropertyCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreatePropertyCollection() As PropertyCollection
[C#]
protected virtual PropertyCollection CreatePropertyCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreatePropertyCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreatePropertyCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreatePropertyCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreatePropertyRule Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreatePropertyRule( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
) As PropertyRule
[C#]
protected virtual PropertyRule CreatePropertyRule(
Property property,
Role role,
State state,
bool isVisible,
bool isEnabled
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreatePropertyRuleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreatePropertyRuleCollection() As PropertyRuleCollection
[C#]
protected virtual PropertyRuleCollection CreatePropertyRuleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreatePropertyRuleCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreatePropertyRuleCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreatePropertyRuleCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateRole Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateRole( _
ByVal id As String _
) As Role
[C#]
protected virtual Role CreateRole(
string id
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateRoleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateRoleCollection() As RoleCollection
[C#]
protected virtual RoleCollection CreateRoleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateRoleCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateRoleCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreateRoleCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateState Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateState( _
ByVal id As String _
) As State
[C#]
protected virtual State CreateState(
string id
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateStateCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateStateCollection() As StateCollection
[C#]
protected virtual StateCollection CreateStateCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.CreateStateCollectionUpdater Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function CreateStateCollectionUpdater() As ICollectionUpdater
[C#]
protected virtual ICollectionUpdater CreateStateCollectionUpdater();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureActionCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsureActionCollection()
[C#]
protected virtual void EnsureActionCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureActionRuleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsureActionRuleCollection()
[C#]
protected virtual void EnsureActionRuleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureNewObjectPolicyOwnershipConsistency Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub EnsureNewObjectPolicyOwnershipConsistency( _
ByVal newObject As ObjectBase _
)
[C#]
protected void EnsureNewObjectPolicyOwnershipConsistency(
ObjectBase newObject
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureNewRuleConsistency Method

This member supports the component' s implementation and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub EnsureNewRuleConsistency( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
)
[C#]
protected void EnsureNewRuleConsistency(
NamedObjectBase protectedObject,
Role role,
State state
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsurePropertyCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsurePropertyCollection()
[C#]
protected virtual void EnsurePropertyCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsurePropertyRuleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsurePropertyRuleCollection()
[C#]
protected virtual void EnsurePropertyRuleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureRoleCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsureRoleCollection()
[C#]
protected virtual void EnsureRoleCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.EnsureStateCollection Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub EnsureStateCollection()
[C#]
protected virtual void EnsureStateCollection();

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


ExecuteAction Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicy.ExecuteAction Method

[This is preliminary documentation and subject to change.]

Executes the specified Action.

Overload List

Executes the specified Action.

public void ExecuteAction(Action);

Executes the Action associated with the given action authorization rule.

public virtual void ExecuteAction(ActionRule);

Executes the action identified by its Id.

public void ExecuteAction(string);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ExecuteAction Method (Action)

Executes the specified Action.

[Visual Basic]
Overloads Public Sub ExecuteAction( _
ByVal action As Action _
)
[C#]
public void ExecuteAction(
Action action
);

Parameters

action
The action to be executed.

Remarks

The "execution" of the action means that the authorization rules associated with the action are evaluated according to the CurrentPrincipal role membership and, if the action is allowed, the CurrentState of the AuthorizationPolicy instance is set to the TargetState property value of the chosen ActionRule.

Exceptions

Exception Type | Condition
PermissionDeniedException | The CurrentPrincipal is not allowed to execute the action.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.ExecuteAction Overload List


AuthorizationPolicy.ExecuteAction Method (ActionRule)

Executes the Action associated with the given action authorization rule.

[Visual Basic]
Overridable Overloads Public Sub ExecuteAction( _
ByVal actionRule As ActionRule _
)
[C#]
public virtual void ExecuteAction(
ActionRule actionRule
);

Parameters

actionRule
The action authorization rule associated with the action that is to be executed.

Remarks

The "execution" of the action means that all the action authorization rules associated with the action are evaluated according to the CurrentPrincipal role membership and, if the actionRule is allowed, the CurrentState of the AuthorizationPolicy instance is set to the TargetState property value of the actionRule.

This overload is sometimes useful for non-deterministic authorization policies in that it allows to execute an action with more than one enabled authorization rule with different TargetStates.

Exceptions

Exception Type | Condition
PermissionDeniedException | The CurrentPrincipal is not allowed to execute the action.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.ExecuteAction Overload List


AuthorizationPolicy.ExecuteAction Method (String)

Executes the action identified by its Id.

[Visual Basic]
Overloads Public Sub ExecuteAction( _
ByVal actionId As String _
)
[C#]
public void ExecuteAction(
string actionId
);

Parameters

actionId
The Id Id of the action to be executed.

Remarks

The "execution" of the action means that the authorization rules associated with the action are evaluated according to the CurrentPrincipal role membership and, if the action is allowed, the CurrentState of the AuthorizationPolicy instance is set to the TargetState property value of the chosen ActionRule.

CAUTION If you pass-in an actionId that doesn't identify an action contained in the Actions collection, the policy treats it as an attempt to execute a denied action (that is, it throws the PermissionDeniedException).

Exceptions

Exception Type | Condition
PermissionDeniedException | The CurrentPrincipal is not allowed to execute the action.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.ExecuteAction Overload List


AuthorizationPolicy.ExecuteActionInternal Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub ExecuteActionInternal( _
ByVal actionRule As ActionRule _
)
[C#]
protected virtual void ExecuteActionInternal(
ActionRule actionRule
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetAuthorizedRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub GetAuthorizedRules( _
ByVal currentRules As RuleCollectionBase, _
ByVal authorizedRules As RuleCollectionBase _
)
[C#]
protected void GetAuthorizedRules(
RuleCollectionBase currentRules,
RuleCollectionBase authorizedRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetDefinedActionRules Method

Returns all the ActionRule objects defined for the current authorization context.

[Visual Basic]
Overridable Public Function GetDefinedActionRules( _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As ActionRuleCollection
[C#]
public virtual ActionRuleCollection GetDefinedActionRules(
VisibleOption visible,
EnabledOption enabled
);

Parameters

visible
What value of the IsVisible property is required.
enabled
What value of the IsEnabled property is required.

Return Value

A collection of ActionRule objects with the required IsVisible and IsEnabled property values.

Remarks

The method enumerates the ActionRules collection and returns all rules defined for the current authorization context with the values of the IsVisible and IsEnabled property corresponding to the visible and enabled arguments, respectively.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetDefinedPropertyRules Method

Returns all PropertyRule objects defined for the current authorization context.

[Visual Basic]
Overridable Public Function GetDefinedPropertyRules( _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As PropertyRuleCollection
[C#]
public virtual PropertyRuleCollection GetDefinedPropertyRules(
VisibleOption visible,
EnabledOption enabled
);

Parameters

visible
The required value for the IsVisible property for the returned objects.
enabled
The required value for the IsEnabled property for the returned objects.

Return Value

An instance of the PropertyRuleCollection containing property rules with the reuqired property values.

Remarks

The method enumerates the PropertyRules collection and returns all rules defined for the current authorization context with the values of the IsVisible and IsEnabled property corresponding to the visible and enabled arguments, respectively.

Example

The following example defines a very simple authorization policy and uses assertions to verify the content of the returned PropertyRuleCollection instance:

[Visual Basic]
' One role with only enabled property rules can't be
' non-deterministic.
Dim policy As AuthorizationPolicy =  New AuthorizationPolicy()

' Our sole role - the DynamicRole with everyone being member
AuthorizationPolicy.Roles.Add(New DynamicRole("User",True))

' One default state.
AuthorizationPolicy.States.AddNew("Default")

' Two properties.
AuthorizationPolicy.Properties.AddNew("Title")
AuthorizationPolicy.Properties.AddNew("Content")

' Each property is enabled and visible (by default).
AuthorizationPolicy.PropertyRules.AddNew("Title", "User")
AuthorizationPolicy.PropertyRules.AddNew("Content", "User")

' Any visible and enabled options - return all rules.
Dim rules As PropertyRuleCollection =  AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any,EnabledOption.Any)
Assert.AreEqual(2, rules.Count)

' Only visible and enabled options - all rules again.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled)
Assert.AreEqual(2, rules.Count)

' Invisible, don't care aboud Enabled - none.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any)
Assert.AreEqual(0, rules.Count)

' Disabled, don't care about visibility.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled)
Assert.AreEqual(0, rules.Count)

'
' Now make the Title property not visible and test.
'

AuthorizationPolicy.PropertyRules.Lookup("Title", "User", "Default").IsVisible = False

' Any option - all rules should be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.Any)
Assert.AreEqual(2, rules.Count)

' Only visible and enabled options - Title(User) [Default: false, true] not returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled)
Assert.AreEqual(1, rules.Count)
Assert.AreEqual("Content", rules(0).Property.Id)
Assert.AreSame(AuthorizationPolicy.Properties("Content"), rules(0).Property)

' Invisible, don't care aboud Enabled - the Tile(User) [Default: false, true] should
' be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any)
Assert.AreEqual(1, rules.Count)
Assert.AreEqual("Title", rules(0).Property.Id)
Assert.AreSame(AuthorizationPolicy.Properties("Title"), rules(0).Property)

' Disabled, don't care about visibility - none.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled)
Assert.AreEqual(0, rules.Count)

'
' Now make the Content property disabled and test.
' (The Title is now not visible, the Content is now disabled).

AuthorizationPolicy.PropertyRules.Lookup("Content", "User", "Default").IsEnabled = False

' Any option - all rules should be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.Any)
Assert.AreEqual(2, rules.Count)

' Only visible and enabled options - none returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled)
Assert.AreEqual(0, rules.Count)

' Invisible, don't care aboud Enabled - the Tile(User) [Default: false, true] should
' be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any)
Assert.AreEqual(1, rules.Count)
Assert.AreEqual("Title", rules(0).Property.Id)
Assert.AreSame(AuthorizationPolicy.Properties("Title"), rules(0).Property)

' Disabled, don't care about visibility - Content.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled)
Assert.AreEqual(1, rules.Count)
Assert.AreEqual("Content", rules(0).Property.Id)
Assert.AreSame(AuthorizationPolicy.Properties("Content"), rules(0).Property)

[C#]
// One role with only enabled property rules can't be
// non-deterministic.
AuthorizationPolicy policy = new AuthorizationPolicy();

// Our sole role - the DynamicRole with everyone being member
AuthorizationPolicy.Roles.Add(new DynamicRole("User", true));

// One default state.
AuthorizationPolicy.States.AddNew("Default");

// Two properties.
AuthorizationPolicy.Properties.AddNew("Title");
AuthorizationPolicy.Properties.AddNew("Content");

// Each property is enabled and visible (by default).
AuthorizationPolicy.PropertyRules.AddNew("Title", "User");
AuthorizationPolicy.PropertyRules.AddNew("Content", "User");

// Any visible and enabled options - return all rules.
PropertyRuleCollection rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.Any);
Assert.AreEqual(2, rules.Count);

// Only visible and enabled options - all rules again.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled);
Assert.AreEqual(2, rules.Count);

// Invisible, don't care aboud Enabled - none.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any);
Assert.AreEqual(0, rules.Count);

// Disabled, don't care about visibility.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled);
Assert.AreEqual(0, rules.Count);

//
// Now make the Title property not visible and test.
//

AuthorizationPolicy.PropertyRules.Lookup("Title", "User", "Default").IsVisible = false;

// Any option - all rules should be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.Any);
Assert.AreEqual(2, rules.Count);

// Only visible and enabled options - Title(User) [Default: false, true] not returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled);
Assert.AreEqual(1, rules.Count);
Assert.AreEqual("Content", rules[0].Property.Id);
Assert.AreSame(AuthorizationPolicy.Properties["Content"], rules[0].Property);

// Invisible, don't care aboud Enabled - the Tile(User) [Default: false, true] should
// be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any);
Assert.AreEqual(1, rules.Count);
Assert.AreEqual("Title", rules[0].Property.Id);
Assert.AreSame(AuthorizationPolicy.Properties["Title"], rules[0].Property);

// Disabled, don't care about visibility - none.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled);
Assert.AreEqual(0, rules.Count);

//
// Now make the Content property disabled and test.
// (The Title is now not visible, the Content is now disabled).

AuthorizationPolicy.PropertyRules.Lookup("Content", "User", "Default").IsEnabled = false;

// Any option - all rules should be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.Any);
Assert.AreEqual(2, rules.Count);

// Only visible and enabled options - none returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Visible, EnabledOption.Enabled);
Assert.AreEqual(0, rules.Count);

// Invisible, don't care aboud Enabled - the Tile(User) [Default: false, true] should
// be returned.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.NotVisible, EnabledOption.Any);
Assert.AreEqual(1, rules.Count);
Assert.AreEqual("Title", rules[0].Property.Id);
Assert.AreSame(AuthorizationPolicy.Properties["Title"], rules[0].Property);

// Disabled, don't care about visibility - Content.
rules = AuthorizationPolicy.GetDefinedPropertyRules(VisibleOption.Any, EnabledOption.NotEnabled);
Assert.AreEqual(1, rules.Count);
Assert.AreEqual("Content", rules[0].Property.Id);
Assert.AreSame(AuthorizationPolicy.Properties["Content"], rules[0].Property);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | VisibleOption | EnabledOption


AuthorizationPolicy.GetDistinctProtectedObjects Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function GetDistinctProtectedObjects( _
ByVal rules As RuleCollectionBase _
) As ArrayList
[C#]
protected ArrayList GetDistinctProtectedObjects(
RuleCollectionBase rules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetExecutableActionRules Method

Returns all the ActionRule objects for actions that are executable in the current authorization context.

[Visual Basic]
Overridable Public Function GetExecutableActionRules() As ActionRuleCollection
[C#]
public virtual ActionRuleCollection GetExecutableActionRules();

Return Value

Collection of ActionRule objects associated with executable actions.

Remarks

An action is executable if calling the ExecuteAction method for the given action doesn't throw an exception.

If this method returns more than one ActionRule with different values of the TargetState property, the authorization policy is said to be non-deterministic.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetExecutableActionRulesInternal Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function GetExecutableActionRulesInternal( _
ByVal resolveMultipleTargetStates As Boolean _
) As ActionRuleCollection
[C#]
protected virtual ActionRuleCollection GetExecutableActionRulesInternal(
bool resolveMultipleTargetStates
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetChangeablePropertyRules Method

Return all PropertyRule objects that are changeable in the current authorization context.

[Visual Basic]
Overridable Public Function GetChangeablePropertyRules() As PropertyRuleCollection
[C#]
public virtual PropertyRuleCollection GetChangeablePropertyRules();

Return Value

All PropertyRule objects having the IsEnabled property equal to true.

Remarks

This method takes into account the possible non-determinism of the associated authorization policy: if there are two (or more) PropertyRules available for the current context and at least on of the rules has its IsEnabled property set to false, none of the rules are returned.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetResolvedActionRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub GetResolvedActionRules( _
ByVal authorizedRules As ActionRuleCollection, _
ByVal resolveMultipleTargetStates As Boolean, _
ByVal resolvedRules As ActionRuleCollection _
)
[C#]
protected virtual void GetResolvedActionRules(
ActionRuleCollection authorizedRules,
bool resolveMultipleTargetStates,
ActionRuleCollection resolvedRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.GetResolvedPropertyRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub GetResolvedPropertyRules( _
ByVal authorizedRules As PropertyRuleCollection, _
ByVal resolvedRules As PropertyRuleCollection _
)
[C#]
protected virtual void GetResolvedPropertyRules(
PropertyRuleCollection authorizedRules,
PropertyRuleCollection resolvedRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.HasDistinctTargetStates Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function HasDistinctTargetStates( _
ByVal rules As ActionRuleCollection _
) As Boolean
[C#]
protected bool HasDistinctTargetStates(
ActionRuleCollection rules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


IsActionExecutable Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicy.IsActionExecutable Method

[This is preliminary documentation and subject to change.]

Returns a value specifying if the specified action is executable in the current authorization context.

Overload List

Returns a value specifying if the specified action is executable in the current authorization context.

public bool IsActionExecutable(Action);

Returns a value specifying if the action associated with the given rule is executable in the current authorization context.

public virtual bool IsActionExecutable(ActionRule);

Returns a value specifying if the specified action is executable in the current authorization context.

public bool IsActionExecutable(string);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.IsActionExecutable Method (Action)

Returns a value specifying if the specified action is executable in the current authorization context.

[Visual Basic]
Overloads Public Function IsActionExecutable( _
ByVal action As Action _
) As Boolean
[C#]
public bool IsActionExecutable(
Action action
);

Parameters

action
The action whose executability is queried.

Return Value

true if the action is executable; false otherwise.

Remarks

When this method returns true, you can be sure that when you call ExecuteAction in the same authorization context and with the same argument, the call will not throw an exception (barring catastrophic failure).

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsActionExecutable Overload List


AuthorizationPolicy.IsActionExecutable Method (ActionRule)

Returns a value specifying if the action associated with the given rule is executable in the current authorization context.

[Visual Basic]
Overridable Overloads Public Function IsActionExecutable( _
ByVal rule As ActionRule _
) As Boolean
[C#]
public virtual bool IsActionExecutable(
ActionRule rule
);

Parameters

rule
The ActionRule whose associated action executability is queried.

Return Value

true if the associated action is executable; false otherwise.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsActionExecutable Overload List


AuthorizationPolicy.IsActionExecutable Method (String)

Returns a value specifying if the specified action is executable in the current authorization context.

[Visual Basic]
Overloads Public Function IsActionExecutable( _
ByVal actionId As String _
) As Boolean
[C#]
public bool IsActionExecutable(
string actionId
);

Parameters

actionId
The Id of the action whose executability is queried.

Return Value

true if the action is executable; false otherwise.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsActionExecutable Overload List


AuthorizationPolicy.IsNewRuleObjectPolicyOwnershipValid Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function IsNewRuleObjectPolicyOwnershipValid( _
ByVal newObject As ObjectBase _
) As Boolean
[C#]
protected bool IsNewRuleObjectPolicyOwnershipValid(
ObjectBase newObject
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.IsNewRuleValid Method

This member supports the component' s implementation and is not intended to be used directly from your code.

[Visual Basic]
Overridable Public Function IsNewRuleValid( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
) As Boolean
[C#]
public virtual bool IsNewRuleValid(
NamedObjectBase protectedObject,
Role role,
State state
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.IsOwnedObject Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function IsOwnedObject( _
ByVal obj As ObjectBase _
) As Boolean
[C#]
protected bool IsOwnedObject(
ObjectBase obj
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


IsPropertyChangeable Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicy.IsPropertyChangeable Method

[This is preliminary documentation and subject to change.]

Returns a value specifying if the Property is changeable in the current authorization context.

Overload List

Returns a value specifying if the Property is changeable in the current authorization context.

public bool IsPropertyChangeable(Property);

Returns a value specifying if the Property associated with the given rule is changeable in the current authorization context.

public virtual bool IsPropertyChangeable(PropertyRule);

Returns a value specifying if the Property with the given Id is changeable in the current authorization context.

public bool IsPropertyChangeable(string);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.IsPropertyChangeable Method (Property)

Returns a value specifying if the Property is changeable in the current authorization context.

[Visual Basic]
Overloads Public Function IsPropertyChangeable( _
ByVal property As Property _
) As Boolean
[C#]
public bool IsPropertyChangeable(
Property property
);

Parameters

property
The Property whose changeability is queried.

Return Value

true if the property is changeable; false otherwise.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsPropertyChangeable Overload List


AuthorizationPolicy.IsPropertyChangeable Method (PropertyRule)

Returns a value specifying if the Property associated with the given rule is changeable in the current authorization context.

[Visual Basic]
Overridable Overloads Public Function IsPropertyChangeable( _
ByVal rule As PropertyRule _
) As Boolean
[C#]
public virtual bool IsPropertyChangeable(
PropertyRule rule
);

Parameters

rule
The PropertyRule whose associated Property's changeability is queried.

Return Value

true if the associated property is changeable; false otherwise.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsPropertyChangeable Overload List


AuthorizationPolicy.IsPropertyChangeable Method (String)

Returns a value specifying if the Property with the given Id is changeable in the current authorization context.

[Visual Basic]
Overloads Public Function IsPropertyChangeable( _
ByVal propertyId As String _
) As Boolean
[C#]
public bool IsPropertyChangeable(
string propertyId
);

Parameters

propertyId
The Id of the Property whose changeability is queried.

Return Value

true if the property is changeable; false otherwise.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.IsPropertyChangeable Overload List


AuthorizationPolicy.IsRoleMember Method

Determines if the given principal is member of the given role.

[Visual Basic]
Overridable Protected Function IsRoleMember( _
ByVal principal As IPrincipal, _
ByVal role As Role _
) As Boolean
[C#]
protected virtual bool IsRoleMember(
IPrincipal principal,
Role role
);

Parameters

principal
The IPrincipal whose role membership is checked.
role
The Role to check membership within.

Return Value

true if the principal is member of the role; false otherwise.

Remarks

The implementation simply invokes the role.IsMember(principal) method.

Example

The following is an example of an overriden IsRoleMember method. The example simply returns false from the method thus making the authorization policy refuse to execute action regardless of the CurrentPrincipal role membership:

[Visual Basic]
Private Class NoOpAuthorizationPolicy
  Inherits AuthorizationPolicy
  Protected Overrides Function IsRoleMember(ByVal principal As IPrincipal, ByVal role As Role) As Boolean
    Return False
  End Function
End Class

[C#]
private class NoOpAuthorizationPolicy : AuthorizationPolicy
{
  protected override bool IsRoleMember(IPrincipal principal, Role role)
  {
    return false;
  }
}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.OnActionExecuted Method

Raises the ActionExecuted event.

[Visual Basic]
Overridable Protected Sub OnActionExecuted( _
ByVal e As ActionExecutionEventArgs _
)
[C#]
protected virtual void OnActionExecuted(
ActionExecutionEventArgs e
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.OnActionExecuting Method

Raises the ActionExecuting event.

[Visual Basic]
Overridable Protected Sub OnActionExecuting( _
ByVal e As ActionExecutionEventArgs _
)
[C#]
protected virtual void OnActionExecuting(
ActionExecutionEventArgs e
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.OnInstanceChanged Method

Raises the InstanceChanged event.

[Visual Basic]
Overridable Protected Sub OnInstanceChanged( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void OnInstanceChanged(
object sender,
ChangeEventArgs e
);

Parameters

sender
The event originator.
e
An instance of the ChangeEventArgs-derived class containing the event data.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.OnInstanceChanging Method

Raises the InstanceChanging event.

[Visual Basic]
Overridable Protected Sub OnInstanceChanging( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void OnInstanceChanging(
object sender,
ChangeEventArgs e
);

Parameters

sender
The event originator.
e
An instance of the ChangeEventArgs-derived class containing the event data.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.PropagateChangedEvent Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Protected Sub PropagateChangedEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected override void PropagateChangedEvent(
object sender,
ChangeEventArgs e
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.PropagateChangingEvent Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Protected Sub PropagateChangingEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected override void PropagateChangingEvent(
object sender,
ChangeEventArgs e
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


RaiseAuthorizationContextChangedEvent Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicy.RaiseAuthorizationContextChangedEvent Method

[This is preliminary documentation and subject to change.]

Raises the AuthorizationContextChanged event.

Overload List

Raises the AuthorizationContextChanged event.

public void RaiseAuthorizationContextChangedEvent();

Raises the AuthorizationContextChanged event.

public virtual void RaiseAuthorizationContextChangedEvent(EventArgs);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.RaiseAuthorizationContextChangedEvent Method ()

Raises the AuthorizationContextChanged event.

[Visual Basic]
Overloads Public Sub RaiseAuthorizationContextChangedEvent()
[C#]
public void RaiseAuthorizationContextChangedEvent();

Remarks

The ActionExecuting and ActionExecuted events are raised before and after an action is executed by calling one of the overloaded ExecuteAction methods.

For an example please see the RaiseAuthorizationContextChangedEvent help topic.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.RaiseAuthorizationContextChangedEvent Overload List


AuthorizationPolicy.RaiseAuthorizationContextChangedEvent Method (EventArgs)

Raises the AuthorizationContextChanged event.

[Visual Basic]
Overridable Overloads Public Sub RaiseAuthorizationContextChangedEvent( _
ByVal e As EventArgs _
)
[C#]
public virtual void RaiseAuthorizationContextChangedEvent(
EventArgs e
);

Parameters

e
An instance of the EventArgs class to associate with the event. Typically, you'd pass the Empty value or call the RaiseAuthorizationContextChangedEvent parameterless overload of this method.

Remarks

You should call this method whenever you change the authorization context outside of the policy as the following example illustrates:

Example

[Visual Basic]

Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

Public Class RaiseAuthorizationContextChangedEvent
  Public Shared Sub Main()
    ' Simple policy that grants the Author role the Create action.
    Dim xmlPolicy As String = "<authorizationPolicy>" & _
      "<role id=""Author""/>" & _
      "<state id=""Default""/>" & _
      "<action id=""Create""/>" & _
      "<actionRule action=""Create"" Role=""Author""/>" & _
      "</authorizationPolicy>"

    ' Create the policy and hook the AuthorizationContextChanged event.
    Dim policy As AuthorizationPolicy = AuthorizationPolicyLoader.LoadFromXml(xmlPolicy)
    AddHandler policy.AuthorizationContextChanged, New EventHandler(AddressOf HandleAuthorizationContextChanged)

    ' Assign a custom principal in the Author role and make sure the
    ' Create action is executable.
    Console.WriteLine("Assigning CurrentPrincipal")
    policy.CurrentPrincipal = New ExtendedPrincipal(New GenericIdentity("John"), New String() {"Author"})
    Debug.Assert(policy.IsActionExecutable("Create"))

    ' Executing an action always raises the AuthorizationContextChanged event even
    ' if no state change takes place.
    Console.WriteLine("Executing Create action")
    policy.ExecuteAction("Create")

    ' Now change the principal and and note that the
    ' AuthorizationContextChanged event isn't raised automatically.
    Console.WriteLine("Changing CurrentPrincipal role membership")
    DirectCast(policy.CurrentPrincipal, ExtendedPrincipal).Roles.RemoveAt("Author")

    Console.WriteLine("Raising the AuthorizationContextChanged event manually")
    policy.RaiseAuthorizationContextChangedEvent()
  End Sub

  Private Shared Sub HandleAuthorizationContextChanged(ByVal sender As Object, ByVal e As EventArgs)
    Console.WriteLine(" ** Authorization context changed ** ")
  End Sub

End Class

[C#]

using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

public class RaiseAuthorizationContextChangedEvent
{
  public static void Main()
  {
    // Simple policy that grants the Author role the Create action.
    string xmlPolicy = "<authorizationPolicy>" +
      "<role id=\"Author\"/>" +
      "<state id=\"Default\"/>" +
      "<action id=\"Create\"/>" +
      "<actionRule action=\"Create\" Role=\"Author\"/>" +
      "</authorizationPolicy>";

    // Create the policy and hook the AuthorizationContextChanged event.
    AuthorizationPolicy policy = AuthorizationPolicyLoader.LoadFromXml(xmlPolicy);
    policy.AuthorizationContextChanged += new EventHandler(HandleAuthorizationContextChanged);

    // Assign a custom principal in the Author role and make sure the
    // Create action is executable.
    Console.WriteLine("Assigning CurrentPrincipal");
    policy.CurrentPrincipal = new ExtendedPrincipal(new GenericIdentity("John"), new string[] {"Author"});
    Debug.Assert(policy.IsActionExecutable("Create"));

    // Executing an action always raises the AuthorizationContextChanged event even
    // if no state change takes place.
    Console.WriteLine("Executing Create action");
    policy.ExecuteAction("Create");

    // Now change the principal and and note that the
    // AuthorizationContextChanged event isn't raised automatically.
    Console.WriteLine("Changing CurrentPrincipal role membership");
    ((ExtendedPrincipal)policy.CurrentPrincipal).Roles.RemoveAt("Author");

    Console.WriteLine("Raising the AuthorizationContextChanged event manually");
    policy.RaiseAuthorizationContextChangedEvent();
  }

  private static void HandleAuthorizationContextChanged(object sender, EventArgs e)
  {
    Console.WriteLine(" ** Authorization context changed ** ");
  }

}
The code above generates the following console output:
Assigning CurrentPrincipal
 ** Authorization context changed **
Executing Create action
 ** Authorization context changed **
Changing CurrentPrincipal role membership
Raising the AuthorizationContextChanged event manually
 ** Authorization context changed **

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace | AuthorizationPolicy.RaiseAuthorizationContextChangedEvent Overload List


AuthorizationPolicy.RemoveRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub RemoveRules( _
ByVal rules As RuleCollectionBase, _
ByVal toBeRemoved As IList _
)
[C#]
protected void RemoveRules(
RuleCollectionBase rules,
IList toBeRemoved
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ResolveConflictingEnabledRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub ResolveConflictingEnabledRules( _
ByVal protectedObject As NamedObjectBase, _
ByVal inputRules As RuleCollectionBase, _
ByVal outputRules As RuleCollectionBase _
)
[C#]
protected void ResolveConflictingEnabledRules(
NamedObjectBase protectedObject,
RuleCollectionBase inputRules,
RuleCollectionBase outputRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ResolveExecutableActionRules Method

Resolves the available authorization rules and fills the output resolvedRules with ActionRule objects associated with executable actions.

[Visual Basic]
Overridable Protected Sub ResolveExecutableActionRules( _
ByVal action As Action, _
ByVal authorizedRules As ActionRuleCollection, _
ByVal resolveMultipleTargetStates As Boolean, _
ByVal resolvedRules As ActionRuleCollection _
)
[C#]
protected virtual void ResolveExecutableActionRules(
Action action,
ActionRuleCollection authorizedRules,
bool resolveMultipleTargetStates,
ActionRuleCollection resolvedRules
);

Parameters

action
The action whose executability is checked.
authorizedRules
The ActionRules that belong to the CurrentPrincipal in the CurrentState.
resolveMultipleTargetStates
true signifies that the implementation should not return multiple action rules with different TargetState property values.
resolvedRules
The rules that the implementation considers executable.

Remarks

If the resolveMultipleTargetStates argument is true, the implementation simply copies all the rules from the authorizedRules collection to the output resolvedRules collection.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ResolveProtectedObjectRules Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub ResolveProtectedObjectRules( _
ByVal protectedObject As NamedObjectBase, _
ByVal objectRules As RuleCollectionBase, _
ByVal outputRules As RuleCollectionBase _
)
[C#]
protected virtual void ResolveProtectedObjectRules(
NamedObjectBase protectedObject,
RuleCollectionBase objectRules,
RuleCollectionBase outputRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ResolveRulesRoleMembership Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Sub ResolveRulesRoleMembership( _
ByVal inputRules As RuleCollectionBase, _
ByVal outputRules As RuleCollectionBase _
)
[C#]
protected virtual void ResolveRulesRoleMembership(
RuleCollectionBase inputRules,
RuleCollectionBase outputRules
);

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy Events

The events of the AuthorizationPolicy class are listed below. For a complete list of AuthorizationPolicy class members, see the AuthorizationPolicy Members topic.

Public Instance Events

ActionExecuted | Occurs after an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
ActionExecuting | Occurs before an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
AuthorizationContextChanged | The event is raised whenever the authorization context of the policy is changed.
InstanceChanged | The event is raised after a policy object has been changed.
InstanceChanging | The event is raised before a policy object is changed.
ResolveRoleMembership | The event is raised as part of the role resolution process.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ActionExecuted Event

Occurs after an Action is executed as a result of calling one of the ExecuteAction overloaded methods.

[Visual Basic]
Public Event ActionExecuted As ActionExecutionEventHandler
[C#]
public event ActionExecutionEventHandler ActionExecuted;

Event Data

The event handler receives an argument of type ActionExecutionEventArgs containing data related to this event. The following ActionExecutionEventArgs property provides information specific to this event.

Property | Description
ActionRule | Returns the ActionRule for the action being executed.

Example

The following example illustrates programming with the ActionExecuting and ActionExecuted events:

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

Public Class ActionExecutingActionExecutedEvents
  Public Shared Sub Main()
    ' Create policy and hook the action execution events.
    Dim policy As AuthorizationPolicy = New AuthorizationPolicy
    AddHandler policy.ActionExecuting, AddressOf HandleActionExecutingEvent
    AddHandler policy.ActionExecuted, AddressOf HandleActionExecutedEvent

    ' Populate the policy with a simple model - the Author can execute the Save
    ' action that moves the policy from the New to the Saved state. (More precisely, the Save action
    ' moves the policy's subject, such as 'document', from New to the Saved state.)
    policy.Roles.AddNew("Author")
    policy.States.AddNew("New")
    policy.States.AddNew("Saved")
    policy.Actions.AddNew("Save")
    policy.ActionRules.AddNew("Save", "Author", "New", "Saved")

    ' Initialize the authorization context.
    policy.CurrentPrincipal = New ExtendedPrincipal(New GenericIdentity("John"), New String() {"Author"})
    policy.CurrentState = policy.States("New")

    ' Executing the Save action will raise the action execution events.
    Console.WriteLine("Executing Save action")
    policy.ExecuteAction("Save")
    Console.WriteLine("Save action executed")
  End Sub

  Private Shared Sub HandleActionExecutingEvent(ByVal sender As Object, ByVal e As ActionExecutionEventArgs)
    Console.WriteLine(" ** ActionExecuting: {0}", e.ActionRule.Action)
  End Sub

  Private Shared Sub HandleActionExecutedEvent(ByVal sender As Object, ByVal e As ActionExecutionEventArgs)
    Console.WriteLine(" ** ActionExecuted: {0}", e.ActionRule.Action)
  End Sub

End Class

[C#]
using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

public class ActionExecutingActionExecutedEvents
{
  public static void Main()
  {
    // Create policy and hook the action execution events.
    AuthorizationPolicy policy = new AuthorizationPolicy();
    policy.ActionExecuting += new ActionExecutionEventHandler(HandleActionExecutingEvent);
    policy.ActionExecuted += new ActionExecutionEventHandler(HandleActionExecutedEvent);

    // Populate the policy with a simple model - the Author can execute the Save
    // action that moves the policy from the New to the Saved state. (More precisely, the Save action
    // moves the policy's subject, such as 'document', from New to the Saved state.)
    policy.Roles.AddNew("Author");
    policy.States.AddNew("New");
    policy.States.AddNew("Saved");
    policy.Actions.AddNew("Save");
    policy.ActionRules.AddNew("Save", "Author", "New", "Saved");

    // Initialize the authorization context.
    policy.CurrentPrincipal = new ExtendedPrincipal(new GenericIdentity("John"), new string[] {"Author"});
    policy.CurrentState = policy.States["New"];

    // Executing the Save action will raise the action execution events.
    Console.WriteLine("Executing Save action");
    policy.ExecuteAction("Save");
    Console.WriteLine("Save action executed");
  }

  private static void HandleActionExecutingEvent(object sender, ActionExecutionEventArgs e)
  {
    Console.WriteLine(" ** ActionExecuting: {0}", e.ActionRule.Action);
  }

  private static void HandleActionExecutedEvent(object sender, ActionExecutionEventArgs e)
  {
    Console.WriteLine(" ** ActionExecuted: {0}", e.ActionRule.Action);
  }

}
The code above produces the following console output:
Executing Save action
 ** ActionExecuting: Save
 ** ActionExecuted: Save
Save action executed

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ActionExecuting Event

Occurs before an Action is executed as a result of calling one of the ExecuteAction overloaded methods.

[Visual Basic]
Public Event ActionExecuting As ActionExecutionEventHandler
[C#]
public event ActionExecutionEventHandler ActionExecuting;

Event Data

The event handler receives an argument of type ActionExecutionEventArgs containing data related to this event. The following ActionExecutionEventArgs property provides information specific to this event.

Property | Description
ActionRule | Returns the ActionRule for the action being executed.

Example

For an example please see the ActionExecuted documentation page.

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.AuthorizationContextChanged Event

The event is raised whenever the authorization context of the policy is changed.

[Visual Basic]
Public Event AuthorizationContextChanged As EventHandler
[C#]
public event EventHandler AuthorizationContextChanged;

Remarks

The following are the reasons that cause the AuthorizationContextChanged event to be raised:

  • The CurrentPrincipal property changes.
  • The CurrentState property changes either directly or by executing an action.
  • The RaiseAuthorizationContextChangedEvent method is called.
CAUTION If you change the authorization context outside of the policy (for example by adding a role to a custom principal currently associated with the policy), be sure to raise the AuthorizationContextChanged event manually by calling the RaiseAuthorizationContextChangedEvent method.
The AuthorizationContextChanged event handlers are not serialized along with the policy; if you're transferring policies across AppDomain or machine boundaries, the event handlers won't be marshaled and used in the remote domain.

Example

The following example illustrates when the AuthorizationContextChanged event is raised and how to handle it:

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

Public Class AuthorizationContextChangedEvent
  Public Shared Sub Main()
    ' Create policy and hook the AuthorizationContextChanged event.
    Dim policy As New AuthorizationPolicy
    AddHandler policy.AuthorizationContextChanged, AddressOf HandleAuthorizationContextChanged

    ' Populate the policy with a simple model - the Author can execute the Save
    ' action that moves the policy from the New to the Saved state. (More precisely, the Save action
    ' moves the policy's subject, such as 'document', from New to the Saved state.)
    policy.Roles.AddNew("Author")

    ' The first state added to the policy becomes the current state, so this also
    ' raises the AuthorizationContextChanged just like setting the CurrentState
    ' property directly.
    Console.WriteLine("Adding first state")
    policy.States.AddNew("New")

    policy.States.AddNew("Saved")
    policy.Actions.AddNew("Save")
    policy.ActionRules.AddNew("Save", "Author", "New", "Saved")

    ' Setting the CurrentPrincipal raises the AuthorizationContextChanged event.
    Console.WriteLine("Assigning CurrentPrincipal")
    policy.CurrentPrincipal = New ExtendedPrincipal(New GenericIdentity("John"), New String() {"Author"})
    Debug.Assert(policy.IsActionExecutable("Save"))

    ' Executing an action also raises the AuthorizationContextChanged event (even
    ' if no state change takes place).
    Console.WriteLine("Executing Save action")
    policy.ExecuteAction("Save")

    ' Setting the CurrentState also raises the AuthorizationContextChanged event.
    Console.WriteLine("Assigning CurrentState")
    policy.CurrentState = policy.States("New")
  End Sub

  Private Shared Sub HandleAuthorizationContextChanged(ByVal sender As Object, ByVal e As EventArgs)
    Console.WriteLine(" ** Authorization context changed ** ")
  End Sub

End Class

[C#]
using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

public class AuthorizationContextChangedEvent
{
  public static void Main()
  {
    // Create policy and hook the AuthorizationContextChanged event.
    AuthorizationPolicy policy = new AuthorizationPolicy();
    policy.AuthorizationContextChanged += new EventHandler(HandleAuthorizationContextChanged);

    // Populate the policy with a simple model - the Author can execute the Save
    // action that moves the policy from the New to the Saved state. (More precisely, the Save action
    // moves the policy's subject, such as 'document', from New to the Saved state.)
    policy.Roles.AddNew("Author");

    // The first state added to the policy becomes the current state, so this also
    // raises the AuthorizationContextChanged just like setting the CurrentState
    // property directly.
    Console.WriteLine("Adding first state");
    policy.States.AddNew("New");

    policy.States.AddNew("Saved");
    policy.Actions.AddNew("Save");
    policy.ActionRules.AddNew("Save", "Author", "New", "Saved");

    // Setting the CurrentPrincipal raises the AuthorizationContextChanged event.
    Console.WriteLine("Assigning CurrentPrincipal");
    policy.CurrentPrincipal = new ExtendedPrincipal(new GenericIdentity("John"), new string[] {"Author"});
    Debug.Assert(policy.IsActionExecutable("Save"));

    // Executing an action also raises the AuthorizationContextChanged event (even
    // if no state change takes place).
    Console.WriteLine("Executing Save action");
    policy.ExecuteAction("Save");

    // Setting the CurrentState also raises the AuthorizationContextChanged event.
    Console.WriteLine("Assigning CurrentState");
    policy.CurrentState = policy.States["New"];
  }

  private static void HandleAuthorizationContextChanged(object sender, EventArgs e)
  {
    Console.WriteLine(" ** Authorization context changed ** ");
  }

}
The code above produces the following console output:
Adding first state
 ** Authorization context changed **
Assigning CurrentPrincipal
 ** Authorization context changed **
Executing Save action
 ** Authorization context changed **
Assigning CurrentState
 ** Authorization context changed **

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace |


AuthorizationPolicy.InstanceChanged Event

The event is raised after a policy object has been changed.

[Visual Basic]
Public Event InstanceChanged As ChangeEventHandler
[C#]
public event ChangeEventHandler InstanceChanged;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

Implements

IChangeEventSource.InstanceChanged

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.InstanceChanging Event

The event is raised before a policy object is changed.

[Visual Basic]
Public Event InstanceChanging As ChangeEventHandler
[C#]
public event ChangeEventHandler InstanceChanging;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

Implements

IChangeEventSource.InstanceChanging

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicy.ResolveRoleMembership Event

The event is raised as part of the role resolution process.

[Visual Basic]
Public Event ResolveRoleMembership As ResolveRoleMembershipEventHandler
[C#]
public event ResolveRoleMembershipEventHandler ResolveRoleMembership;

Event Data

The event handler receives an argument of type ResolveRoleMembershipEventArgs containing data related to this event. The following ResolveRoleMembershipEventArgs properties provide information specific to this event.

Property | Description
IsResolved | Sets or returns a value specifying whether the event handler resolved the role membership.
IsRoleMember | Sets or returns a flag specifying whether the IPrincipal associated with the event is member of the Role associated with the event.
Principal | Returns the IPrincipal reference whose membership in the role specified by the Role property should be determined.
Role | Returns a reference to the Role for which the membership of the principal specified by the Principal property should be determined.

Remarks

CAUTION If there are multiple handlers of this event, the last one that explicitly sets the IsResolved property to true will ultimately provide the outcome of the role resolution process.
The ResolveRoleMembership event handlers are not serialized along with the policy. This means that if you're transferring policies across AppDomain or machine boundaries, the event handlers won't be marshaled and used in the remote domain.

Example

The following example illustrates how to use the ResolveRoleMembership the event to 'override' normal role resolution process and to allow any principal to be handled as member of any role (regardless of the actual role membership):

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

'''
''' The class illustrates usage of the ResolveRoleMembership
''' event that is raised by the AuthorizationPolicy class while
''' evaluating the policy.
'''
Public Class ResolveRoleMembershipEvent

  '''
  ''' Represents the entry point of the application.
  '''
  Public Shared Sub Main()
    ' Populate a very simple policy with one state, role, action
    ' and action rule.
    Dim policy As New AuthorizationPolicy
    policy.States.AddNew("Default")
    policy.Roles.AddNew("User")
    policy.Actions.AddNew("Logon")

    ' The following statement grants the User role persmission to
    ' execute the Logon action (in the Default state, which is implicit in this case).
    policy.ActionRules.AddNew("Logon", "User")

    ' Now we'll set up the authorization context: the current state is already
    ' set to the sole Default state and we'll associate the policy with an
    ' generic principal without roles.
    policy.CurrentPrincipal = New GenericPrincipal(New GenericIdentity("Joe"), Nothing)

    ' Because the principal has no roles, the Logon action should be disabled.
    Debug.Assert(Not policy.IsActionExecutable("Logon"))

    ' Now we'll handle the ResolveRoleMembership event and always mark the passed-in
    ' role as belonging to the current principal.
    AddHandler policy.ResolveRoleMembership, AddressOf policy_ResolveRoleMembership

    ' Our ResolveRoleMembership handler ensures that any principal is member of any
    ' defined role, so the Logon action is now permitted.
    Debug.Assert(policy.IsActionExecutable("Logon"))
    policy.ExecuteAction("Logon")
  End Sub

  '''
  ''' Handles the ResolveRoleMembership event. Always indicates that the passed-in role
  ''' belongs to the current principal.
  '''
  Private Shared Sub policy_ResolveRoleMembership(ByVal sender As Object, ByVal e As ResolveRoleMembershipEventArgs)
    e.IsResolved = True ' disable further role membership checks by the owning AuthorizationPolicy
    e.IsRoleMember = True  ' mark the current principal as member of the role.
  End Sub

End Class

[C#]
using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

/// The class illustrates usage of the ResolveRoleMembership
/// event that is raised by the AuthorizationPolicy class while
/// evaluating the policy.
public class ResolveRoleMembershipEvent
{

  /// Represents the entry point of the application.
  public static void Main()
  {
    // Populate a very simple policy with one state, role, action
    // and action rule.
    AuthorizationPolicy policy = new AuthorizationPolicy();
    policy.States.AddNew("Default");
    policy.Roles.AddNew("User");
    policy.Actions.AddNew("Logon");

    // The following statement grants the User role persmission to
    // execute the Logon action (in the Default state, which is implicit).
    policy.ActionRules.AddNew("Logon", "User");

    // Now we'll set up the authorization context: the current state is already
    // set to the sole Default state and we'll associate the policy with an
    // generic principal without roles.
    policy.CurrentPrincipal = new GenericPrincipal(new GenericIdentity("Joe"), null);

    // Because the principal has no roles, the Logon action should be disabled.
    Debug.Assert(!policy.IsActionExecutable("Logon"));

    // Now we'll handle the ResolveRoleMembership event and always mark the passed-in
    // role as belonging to the current principal.
    policy.ResolveRoleMembership += new ResolveRoleMembershipEventHandler(policy_ResolveRoleMembership);

    // Our ResolveRoleMembership handler ensures that any principal is member of any
    // defined role, so the Logon action is now permitted.
    Debug.Assert(policy.IsActionExecutable("Logon"));
    policy.ExecuteAction("Logon");
  }

  /// Handles the ResolveRoleMembership event. Always indicates that the passed-in role
  /// belongs to the current principal.
  private static void policy_ResolveRoleMembership(object sender, ResolveRoleMembershipEventArgs e)
  {
    e.IsResolved = true; // disable further role membership checks by the owning AuthorizationPolicy
    e.IsRoleMember = true;  // mark the current principal as member of the role.
  }

}

See Also

AuthorizationPolicy Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader Class

Provides methods for saving and loading authorization policys to/from various media types.

For a list of all members of this type, see AuthorizationPolicyLoader Members.

System.Object
LaMarvin.Constable.AuthorizationPolicyLoader

[Visual Basic]
NotInheritable Public Class AuthorizationPolicyLoader
[C#]
public sealed class AuthorizationPolicyLoader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The class exposes only static (Shared in Visual Basic) methods.

Example

The following example uses the AuthorizationPolicyLoader.LoadFromFile method to load an authorization policy stored in XML file named "c:\model.xml":

[Visual Basic]
Dim policy As AuthorizationPolicy = AuthorizationPolicyLoader.LoadFromFile("c:\model.xml")

[C#]
AuthorizationPolicy policy = AuthorizationPolicyLoader.LoadFromFile(@"c:\model.xml");

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

AuthorizationPolicyLoader Members | LaMarvin.Constable Namespace


AuthorizationPolicyLoader Members

AuthorizationPolicyLoader overview

Public Static (Shared) Properties

TypeResolver Sets or returns a reference to an IPolicyLoaderTypeResolver implementation that will be used for loading of custom policy object types.

Public Static (Shared) Methods

GetXml | Gets a XML string representing the given AuthorizationPolicy.
IsPropertySerializable | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
LoadFromFile | Loads an authorization policy from a XML file.
LoadFromStream | Loads an instance of the AuthorizationPolicy class from the given stream.
LoadFromXml | Overloaded. Loads an instance of the AuthorizationPolicy class from the given XML string.
LoadFromXmlResource | Overloaded. Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the calling assembly's manifest.
SaveToFile | Overloaded. Stores the authorization policy contained in an AuthorizationPolicy instance in a file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader Properties

The properties of the AuthorizationPolicyLoader class are listed below. For a complete list of AuthorizationPolicyLoader class members, see the AuthorizationPolicyLoader Members topic.

Public Static (Shared) Properties

TypeResolver Sets or returns a reference to an IPolicyLoaderTypeResolver implementation that will be used for loading of custom policy object types.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.TypeResolver Property

Sets or returns a reference to an IPolicyLoaderTypeResolver implementation that will be used for loading of custom policy object types.

[Visual Basic]
Public Shared Property TypeResolver As IPolicyLoaderTypeResolver
[C#]
public static Design.IPolicyLoaderTypeResolver TypeResolver {get; set;}

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader Methods

The methods of the AuthorizationPolicyLoader class are listed below. For a complete list of AuthorizationPolicyLoader class members, see the AuthorizationPolicyLoader Members topic.

Public Static (Shared) Methods

GetXml | Gets a XML string representing the given AuthorizationPolicy.
IsPropertySerializable | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
LoadFromFile | Loads an authorization policy from a XML file.
LoadFromStream | Loads an instance of the AuthorizationPolicy class from the given stream.
LoadFromXml | Overloaded. Loads an instance of the AuthorizationPolicy class from the given XML string.
LoadFromXmlResource | Overloaded. Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the calling assembly's manifest.
SaveToFile | Overloaded. Stores the authorization policy contained in an AuthorizationPolicy instance in a file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.GetXml Method

Gets a XML string representing the given AuthorizationPolicy.

[Visual Basic]
Public Shared Function GetXml( _
ByVal policy As AuthorizationPolicy _
) As String
[C#]
public static string GetXml(
AuthorizationPolicy policy
);

Parameters

policy
The AuthorizationPolicy instance whose XML representation will be returned.

Return Value

A String with XML representing the policy instance.

Example

The following example populates a simple authorization policy and writes its XML representation to the console:

[Visual Basic]
// Create and populate the policy.
Dim policy As New AuthorizationPolicy()

// States.
policy.States.AddNew("Default")

// Roles.
policy.Roles.AddNew("User")
policy.Roles.Add(New WindowsRole("Admin", "BUILTIN\Administrators"))

// Actions.
policy.Actions.AddNew("Logoff")
policy.Actions.AddNew("Shutdown")

// Action rules for User.
policy.ActionRules.AddNew("Logoff", "User")
policy.ActionRules.AddNew("Shutdown", "User").IsEnabled = False

// Action rules for Admin.
policy.ActionRules.AddNew("Logoff", "Admin")
policy.ActionRules.AddNew("Shutdown", "Admin")

// Get a XML representation of the model.
Dim xml As String = AuthorizationPolicyLoader.GetXml(policy)
Console.WriteLine(xml)

[C#]
// Create and populate the policy.
AuthorizationPolicy policy = new AuthorizationPolicy();

// States.
policy.States.AddNew("Default");

// Roles.
policy.Roles.AddNew("User");
policy.Roles.Add(new WindowsRole("Admin", @"BUILTIN\Administrators"));

// Actions.
policy.Actions.AddNew("Logoff");
policy.Actions.AddNew("Shutdown");

// Action rules for User.
policy.ActionRules.AddNew("Logoff", "User");
policy.ActionRules.AddNew("Shutdown", "User").IsEnabled = false;

// Action rules for Admin.
policy.ActionRules.AddNew("Logoff", "Admin");
policy.ActionRules.AddNew("Shutdown", "Admin");

// Get a XML representation of the model.
string xml = AuthorizationPolicyLoader.GetXml(policy);
Console.WriteLine(xml);
The console output generated by the above code looks like this:
<authorizationPolicy id="" currentState="Default">
    <!--Roles-->
    <role id="User" />
    <role id="Admin" type="windows" WindowsGroupName="BUILTIN\Administrators" />
    <!--States-->
    <state id="Default" />
    <!--Actions-->
    <action id="Logoff" />
    <action id="Shutdown" />
    <!--Properties-->
    <!--Action authorization rules-->
    <actionRule action="Logoff" role="User" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <actionRule action="Shutdown" role="User" state="Default" targetState="Default" isEnabled="False" isVisible="True" />
    <actionRule action="Logoff" role="Admin" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <actionRule action="Shutdown" role="Admin" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <!--Property authorization rules-->
</authorizationPolicy>

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.IsPropertySerializable Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Function IsPropertySerializable( _
ByVal property As PropertyDescriptor _
) As Boolean
[C#]
public static bool IsPropertySerializable(
PropertyDescriptor property
);

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.LoadFromFile Method

Loads an authorization policy from a XML file.

[Visual Basic]
Public Shared Function LoadFromFile( _
ByVal xmlFileName As String _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromFile(
string xmlFileName
);

Parameters

xmlFileName
The path to a XML file containing the authorization policy.

Return Value

A reference to an AuthorizationPolicy class populated from the data in the xmlFileName.

Remarks

The CurrentState is preserved while loading / saving authorizaton models. However, the CurrentPrincipal is not saved.

CAUTION Because the XML file doesn't store the current principal, before using the AuthorizationPolicy instance be sure to specify feasible CurrentPrincipal reference to be used to resolve role membership.

Example

The following example loads an authorization policy from a file and prepares the authorization context by setting the CurrentPrincipal property to an instance of the ExtendedPrincipal class.

[Visual Basic]
Dim policy As AuthorizationPolicy = AuthorizationPolicyLoader.LoadFromFile("c:\model.xml")
policy.CurrentPrincipal = New ExtendedPrincipal

[C#]
AuthorizationPolicy policy = AuthorizationPolicyLoader.LoadFromFile(@"c:\model.xml");;
policy.CurrentPrincipal = new ExtendedPrincipal();

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.LoadFromStream Method

Loads an instance of the AuthorizationPolicy class from the given stream.

[Visual Basic]
Public Shared Function LoadFromStream( _
ByVal stream As Stream _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromStream(
Stream stream
);

Parameters

stream
The stream containing the authorization policy to be loaded.

Return Value

An instance of the AuthorizationPolicy class populated from the given stream.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


LoadFromXml Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicyLoader.LoadFromXml Method

[This is preliminary documentation and subject to change.]

Loads an instance of the AuthorizationPolicy class from the given XML string.

Overload List

Loads an instance of the AuthorizationPolicy class from the given XML string.

public static AuthorizationPolicy LoadFromXml(string);

Loads an authorization policy from the given XML node.

public static AuthorizationPolicy LoadFromXml(XmlNode);

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicy


AuthorizationPolicyLoader.LoadFromXml Method (String)

Loads an instance of the AuthorizationPolicy class from the given XML string.

[Visual Basic]
Overloads Public Shared Function LoadFromXml( _
ByVal xml As String _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromXml(
string xml
);

Parameters

xml
The XML string containing the definition of a valid authorization policy.

Return Value

An instance of the AuthorizationPolicy class initialized according to the data found in the XML string.

Remarks

The XML string must contain well-formed XML starting with the <authorizationPolicy> element.

See the GetXml method to see how you can get a XML string representing an AuthorizationPolicy instance.

CAUTION After loading the model, be sure to set the CurrentPrincipal property because it is not preserved while saving and loading XML files.

Example

The following example loads the document approval authorization policy defined in the _doc.xml file.

[Visual Basic]
Dim docAuthorizationPolicy As AuthorizationPolicy = AuthorizationPolicyLoader.LoadFromXml("_doc.xml")

[C#]
AuthorizationPolicy docAuthorizationPolicy = AuthorizationPolicyLoader.LoadFromXml(@"_doc.xml");

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.LoadFromXml Overload List | AuthorizationPolicy


AuthorizationPolicyLoader.LoadFromXml Method (XmlNode)

Loads an authorization policy from the given XML node.

[Visual Basic]
Overloads Public Shared Function LoadFromXml( _
ByVal policyNode As XmlNode _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromXml(
XmlNode policyNode
);

Parameters

policyNode
A valid reference to the "authorizationPolicy" element node.

Return Value

A reference to the loaded AuthorizationPolicy instance.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the policyNode argument value.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.LoadFromXml Overload List


LoadFromXmlResource Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicyLoader.LoadFromXmlResource Method

Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the calling assembly's manifest.

Overload List

Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the calling assembly's manifest.

public static AuthorizationPolicy LoadFromXmlResource(string);

Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the specified encoding in the calling assembly's manifest.

public static AuthorizationPolicy LoadFromXmlResource(string,Encoding);

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.LoadFromXmlResource Method (String)

Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the calling assembly's manifest.

[Visual Basic]
Overloads Public Shared Function LoadFromXmlResource( _
ByVal resourceName As String _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromXmlResource(
string resourceName
);

Parameters

resourceName
The name of the resource embedded in the calling assembly's manifest.

Return Value

An instance of the AuthorizationPolicy class populated from the given resource.

Example

The following example loads an authorization policy embedded as a resource named "LaMarvin.Constable.Test._doc.xml":

[Visual Basic]
Dim resourceName As String = "LaMarvin.Constable.Test._doc.xml"
Dim policy As AuthorizationPolicy = AuthorizationPolicyLoader.LoadFromXmlResource(resourceName)

[C#]
string resourceName = "LaMarvin.Constable.Test._doc.xml";
AuthorizationPolicy policy = AuthorizationPolicyLoader.LoadFromXmlResource(resourceName);
CAUTION Please note that we've qualified the name of the embedded XML file ("_doc.xml") with the default namespace that is defined for the particular assembly's project. If you're not sure what is the fully qualified name of your embedded resource, just compile the assembly and examine it with the ILDasm tool that comes with .NET Framework installation.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.LoadFromXmlResource Overload List


AuthorizationPolicyLoader.LoadFromXmlResource Method (String, Encoding)

Loads an instance of the AuthorizationPolicy class populated from an authorization policy stored as a XML resource in the specified encoding in the calling assembly's manifest.

[Visual Basic]
Overloads Public Shared Function LoadFromXmlResource( _
ByVal resourceName As String, _
ByVal encoding As Encoding _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadFromXmlResource(
string resourceName,
Encoding encoding
);

Parameters

resourceName
The name of the resource embedded in the calling assembly's manifest.
encoding
The encoding of the XML resource.

Return Value

An instance of the AuthorizationPolicy class populated from the given resource.

Remarks

Set the LoadFromXmlResource overload for an example.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.LoadFromXmlResource Overload List


SaveToFile Method

Constable Authorization Engine 2.0 BETA

AuthorizationPolicyLoader.SaveToFile Method

Stores the authorization policy contained in an AuthorizationPolicy instance in a file.

Overload List

Stores the authorization policy contained in the AuthorizationPolicy instance in the file identified by the fileName argument.

public static void SaveToFile(AuthorizationPolicy,string);

Stores the authorization policy contained in the AuthorizationPolicy instance in the file identified by the fileName argument in the specified encoding.

public static void SaveToFile(AuthorizationPolicy,string,Encoding);

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.SaveToFile Method (AuthorizationPolicy, String)

Stores the authorization policy contained in the AuthorizationPolicy instance in the file identified by the fileName argument.

[Visual Basic]
Overloads Public Shared Sub SaveToFile( _
ByVal policy As AuthorizationPolicy, _
ByVal fileName As String _
)
[C#]
public static void SaveToFile(
AuthorizationPolicy policy,
string fileName
);

Parameters

policy
The AuthorizationPolicy instance containing the authorization model to be saved.
fileName
The file in which to store the authorization policy. If the file exists, the method will truncate it and overwrite it with the new content.

Remarks

The method writes the file using UTF-8 encoding. In order to use different encoding, use the SaveToFile overload.

Example

The following example populates a simple model and saves it to a file:

[Visual Basic]
' Create and populate the policy.
Dim policy As New AuthorizationPolicy

' States.
policy.States.AddNew("Default")

' Roles.
policy.Roles.AddNew("User")
policy.Roles.Add(New WindowsRole("Admin", @"BUILTIN\Administrators"))

' Actions.
policy.Actions.AddNew("Logoff")
policy.Actions.AddNew("Shutdown")

' Action rules for User.
policy.ActionRules.AddNew("Logoff", "User")
policy.ActionRules.AddNew("Shutdown", "User").IsEnabled = False

' Action rules for Admin.
policy.ActionRules.AddNew("Logoff", "Admin")
policy.ActionRules.AddNew("Shutdown", "Admin")

' Save the model.
AuthorizationPolicyLoader.SaveToFile(policy, "c:\model.xml")

[C#]
// Create and populate the policy.
AuthorizationPolicy policy = new AuthorizationPolicy();

// States.
policy.States.AddNew("Default");

// Roles.
policy.Roles.AddNew("User");
policy.Roles.Add(new WindowsRole("Admin", @"BUILTIN\Administrators"));

// Actions.
policy.Actions.AddNew("Logoff");
policy.Actions.AddNew("Shutdown");

// Action rules for User.
policy.ActionRules.AddNew("Logoff", "User");
policy.ActionRules.AddNew("Shutdown", "User").IsEnabled = false;

// Action rules for Admin.
policy.ActionRules.AddNew("Logoff", "Admin");
policy.ActionRules.AddNew("Shutdown", "Admin");

// Save the model.
AuthorizationPolicyLoader.SaveToFile(policy, @"c:\model.xml");
The resulting c:\model.xml file looks like this:
<?xml version="1.0" encoding="utf-8"?>
<!--Generated by LaMarvin.Constable.AuthorizationPolicyLoader, LaMarvin.Constable, Version=2.0.289.0, Culture=neutral, PublicKeyToken=351c1e2b8552ee8a.-->
<!--Generated on \\PALO at 03/05/2006 12:06:40.-->
<authorizationPolicy id="" currentState="Default">
    <!--Roles-->
    <role id="User" />
    <role id="Admin" type="windows" windowsGroupName="BUILTIN\Administrators" />
    <!--States-->
    <state id="Default" />
    <!--Actions-->
    <action id="Logoff" />
    <action id="Shutdown" />
    <!--Properties-->
    <!--Action authorization rules-->
    <actionRule action="Logoff" role="User" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <actionRule action="Shutdown" role="User" state="Default" targetState="Default" isEnabled="False" isVisible="True" />
    <actionRule action="Logoff" role="Admin" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <actionRule action="Shutdown" role="Admin" state="Default" targetState="Default" isEnabled="True" isVisible="True" />
    <!--Property authorization rules-->
</authorizationPolicy>

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.SaveToFile Overload List


AuthorizationPolicyLoader.SaveToFile Method (AuthorizationPolicy, String, Encoding)

Stores the authorization policy contained in the AuthorizationPolicy instance in the file identified by the fileName argument in the specified encoding.

[Visual Basic]
Overloads Public Shared Sub SaveToFile( _
ByVal policy As AuthorizationPolicy, _
ByVal fileName As String, _
ByVal encoding As Encoding _
)
[C#]
public static void SaveToFile(
AuthorizationPolicy policy,
string fileName,
Encoding encoding
);

Parameters

policy
The AuthorizationPolicy instance containing the authorization model to be saved.
fileName
The file in which to store the authorization policy. If the file exists, the method will truncate it and overwrite it with the new content.
encoding
The encoding to generate. If encoding is a a null reference (Nothing in Visual Basic), it writes the file out as UTF-8.

See Also

AuthorizationPolicyLoader Class | LaMarvin.Constable Namespace | AuthorizationPolicyLoader.SaveToFile Overload List


AuthorizationPolicyLoader.XmlElementNames Class

Defines the names of XML elements that comprise the definition of an authorization policy stored in a XML file.

For a list of all members of this type, see AuthorizationPolicyLoader.XmlElementNames Members.

System.Object
LaMarvin.Constable.AuthorizationPolicyLoader.XmlElementNames

[Visual Basic]
NotInheritable Public Class AuthorizationPolicyLoader.XmlElementNames
[C#]
public sealed class AuthorizationPolicyLoader.XmlElementNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

AuthorizationPolicyLoader.XmlElementNames Members | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames Members

AuthorizationPolicyLoader.XmlElementNames overview

Public Static (Shared) Fields

Action | The "action" element.
ActionRule | The "actionRule" element.
AuthorizationPolicy | The outermost "authorizationPolicy" element.
Property | The "property" element.
PropertyRule | The "propertyRule" element.
Role | The "role" element.
State | The "state" element.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames Fields

The fields of the AuthorizationPolicyLoader.XmlElementNames class are listed below. For a complete list of AuthorizationPolicyLoader.XmlElementNames class members, see the AuthorizationPolicyLoader.XmlElementNames Members topic.

Public Static (Shared) Fields

Action | The "action" element.
ActionRule | The "actionRule" element.
AuthorizationPolicy | The outermost "authorizationPolicy" element.
Property | The "property" element.
PropertyRule | The "propertyRule" element.
Role | The "role" element.
State | The "state" element.

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.Action Field

The "action" element.

[Visual Basic]
Public Const Action As String = "action"
[C#]
public const string Action = "action";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.ActionRule Field

The "actionRule" element.

[Visual Basic]
Public Const ActionRule As String = "actionRule"
[C#]
public const string ActionRule = "actionRule";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.AuthorizationPolicy Field

The outermost "authorizationPolicy" element.

[Visual Basic]
Public Const AuthorizationPolicy As String = "authorizationPolicy"
[C#]
public const string AuthorizationPolicy = "authorizationPolicy";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.Property Field

The "property" element.

[Visual Basic]
Public Const Property As String = "property"
[C#]
public const string Property = "property";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.PropertyRule Field

The "propertyRule" element.

[Visual Basic]
Public Const PropertyRule As String = "propertyRule"
[C#]
public const string PropertyRule = "propertyRule";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.Role Field

The "role" element.

[Visual Basic]
Public Const Role As String = "role"
[C#]
public const string Role = "role";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


AuthorizationPolicyLoader.XmlElementNames.State Field

The "state" element.

[Visual Basic]
Public Const State As String = "state"
[C#]
public const string State = "state";

See Also

AuthorizationPolicyLoader.XmlElementNames Class | LaMarvin.Constable Namespace


ConstableException Class

The base class for all exceptions generated by the CAZE library.

For a list of all members of this type, see ConstableException Members.

System.Object
System.Exception
LaMarvin.Constable.ConstableException
LaMarvin.Constable.DuplicateAuthorizationRuleException
LaMarvin.Constable.NonDeterministicModelException
LaMarvin.Constable.PermissionDeniedException

[Visual Basic]
<Serializable>
Public Class ConstableException
Inherits Exception
[C#]
[Serializable]
public class ConstableException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ConstableException Members | LaMarvin.Constable Namespace


ConstableException Members

ConstableException overview

Public Instance Constructors

ConstableException Overloaded. Initializes a new instance of the ConstableException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ConstableException Overloaded. Initializes a new instance of the ConstableException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstableException Class | LaMarvin.Constable Namespace


ConstableException Constructor

Initializes a new instance of the ConstableException class.

Overload List

Initializes a new instance of the ConstableException class.

public ConstableException();

Initializes a new instance of the ConstableException class for deserialization.

protected ConstableException(SerializationInfo,StreamingContext);

Initializes a new instance of the ConstableException class with the given message.

public ConstableException(string);

Initializes a new instance of the ConstableException class with the given message and an inner Exception.

public ConstableException(string,Exception);

See Also

ConstableException Class | LaMarvin.Constable Namespace


ConstableException Constructor ()

Initializes a new instance of the ConstableException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ConstableException();

See Also

ConstableException Class | LaMarvin.Constable Namespace | ConstableException Constructor Overload List


ConstableException Constructor (String)

Initializes a new instance of the ConstableException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public ConstableException(
string message
);

See Also

ConstableException Class | LaMarvin.Constable Namespace | ConstableException Constructor Overload List


ConstableException Constructor (String, Exception)

Initializes a new instance of the ConstableException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public ConstableException(
string message,
Exception innerException
);

See Also

ConstableException Class | LaMarvin.Constable Namespace | ConstableException Constructor Overload List


ConstableException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ConstableException class for deserialization.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected ConstableException(
SerializationInfo info,
StreamingContext context
);

See Also

ConstableException Class | LaMarvin.Constable Namespace | ConstableException Constructor Overload List


DuplicateAuthorizationRuleException Class

The exception that is thrown by an AuthorizationPolicy when attempting to add a duplicate authorization rule to the ActionRules or PropertyRules collections.

For a list of all members of this type, see DuplicateAuthorizationRuleException Members.

System.Object
System.Exception
LaMarvin.Constable.ConstableException
LaMarvin.Constable.DuplicateAuthorizationRuleException

[Visual Basic]
<Serializable>
Public Class DuplicateAuthorizationRuleException
Inherits ConstableException
[C#]
[Serializable]
public class DuplicateAuthorizationRuleException : ConstableException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

DuplicateAuthorizationRuleException Members | LaMarvin.Constable Namespace


DuplicateAuthorizationRuleException Members

DuplicateAuthorizationRuleException overview

Public Instance Constructors

DuplicateAuthorizationRuleException Overloaded. Initializes a new instance of the DuplicateAuthorizationRuleException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

DuplicateAuthorizationRuleException Overloaded. Initializes a new instance of the DuplicateAuthorizationRuleException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace


DuplicateAuthorizationRuleException Constructor

Initializes a new instance of the DuplicateAuthorizationRuleException class.

Overload List

Initializes a new instance of the DuplicateAuthorizationRuleException class.

public DuplicateAuthorizationRuleException();

Initializes a new instance of the DuplicateAuthorizationRuleException class while deserializng the object.

protected DuplicateAuthorizationRuleException(SerializationInfo,StreamingContext);

Initializes a new instance of the DuplicateAuthorizationRuleException class with the given message.

public DuplicateAuthorizationRuleException(string);

Initializes a new instance of the DuplicateAuthorizationRuleException class with the given message and an inner Exception.

public DuplicateAuthorizationRuleException(string,Exception);

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace


DuplicateAuthorizationRuleException Constructor ()

Initializes a new instance of the DuplicateAuthorizationRuleException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DuplicateAuthorizationRuleException();

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace | DuplicateAuthorizationRuleException Constructor Overload List


DuplicateAuthorizationRuleException Constructor (String)

Initializes a new instance of the DuplicateAuthorizationRuleException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public DuplicateAuthorizationRuleException(
string message
);

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace | DuplicateAuthorizationRuleException Constructor Overload List


DuplicateAuthorizationRuleException Constructor (String, Exception)

Initializes a new instance of the DuplicateAuthorizationRuleException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public DuplicateAuthorizationRuleException(
string message,
Exception innerException
);

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace | DuplicateAuthorizationRuleException Constructor Overload List


DuplicateAuthorizationRuleException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the DuplicateAuthorizationRuleException class while deserializng the object.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected DuplicateAuthorizationRuleException(
SerializationInfo info,
StreamingContext context
);

See Also

DuplicateAuthorizationRuleException Class | LaMarvin.Constable Namespace | DuplicateAuthorizationRuleException Constructor Overload List


EnabledOption Enumeration

Specifies the required value of the IsEnabled property for rules to be returned from the GetDefinedActionRules and GetDefinedPropertyRules methods.

[Visual Basic]
<Serializable>
Public Enum EnabledOption
[C#]
[Serializable]
public enum EnabledOption

Members

Member Name | Description
Enabled | Return only rules with the IsEnabled property set to true.
NotEnabled | Return only rules with the IsEnabled property set to false.
Any | Return rules regardless of the IsEnabled property value.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

LaMarvin.Constable Namespace


NonDeterministicModelException Class

The exception that is thrown by the ExecuteAction method when attempting to execute a non-deterministic action.

For a list of all members of this type, see NonDeterministicModelException Members.

System.Object
System.Exception
LaMarvin.Constable.ConstableException
LaMarvin.Constable.NonDeterministicModelException

[Visual Basic]
<Serializable>
Public Class NonDeterministicModelException
Inherits ConstableException
[C#]
[Serializable]
public class NonDeterministicModelException : ConstableException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

NonDeterministicModelException Members | LaMarvin.Constable Namespace


NonDeterministicModelException Members

NonDeterministicModelException overview

Public Instance Constructors

NonDeterministicModelException Overloaded. Initializes a new instance of the NonDeterministicModelException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

NonDeterministicModelException Overloaded. Initializes a new instance of the NonDeterministicModelException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace


NonDeterministicModelException Constructor

Initializes a new instance of the NonDeterministicModelException class.

Overload List

Initializes a new instance of the NonDeterministicModelException class.

public NonDeterministicModelException();

Initializes a new instance of the NonDeterministicModelException class while deserializng the object.

protected NonDeterministicModelException(SerializationInfo,StreamingContext);

Initializes a new instance of the NonDeterministicModelException class with the given message.

public NonDeterministicModelException(string);

Initializes a new instance of the NonDeterministicModelException class with the given message and an inner Exception.

public NonDeterministicModelException(string,Exception);

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace


NonDeterministicModelException Constructor ()

Initializes a new instance of the NonDeterministicModelException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NonDeterministicModelException();

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace | NonDeterministicModelException Constructor Overload List


NonDeterministicModelException Constructor (String)

Initializes a new instance of the NonDeterministicModelException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public NonDeterministicModelException(
string message
);

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace | NonDeterministicModelException Constructor Overload List


NonDeterministicModelException Constructor (String, Exception)

Initializes a new instance of the NonDeterministicModelException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public NonDeterministicModelException(
string message,
Exception innerException
);

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace | NonDeterministicModelException Constructor Overload List


NonDeterministicModelException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the NonDeterministicModelException class while deserializng the object.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected NonDeterministicModelException(
SerializationInfo info,
StreamingContext context
);

See Also

NonDeterministicModelException Class | LaMarvin.Constable Namespace | NonDeterministicModelException Constructor Overload List


PermissionDeniedException Class

The exception that is thrown by the ExecuteAction method when attempting to execute a disabled action.

For a list of all members of this type, see PermissionDeniedException Members.

System.Object
System.Exception
LaMarvin.Constable.ConstableException
LaMarvin.Constable.PermissionDeniedException

[Visual Basic]
<Serializable>
Public Class PermissionDeniedException
Inherits ConstableException
[C#]
[Serializable]
public class PermissionDeniedException : ConstableException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

PermissionDeniedException Members | LaMarvin.Constable Namespace


PermissionDeniedException Members

PermissionDeniedException overview

Public Instance Constructors

PermissionDeniedException Overloaded. Initializes a new instance of the PermissionDeniedException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

PermissionDeniedException Overloaded. Initializes a new instance of the PermissionDeniedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace


PermissionDeniedException Constructor

Initializes a new instance of the PermissionDeniedException class.

Overload List

Initializes a new instance of the PermissionDeniedException class.

public PermissionDeniedException();

Initializes a new instance of the PermissionDeniedException class while deserializng the object.

protected PermissionDeniedException(SerializationInfo,StreamingContext);

Initializes a new instance of the PermissionDeniedException class with the given message.

public PermissionDeniedException(string);

Initializes a new instance of the PermissionDeniedException class with the given message and an inner Exception.

public PermissionDeniedException(string,Exception);

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace


PermissionDeniedException Constructor ()

Initializes a new instance of the PermissionDeniedException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PermissionDeniedException();

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace | PermissionDeniedException Constructor Overload List


PermissionDeniedException Constructor (String)

Initializes a new instance of the PermissionDeniedException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public PermissionDeniedException(
string message
);

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace | PermissionDeniedException Constructor Overload List


PermissionDeniedException Constructor (String, Exception)

Initializes a new instance of the PermissionDeniedException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public PermissionDeniedException(
string message,
Exception innerException
);

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace | PermissionDeniedException Constructor Overload List


PermissionDeniedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PermissionDeniedException class while deserializng the object.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected PermissionDeniedException(
SerializationInfo info,
StreamingContext context
);

See Also

PermissionDeniedException Class | LaMarvin.Constable Namespace | PermissionDeniedException Constructor Overload List


ResolveRoleMembershipEventArgs Class

Defines arguments for the ResolveRoleMembership event.

For a list of all members of this type, see ResolveRoleMembershipEventArgs Members.

System.Object
System.EventArgs
LaMarvin.Constable.ResolveRoleMembershipEventArgs

[Visual Basic]
<Serializable>
Public Class ResolveRoleMembershipEventArgs
Inherits EventArgs
[C#]
[Serializable]
public class ResolveRoleMembershipEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ResolveRoleMembershipEventArgs Members | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs Members

ResolveRoleMembershipEventArgs overview

Public Instance Constructors

ResolveRoleMembershipEventArgs Overloaded. Initializes a new instance of the ResolveRoleMembershipEventArgs class.

Public Instance Properties

IsResolved | Sets or returns a value specifying whether the event handler resolved the role membership.
IsRoleMember | Sets or returns a flag specifying whether the IPrincipal associated with the event is member of the Role associated with the event.
Principal | Returns the IPrincipal reference whose membership in the role specified by the Role property should be determined.
Role | Returns a reference to the Role for which the membership of the principal specified by the Principal property should be determined.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs Constructor

Initializes a new instance of the ResolveRoleMembershipEventArgs class with the given principal and role.

Overload List

Initializes a new instance of the ResolveRoleMembershipEventArgs class with the given principal and role.

public ResolveRoleMembershipEventArgs(IPrincipal,Role);

Initializes a new instance of the ResolveRoleMembershipEventArgs class with the given principalm role and resolution flags.

public ResolveRoleMembershipEventArgs(IPrincipal,Role,bool,bool);

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs Constructor (IPrincipal, Role)

Initializes a new instance of the ResolveRoleMembershipEventArgs class with the given principal and role.

[Visual Basic]
Overloads Public Sub New( _
ByVal principal As IPrincipal, _
ByVal role As Role _
)
[C#]
public ResolveRoleMembershipEventArgs(
IPrincipal principal,
Role role
);

Parameters

principal
The principal for which the membership should be determined.
role
The role for which the membership should be determined.

Remarks

The IsResolved and IsRoleMember properties are set to false by this constructor.

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace | ResolveRoleMembershipEventArgs Constructor Overload List


ResolveRoleMembershipEventArgs Constructor (IPrincipal, Role, Boolean, Boolean)

Initializes a new instance of the ResolveRoleMembershipEventArgs class with the given principalm role and resolution flags.

[Visual Basic]
Overloads Public Sub New( _
ByVal principal As IPrincipal, _
ByVal role As Role, _
ByVal isResolved As Boolean, _
ByVal isRoleMember As Boolean _
)
[C#]
public ResolveRoleMembershipEventArgs(
IPrincipal principal,
Role role,
bool isResolved,
bool isRoleMember
);

Parameters

principal
The principal for which the membership should be determined.
role
The role for which the membership should be determined.
isResolved
The initial value of the IsResolved property.
isRoleMember
The initial value of the IsRoleMember property.

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace | ResolveRoleMembershipEventArgs Constructor Overload List


ResolveRoleMembershipEventArgs Properties

The properties of the ResolveRoleMembershipEventArgs class are listed below. For a complete list of ResolveRoleMembershipEventArgs class members, see the ResolveRoleMembershipEventArgs Members topic.

Public Instance Properties

IsResolved | Sets or returns a value specifying whether the event handler resolved the role membership.
IsRoleMember | Sets or returns a flag specifying whether the IPrincipal associated with the event is member of the Role associated with the event.
Principal | Returns the IPrincipal reference whose membership in the role specified by the Role property should be determined.
Role | Returns a reference to the Role for which the membership of the principal specified by the Principal property should be determined.

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs.IsResolved Property

Sets or returns a value specifying whether the event handler resolved the role membership.

[Visual Basic]
Public Property IsResolved As Boolean
[C#]
public bool IsResolved {get; set;}

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs.IsRoleMember Property

Sets or returns a flag specifying whether the IPrincipal associated with the event is member of the Role associated with the event.

[Visual Basic]
Public Property IsRoleMember As Boolean
[C#]
public bool IsRoleMember {get; set;}

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs.Principal Property

Returns the IPrincipal reference whose membership in the role specified by the Role property should be determined.

[Visual Basic]
Public ReadOnly Property Principal As IPrincipal
[C#]
public System.Security.Principal.IPrincipal Principal {get;}

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventArgs.Role Property

Returns a reference to the Role for which the membership of the principal specified by the Principal property should be determined.

[Visual Basic]
Public ReadOnly Property Role As Role
[C#]
public Model.Role Role {get;}

See Also

ResolveRoleMembershipEventArgs Class | LaMarvin.Constable Namespace


ResolveRoleMembershipEventHandler Delegate

The signature for methods that can handle the ResolveRoleMembership event.

[Visual Basic]
<Serializable>
Public Delegate Sub ResolveRoleMembershipEventHandler( _
ByVal sender As Object, _
ByVal e As ResolveRoleMembershipEventArgs _
)
[C#]
[Serializable]
public delegate void ResolveRoleMembershipEventHandler(
object sender,
ResolveRoleMembershipEventArgs e
);

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

LaMarvin.Constable Namespace


VisibleOption Enumeration

Specifies the required value of the IsVisible property for rules to be returned from the GetDefinedActionRules and GetDefinedPropertyRules methods.

[Visual Basic]
<Serializable>
Public Enum VisibleOption
[C#]
[Serializable]
public enum VisibleOption

Members

Member Name | Description
Visible | Return only rules with the IsVisible property set to true.
NotVisible | Return only rules with the IsVisible property set to false.
Any | Return rules regardless of the IsVisible property value.

Requirements

Namespace: LaMarvin.Constable

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

LaMarvin.Constable Namespace


LaMarvin.Constable.Design

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design Namespace

[This is preliminary documentation and subject to change.]

Contains types comprising the Constable Authorization Engine Design Environment implementing types for designing, testing, storing and retrieving authorization policies and policy documents.

Namespace hierarchy

Classes

Class | Description
AuthorizationContextPropertyGridAdapter | Provides a PropertyGrid-editable representation of the Constable Authorization Engine (CAZE) authorization context.
DesignHelper | Provides commonly used services for the CAZE Design Environment.
PolicyDesignApplicationContext | [TBD]
PolicyDesignContextControlAttribute | [TBD]
SerializablePropertyAttribute | Marks a property of a custom policy object type as available for serialization and deserialization to/from persistence medium.

Interfaces

Interface | Description
IPolicyDesignContextControl | Represents a contract for controls that the Policy Designer can show as a separate tab in the main window.
IPolicyDesignExtension | [TBD]
IPolicyDesignHost | [TBD]
IPolicyLoaderContext | Represents contextual information for custom policy loaders that implement the IPolicyLoaderTypeResolver interface.
IPolicyLoaderTypeResolver | Represents a contract for creating policy objects in the course of loading an authorization policy from a persitence medium
IPolicySimulationView | [TBD]

Enumerations

Enumeration | Description
PolicyDesignHostMenuItem | [TBD]


AuthorizationContextPropertyGridAdapter Class

Provides a PropertyGrid-editable representation of the Constable Authorization Engine (CAZE) authorization context.

For a list of all members of this type, see AuthorizationContextPropertyGridAdapter Members.

System.Object
LaMarvin.Constable.Design.AuthorizationContextPropertyGridAdapter

[Visual Basic]
NotInheritable Public Class AuthorizationContextPropertyGridAdapter
[C#]
public sealed class AuthorizationContextPropertyGridAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The CAZE authorization context is represented by values of the AuthorizationPolicy.CurrentPrincipal and AuthorizationPolicy.CurrentState properties. The AuthorizationContextPropertyGridAdapter provides an adapter that allows for user-friendly modification of these properties from within the PropertyGrid.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

AuthorizationContextPropertyGridAdapter Members | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter Members

AuthorizationContextPropertyGridAdapter overview

Public Instance Constructors

AuthorizationContextPropertyGridAdapter Constructor Initializes a new instance of the AuthorizationContextPropertyGridAdapter class.

Public Instance Properties

CurrentState | Gets or sets the current state of the associated AuthorizationPolicy.
Policy | Gets the associated AuthorizationPolicy.
Roles | Gets or sets the collection of roles that the associated CurrentPrincipal is member of.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter Constructor

Initializes a new instance of the AuthorizationContextPropertyGridAdapter class.

[Visual Basic]
Public Sub New( _
ByVal policy As AuthorizationPolicy _
)
[C#]
public AuthorizationContextPropertyGridAdapter(
AuthorizationPolicy policy
);

Parameters

policy
The associated policy.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter Properties

The properties of the AuthorizationContextPropertyGridAdapter class are listed below. For a complete list of AuthorizationContextPropertyGridAdapter class members, see the AuthorizationContextPropertyGridAdapter Members topic.

Public Instance Properties

CurrentState | Gets or sets the current state of the associated AuthorizationPolicy.
Policy | Gets the associated AuthorizationPolicy.
Roles | Gets or sets the collection of roles that the associated CurrentPrincipal is member of.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter.CurrentState Property

Gets or sets the current state of the associated AuthorizationPolicy.

[Visual Basic]
Public Property CurrentState As State
[C#]
public LaMarvin.Constable.Model.State CurrentState {get; set;}

Property Value

The CurrentState state of the associated policy.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter.Policy Property

Gets the associated AuthorizationPolicy.

[Visual Basic]
Public ReadOnly Property Policy As AuthorizationPolicy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get;}

Property Value

The authorization policy.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


AuthorizationContextPropertyGridAdapter.Roles Property

Gets or sets the collection of roles that the associated CurrentPrincipal is member of.

[Visual Basic]
Public Property Roles As StringCollection
[C#]
public System.Collections.Specialized.StringCollection Roles {get; set;}

Property Value

The collection of roles.

See Also

AuthorizationContextPropertyGridAdapter Class | LaMarvin.Constable.Design Namespace


DesignHelper Class

Provides commonly used services for the CAZE Design Environment.

For a list of all members of this type, see DesignHelper Members.

System.Object
LaMarvin.Constable.Design.DesignHelper

[Visual Basic]
NotInheritable Public Class DesignHelper
[C#]
public sealed class DesignHelper

Thread Safety

This type is not safe for multithreaded operations.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

DesignHelper Members | LaMarvin.Constable.Design Namespace


DesignHelper Members

DesignHelper overview

Public Static (Shared) Methods

ClonePolicy | [TBD]
CopyProperties | [TBD]
CreateActionRuleInstance | [TBD]
CreateDefaultPolicyDocument | [TBD]
CreateInstance | [TBD]
CreateNewNamedObject | [TBD]
CreateNewNamedObjectNoPrompt | [TBD]
CreatePropertyRuleInstance | [TBD]
GenerateUniqueNamedObjectId | Overloaded. Generates an Id that is guaranteed to be unique within the collection.
GetAssemblyFilterUsedForSelectType | [TBD]
GetCloningHandler | Overloaded. [TBD]
GetDefaultPolicyStore | [TBD]
GetInternalOwner | [TBD]
GetRealObservedInstance | Returns a reference to a "real" policy object. If the passed-in instance supports the IChangeEventObserver interface (i.e. it is an adapter), it returns the first ObservedPropertyChangeSenders, if any.
GetTypeDisplayName | Overloaded. [TBD]
GetTypeFilterUsedForSelectType | [TBD]
LoadDefaultPolicy | [TBD]
RegisterIntrinsicExtensions | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
SelectType | [TBD]
ShowError | Overloaded. [TBD]
ShowNewPolicyWindow | [TBD]
ShowUrl | Passes the specified URL to the Windows shell.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper Methods

The methods of the DesignHelper class are listed below. For a complete list of DesignHelper class members, see the DesignHelper Members topic.

Public Static (Shared) Methods

ClonePolicy | [TBD]
CopyProperties | [TBD]
CreateActionRuleInstance | [TBD]
CreateDefaultPolicyDocument | [TBD]
CreateInstance | [TBD]
CreateNewNamedObject | [TBD]
CreateNewNamedObjectNoPrompt | [TBD]
CreatePropertyRuleInstance | [TBD]
GenerateUniqueNamedObjectId | Overloaded. Generates an Id that is guaranteed to be unique within the collection.
GetAssemblyFilterUsedForSelectType | [TBD]
GetCloningHandler | Overloaded. [TBD]
GetDefaultPolicyStore | [TBD]
GetInternalOwner | [TBD]
GetRealObservedInstance | Returns a reference to a "real" policy object. If the passed-in instance supports the IChangeEventObserver interface (i.e. it is an adapter), it returns the first ObservedPropertyChangeSenders, if any.
GetTypeDisplayName | Overloaded. [TBD]
GetTypeFilterUsedForSelectType | [TBD]
LoadDefaultPolicy | [TBD]
RegisterIntrinsicExtensions | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
SelectType | [TBD]
ShowError | Overloaded. [TBD]
ShowNewPolicyWindow | [TBD]
ShowUrl | Passes the specified URL to the Windows shell.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.ClonePolicy Method

[TBD]

[Visual Basic]
Public Shared Function ClonePolicy( _
ByVal policy As AuthorizationPolicy _
) As AuthorizationPolicy
[C#]
public static AuthorizationPolicy ClonePolicy(
AuthorizationPolicy policy
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CopyProperties Method

[TBD]

[Visual Basic]
Public Shared Sub CopyProperties( _
ByVal source As Object, _
ByVal target As Object _
)
[C#]
public static void CopyProperties(
object source,
object target
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreateActionRuleInstance Method

[TBD]

[Visual Basic]
Public Shared Function CreateActionRuleInstance( _
ByVal type As Type, _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State _
) As ActionRule
[C#]
public static ActionRule CreateActionRuleInstance(
Type type,
Action action,
Role role,
State state,
State targetState
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreateDefaultPolicyDocument Method

[TBD]

[Visual Basic]
Public Shared Function CreateDefaultPolicyDocument() As PolicyDocument
[C#]
public static PolicyDocument CreateDefaultPolicyDocument();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreateInstance Method

[TBD]

[Visual Basic]
Public Shared Function CreateInstance( _
ByVal type As Type, _
ByVal ctorArgTypes As Type(), _
ByVal ctorArgValues As Object() _
) As Object
[C#]
public static object CreateInstance(
Type type,
Type[] ctorArgTypes,
object[] ctorArgValues
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreateNewNamedObject Method

[TBD]

[Visual Basic]
Public Shared Function CreateNewNamedObject( _
ByVal dialogOwner As IWin32Window, _
ByVal objectType As Type _
) As NamedObjectBase
[C#]
public static NamedObjectBase CreateNewNamedObject(
IWin32Window dialogOwner,
Type objectType
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreateNewNamedObjectNoPrompt Method

[TBD]

[Visual Basic]
Public Shared Function CreateNewNamedObjectNoPrompt( _
ByVal objectType As Type _
) As NamedObjectBase
[C#]
public static NamedObjectBase CreateNewNamedObjectNoPrompt(
Type objectType
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.CreatePropertyRuleInstance Method

[TBD]

[Visual Basic]
Public Shared Function CreatePropertyRuleInstance( _
ByVal type As Type, _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State _
) As PropertyRule
[C#]
public static PropertyRule CreatePropertyRuleInstance(
Type type,
Property property,
Role role,
State state
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


GenerateUniqueNamedObjectId Method

Constable Authorization Engine 2.0 BETA

DesignHelper.GenerateUniqueNamedObjectId Method

[This is preliminary documentation and subject to change.]

Generates an Id that is guaranteed to be unique within the collection.

Overload List

Generates an Id that is guaranteed to be unique within the collection.

public static string GenerateUniqueNamedObjectId(NamedObjectCollectionBase);

Generates an Id that is guaranteed to be unique within the collection.

public static string GenerateUniqueNamedObjectId(NamedObjectCollectionBase,string);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.GenerateUniqueNamedObjectId Method (NamedObjectCollectionBase)

Generates an Id that is guaranteed to be unique within the collection.

[Visual Basic]
Overloads Public Shared Function GenerateUniqueNamedObjectId( _
ByVal collection As NamedObjectCollectionBase _
) As String
[C#]
public static string GenerateUniqueNamedObjectId(
NamedObjectCollectionBase collection
);

Parameters

collection
The collection in which the Id should be unique.

Return Value

Returns an Id that is guaranteed to be unique within the collection.

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GenerateUniqueNamedObjectId Overload List


DesignHelper.GenerateUniqueNamedObjectId Method (NamedObjectCollectionBase, String)

Generates an Id that is guaranteed to be unique within the collection.

[Visual Basic]
Overloads Public Shared Function GenerateUniqueNamedObjectId( _
ByVal collection As NamedObjectCollectionBase, _
ByVal baseId As String _
) As String
[C#]
public static string GenerateUniqueNamedObjectId(
NamedObjectCollectionBase collection,
string baseId
);

Parameters

collection
The collection in which the Id should be unique.
baseId
The base Id to form a prefix to the generated Id.

Return Value

Returns an Id that is guaranteed to be unique within the collection.

Remarks

The method appends a numeric sufix to the baseId parameter that will make the resulting Id unique within the collection.

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GenerateUniqueNamedObjectId Overload List


DesignHelper.GetAssemblyFilterUsedForSelectType Method

[TBD]

[Visual Basic]
Public Shared Function GetAssemblyFilterUsedForSelectType() As AssemblyFilterDelegate
[C#]
public static AssemblyFilterDelegate GetAssemblyFilterUsedForSelectType();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


GetCloningHandler Method

Constable Authorization Engine 2.0 BETA

DesignHelper.GetCloningHandler Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public static CloningNamedObjectHandler GetCloningHandler(object);

[TBD]

public static CloningNamedObjectHandler GetCloningHandler(Type);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.GetCloningHandler Method (Object)

[TBD]

[Visual Basic]
Overloads Public Shared Function GetCloningHandler( _
ByVal instance As Object _
) As CloningNamedObjectHandler
[C#]
public static CloningNamedObjectHandler GetCloningHandler(
object instance
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GetCloningHandler Overload List


DesignHelper.GetCloningHandler Method (Type)

[TBD]

[Visual Basic]
Overloads Public Shared Function GetCloningHandler( _
ByVal namedObjectType As Type _
) As CloningNamedObjectHandler
[C#]
public static CloningNamedObjectHandler GetCloningHandler(
Type namedObjectType
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GetCloningHandler Overload List


DesignHelper.GetDefaultPolicyStore Method

[TBD]

[Visual Basic]
Public Shared Function GetDefaultPolicyStore() As PersistentStore
[C#]
public static PersistentStore GetDefaultPolicyStore();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.GetInternalOwner Method

[TBD]

[Visual Basic]
Public Shared Function GetInternalOwner( _
ByVal instance As ObjectBase _
) As ObjectCollectionBase
[C#]
public static ObjectCollectionBase GetInternalOwner(
ObjectBase instance
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.GetRealObservedInstance Method

Returns a reference to a "real" policy object. If the passed-in instance supports the IChangeEventObserver interface (i.e. it is an adapter), it returns the first ObservedPropertyChangeSenders, if any.

[Visual Basic]
Public Shared Function GetRealObservedInstance( _
ByVal instance As Object _
) As Object
[C#]
public static object GetRealObservedInstance(
object instance
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


GetTypeDisplayName Method

Constable Authorization Engine 2.0 BETA

DesignHelper.GetTypeDisplayName Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public static string GetTypeDisplayName(object);

[TBD]

public static string GetTypeDisplayName(string);

[TBD]

public static string GetTypeDisplayName(Type);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.GetTypeDisplayName Method (Object)

[TBD]

[Visual Basic]
Overloads Public Shared Function GetTypeDisplayName( _
ByVal instance As Object _
) As String
[C#]
public static string GetTypeDisplayName(
object instance
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GetTypeDisplayName Overload List


DesignHelper.GetTypeDisplayName Method (String)

[TBD]

[Visual Basic]
Overloads Public Shared Function GetTypeDisplayName( _
ByVal typeName As String _
) As String
[C#]
public static string GetTypeDisplayName(
string typeName
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GetTypeDisplayName Overload List


DesignHelper.GetTypeDisplayName Method (Type)

[TBD]

[Visual Basic]
Overloads Public Shared Function GetTypeDisplayName( _
ByVal type As Type _
) As String
[C#]
public static string GetTypeDisplayName(
Type type
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.GetTypeDisplayName Overload List


DesignHelper.GetTypeFilterUsedForSelectType Method

[TBD]

[Visual Basic]
Public Shared Function GetTypeFilterUsedForSelectType() As TypeFilterDelegate
[C#]
public static TypeFilterDelegate GetTypeFilterUsedForSelectType();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.LoadDefaultPolicy Method

[TBD]

[Visual Basic]
Public Shared Function LoadDefaultPolicy() As AuthorizationPolicy
[C#]
public static AuthorizationPolicy LoadDefaultPolicy();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.RegisterIntrinsicExtensions Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Sub RegisterIntrinsicExtensions()
[C#]
public static void RegisterIntrinsicExtensions();

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.SelectType Method

[TBD]

[Visual Basic]
Public Shared Function SelectType( _
ByVal dialogOwner As IWin32Window, _
ByVal baseType As Type _
) As Type
[C#]
public static Type SelectType(
IWin32Window dialogOwner,
Type baseType
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


ShowError Method

Constable Authorization Engine 2.0 BETA

DesignHelper.ShowError Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public static void ShowError(Exception);

[TBD]

public static void ShowError(string);

[TBD]

public static void ShowError(string,Exception,IWin32Window);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.ShowError Method (Exception)

[TBD]

[Visual Basic]
Overloads Public Shared Sub ShowError( _
ByVal ex As Exception _
)
[C#]
public static void ShowError(
Exception ex
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.ShowError Overload List


DesignHelper.ShowError Method (String)

[TBD]

[Visual Basic]
Overloads Public Shared Sub ShowError( _
ByVal message As String _
)
[C#]
public static void ShowError(
string message
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.ShowError Overload List


DesignHelper.ShowError Method (String, Exception, IWin32Window)

[TBD]

[Visual Basic]
Overloads Public Shared Sub ShowError( _
ByVal message As String, _
ByVal ex As Exception, _
ByVal dialogOwner As IWin32Window _
)
[C#]
public static void ShowError(
string message,
Exception ex,
IWin32Window dialogOwner
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace | DesignHelper.ShowError Overload List


DesignHelper.ShowNewPolicyWindow Method

[TBD]

[Visual Basic]
Public Shared Sub ShowNewPolicyWindow( _
ByVal policy As AuthorizationPolicy, _
ByVal markDirty As Boolean _
)
[C#]
public static void ShowNewPolicyWindow(
AuthorizationPolicy policy,
bool markDirty
);

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


DesignHelper.ShowUrl Method

Passes the specified URL to the Windows shell.

[Visual Basic]
Public Shared Function ShowUrl( _
ByVal url As String _
) As Boolean
[C#]
public static bool ShowUrl(
string url
);

Parameters

url
The URL.

Return Value

true if the URL was displayed correctly; otherwise false.

Remarks

If an exception is raised inside the method, it is catched and displayed by calling the ShowError method.

See Also

DesignHelper Class | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl Interface

Represents a contract for controls that the Policy Designer can show as a separate tab in the main window.

For a list of all members of this type, see IPolicyDesignContextControl Members.

[Visual Basic]
Public Interface IPolicyDesignContextControl
[C#]
public interface IPolicyDesignContextControl

Types that implement IPolicyDesignContextControl

Type | Description
PolicyDesignModelContextControl | [TBD]
PolicyDesignSimulationContextControl | [TBD]

Remarks

Control-derived classes that implement the IPolicyDesignContextControl interface are called policy design context controls. The Policy Designer (represented by the PolicyDesignForm form class) displays a separate tab for each policy design context control available in the current AppDomain.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

IPolicyDesignContextControl Members | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl Members

IPolicyDesignContextControl overview

Public Instance Properties

PolicyDocument Gets or sets the PolicyDocument that should be associated with the control.

Public Instance Methods

AddContextCommands | Informs the control that it should add its own commands to the IPolicyDesignHost menus.
ContextActivated | Called by the Policy Designer to inform the control that the context that the control represents has been activated.
ContextDeactivated | Informs the control that it is being deactivated.
GetContextCommandManager | Returns a reference to the CommandManager instance that manages the context-specific Commands.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl Properties

The properties of the IPolicyDesignContextControl interface are listed below. For a complete list of IPolicyDesignContextControl interface members, see the IPolicyDesignContextControl Members topic.

Public Instance Properties

PolicyDocument Gets or sets the PolicyDocument that should be associated with the control.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl.PolicyDocument Property

Gets or sets the PolicyDocument that should be associated with the control.

[Visual Basic]
Property PolicyDocument As PolicyDocument
[C#]
Persistence.PolicyDocument PolicyDocument {get; set;}

Remarks

Typically, implementations will save the PolicyDocument reference to a member variable and also subscribe to the PolicyChanged and PolicyDocument.Policy.InstanceChanged events in order to refresh the control display whenever the policy or the policy document change.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl Methods

The methods of the IPolicyDesignContextControl interface are listed below. For a complete list of IPolicyDesignContextControl interface members, see the IPolicyDesignContextControl Members topic.

Public Instance Methods

AddContextCommands | Informs the control that it should add its own commands to the IPolicyDesignHost menus.
ContextActivated | Called by the Policy Designer to inform the control that the context that the control represents has been activated.
ContextDeactivated | Informs the control that it is being deactivated.
GetContextCommandManager | Returns a reference to the CommandManager instance that manages the context-specific Commands.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl.AddContextCommands Method

Informs the control that it should add its own commands to the IPolicyDesignHost menus.

[Visual Basic]
Sub AddContextCommands()
[C#]
void AddContextCommands();

Remarks

The implementation should use the IPolicyDesignHost reference that was passed to the ContextActivated method.

The control should maintain an instance of the CommandManager class managing a set of context-specific Command objects. The control then adds menu items and toolbar buttons associated with the commands to the host menus (accessible though the GetHostMenu method) and the toolbar (accessible though the HostToolBar property). The association of commands with the menu items and toolbar buttons (commonly refered to as UI elements) allows the Policy Designer to remove the context specific commands upon the context deactivation (i.e. when calling the ContextDeactivated method).

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl.ContextActivated Method

Called by the Policy Designer to inform the control that the context that the control represents has been activated.

[Visual Basic]
Sub ContextActivated( _
ByVal host As IPolicyDesignHost _
)
[C#]
void ContextActivated(
IPolicyDesignHost host
);

Parameters

host
The hosting form reference.

Remarks

When the user clicks a tab in the Policy Designer window, the designer calls the ContextActivated method passing itself as the IPolicyDesignHost implementation. The implementation should store the passed-in host reference for subsequent use.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl.ContextDeactivated Method

Informs the control that it is being deactivated.

[Visual Basic]
Sub ContextDeactivated()
[C#]
void ContextDeactivated();

Remarks

A single instance of a policy design context control can be activated and deactivated multiple times during its lifetime.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignContextControl.GetContextCommandManager Method

Returns a reference to the CommandManager instance that manages the context-specific Commands.

[Visual Basic]
Function GetContextCommandManager() As CommandManager
[C#]
CommandManager GetContextCommandManager();

Remarks

The host uses the returned CommandManager to find and remove context-specific commands when the context is being deactivated.

See Also

IPolicyDesignContextControl Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension Interface

[TBD]

For a list of all members of this type, see IPolicyDesignExtension Members.

[Visual Basic]
Public Interface IPolicyDesignExtension
[C#]
public interface IPolicyDesignExtension

Types that implement IPolicyDesignExtension

Type | Description
PolicyStatisticsForm | [TBD]

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

IPolicyDesignExtension Members | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension Members

IPolicyDesignExtension overview

Public Instance Properties

PolicyDocument [TBD]

Public Instance Methods

Initialize | [TBD]
ShutDown | [TBD]

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension Properties

The properties of the IPolicyDesignExtension interface are listed below. For a complete list of IPolicyDesignExtension interface members, see the IPolicyDesignExtension Members topic.

Public Instance Properties

PolicyDocument [TBD]

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension.PolicyDocument Property

[TBD]

[Visual Basic]
Property PolicyDocument As PolicyDocument
[C#]
Persistence.PolicyDocument PolicyDocument {get; set;}

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension Methods

The methods of the IPolicyDesignExtension interface are listed below. For a complete list of IPolicyDesignExtension interface members, see the IPolicyDesignExtension Members topic.

Public Instance Methods

Initialize | [TBD]
ShutDown | [TBD]

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension.Initialize Method

[TBD]

[Visual Basic]
Sub Initialize( _
ByVal host As IPolicyDesignHost _
)
[C#]
void Initialize(
IPolicyDesignHost host
);

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignExtension.ShutDown Method

[TBD]

[Visual Basic]
Sub ShutDown()
[C#]
void ShutDown();

See Also

IPolicyDesignExtension Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost Interface

[TBD]

For a list of all members of this type, see IPolicyDesignHost Members.

[Visual Basic]
Public Interface IPolicyDesignHost
[C#]
public interface IPolicyDesignHost

Types that implement IPolicyDesignHost

Type | Description
PolicyDesignForm | [TBD]

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

IPolicyDesignHost Members | LaMarvin.Constable.Design Namespace


IPolicyDesignHost Members

IPolicyDesignHost overview

Public Instance Properties

HostCommandManager | [TBD]
HostStatusBar | [TBD]
HostToolBar | [TBD]
HostWindow | [TBD]

Public Instance Methods

GetHostMenu [TBD]

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost Properties

The properties of the IPolicyDesignHost interface are listed below. For a complete list of IPolicyDesignHost interface members, see the IPolicyDesignHost Members topic.

Public Instance Properties

HostCommandManager | [TBD]
HostStatusBar | [TBD]
HostToolBar | [TBD]
HostWindow | [TBD]

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost.HostCommandManager Property

[TBD]

[Visual Basic]
Property HostCommandManager As CommandManager
[C#]
LaMarvin.Windows.Forms.CommandManagement.CommandManager HostCommandManager {get;}

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost.HostStatusBar Property

[TBD]

[Visual Basic]
Property HostStatusBar As StatusBar
[C#]
System.Windows.Forms.StatusBar HostStatusBar {get;}

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost.HostToolBar Property

[TBD]

[Visual Basic]
Property HostToolBar As ToolBar
[C#]
System.Windows.Forms.ToolBar HostToolBar {get;}

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost.HostWindow Property

[TBD]

[Visual Basic]
Property HostWindow As IWin32Window
[C#]
System.Windows.Forms.IWin32Window HostWindow {get;}

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost Methods

The methods of the IPolicyDesignHost interface are listed below. For a complete list of IPolicyDesignHost interface members, see the IPolicyDesignHost Members topic.

Public Instance Methods

GetHostMenu [TBD]

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyDesignHost.GetHostMenu Method

[TBD]

[Visual Basic]
Function GetHostMenu( _
ByVal item As PolicyDesignHostMenuItem _
) As MenuItem
[C#]
MenuItem GetHostMenu(
PolicyDesignHostMenuItem item
);

See Also

IPolicyDesignHost Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext Interface

Represents contextual information for custom policy loaders that implement the IPolicyLoaderTypeResolver interface.

For a list of all members of this type, see IPolicyLoaderContext Members.

[Visual Basic]
Public Interface IPolicyLoaderContext
[C#]
public interface IPolicyLoaderContext

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

IPolicyLoaderContext Members | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext Members

IPolicyLoaderContext overview

Public Instance Properties

AssemblyName | Gets the name of the assembly containing the type being created.
AssemblyQualifiedTypeName | Gets the assembly-qualified name of type being created.
BaseType | Gets the base type of the policy object that should be created.
ConstructorArgumentTypes | Gets an array of Type references that the TypeName type's constructor expects.
ConstructorArgumentValues | Gets an array of arguments to be passed to the TypeName type's constructor.
Exception | Gets the exception that was raised while attempting to create an instance of the object identified by the AssemblyQualifiedTypeName.
PropertyValues | Gets the dictionary of property names and values as retrieved from the persisted policy by the AuthorizationPolicyLoader.
TypeName | Gets the name of the type that should be created.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext Properties

The properties of the IPolicyLoaderContext interface are listed below. For a complete list of IPolicyLoaderContext interface members, see the IPolicyLoaderContext Members topic.

Public Instance Properties

AssemblyName | Gets the name of the assembly containing the type being created.
AssemblyQualifiedTypeName | Gets the assembly-qualified name of type being created.
BaseType | Gets the base type of the policy object that should be created.
ConstructorArgumentTypes | Gets an array of Type references that the TypeName type's constructor expects.
ConstructorArgumentValues | Gets an array of arguments to be passed to the TypeName type's constructor.
Exception | Gets the exception that was raised while attempting to create an instance of the object identified by the AssemblyQualifiedTypeName.
PropertyValues | Gets the dictionary of property names and values as retrieved from the persisted policy by the AuthorizationPolicyLoader.
TypeName | Gets the name of the type that should be created.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.AssemblyName Property

Gets the name of the assembly containing the type being created.

[Visual Basic]
Property AssemblyName As String
[C#]
string AssemblyName {get;}

Property Value

The name of the assembly.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.AssemblyQualifiedTypeName Property

Gets the assembly-qualified name of type being created.

[Visual Basic]
Property AssemblyQualifiedTypeName As String
[C#]
string AssemblyQualifiedTypeName {get;}

Property Value

The name of the assembly qualified type.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.BaseType Property

Gets the base type of the policy object that should be created.

[Visual Basic]
Property BaseType As Type
[C#]
System.Type BaseType {get;}

Property Value

A Type reference to one of the base authorization policy object types.

Remarks

Returns a Type reference to one of the following types: Role, State, Action, Property, ActionRule or PropertyRule

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.ConstructorArgumentTypes Property

Gets an array of Type references that the TypeName type's constructor expects.

[Visual Basic]
Property ConstructorArgumentTypes As Type()
[C#]
System.Type[] ConstructorArgumentTypes {get;}

Property Value

The constructor argument types array.

Remarks

The returned array is parallel to the array returned by the ConstructorArgumentValues property.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.ConstructorArgumentValues Property

Gets an array of arguments to be passed to the TypeName type's constructor.

[Visual Basic]
Property ConstructorArgumentValues As Object()
[C#]
object[] ConstructorArgumentValues {get;}

Property Value

The constructor argument values.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.Exception Property

Gets the exception that was raised while attempting to create an instance of the object identified by the AssemblyQualifiedTypeName.

[Visual Basic]
Property Exception As Exception
[C#]
System.Exception Exception {get;}

Property Value

The exception reference.

Remarks

The AuthorizationPolicyLoader creates objects in two phases:

First it calls the CreateInstance method. If the method returns a valid object, it continues loading the next policy object. If the method raises an exception, the exception is stored in this Exception property and the AuthorizationPolicyLoader calls the CreateFallbackInstance method passing it the IPolicyLoaderContext reference with the Exception property set to the exception.

This allows IPolicyLoaderTypeResolver implementation to create "fallback" (substitute) objects for types that aren't available to the Design Environment.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.PropertyValues Property

Gets the dictionary of property names and values as retrieved from the persisted policy by the AuthorizationPolicyLoader.

[Visual Basic]
Property PropertyValues As Hashtable
[C#]
System.Collections.Hashtable PropertyValues {get;}

Property Value

The property values.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderContext.TypeName Property

Gets the name of the type that should be created.

[Visual Basic]
Property TypeName As String
[C#]
string TypeName {get;}

Property Value

The namespace-qualified name of the type.

See Also

IPolicyLoaderContext Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderTypeResolver Interface

Represents a contract for creating policy objects in the course of loading an authorization policy from a persitence medium

For a list of all members of this type, see IPolicyLoaderTypeResolver Members.

[Visual Basic]
Public Interface IPolicyLoaderTypeResolver
[C#]
public interface IPolicyLoaderTypeResolver

Types that implement IPolicyLoaderTypeResolver

Type | Description
PolicyLoader | [TBD]

Remarks

The AuthorizationPolicyLoader uses implementations of the interface associated with it by means of setting the TypeResolver property.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

IPolicyLoaderTypeResolver Members | LaMarvin.Constable.Design Namespace


IPolicyLoaderTypeResolver Members

IPolicyLoaderTypeResolver overview

Public Instance Methods

CreateFallbackInstance | The implementation should create an instance of an available type because the AssemblyQualifiedTypeName isn't available.
CreateInstance | The implementation should create an instance of a type described by the context argument.

See Also

IPolicyLoaderTypeResolver Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderTypeResolver Methods

The methods of the IPolicyLoaderTypeResolver interface are listed below. For a complete list of IPolicyLoaderTypeResolver interface members, see the IPolicyLoaderTypeResolver Members topic.

Public Instance Methods

CreateFallbackInstance | The implementation should create an instance of an available type because the AssemblyQualifiedTypeName isn't available.
CreateInstance | The implementation should create an instance of a type described by the context argument.

See Also

IPolicyLoaderTypeResolver Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderTypeResolver.CreateFallbackInstance Method

The implementation should create an instance of an available type because the AssemblyQualifiedTypeName isn't available.

[Visual Basic]
Function CreateFallbackInstance( _
ByVal context As IPolicyLoaderContext _
) As Object
[C#]
object CreateFallbackInstance(
IPolicyLoaderContext context
);

Parameters

context
The loader context.

Return Value

A reference to a new object created using the context information.

Remarks

This method is called by the AuthorizationPolicyLoader if the previous CreateInstance call with the same context generated an exception or returned a null reference (Nothing in Visual Basic). The implementation should create an instance of the BaseType and not the TypeName, because it isn't available.

See Also

IPolicyLoaderTypeResolver Interface | LaMarvin.Constable.Design Namespace


IPolicyLoaderTypeResolver.CreateInstance Method

The implementation should create an instance of a type described by the context argument.

[Visual Basic]
Function CreateInstance( _
ByVal context As IPolicyLoaderContext _
) As Object
[C#]
object CreateInstance(
IPolicyLoaderContext context
);

Parameters

context
The loader context.

Return Value

A reference to a new object created using the context information.

Remarks

Implementations typically use the AssemblyQualifiedTypeName property value to locate the desired object's type and the ConstructorArgumentTypes and ConstructorArgumentValues to invoke the type's constructor using reflection.

See Also

IPolicyLoaderTypeResolver Interface | LaMarvin.Constable.Design Namespace


IPolicySimulationView Interface

[TBD]

For a list of all members of this type, see IPolicySimulationView Members.

[Visual Basic]
Public Interface IPolicySimulationView
[C#]
public interface IPolicySimulationView

Types that implement IPolicySimulationView

Type | Description
DefaultPolicySimulationViewControl | [TBD]
PolicySimulationViewFormControl | Represents a form-like view of the authorization policy with executable ActionRules represented by command buttons and changeable PropertyRules represented by text boxes.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

IPolicySimulationView Members | LaMarvin.Constable.Design Namespace


IPolicySimulationView Members

IPolicySimulationView overview

Public Instance Properties

Policy | [TBD]
ViewProperties | [TBD]

See Also

IPolicySimulationView Interface | LaMarvin.Constable.Design Namespace


IPolicySimulationView Properties

The properties of the IPolicySimulationView interface are listed below. For a complete list of IPolicySimulationView interface members, see the IPolicySimulationView Members topic.

Public Instance Properties

Policy | [TBD]
ViewProperties | [TBD]

See Also

IPolicySimulationView Interface | LaMarvin.Constable.Design Namespace


IPolicySimulationView.Policy Property

[TBD]

[Visual Basic]
Property Policy As AuthorizationPolicy
[C#]
LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

See Also

IPolicySimulationView Interface | LaMarvin.Constable.Design Namespace


IPolicySimulationView.ViewProperties Property

[TBD]

[Visual Basic]
Property ViewProperties As Object
[C#]
object ViewProperties {get;}

See Also

IPolicySimulationView Interface | LaMarvin.Constable.Design Namespace


PolicyDesignApplicationContext Class

[TBD]

For a list of all members of this type, see PolicyDesignApplicationContext Members.

System.Object
System.Windows.Forms.ApplicationContext
LaMarvin.Constable.Design.PolicyDesignApplicationContext

[Visual Basic]
NotInheritable Public Class PolicyDesignApplicationContext
Inherits ApplicationContext
[C#]
public sealed class PolicyDesignApplicationContext : ApplicationContext

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDesignApplicationContext Members | LaMarvin.Constable.Design Namespace


PolicyDesignApplicationContext Members

PolicyDesignApplicationContext overview

Public Instance Constructors

PolicyDesignApplicationContext Constructor [TBD]

Public Instance Properties

MainForm (inherited from ApplicationContext) Gets or sets the Form to use as context.

Public Instance Methods

Dispose (inherited from ApplicationContext) | Releases all resources used by the ApplicationContext .
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExitThread (inherited from ApplicationContext) | Terminates the message loop of the thread.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ThreadExit (inherited from ApplicationContext) Occurs when the message loop of the thread should be terminated, by calling ExitThread .

See Also

PolicyDesignApplicationContext Class | LaMarvin.Constable.Design Namespace


PolicyDesignApplicationContext Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyDesignApplicationContext();

See Also

PolicyDesignApplicationContext Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute Class

[TBD]

For a list of all members of this type, see PolicyDesignContextControlAttribute Members.

System.Object
System.Attribute
LaMarvin.Constable.Design.PolicyDesignContextControlAttribute

[Visual Basic]
NotInheritable Public Class PolicyDesignContextControlAttribute
Inherits Attribute
[C#]
public sealed class PolicyDesignContextControlAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDesignContextControlAttribute Members | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute Members

PolicyDesignContextControlAttribute overview

Public Instance Constructors

PolicyDesignContextControlAttribute Constructor [TBD]

Public Instance Properties

ContextDescription | [TBD]
ContextName | [TBD]
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals | [TBD]
GetHashCode | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal contextName As String, _
ByVal contextDescription As String _
)
[C#]
public PolicyDesignContextControlAttribute(
string contextName,
string contextDescription
);

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute Properties

The properties of the PolicyDesignContextControlAttribute class are listed below. For a complete list of PolicyDesignContextControlAttribute class members, see the PolicyDesignContextControlAttribute Members topic.

Public Instance Properties

ContextDescription | [TBD]
ContextName | [TBD]
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute.ContextDescription Property

[TBD]

[Visual Basic]
Public ReadOnly Property ContextDescription As String
[C#]
public string ContextDescription {get;}

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute.ContextName Property

[TBD]

[Visual Basic]
Public ReadOnly Property ContextName As String
[C#]
public string ContextName {get;}

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute Methods

The methods of the PolicyDesignContextControlAttribute class are listed below. For a complete list of PolicyDesignContextControlAttribute class members, see the PolicyDesignContextControlAttribute Members topic.

Public Instance Methods

Equals | [TBD]
GetHashCode | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute.Equals Method

[TBD]

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignContextControlAttribute.GetHashCode Method

[TBD]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

PolicyDesignContextControlAttribute Class | LaMarvin.Constable.Design Namespace


PolicyDesignHostMenuItem Enumeration

[TBD]

[Visual Basic]
Public Enum PolicyDesignHostMenuItem
[C#]
public enum PolicyDesignHostMenuItem

Members

Member Name | Description
File | [TBD]
Edit | [TBD]
View | [TBD]
Tools | [TBD]
Window | [TBD]
Help | [TBD]

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute Class

Marks a property of a custom policy object type as available for serialization and deserialization to/from persistence medium.

For a list of all members of this type, see SerializablePropertyAttribute Members.

System.Object
System.Attribute
LaMarvin.Constable.Design.SerializablePropertyAttribute

[Visual Basic]
<Serializable>
NotInheritable Public Class SerializablePropertyAttribute
Inherits Attribute
[C#]
[Serializable]
public sealed class SerializablePropertyAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

SerializablePropertyAttribute Members | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute Members

SerializablePropertyAttribute overview

Public Instance Constructors

SerializablePropertyAttribute Overloaded. Initializes a new instance of the SerializablePropertyAttribute class.

Public Instance Properties

Serializable | Gets or sets a value indicating whether the property to which this SerializablePropertyAttribute attribute is applied is serializable.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals | Compares two SerializablePropertyAttribute attributes for equality.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute Constructor

Initializes a new instance of the SerializablePropertyAttribute class with the Serializable property set to true.

Overload List

Initializes a new instance of the SerializablePropertyAttribute class with the Serializable property set to true.

public SerializablePropertyAttribute();

Initializes a new instance of the SerializablePropertyAttribute class with the given serializable value.

public SerializablePropertyAttribute(bool);

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute Constructor ()

Initializes a new instance of the SerializablePropertyAttribute class with the Serializable property set to true.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SerializablePropertyAttribute();

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace | SerializablePropertyAttribute Constructor Overload List


SerializablePropertyAttribute Constructor (Boolean)

Initializes a new instance of the SerializablePropertyAttribute class with the given serializable value.

[Visual Basic]
Overloads Public Sub New( _
ByVal serializable As Boolean _
)
[C#]
public SerializablePropertyAttribute(
bool serializable
);

Parameters

serializable
The initial value of the Serializable property.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace | SerializablePropertyAttribute Constructor Overload List


SerializablePropertyAttribute Properties

The properties of the SerializablePropertyAttribute class are listed below. For a complete list of SerializablePropertyAttribute class members, see the SerializablePropertyAttribute Members topic.

Public Instance Properties

Serializable | Gets or sets a value indicating whether the property to which this SerializablePropertyAttribute attribute is applied is serializable.
TypeId (inherited from Attribute) | When implemented in a derived class, gets a unique identifier for this Attribute.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute.Serializable Property

Gets or sets a value indicating whether the property to which this SerializablePropertyAttribute attribute is applied is serializable.

[Visual Basic]
Public Property Serializable As Boolean
[C#]
public bool Serializable {get; set;}

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute Methods

The methods of the SerializablePropertyAttribute class are listed below. For a complete list of SerializablePropertyAttribute class members, see the SerializablePropertyAttribute Members topic.

Public Instance Methods

Equals | Compares two SerializablePropertyAttribute attributes for equality.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute.Equals Method

Compares two SerializablePropertyAttribute attributes for equality.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The other SerializablePropertyAttribute instance.

Return Value

true if the other object is an instance of the SerializablePropertyAttribute type and has the same value of the Serializable property as this object.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


SerializablePropertyAttribute.GetHashCode Method

Returns the hash code for this instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

A 32-bit signed integer hash code.

See Also

SerializablePropertyAttribute Class | LaMarvin.Constable.Design Namespace


LaMarvin.Constable.Design.Clipboard

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Clipboard Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting clipboard operations for authorization policy objects.

Namespace hierarchy

Classes

Class | Description
ActionClipboardHandler | Provides the IClipboardHandler implementation for Action-compatible types.
ActionRuleClipboardHandler | Provides the IClipboardHandler implementation for ActionRule-compatible types.
NamedObjectClipboardHandler | Provides the common IClipboardHandler implementation for NamedObjectBase-derived classes.
PolicyClipboardHandler | Provides the IClipboardHandler implementation for AuthorizationPolicy-compatible types.
PropertyClipboardHandler | Provides the IClipboardHandler implementation for Property-compatible types.
PropertyRuleRuleClipboardHandler | Provides the IClipboardHandler implementation for PropertyRule-compatible types.
RoleClipboardHandler | Provides the IClipboardHandler implementation for Role-compatible types.
RuleBaseClipboardHandler | Provides the common IClipboardHandler implementation for RuleBase-derived classes.
StateClipboardHandler | Provides the IClipboardHandler implementation for State-compatible types.


ActionClipboardHandler Class

Provides the IClipboardHandler implementation for Action-compatible types.

For a list of all members of this type, see ActionClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionClipboardHandler

[Visual Basic]
Public Class ActionClipboardHandler
Inherits NamedObjectClipboardHandler
[C#]
public class ActionClipboardHandler : NamedObjectClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


ActionClipboardHandler Members

ActionClipboardHandler overview

Public Instance Constructors

ActionClipboardHandler Constructor Initializes a new instance of the ActionClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Actions collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

ActionClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionClipboardHandler Constructor

Initializes a new instance of the ActionClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public ActionClipboardHandler();

See Also

ActionClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionClipboardHandler Methods

The methods of the ActionClipboardHandler class are listed below. For a complete list of ActionClipboardHandler class members, see the ActionClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Actions collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

ActionClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.Actions collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

ActionClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler Class

Provides the IClipboardHandler implementation for ActionRule-compatible types.

For a list of all members of this type, see ActionRuleClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.RuleBaseClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionRuleClipboardHandler

[Visual Basic]
Public Class ActionRuleClipboardHandler
Inherits RuleBaseClipboardHandler
[C#]
public class ActionRuleClipboardHandler : RuleBaseClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionRuleClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler Members

ActionRuleClipboardHandler overview

Public Instance Constructors

ActionRuleClipboardHandler Constructor Initializes a new instance of the ActionRuleClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from RuleBaseClipboardHandler) | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from RuleBaseClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from RuleBaseClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.ActionRules collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the ActionRule type.
ValidateTargetPolicy (inherited from RuleBaseClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

ActionRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler Constructor

Initializes a new instance of the ActionRuleClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public ActionRuleClipboardHandler();

See Also

ActionRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler Methods

The methods of the ActionRuleClipboardHandler class are listed below. For a complete list of ActionRuleClipboardHandler class members, see the ActionRuleClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from RuleBaseClipboardHandler) | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from RuleBaseClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from RuleBaseClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.ActionRules collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the ActionRule type.
ValidateTargetPolicy (inherited from RuleBaseClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

ActionRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.ActionRules collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

ActionRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


ActionRuleClipboardHandler.ValidateInstance Method

Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the ActionRule type.

[Visual Basic]
Overrides Protected Sub ValidateInstance( _
ByVal instance As Object _
)
[C#]
protected override void ValidateInstance(
object instance
);

See Also

ActionRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler Class

Provides the common IClipboardHandler implementation for NamedObjectBase-derived classes.

For a list of all members of this type, see NamedObjectClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyClipboardHandler
LaMarvin.Constable.Design.Clipboard.RoleClipboardHandler
LaMarvin.Constable.Design.Clipboard.StateClipboardHandler

[Visual Basic]
MustInherit Public Class NamedObjectClipboardHandler
Inherits ClipboardHandler
[C#]
public abstract class NamedObjectClipboardHandler : ClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

NamedObjectClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler Members

NamedObjectClipboardHandler overview

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

NamedObjectClipboardHandler Constructor Initializes a new instance of the NamedObjectClipboardHandler class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Derived classes should return a reference to the IList implementation that owns objects of the supported type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler Constructor

Initializes a new instance of the NamedObjectClipboardHandler class.

[Visual Basic]
Protected Sub New()
[C#]
protected NamedObjectClipboardHandler();

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler Methods

The methods of the NamedObjectClipboardHandler class are listed below. For a complete list of NamedObjectClipboardHandler class members, see the NamedObjectClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Derived classes should return a reference to the IList implementation that owns objects of the supported type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler.CutPerformed Method

Removes the instance from the owning list.

[Visual Basic]
Overrides Public Sub CutPerformed( _
ByVal instance As Object _
) _
Implements IClipboardHandler.CutPerformed
[C#]
public override void CutPerformed(
object instance
);

Implements

IClipboardHandler.CutPerformed

Remarks

The reference to the list (collection) that owns the instance is retrieved by calling the overriden GetOwningList method.

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler.GetOwningList Method

Derived classes should return a reference to the IList implementation that owns objects of the supported type.

[Visual Basic]
MustOverride Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected abstract IList GetOwningList(
AuthorizationPolicy policy
);

Remarks

For example, the ActionClipboardHandler's implementation returns a reference to the AuthorizationPolicy.Actions collection.

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler.Paste Method

Adds the pasted instance to the target owning list.

[Visual Basic]
Overrides Public Sub Paste( _
ByVal instance As Object, _
ByVal target As Object _
) _
Implements IClipboardHandler.Paste
[C#]
public override void Paste(
object instance,
object target
);

Implements

IClipboardHandler.Paste

Remarks

The reference to the list (collection) that will own the instance is retrieved by calling the overriden GetOwningList method.

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler.ValidateInstance Method

Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.

[Visual Basic]
Overridable Protected Sub ValidateInstance( _
ByVal instance As Object _
)
[C#]
protected virtual void ValidateInstance(
object instance
);

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


NamedObjectClipboardHandler.ValidateTargetPolicy Method

Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

[Visual Basic]
Overridable Protected Sub ValidateTargetPolicy( _
ByVal target As Object _
)
[C#]
protected virtual void ValidateTargetPolicy(
object target
);

See Also

NamedObjectClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler Class

Provides the IClipboardHandler implementation for AuthorizationPolicy-compatible types.

For a list of all members of this type, see PolicyClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.PolicyClipboardHandler

[Visual Basic]
Public Class PolicyClipboardHandler
Inherits ClipboardHandler
[C#]
public class PolicyClipboardHandler : ClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler Members

PolicyClipboardHandler overview

Public Instance Constructors

PolicyClipboardHandler Constructor Initializes a new instance of the PolicyClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut | Gets a flag indicating whether the AuthorizationPolicy instance can be cut.
CanPaste | Gets a flag indicating whether the instance can be pasted.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | The method does nothing (AuthorizationPolicy objects cannot be cut).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Opens the pasted AuthorizationPolicy instance in a new Policy Designer window.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler Constructor

Initializes a new instance of the PolicyClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public PolicyClipboardHandler();

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler Methods

The methods of the PolicyClipboardHandler class are listed below. For a complete list of PolicyClipboardHandler class members, see the PolicyClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut | Gets a flag indicating whether the AuthorizationPolicy instance can be cut.
CanPaste | Gets a flag indicating whether the instance can be pasted.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | The method does nothing (AuthorizationPolicy objects cannot be cut).
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Opens the pasted AuthorizationPolicy instance in a new Policy Designer window.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler.CanCut Method

Gets a flag indicating whether the AuthorizationPolicy instance can be cut.

[Visual Basic]
Overrides Public Function CanCut( _
ByVal instance As Object _
) As Boolean _
Implements IClipboardHandler.CanCut
[C#]
public override bool CanCut(
object instance
);

Implements

IClipboardHandler.CanCut

Remarks

The implementation always returns false because AuthorizationPolicy objects are root objects; they aren't owned and cannot be cut.

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler.CanPaste Method

Gets a flag indicating whether the instance can be pasted.

[Visual Basic]
Overrides Public Function CanPaste( _
ByVal instance As Object, _
ByVal target As Object, _
ByRef willPromptUser As Boolean _
) As Boolean _
Implements IClipboardHandler.CanPaste
[C#]
public override bool CanPaste(
object instance,
object target,
ref bool willPromptUser
);

Parameters

instance
The AuthorizationPolicy instance being pasted.
target
A reference to a target AuthorizationPolicy instance.
willPromptUser
An output flag indicating whether the handler will display a dialog prompt before pasting the object (true) or the paste operation won't require further user interaction (false).

Return Value

true if the instance can be pasted; otherwise false.

Implements

IClipboardHandler.CanPaste

Remarks

The implementation ignores the target argument and it always sets the output willPromptUser argument to true, because the Paste operation for AuthorizationPolicy objects clones the pasted policy and displays it in a new Policy Designer window.

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler.CutPerformed Method

The method does nothing (AuthorizationPolicy objects cannot be cut).

[Visual Basic]
Overrides Public Sub CutPerformed( _
ByVal instance As Object _
) _
Implements IClipboardHandler.CutPerformed
[C#]
public override void CutPerformed(
object instance
);

Implements

IClipboardHandler.CutPerformed

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PolicyClipboardHandler.Paste Method

Opens the pasted AuthorizationPolicy instance in a new Policy Designer window.

[Visual Basic]
Overrides Public Sub Paste( _
ByVal instance As Object, _
ByVal target As Object _
) _
Implements IClipboardHandler.Paste
[C#]
public override void Paste(
object instance,
object target
);

Parameters

instance
The AuthorizationPolicy instance being pasted.
target
A reference to a target AuthorizationPolicy instance.

Implements

IClipboardHandler.Paste

Remarks

The implementation ignores the target reference because the Paste operation for AuthorizationPolicy objects displays the pasted policy in a new Policy Designer window.

See Also

PolicyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyClipboardHandler Class

Provides the IClipboardHandler implementation for Property-compatible types.

For a list of all members of this type, see PropertyClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyClipboardHandler

[Visual Basic]
Public Class PropertyClipboardHandler
Inherits NamedObjectClipboardHandler
[C#]
public class PropertyClipboardHandler : NamedObjectClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


PropertyClipboardHandler Members

PropertyClipboardHandler overview

Public Instance Constructors

PropertyClipboardHandler Constructor Initializes a new instance of the PropertyClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Properties collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

PropertyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyClipboardHandler Constructor

Initializes a new instance of the PropertyClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyClipboardHandler();

See Also

PropertyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyClipboardHandler Methods

The methods of the PropertyClipboardHandler class are listed below. For a complete list of PropertyClipboardHandler class members, see the PropertyClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Properties collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

PropertyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.Properties collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

PropertyClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler Class

Provides the IClipboardHandler implementation for PropertyRule-compatible types.

For a list of all members of this type, see PropertyRuleRuleClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.RuleBaseClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyRuleRuleClipboardHandler

[Visual Basic]
Public Class PropertyRuleRuleClipboardHandler
Inherits RuleBaseClipboardHandler
[C#]
public class PropertyRuleRuleClipboardHandler : RuleBaseClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyRuleRuleClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler Members

PropertyRuleRuleClipboardHandler overview

Public Instance Constructors

PropertyRuleRuleClipboardHandler Constructor Initializes a new instance of the PropertyRuleRuleClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from RuleBaseClipboardHandler) | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from RuleBaseClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from RuleBaseClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.PropertyRules collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the PropertyRule type.
ValidateTargetPolicy (inherited from RuleBaseClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

PropertyRuleRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler Constructor

Initializes a new instance of the PropertyRuleRuleClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyRuleRuleClipboardHandler();

See Also

PropertyRuleRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler Methods

The methods of the PropertyRuleRuleClipboardHandler class are listed below. For a complete list of PropertyRuleRuleClipboardHandler class members, see the PropertyRuleRuleClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from RuleBaseClipboardHandler) | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from RuleBaseClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from RuleBaseClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.PropertyRules collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the PropertyRule type.
ValidateTargetPolicy (inherited from RuleBaseClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

PropertyRuleRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.PropertyRules collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

PropertyRuleRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


PropertyRuleRuleClipboardHandler.ValidateInstance Method

Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the PropertyRule type.

[Visual Basic]
Overrides Protected Sub ValidateInstance( _
ByVal instance As Object _
)
[C#]
protected override void ValidateInstance(
object instance
);

See Also

PropertyRuleRuleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RoleClipboardHandler Class

Provides the IClipboardHandler implementation for Role-compatible types.

For a list of all members of this type, see RoleClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.RoleClipboardHandler

[Visual Basic]
Public Class RoleClipboardHandler
Inherits NamedObjectClipboardHandler
[C#]
public class RoleClipboardHandler : NamedObjectClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RoleClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


RoleClipboardHandler Members

RoleClipboardHandler overview

Public Instance Constructors

RoleClipboardHandler Constructor Initializes a new instance of the RoleClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Roles collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

RoleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RoleClipboardHandler Constructor

Initializes a new instance of the RoleClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public RoleClipboardHandler();

See Also

RoleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RoleClipboardHandler Methods

The methods of the RoleClipboardHandler class are listed below. For a complete list of RoleClipboardHandler class members, see the RoleClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.Roles collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

RoleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RoleClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.Roles collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

RoleClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler Class

Provides the common IClipboardHandler implementation for RuleBase-derived classes.

For a list of all members of this type, see RuleBaseClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.RuleBaseClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionRuleClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyRuleRuleClipboardHandler

[Visual Basic]
MustInherit Public Class RuleBaseClipboardHandler
Inherits ClipboardHandler
[C#]
public abstract class RuleBaseClipboardHandler : ClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RuleBaseClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler Members

RuleBaseClipboardHandler overview

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleBaseClipboardHandler Constructor Initializes a new instance of the RuleBaseClipboardHandler class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Derived classes should return a reference to the IList implementation that owns objects of the supported type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the RuleBase type.
ValidateTargetPolicy | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler Constructor

Initializes a new instance of the RuleBaseClipboardHandler class.

[Visual Basic]
Protected Sub New()
[C#]
protected RuleBaseClipboardHandler();

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler Methods

The methods of the RuleBaseClipboardHandler class are listed below. For a complete list of RuleBaseClipboardHandler class members, see the RuleBaseClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste | Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Derived classes should return a reference to the IList implementation that owns objects of the supported type.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the RuleBase type.
ValidateTargetPolicy | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.CanPaste Method

Gets a flag indicating whether the instance can be pasted into the target AuthorizationPolicy.

[Visual Basic]
Overrides Public Function CanPaste( _
ByVal instance As Object, _
ByVal target As Object, _
ByRef willPromptUser As Boolean _
) As Boolean _
Implements IClipboardHandler.CanPaste
[C#]
public override bool CanPaste(
object instance,
object target,
ref bool willPromptUser
);

Parameters

instance
The instance being pasted.
target
A reference to an AuthorizationPolicy instance that will own the pasted instance.
willPromptUser
An output flag indicating whether the handler will display a dialog prompt before pasting the object (true) or the paste operation won't require further user interaction (false).

Return Value

true if the instance can be pasted; otherwise false.

Implements

IClipboardHandler.CanPaste

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.CutPerformed Method

Removes the instance from the owning list.

[Visual Basic]
Overrides Public Sub CutPerformed( _
ByVal instance As Object _
) _
Implements IClipboardHandler.CutPerformed
[C#]
public override void CutPerformed(
object instance
);

Implements

IClipboardHandler.CutPerformed

Remarks

The reference to the list (collection) that owns the instance is retrieved by calling the overriden GetOwningList method.

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.GetOwningList Method

Derived classes should return a reference to the IList implementation that owns objects of the supported type.

[Visual Basic]
MustOverride Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected abstract IList GetOwningList(
AuthorizationPolicy policy
);

Remarks

For example, the ActionRuleClipboardHandler's implementation returns a reference to the AuthorizationPolicy.ActionRules collection.

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.Paste Method

Adds the pasted instance to the target owning list.

[Visual Basic]
Overrides Public Sub Paste( _
ByVal instance As Object, _
ByVal target As Object _
) _
Implements IClipboardHandler.Paste
[C#]
public override void Paste(
object instance,
object target
);

Implements

IClipboardHandler.Paste

Remarks

The reference to the list (collection) that will own the instance is retrieved by calling the overriden GetOwningList method.

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.ValidateInstance Method

Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the RuleBase type.

[Visual Basic]
Overridable Protected Sub ValidateInstance( _
ByVal instance As Object _
)
[C#]
protected virtual void ValidateInstance(
object instance
);

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


RuleBaseClipboardHandler.ValidateTargetPolicy Method

Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

[Visual Basic]
Overridable Protected Sub ValidateTargetPolicy( _
ByVal target As Object _
)
[C#]
protected virtual void ValidateTargetPolicy(
object target
);

See Also

RuleBaseClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


StateClipboardHandler Class

Provides the IClipboardHandler implementation for State-compatible types.

For a list of all members of this type, see StateClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.StateClipboardHandler

[Visual Basic]
Public Class StateClipboardHandler
Inherits NamedObjectClipboardHandler
[C#]
public class StateClipboardHandler : NamedObjectClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Clipboard

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

StateClipboardHandler Members | LaMarvin.Constable.Design.Clipboard Namespace


StateClipboardHandler Members

StateClipboardHandler overview

Public Instance Constructors

StateClipboardHandler Constructor Initializes a new instance of the StateClipboardHandler class.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.States collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

StateClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


StateClipboardHandler Constructor

Initializes a new instance of the StateClipboardHandler class.

[Visual Basic]
Public Sub New()
[C#]
public StateClipboardHandler();

See Also

StateClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


StateClipboardHandler Methods

The methods of the StateClipboardHandler class are listed below. For a complete list of StateClipboardHandler class members, see the StateClipboardHandler Members topic.

Public Instance Methods

CanCopy (inherited from ClipboardHandler) | Implements the CanCopy interface method.
CanCut (inherited from ClipboardHandler) | Implements the CanCut interface method.
CanPaste (inherited from ClipboardHandler) | Implements the CanPaste interface method.
CopyPerformed (inherited from ClipboardHandler) | Implements the CopyPerformed interface method.
CutPerformed (inherited from NamedObjectClipboardHandler) | Removes the instance from the owning list.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste (inherited from NamedObjectClipboardHandler) | Adds the pasted instance to the target owning list.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetOwningList | Returns a reference to the AuthorizationPolicy.States collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ValidateInstance (inherited from NamedObjectClipboardHandler) | Ensures the passed-in instance reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the NamedObjectBase type.
ValidateTargetPolicy (inherited from NamedObjectClipboardHandler) | Ensures the passed-in target reference is not a null reference (Nothing in Visual Basic) and that its type is compatible with the AuthorizationPolicy type.

See Also

StateClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


StateClipboardHandler.GetOwningList Method

Returns a reference to the AuthorizationPolicy.States collection.

[Visual Basic]
Overrides Protected Function GetOwningList( _
ByVal policy As AuthorizationPolicy _
) As IList
[C#]
protected override IList GetOwningList(
AuthorizationPolicy policy
);

See Also

StateClipboardHandler Class | LaMarvin.Constable.Design.Clipboard Namespace


LaMarvin.Constable.Design.Cloning

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Cloning Namespace

[This is preliminary documentation and subject to change.]

Contains type supporting cloning operations for authorization policy objects.

Namespace hierarchy

Classes

Class | Description
CloningActionHandler | [TBD]
CloningNamedObjectHandler | [TBD]
CloningPropertyHandler | [TBD]
CloningRoleHandler | [TBD]
CloningStateHandler | [TBD]


CloningActionHandler Class

[TBD]

For a list of all members of this type, see CloningActionHandler Members.

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningActionHandler

[Visual Basic]
Public Class CloningActionHandler
Inherits CloningNamedObjectHandler
[C#]
public class CloningActionHandler : CloningNamedObjectHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Cloning

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CloningActionHandler Members | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler Members

CloningActionHandler overview

Public Instance Constructors

CloningActionHandler Constructor Initializes a new instance of the CloningActionHandler class.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler Constructor

Initializes a new instance of the CloningActionHandler class.

[Visual Basic]
Public Sub New()
[C#]
public CloningActionHandler();

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler Properties

The properties of the CloningActionHandler class are listed below. For a complete list of CloningActionHandler class members, see the CloningActionHandler Members topic.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.ClonesActionRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesActionRules As Boolean
[C#]
public override bool ClonesActionRules {get;}

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.ClonesPropertyRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesPropertyRules As Boolean
[C#]
public override bool ClonesPropertyRules {get;}

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.DialogCaption Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogCaption As String
[C#]
public override string DialogCaption {get;}

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.DialogInfoTip Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogInfoTip As String
[C#]
public override string DialogInfoTip {get;}

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler Methods

The methods of the CloningActionHandler class are listed below. For a complete list of CloningActionHandler class members, see the CloningActionHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetActionRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetActionRulesToBeCloned( _
ByVal actionRules As ActionRuleCollection _
)
[C#]
public override void GetActionRulesToBeCloned(
ActionRuleCollection actionRules
);

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetClonedActionRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedActionRuleConstructorArguments( _
ByVal templateRule As ActionRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef action As Action, _
ByRef role As Role, _
ByRef state As State, _
ByRef targetState As State _
) As Boolean
[C#]
public override bool GetClonedActionRuleConstructorArguments(
ActionRule templateRule,
NamedObjectBase clonedObject,
ref Action action,
ref Role role,
ref State state,
ref State targetState
);

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetClonedPropertyRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedPropertyRuleConstructorArguments( _
ByVal templateRule As PropertyRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef property As Property, _
ByRef role As Role, _
ByRef state As State _
) As Boolean
[C#]
public override bool GetClonedPropertyRuleConstructorArguments(
PropertyRule templateRule,
NamedObjectBase clonedObject,
ref Property property,
ref Role role,
ref State state
);

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetPropertyRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetPropertyRulesToBeCloned( _
ByVal propertyRules As PropertyRuleCollection _
)
[C#]
public override void GetPropertyRulesToBeCloned(
PropertyRuleCollection propertyRules
);

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetTemplateObjectBaseType Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectBaseType() As Type
[C#]
public override Type GetTemplateObjectBaseType();

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningActionHandler.GetTemplateObjectPolicyCollection Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectPolicyCollection() As NamedObjectCollectionBase
[C#]
public override NamedObjectCollectionBase GetTemplateObjectPolicyCollection();

See Also

CloningActionHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler Class

[TBD]

For a list of all members of this type, see CloningNamedObjectHandler Members.

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningActionHandler
LaMarvin.Constable.Design.Cloning.CloningPropertyHandler
LaMarvin.Constable.Design.Cloning.CloningRoleHandler
LaMarvin.Constable.Design.Cloning.CloningStateHandler

[Visual Basic]
MustInherit Public Class CloningNamedObjectHandler
[C#]
public abstract class CloningNamedObjectHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Cloning

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CloningNamedObjectHandler Members | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler Members

CloningNamedObjectHandler overview

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject | [TBD]
TemplateObjectPolicy | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule | [TBD]
InitializeClonedPropertyRule | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

CloningNamedObjectHandler Constructor Initializes a new instance of the CloningNamedObjectHandler class.

Protected Instance Methods

AssertInitialized | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler Constructor

Initializes a new instance of the CloningNamedObjectHandler class.

[Visual Basic]
Protected Sub New()
[C#]
protected CloningNamedObjectHandler();

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler Properties

The properties of the CloningNamedObjectHandler class are listed below. For a complete list of CloningNamedObjectHandler class members, see the CloningNamedObjectHandler Members topic.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject | [TBD]
TemplateObjectPolicy | [TBD]

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.ClonesActionRules Property

[TBD]

[Visual Basic]
MustOverride Public ReadOnly Property ClonesActionRules As Boolean
[C#]
public abstract bool ClonesActionRules {get;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.ClonesPropertyRules Property

[TBD]

[Visual Basic]
MustOverride Public ReadOnly Property ClonesPropertyRules As Boolean
[C#]
public abstract bool ClonesPropertyRules {get;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.DialogCaption Property

[TBD]

[Visual Basic]
MustOverride Public ReadOnly Property DialogCaption As String
[C#]
public abstract string DialogCaption {get;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.DialogInfoTip Property

[TBD]

[Visual Basic]
MustOverride Public ReadOnly Property DialogInfoTip As String
[C#]
public abstract string DialogInfoTip {get;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.TemplateObject Property

[TBD]

[Visual Basic]
Overridable Public Property TemplateObject As NamedObjectBase
[C#]
public virtual LaMarvin.Constable.Model.NamedObjectBase TemplateObject {get; set;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.TemplateObjectPolicy Property

[TBD]

[Visual Basic]
Public ReadOnly Property TemplateObjectPolicy As AuthorizationPolicy
[C#]
public LaMarvin.Constable.AuthorizationPolicy TemplateObjectPolicy {get;}

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler Methods

The methods of the CloningNamedObjectHandler class are listed below. For a complete list of CloningNamedObjectHandler class members, see the CloningNamedObjectHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule | [TBD]
InitializeClonedPropertyRule | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.AssertInitialized Method

[TBD]

[Visual Basic]
Protected Sub AssertInitialized()
[C#]
protected void AssertInitialized();

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetActionRulesToBeCloned Method

[TBD]

[Visual Basic]
MustOverride Public Sub GetActionRulesToBeCloned( _
ByVal actionRules As ActionRuleCollection _
)
[C#]
public abstract void GetActionRulesToBeCloned(
ActionRuleCollection actionRules
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetClonedActionRuleConstructorArguments Method

[TBD]

[Visual Basic]
MustOverride Public Function GetClonedActionRuleConstructorArguments( _
ByVal templateRule As ActionRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef action As Action, _
ByRef role As Role, _
ByRef state As State, _
ByRef targetState As State _
) As Boolean
[C#]
public abstract bool GetClonedActionRuleConstructorArguments(
ActionRule templateRule,
NamedObjectBase clonedObject,
ref Action action,
ref Role role,
ref State state,
ref State targetState
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetClonedPropertyRuleConstructorArguments Method

[TBD]

[Visual Basic]
MustOverride Public Function GetClonedPropertyRuleConstructorArguments( _
ByVal templateRule As PropertyRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef property As Property, _
ByRef role As Role, _
ByRef state As State _
) As Boolean
[C#]
public abstract bool GetClonedPropertyRuleConstructorArguments(
PropertyRule templateRule,
NamedObjectBase clonedObject,
ref Property property,
ref Role role,
ref State state
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetPropertyRulesToBeCloned Method

[TBD]

[Visual Basic]
MustOverride Public Sub GetPropertyRulesToBeCloned( _
ByVal propertyRules As PropertyRuleCollection _
)
[C#]
public abstract void GetPropertyRulesToBeCloned(
PropertyRuleCollection propertyRules
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetTemplateObjectBaseType Method

[TBD]

[Visual Basic]
MustOverride Public Function GetTemplateObjectBaseType() As Type
[C#]
public abstract Type GetTemplateObjectBaseType();

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetTemplateObjectPolicyCollection Method

[TBD]

[Visual Basic]
MustOverride Public Function GetTemplateObjectPolicyCollection() As NamedObjectCollectionBase
[C#]
public abstract NamedObjectCollectionBase GetTemplateObjectPolicyCollection();

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.GetTemplateObjectPolicyCore Method

[TBD]

[Visual Basic]
Protected Function GetTemplateObjectPolicyCore( _
ByVal templateObject As ObjectBase _
) As AuthorizationPolicy
[C#]
protected AuthorizationPolicy GetTemplateObjectPolicyCore(
ObjectBase templateObject
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.InitializeClonedActionRule Method

[TBD]

[Visual Basic]
Overridable Public Function InitializeClonedActionRule( _
ByVal newRule As ActionRule _
) As Boolean
[C#]
public virtual bool InitializeClonedActionRule(
ActionRule newRule
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningNamedObjectHandler.InitializeClonedPropertyRule Method

[TBD]

[Visual Basic]
Overridable Public Function InitializeClonedPropertyRule( _
ByVal newRule As PropertyRule _
) As Boolean
[C#]
public virtual bool InitializeClonedPropertyRule(
PropertyRule newRule
);

See Also

CloningNamedObjectHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler Class

[TBD]

For a list of all members of this type, see CloningPropertyHandler Members.

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningPropertyHandler

[Visual Basic]
Public Class CloningPropertyHandler
Inherits CloningNamedObjectHandler
[C#]
public class CloningPropertyHandler : CloningNamedObjectHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Cloning

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CloningPropertyHandler Members | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler Members

CloningPropertyHandler overview

Public Instance Constructors

CloningPropertyHandler Constructor Initializes a new instance of the CloningPropertyHandler class.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler Constructor

Initializes a new instance of the CloningPropertyHandler class.

[Visual Basic]
Public Sub New()
[C#]
public CloningPropertyHandler();

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler Properties

The properties of the CloningPropertyHandler class are listed below. For a complete list of CloningPropertyHandler class members, see the CloningPropertyHandler Members topic.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.ClonesActionRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesActionRules As Boolean
[C#]
public override bool ClonesActionRules {get;}

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.ClonesPropertyRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesPropertyRules As Boolean
[C#]
public override bool ClonesPropertyRules {get;}

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.DialogCaption Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogCaption As String
[C#]
public override string DialogCaption {get;}

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.DialogInfoTip Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogInfoTip As String
[C#]
public override string DialogInfoTip {get;}

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler Methods

The methods of the CloningPropertyHandler class are listed below. For a complete list of CloningPropertyHandler class members, see the CloningPropertyHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetActionRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetActionRulesToBeCloned( _
ByVal actionRules As ActionRuleCollection _
)
[C#]
public override void GetActionRulesToBeCloned(
ActionRuleCollection actionRules
);

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetClonedActionRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedActionRuleConstructorArguments( _
ByVal templateRule As ActionRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef action As Action, _
ByRef role As Role, _
ByRef state As State, _
ByRef targetState As State _
) As Boolean
[C#]
public override bool GetClonedActionRuleConstructorArguments(
ActionRule templateRule,
NamedObjectBase clonedObject,
ref Action action,
ref Role role,
ref State state,
ref State targetState
);

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetClonedPropertyRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedPropertyRuleConstructorArguments( _
ByVal templateRule As PropertyRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef property As Property, _
ByRef role As Role, _
ByRef state As State _
) As Boolean
[C#]
public override bool GetClonedPropertyRuleConstructorArguments(
PropertyRule templateRule,
NamedObjectBase clonedObject,
ref Property property,
ref Role role,
ref State state
);

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetPropertyRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetPropertyRulesToBeCloned( _
ByVal propertyRules As PropertyRuleCollection _
)
[C#]
public override void GetPropertyRulesToBeCloned(
PropertyRuleCollection propertyRules
);

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetTemplateObjectBaseType Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectBaseType() As Type
[C#]
public override Type GetTemplateObjectBaseType();

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningPropertyHandler.GetTemplateObjectPolicyCollection Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectPolicyCollection() As NamedObjectCollectionBase
[C#]
public override NamedObjectCollectionBase GetTemplateObjectPolicyCollection();

See Also

CloningPropertyHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler Class

[TBD]

For a list of all members of this type, see CloningRoleHandler Members.

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningRoleHandler

[Visual Basic]
Public Class CloningRoleHandler
Inherits CloningNamedObjectHandler
[C#]
public class CloningRoleHandler : CloningNamedObjectHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Cloning

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CloningRoleHandler Members | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler Members

CloningRoleHandler overview

Public Instance Constructors

CloningRoleHandler Constructor Initializes a new instance of the CloningRoleHandler class.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler Constructor

Initializes a new instance of the CloningRoleHandler class.

[Visual Basic]
Public Sub New()
[C#]
public CloningRoleHandler();

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler Properties

The properties of the CloningRoleHandler class are listed below. For a complete list of CloningRoleHandler class members, see the CloningRoleHandler Members topic.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.ClonesActionRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesActionRules As Boolean
[C#]
public override bool ClonesActionRules {get;}

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.ClonesPropertyRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesPropertyRules As Boolean
[C#]
public override bool ClonesPropertyRules {get;}

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.DialogCaption Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogCaption As String
[C#]
public override string DialogCaption {get;}

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.DialogInfoTip Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogInfoTip As String
[C#]
public override string DialogInfoTip {get;}

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler Methods

The methods of the CloningRoleHandler class are listed below. For a complete list of CloningRoleHandler class members, see the CloningRoleHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetActionRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetActionRulesToBeCloned( _
ByVal actionRules As ActionRuleCollection _
)
[C#]
public override void GetActionRulesToBeCloned(
ActionRuleCollection actionRules
);

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetClonedActionRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedActionRuleConstructorArguments( _
ByVal templateRule As ActionRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef action As Action, _
ByRef role As Role, _
ByRef state As State, _
ByRef targetState As State _
) As Boolean
[C#]
public override bool GetClonedActionRuleConstructorArguments(
ActionRule templateRule,
NamedObjectBase clonedObject,
ref Action action,
ref Role role,
ref State state,
ref State targetState
);

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetClonedPropertyRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedPropertyRuleConstructorArguments( _
ByVal templateRule As PropertyRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef property As Property, _
ByRef role As Role, _
ByRef state As State _
) As Boolean
[C#]
public override bool GetClonedPropertyRuleConstructorArguments(
PropertyRule templateRule,
NamedObjectBase clonedObject,
ref Property property,
ref Role role,
ref State state
);

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetPropertyRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetPropertyRulesToBeCloned( _
ByVal propertyRules As PropertyRuleCollection _
)
[C#]
public override void GetPropertyRulesToBeCloned(
PropertyRuleCollection propertyRules
);

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetTemplateObjectBaseType Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectBaseType() As Type
[C#]
public override Type GetTemplateObjectBaseType();

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningRoleHandler.GetTemplateObjectPolicyCollection Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectPolicyCollection() As NamedObjectCollectionBase
[C#]
public override NamedObjectCollectionBase GetTemplateObjectPolicyCollection();

See Also

CloningRoleHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler Class

[TBD]

For a list of all members of this type, see CloningStateHandler Members.

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningStateHandler

[Visual Basic]
Public Class CloningStateHandler
Inherits CloningNamedObjectHandler
[C#]
public class CloningStateHandler : CloningNamedObjectHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Cloning

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CloningStateHandler Members | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler Members

CloningStateHandler overview

Public Instance Constructors

CloningStateHandler Constructor Initializes a new instance of the CloningStateHandler class.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler Constructor

Initializes a new instance of the CloningStateHandler class.

[Visual Basic]
Public Sub New()
[C#]
public CloningStateHandler();

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler Properties

The properties of the CloningStateHandler class are listed below. For a complete list of CloningStateHandler class members, see the CloningStateHandler Members topic.

Public Instance Properties

ClonesActionRules | [TBD]
ClonesPropertyRules | [TBD]
DialogCaption | [TBD]
DialogInfoTip | [TBD]
TemplateObject (inherited from CloningNamedObjectHandler) | [TBD]
TemplateObjectPolicy (inherited from CloningNamedObjectHandler) | [TBD]

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.ClonesActionRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesActionRules As Boolean
[C#]
public override bool ClonesActionRules {get;}

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.ClonesPropertyRules Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ClonesPropertyRules As Boolean
[C#]
public override bool ClonesPropertyRules {get;}

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.DialogCaption Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogCaption As String
[C#]
public override string DialogCaption {get;}

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.DialogInfoTip Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property DialogInfoTip As String
[C#]
public override string DialogInfoTip {get;}

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler Methods

The methods of the CloningStateHandler class are listed below. For a complete list of CloningStateHandler class members, see the CloningStateHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetActionRulesToBeCloned | [TBD]
GetClonedActionRuleConstructorArguments | [TBD]
GetClonedPropertyRuleConstructorArguments | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyRulesToBeCloned | [TBD]
GetTemplateObjectBaseType | [TBD]
GetTemplateObjectPolicyCollection | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeClonedActionRule (inherited from CloningNamedObjectHandler) | [TBD]
InitializeClonedPropertyRule (inherited from CloningNamedObjectHandler) | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AssertInitialized (inherited from CloningNamedObjectHandler) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetTemplateObjectPolicyCore (inherited from CloningNamedObjectHandler) | [TBD]
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetActionRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetActionRulesToBeCloned( _
ByVal actionRules As ActionRuleCollection _
)
[C#]
public override void GetActionRulesToBeCloned(
ActionRuleCollection actionRules
);

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetClonedActionRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedActionRuleConstructorArguments( _
ByVal templateRule As ActionRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef action As Action, _
ByRef role As Role, _
ByRef state As State, _
ByRef targetState As State _
) As Boolean
[C#]
public override bool GetClonedActionRuleConstructorArguments(
ActionRule templateRule,
NamedObjectBase clonedObject,
ref Action action,
ref Role role,
ref State state,
ref State targetState
);

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetClonedPropertyRuleConstructorArguments Method

[TBD]

[Visual Basic]
Overrides Public Function GetClonedPropertyRuleConstructorArguments( _
ByVal templateRule As PropertyRule, _
ByVal clonedObject As NamedObjectBase, _
ByRef property As Property, _
ByRef role As Role, _
ByRef state As State _
) As Boolean
[C#]
public override bool GetClonedPropertyRuleConstructorArguments(
PropertyRule templateRule,
NamedObjectBase clonedObject,
ref Property property,
ref Role role,
ref State state
);

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetPropertyRulesToBeCloned Method

[TBD]

[Visual Basic]
Overrides Public Sub GetPropertyRulesToBeCloned( _
ByVal propertyRules As PropertyRuleCollection _
)
[C#]
public override void GetPropertyRulesToBeCloned(
PropertyRuleCollection propertyRules
);

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetTemplateObjectBaseType Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectBaseType() As Type
[C#]
public override Type GetTemplateObjectBaseType();

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


CloningStateHandler.GetTemplateObjectPolicyCollection Method

[TBD]

[Visual Basic]
Overrides Public Function GetTemplateObjectPolicyCollection() As NamedObjectCollectionBase
[C#]
public override NamedObjectCollectionBase GetTemplateObjectPolicyCollection();

See Also

CloningStateHandler Class | LaMarvin.Constable.Design.Cloning Namespace


LaMarvin.Constable.Design.Controls

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Controls Namespace

[This is preliminary documentation and subject to change.]

Contains various controls used throughout the CAZE Design Environment.

Namespace hierarchy

Classes

Class | Description
DefaultPolicySimulationViewControl | [TBD]
PolicyDesignModelContextControl | [TBD]
PolicyDesignSimulationContextControl | [TBD]
PolicySimulationViewFormControl | Represents a form-like view of the authorization policy with executable ActionRules represented by command buttons and changeable PropertyRules represented by text boxes.
RolesSelectorControl | [TBD]


DefaultPolicySimulationViewControl Class

[TBD]

For a list of all members of this type, see DefaultPolicySimulationViewControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
LaMarvin.Constable.Design.Controls.DefaultPolicySimulationViewControl

[Visual Basic]
Public Class DefaultPolicySimulationViewControl
Inherits ContainerControl
Implements IPolicySimulationView
[C#]
public class DefaultPolicySimulationViewControl : ContainerControl, IPolicySimulationView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Controls

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

DefaultPolicySimulationViewControl Members | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl Members

DefaultPolicySimulationViewControl overview

Public Instance Constructors

DefaultPolicySimulationViewControl Constructor [TBD]

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Policy | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedInstance | [TBD]
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ViewProperties | [TBD]
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString | Gets the name of the view.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | [TBD]
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from ContainerControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ContainerControl) |

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public DefaultPolicySimulationViewControl();

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl Properties

The properties of the DefaultPolicySimulationViewControl class are listed below. For a complete list of DefaultPolicySimulationViewControl class members, see the DefaultPolicySimulationViewControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Policy | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedInstance | [TBD]
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ViewProperties | [TBD]
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl.Policy Property

[TBD]

[Visual Basic]
NotOverridable Public Property Policy As AuthorizationPolicy _
Implements IPolicySimulationView.Policy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

Implements

IPolicySimulationView.Policy

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl.SelectedInstance Property

[TBD]

[Visual Basic]
Public ReadOnly Property SelectedInstance As Object
[C#]
public object SelectedInstance {get;}

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl.ViewProperties Property

[TBD]

[Visual Basic]
NotOverridable Public ReadOnly Property ViewProperties As Object _
Implements IPolicySimulationView.ViewProperties
[C#]
public object ViewProperties {get;}

Implements

IPolicySimulationView.ViewProperties

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl Methods

The methods of the DefaultPolicySimulationViewControl class are listed below. For a complete list of DefaultPolicySimulationViewControl class members, see the DefaultPolicySimulationViewControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString | Gets the name of the view.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from ContainerControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from ContainerControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ContainerControl) |

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl.ToString Method

Gets the name of the view.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl Events

The events of the DefaultPolicySimulationViewControl class are listed below. For a complete list of DefaultPolicySimulationViewControl class members, see the DefaultPolicySimulationViewControl Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | [TBD]
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


DefaultPolicySimulationViewControl.SelectionChanged Event

[TBD]

[Visual Basic]
Public Event SelectionChanged As EventHandler
[C#]
public event EventHandler SelectionChanged;

See Also

DefaultPolicySimulationViewControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl Class

[TBD]

For a list of all members of this type, see PolicyDesignModelContextControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
LaMarvin.Constable.Design.Controls.PolicyDesignModelContextControl

[Visual Basic]
Public Class PolicyDesignModelContextControl
Inherits UserControl
Implements IPolicyDesignContextControl, ISupportInitialize
[C#]
public class PolicyDesignModelContextControl : UserControl, IPolicyDesignContextControl, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Controls

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDesignModelContextControl Members | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl Members

PolicyDesignModelContextControl overview

Public Instance Constructors

PolicyDesignModelContextControl Constructor [TBD]

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDefaultContext | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddContextCommands | [TBD]
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContextActivated | [TBD]
ContextDeactivated | [TBD]
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetContextCommandManager | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyDesignModelContextControl();

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl Properties

The properties of the PolicyDesignModelContextControl class are listed below. For a complete list of PolicyDesignModelContextControl class members, see the PolicyDesignModelContextControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDefaultContext | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.IsDefaultContext Property

[TBD]

[Visual Basic]
Public ReadOnly Property IsDefaultContext As Boolean
[C#]
public bool IsDefaultContext {get;}

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.PolicyDocument Property

[TBD]

[Visual Basic]
NotOverridable Public Property PolicyDocument As PolicyDocument _
Implements IPolicyDesignContextControl.PolicyDocument
[C#]
public LaMarvin.Constable.Design.Persistence.PolicyDocument PolicyDocument {get; set;}

Implements

IPolicyDesignContextControl.PolicyDocument

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl Methods

The methods of the PolicyDesignModelContextControl class are listed below. For a complete list of PolicyDesignModelContextControl class members, see the PolicyDesignModelContextControl Members topic.

Public Instance Methods

AddContextCommands | [TBD]
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContextActivated | [TBD]
ContextDeactivated | [TBD]
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetContextCommandManager | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.AddContextCommands Method

[TBD]

[Visual Basic]
NotOverridable Public Sub AddContextCommands() _
Implements IPolicyDesignContextControl.AddContextCommands
[C#]
public void AddContextCommands();

Implements

IPolicyDesignContextControl.AddContextCommands

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.ContextActivated Method

[TBD]

[Visual Basic]
NotOverridable Public Sub ContextActivated( _
ByVal host As IPolicyDesignHost _
) _
Implements IPolicyDesignContextControl.ContextActivated
[C#]
public void ContextActivated(
IPolicyDesignHost host
);

Implements

IPolicyDesignContextControl.ContextActivated

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.ContextDeactivated Method

[TBD]

[Visual Basic]
NotOverridable Public Sub ContextDeactivated() _
Implements IPolicyDesignContextControl.ContextDeactivated
[C#]
public void ContextDeactivated();

Implements

IPolicyDesignContextControl.ContextDeactivated

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

PolicyDesignModelContextControl.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace | PolicyDesignModelContextControl.Dispose Overload List


PolicyDesignModelContextControl.GetContextCommandManager Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetContextCommandManager() As CommandManager _
Implements IPolicyDesignContextControl.GetContextCommandManager
[C#]
public CommandManager GetContextCommandManager();

Implements

IPolicyDesignContextControl.GetContextCommandManager

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignModelContextControl.Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

PolicyDesignModelContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl Class

[TBD]

For a list of all members of this type, see PolicyDesignSimulationContextControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
LaMarvin.Constable.Design.Controls.PolicyDesignSimulationContextControl

[Visual Basic]
Public Class PolicyDesignSimulationContextControl
Inherits UserControl
Implements IPolicyDesignContextControl, ISupportInitialize
[C#]
public class PolicyDesignSimulationContextControl : UserControl, IPolicyDesignContextControl, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Controls

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDesignSimulationContextControl Members | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl Members

PolicyDesignSimulationContextControl overview

Public Instance Constructors

PolicyDesignSimulationContextControl Constructor [TBD]

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDefaultContext | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AddContextCommands | [TBD]
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContextActivated | [TBD]
ContextDeactivated | [TBD]
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetContextCommandManager | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyDesignSimulationContextControl();

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl Properties

The properties of the PolicyDesignSimulationContextControl class are listed below. For a complete list of PolicyDesignSimulationContextControl class members, see the PolicyDesignSimulationContextControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDefaultContext | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.IsDefaultContext Property

[TBD]

[Visual Basic]
Public ReadOnly Property IsDefaultContext As Boolean
[C#]
public bool IsDefaultContext {get;}

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.PolicyDocument Property

[TBD]

[Visual Basic]
NotOverridable Public Property PolicyDocument As PolicyDocument _
Implements IPolicyDesignContextControl.PolicyDocument
[C#]
public LaMarvin.Constable.Design.Persistence.PolicyDocument PolicyDocument {get; set;}

Implements

IPolicyDesignContextControl.PolicyDocument

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl Methods

The methods of the PolicyDesignSimulationContextControl class are listed below. For a complete list of PolicyDesignSimulationContextControl class members, see the PolicyDesignSimulationContextControl Members topic.

Public Instance Methods

AddContextCommands | [TBD]
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
ContextActivated | [TBD]
ContextDeactivated | [TBD]
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetContextCommandManager | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.AddContextCommands Method

[TBD]

[Visual Basic]
NotOverridable Public Sub AddContextCommands() _
Implements IPolicyDesignContextControl.AddContextCommands
[C#]
public void AddContextCommands();

Implements

IPolicyDesignContextControl.AddContextCommands

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.ContextActivated Method

[TBD]

[Visual Basic]
NotOverridable Public Sub ContextActivated( _
ByVal host As IPolicyDesignHost _
) _
Implements IPolicyDesignContextControl.ContextActivated
[C#]
public void ContextActivated(
IPolicyDesignHost host
);

Implements

IPolicyDesignContextControl.ContextActivated

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.ContextDeactivated Method

[TBD]

[Visual Basic]
NotOverridable Public Sub ContextDeactivated() _
Implements IPolicyDesignContextControl.ContextDeactivated
[C#]
public void ContextDeactivated();

Implements

IPolicyDesignContextControl.ContextDeactivated

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

PolicyDesignSimulationContextControl.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicyDesignSimulationContextControl.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace | PolicyDesignSimulationContextControl.Dispose Overload List


PolicyDesignSimulationContextControl.GetContextCommandManager Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetContextCommandManager() As CommandManager _
Implements IPolicyDesignContextControl.GetContextCommandManager
[C#]
public CommandManager GetContextCommandManager();

Implements

IPolicyDesignContextControl.GetContextCommandManager

See Also

PolicyDesignSimulationContextControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl Class

Represents a form-like view of the authorization policy with executable ActionRules represented by command buttons and changeable PropertyRules represented by text boxes.

For a list of all members of this type, see PolicySimulationViewFormControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
LaMarvin.Constable.Design.Controls.PolicySimulationViewFormControl

[Visual Basic]
NotInheritable Public Class PolicySimulationViewFormControl
Inherits UserControl
Implements IPolicySimulationView, ISupportInitialize
[C#]
public sealed class PolicySimulationViewFormControl : UserControl, IPolicySimulationView, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Controls

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicySimulationViewFormControl Members | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl Members

PolicySimulationViewFormControl overview

Public Instance Constructors

PolicySimulationViewFormControl Constructor Initializes a new instance of the PolicySimulationViewFormControl class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Policy | Gets or sets the AuthorizationPolicy instance associated with the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ViewProperties | Returns an object that represents the user-customizable properties of the view.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Refreshes the view according to the current authorization context.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString | Get s string representation of the view that will be displayed in the View menu of the hosting PolicyDesignForm.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl Constructor

Initializes a new instance of the PolicySimulationViewFormControl class.

[Visual Basic]
Public Sub New()
[C#]
public PolicySimulationViewFormControl();

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl Properties

The properties of the PolicySimulationViewFormControl class are listed below. For a complete list of PolicySimulationViewFormControl class members, see the PolicySimulationViewFormControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
Policy | Gets or sets the AuthorizationPolicy instance associated with the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
ViewProperties | Returns an object that represents the user-customizable properties of the view.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl.Policy Property

Gets or sets the AuthorizationPolicy instance associated with the control.

[Visual Basic]
NotOverridable Public Property Policy As AuthorizationPolicy _
Implements IPolicySimulationView.Policy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

Property Value

The AuthorizationPolicy to display in the control.

Implements

IPolicySimulationView.Policy

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl.ViewProperties Property

Returns an object that represents the user-customizable properties of the view.

[Visual Basic]
NotOverridable Public ReadOnly Property ViewProperties As Object _
Implements IPolicySimulationView.ViewProperties
[C#]
public object ViewProperties {get;}

Implements

IPolicySimulationView.ViewProperties

Remarks

Returns a null reference (Nothing in Visual Basic) to indicate there are no custom view properties.

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl Methods

The methods of the PolicySimulationViewFormControl class are listed below. For a complete list of PolicySimulationViewFormControl class members, see the PolicySimulationViewFormControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Refreshes the view according to the current authorization context.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString | Get s string representation of the view that will be displayed in the View menu of the hosting PolicyDesignForm.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl.Refresh Method

Refreshes the view according to the current authorization context.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


PolicySimulationViewFormControl.ToString Method

Get s string representation of the view that will be displayed in the View menu of the hosting PolicyDesignForm.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

PolicySimulationViewFormControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl Class

[TBD]

For a list of all members of this type, see RolesSelectorControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
LaMarvin.Constable.Design.Controls.RolesSelectorControl

[Visual Basic]
Public Class RolesSelectorControl
Inherits UserControl
[C#]
public class RolesSelectorControl : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Controls

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RolesSelectorControl Members | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl Members

RolesSelectorControl overview

Public Instance Constructors

RolesSelectorControl Constructor [TBD]

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsCommitted | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
List | [TBD]
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
UserInteractionFinished | [TBD]
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public RolesSelectorControl();

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl Properties

The properties of the RolesSelectorControl class are listed below. For a complete list of RolesSelectorControl class members, see the RolesSelectorControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsCommitted | [TBD]
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
List | [TBD]
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl.IsCommitted Property

[TBD]

[Visual Basic]
Public ReadOnly Property IsCommitted As Boolean
[C#]
public bool IsCommitted {get;}

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl.List Property

[TBD]

[Visual Basic]
Public ReadOnly Property List As CheckedListBox
[C#]
public System.Windows.Forms.CheckedListBox List {get;}

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl Methods

The methods of the RolesSelectorControl class are listed below. For a complete list of RolesSelectorControl class members, see the RolesSelectorControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

RolesSelectorControl.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace | RolesSelectorControl.Dispose Overload List


RolesSelectorControl Events

The events of the RolesSelectorControl class are listed below. For a complete list of RolesSelectorControl class members, see the RolesSelectorControl Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
UserInteractionFinished | [TBD]
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


RolesSelectorControl.UserInteractionFinished Event

[TBD]

[Visual Basic]
Public Event UserInteractionFinished As EventHandler
[C#]
public event EventHandler UserInteractionFinished;

See Also

RolesSelectorControl Class | LaMarvin.Constable.Design.Controls Namespace


LaMarvin.Constable.Design.Converters

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Converters Namespace

[This is preliminary documentation and subject to change.]

Contains TypeConverter-derived classes supporting type conversions for policy objects.

Namespace hierarchy

Classes

Class | Description
ActionPropertyConverter | [TBD]
CurrentStatePropertyConverter | [TBD]
PropertyPropertyConverter | [TBD]
RolePropertyConverter | [TBD]
RolesPropertyConverter | [TBD]
RuleBasePropertyConverter | [TBD]
StatePropertyConverter | [TBD]
TargetStatePropertyConverter | [TBD]


ActionPropertyConverter Class

[TBD]

For a list of all members of this type, see ActionPropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.ActionPropertyConverter

[Visual Basic]
Public Class ActionPropertyConverter
Inherits RuleBasePropertyConverter
[C#]
public class ActionPropertyConverter : RuleBasePropertyConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionPropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


ActionPropertyConverter Members

ActionPropertyConverter overview

Public Instance Constructors

ActionPropertyConverter Constructor Initializes a new instance of the ActionPropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ActionPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


ActionPropertyConverter Constructor

Initializes a new instance of the ActionPropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public ActionPropertyConverter();

See Also

ActionPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


ActionPropertyConverter Methods

The methods of the ActionPropertyConverter class are listed below. For a complete list of ActionPropertyConverter class members, see the ActionPropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

ActionPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


ActionPropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

ActionPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter Class

[TBD]

For a list of all members of this type, see CurrentStatePropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.CurrentStatePropertyConverter

[Visual Basic]
Public Class CurrentStatePropertyConverter
Inherits TypeConverter
[C#]
public class CurrentStatePropertyConverter : TypeConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CurrentStatePropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter Members

CurrentStatePropertyConverter overview

Public Instance Constructors

CurrentStatePropertyConverter Constructor Initializes a new instance of the CurrentStatePropertyConverter class.

Public Instance Methods

CanConvertFrom | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter Constructor

Initializes a new instance of the CurrentStatePropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public CurrentStatePropertyConverter();

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter Methods

The methods of the CurrentStatePropertyConverter class are listed below. For a complete list of CurrentStatePropertyConverter class members, see the CurrentStatePropertyConverter Members topic.

Public Instance Methods

CanConvertFrom | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CanConvertFrom Method

Constable Authorization Engine 2.0 BETA

CurrentStatePropertyConverter.CanConvertFrom Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override bool CanConvertFrom(ITypeDescriptorContext,Type);

Inherited from TypeConverter.

public bool CanConvertFrom(Type);

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[TBD]

[Visual Basic]
Overrides Overloads Public Function CanConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
ITypeDescriptorContext context,
Type sourceType
);

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | CurrentStatePropertyConverter.CanConvertFrom Overload List


ConvertFrom Method

Constable Authorization Engine 2.0 BETA

CurrentStatePropertyConverter.ConvertFrom Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CurrentStatePropertyConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[TBD]

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

See Also

CurrentStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | CurrentStatePropertyConverter.ConvertFrom Overload List


PropertyPropertyConverter Class

[TBD]

For a list of all members of this type, see PropertyPropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.PropertyPropertyConverter

[Visual Basic]
Public Class PropertyPropertyConverter
Inherits RuleBasePropertyConverter
[C#]
public class PropertyPropertyConverter : RuleBasePropertyConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyPropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


PropertyPropertyConverter Members

PropertyPropertyConverter overview

Public Instance Constructors

PropertyPropertyConverter Constructor Initializes a new instance of the PropertyPropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

PropertyPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


PropertyPropertyConverter Constructor

Initializes a new instance of the PropertyPropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyPropertyConverter();

See Also

PropertyPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


PropertyPropertyConverter Methods

The methods of the PropertyPropertyConverter class are listed below. For a complete list of PropertyPropertyConverter class members, see the PropertyPropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

PropertyPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


PropertyPropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

PropertyPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolePropertyConverter Class

[TBD]

For a list of all members of this type, see RolePropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.RolePropertyConverter

[Visual Basic]
Public Class RolePropertyConverter
Inherits RuleBasePropertyConverter
[C#]
public class RolePropertyConverter : RuleBasePropertyConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RolePropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


RolePropertyConverter Members

RolePropertyConverter overview

Public Instance Constructors

RolePropertyConverter Constructor Initializes a new instance of the RolePropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RolePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolePropertyConverter Constructor

Initializes a new instance of the RolePropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public RolePropertyConverter();

See Also

RolePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolePropertyConverter Methods

The methods of the RolePropertyConverter class are listed below. For a complete list of RolePropertyConverter class members, see the RolePropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RolePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolePropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

RolePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter Class

[TBD]

For a list of all members of this type, see RolesPropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RolesPropertyConverter

[Visual Basic]
Public Class RolesPropertyConverter
Inherits TypeConverter
[C#]
public class RolesPropertyConverter : TypeConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RolesPropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter Members

RolesPropertyConverter overview

Public Instance Constructors

RolesPropertyConverter Constructor Initializes a new instance of the RolesPropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
CanConvertTo | Overloaded. [TBD]
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overloaded. [TBD]
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter Constructor

Initializes a new instance of the RolesPropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public RolesPropertyConverter();

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter Methods

The methods of the RolesPropertyConverter class are listed below. For a complete list of RolesPropertyConverter class members, see the RolesPropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
CanConvertTo | Overloaded. [TBD]
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given object to the type of this converter, using the specified context and culture information.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overloaded. [TBD]
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CanConvertTo Method

Constable Authorization Engine 2.0 BETA

RolesPropertyConverter.CanConvertTo Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override bool CanConvertTo(ITypeDescriptorContext,Type);

Inherited from TypeConverter.

public bool CanConvertTo(Type);

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

[TBD]

[Visual Basic]
Overrides Overloads Public Function CanConvertTo( _
ByVal context As ITypeDescriptorContext, _
ByVal destinationType As Type _
) As Boolean
[C#]
public override bool CanConvertTo(
ITypeDescriptorContext context,
Type destinationType
);

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | RolesPropertyConverter.CanConvertTo Overload List


ConvertTo Method

Constable Authorization Engine 2.0 BETA

RolesPropertyConverter.ConvertTo Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object ConvertTo(ITypeDescriptorContext,CultureInfo,object,Type);

Inherited from TypeConverter.

public object ConvertTo(object,Type);

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RolesPropertyConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[TBD]

[Visual Basic]
Overrides Overloads Public Function ConvertTo( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object, _
ByVal destinationType As Type _
) As Object
[C#]
public override object ConvertTo(
ITypeDescriptorContext context,
CultureInfo culture,
object value,
Type destinationType
);

See Also

RolesPropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | RolesPropertyConverter.ConvertTo Overload List


RuleBasePropertyConverter Class

[TBD]

For a list of all members of this type, see RuleBasePropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.ActionPropertyConverter
LaMarvin.Constable.Design.Converters.PropertyPropertyConverter
LaMarvin.Constable.Design.Converters.RolePropertyConverter
LaMarvin.Constable.Design.Converters.StatePropertyConverter
LaMarvin.Constable.Design.Converters.TargetStatePropertyConverter

[Visual Basic]
MustInherit Public Class RuleBasePropertyConverter
Inherits TypeConverter
[C#]
public abstract class RuleBasePropertyConverter : TypeConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RuleBasePropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


RuleBasePropertyConverter Members

RuleBasePropertyConverter overview

Public Instance Methods

CanConvertFrom | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleBasePropertyConverter Constructor Initializes a new instance of the RuleBasePropertyConverter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RuleBasePropertyConverter Constructor

Initializes a new instance of the RuleBasePropertyConverter class.

[Visual Basic]
Protected Sub New()
[C#]
protected RuleBasePropertyConverter();

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RuleBasePropertyConverter Methods

The methods of the RuleBasePropertyConverter class are listed below. For a complete list of RuleBasePropertyConverter class members, see the RuleBasePropertyConverter Members topic.

Public Instance Methods

CanConvertFrom | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


CanConvertFrom Method

Constable Authorization Engine 2.0 BETA

RuleBasePropertyConverter.CanConvertFrom Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override bool CanConvertFrom(ITypeDescriptorContext,Type);

Inherited from TypeConverter.

public bool CanConvertFrom(Type);

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RuleBasePropertyConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[TBD]

[Visual Basic]
Overrides Overloads Public Function CanConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
ITypeDescriptorContext context,
Type sourceType
);

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | RuleBasePropertyConverter.CanConvertFrom Overload List


ConvertFrom Method

Constable Authorization Engine 2.0 BETA

RuleBasePropertyConverter.ConvertFrom Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);

Inherited from TypeConverter.

public object ConvertFrom(object);

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


RuleBasePropertyConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[TBD]

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
ByVal context As ITypeDescriptorContext, _
ByVal culture As CultureInfo, _
ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
ITypeDescriptorContext context,
CultureInfo culture,
object value
);

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace | RuleBasePropertyConverter.ConvertFrom Overload List


RuleBasePropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
MustOverride Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public abstract NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

RuleBasePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


StatePropertyConverter Class

[TBD]

For a list of all members of this type, see StatePropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.StatePropertyConverter

[Visual Basic]
Public Class StatePropertyConverter
Inherits RuleBasePropertyConverter
[C#]
public class StatePropertyConverter : RuleBasePropertyConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

StatePropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


StatePropertyConverter Members

StatePropertyConverter overview

Public Instance Constructors

StatePropertyConverter Constructor Initializes a new instance of the StatePropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

StatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


StatePropertyConverter Constructor

Initializes a new instance of the StatePropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public StatePropertyConverter();

See Also

StatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


StatePropertyConverter Methods

The methods of the StatePropertyConverter class are listed below. For a complete list of StatePropertyConverter class members, see the StatePropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

StatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


StatePropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

StatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


TargetStatePropertyConverter Class

[TBD]

For a list of all members of this type, see TargetStatePropertyConverter Members.

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.TargetStatePropertyConverter

[Visual Basic]
Public Class TargetStatePropertyConverter
Inherits RuleBasePropertyConverter
[C#]
public class TargetStatePropertyConverter : RuleBasePropertyConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Converters

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

TargetStatePropertyConverter Members | LaMarvin.Constable.Design.Converters Namespace


TargetStatePropertyConverter Members

TargetStatePropertyConverter overview

Public Instance Constructors

TargetStatePropertyConverter Constructor Initializes a new instance of the TargetStatePropertyConverter class.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

TargetStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


TargetStatePropertyConverter Constructor

Initializes a new instance of the TargetStatePropertyConverter class.

[Visual Basic]
Public Sub New()
[C#]
public TargetStatePropertyConverter();

See Also

TargetStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


TargetStatePropertyConverter Methods

The methods of the TargetStatePropertyConverter class are listed below. For a complete list of TargetStatePropertyConverter class members, see the TargetStatePropertyConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type, using the specified context.
ConvertFrom (inherited from RuleBasePropertyConverter) | Overloaded. [TBD]
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the specified context and culture information.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetConvertFromException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
GetConvertToException (inherited from TypeConverter) | Returns an exception to throw when a conversion cannot be performed.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SortProperties (inherited from TypeConverter) | Sorts a collection of properties.

See Also

TargetStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


TargetStatePropertyConverter.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

TargetStatePropertyConverter Class | LaMarvin.Constable.Design.Converters Namespace


LaMarvin.Constable.Design.Editors

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Editors Namespace

[This is preliminary documentation and subject to change.]

Contains UITypeEditor-derived classes supporting the .NET-provided TypeDescriptor infrastructure and PropertyGrid UI editing services.

Namespace hierarchy

Classes

Class | Description
ActionPropertyEditor | [TBD]
CurrentStatePropertyEditor | [TBD]
PropertyPropertyEditor | [TBD]
RolePropertyEditor | [TBD]
RolesPropertyEditor | [TBD]
RuleBasePropertyEditor | [TBD]
StatePropertyEditor | [TBD]
TargetStatePropertyEditor | [TBD]


ActionPropertyEditor Class

[TBD]

For a list of all members of this type, see ActionPropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.ActionPropertyEditor

[Visual Basic]
Public Class ActionPropertyEditor
Inherits RuleBasePropertyEditor
[C#]
public class ActionPropertyEditor : RuleBasePropertyEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionPropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


ActionPropertyEditor Members

ActionPropertyEditor overview

Public Instance Constructors

ActionPropertyEditor Constructor Initializes a new instance of the ActionPropertyEditor class.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

ActionPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


ActionPropertyEditor Constructor

Initializes a new instance of the ActionPropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public ActionPropertyEditor();

See Also

ActionPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


ActionPropertyEditor Methods

The methods of the ActionPropertyEditor class are listed below. For a complete list of ActionPropertyEditor class members, see the ActionPropertyEditor Members topic.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

ActionPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


ActionPropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

ActionPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor Class

[TBD]

For a list of all members of this type, see CurrentStatePropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.CurrentStatePropertyEditor

[Visual Basic]
Public Class CurrentStatePropertyEditor
Inherits UITypeEditor
[C#]
public class CurrentStatePropertyEditor : UITypeEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CurrentStatePropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor Members

CurrentStatePropertyEditor overview

Public Instance Constructors

CurrentStatePropertyEditor Constructor Initializes a new instance of the CurrentStatePropertyEditor class.

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessDropDownResults | [TBD]

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor Constructor

Initializes a new instance of the CurrentStatePropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public CurrentStatePropertyEditor();

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor Methods

The methods of the CurrentStatePropertyEditor class are listed below. For a complete list of CurrentStatePropertyEditor class members, see the CurrentStatePropertyEditor Members topic.

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessDropDownResults | [TBD]

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


EditValue Method

Constable Authorization Engine 2.0 BETA

CurrentStatePropertyEditor.EditValue Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object EditValue(ITypeDescriptorContext,IServiceProvider,object);

Inherited from UITypeEditor.

public object EditValue(IServiceProvider,object);

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[TBD]

[Visual Basic]
Overrides Overloads Public Function EditValue( _
ByVal context As ITypeDescriptorContext, _
ByVal provider As IServiceProvider, _
ByVal value As Object _
) As Object
[C#]
public override object EditValue(
ITypeDescriptorContext context,
IServiceProvider provider,
object value
);

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | CurrentStatePropertyEditor.EditValue Overload List


GetEditStyle Method

Constable Authorization Engine 2.0 BETA

CurrentStatePropertyEditor.GetEditStyle Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

Inherited from UITypeEditor.

public UITypeEditorEditStyle GetEditStyle();

[TBD]

public override UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext);

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


CurrentStatePropertyEditor.GetEditStyle Method (ITypeDescriptorContext)

[TBD]

[Visual Basic]
Overrides Overloads Public Function GetEditStyle( _
ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
ITypeDescriptorContext context
);

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | CurrentStatePropertyEditor.GetEditStyle Overload List


CurrentStatePropertyEditor.ProcessDropDownResults Method

[TBD]

[Visual Basic]
Overridable Protected Function ProcessDropDownResults( _
ByVal state As State, _
ByVal picker As DropDownPicker, _
ByVal canceled As Boolean _
) As Object
[C#]
protected virtual object ProcessDropDownResults(
State state,
DropDownPicker picker,
bool canceled
);

See Also

CurrentStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


PropertyPropertyEditor Class

[TBD]

For a list of all members of this type, see PropertyPropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.PropertyPropertyEditor

[Visual Basic]
Public Class PropertyPropertyEditor
Inherits RuleBasePropertyEditor
[C#]
public class PropertyPropertyEditor : RuleBasePropertyEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyPropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


PropertyPropertyEditor Members

PropertyPropertyEditor overview

Public Instance Constructors

PropertyPropertyEditor Constructor Initializes a new instance of the PropertyPropertyEditor class.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

PropertyPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


PropertyPropertyEditor Constructor

Initializes a new instance of the PropertyPropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyPropertyEditor();

See Also

PropertyPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


PropertyPropertyEditor Methods

The methods of the PropertyPropertyEditor class are listed below. For a complete list of PropertyPropertyEditor class members, see the PropertyPropertyEditor Members topic.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

PropertyPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


PropertyPropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

PropertyPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolePropertyEditor Class

[TBD]

For a list of all members of this type, see RolePropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.RolePropertyEditor

[Visual Basic]
Public Class RolePropertyEditor
Inherits RuleBasePropertyEditor
[C#]
public class RolePropertyEditor : RuleBasePropertyEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RolePropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


RolePropertyEditor Members

RolePropertyEditor overview

Public Instance Constructors

RolePropertyEditor Constructor Initializes a new instance of the RolePropertyEditor class.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

RolePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolePropertyEditor Constructor

Initializes a new instance of the RolePropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public RolePropertyEditor();

See Also

RolePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolePropertyEditor Methods

The methods of the RolePropertyEditor class are listed below. For a complete list of RolePropertyEditor class members, see the RolePropertyEditor Members topic.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

RolePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolePropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

RolePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor Class

[TBD]

For a list of all members of this type, see RolesPropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RolesPropertyEditor

[Visual Basic]
Public Class RolesPropertyEditor
Inherits UITypeEditor
[C#]
public class RolesPropertyEditor : UITypeEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RolesPropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor Members

RolesPropertyEditor overview

Public Instance Constructors

RolesPropertyEditor Constructor Initializes a new instance of the RolesPropertyEditor class.

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessDropDownResults | [TBD]

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor Constructor

Initializes a new instance of the RolesPropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public RolesPropertyEditor();

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor Methods

The methods of the RolesPropertyEditor class are listed below. For a complete list of RolesPropertyEditor class members, see the RolesPropertyEditor Members topic.

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ProcessDropDownResults | [TBD]

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


EditValue Method

Constable Authorization Engine 2.0 BETA

RolesPropertyEditor.EditValue Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object EditValue(ITypeDescriptorContext,IServiceProvider,object);

Inherited from UITypeEditor.

public object EditValue(IServiceProvider,object);

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[TBD]

[Visual Basic]
Overrides Overloads Public Function EditValue( _
ByVal context As ITypeDescriptorContext, _
ByVal provider As IServiceProvider, _
ByVal value As Object _
) As Object
[C#]
public override object EditValue(
ITypeDescriptorContext context,
IServiceProvider provider,
object value
);

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | RolesPropertyEditor.EditValue Overload List


GetEditStyle Method

Constable Authorization Engine 2.0 BETA

RolesPropertyEditor.GetEditStyle Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

Inherited from UITypeEditor.

public UITypeEditorEditStyle GetEditStyle();

[TBD]

public override UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext);

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RolesPropertyEditor.GetEditStyle Method (ITypeDescriptorContext)

[TBD]

[Visual Basic]
Overrides Overloads Public Function GetEditStyle( _
ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
ITypeDescriptorContext context
);

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | RolesPropertyEditor.GetEditStyle Overload List


RolesPropertyEditor.ProcessDropDownResults Method

[TBD]

[Visual Basic]
Overridable Protected Function ProcessDropDownResults( _
ByVal adapter As AuthorizationContextPropertyGridAdapter, _
ByVal list As CheckedListBox, _
ByVal canceled As Boolean _
) As Object
[C#]
protected virtual object ProcessDropDownResults(
AuthorizationContextPropertyGridAdapter adapter,
CheckedListBox list,
bool canceled
);

See Also

RolesPropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor Class

[TBD]

For a list of all members of this type, see RuleBasePropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.ActionPropertyEditor
LaMarvin.Constable.Design.Editors.PropertyPropertyEditor
LaMarvin.Constable.Design.Editors.RolePropertyEditor
LaMarvin.Constable.Design.Editors.StatePropertyEditor
LaMarvin.Constable.Design.Editors.TargetStatePropertyEditor

[Visual Basic]
MustInherit Public Class RuleBasePropertyEditor
Inherits UITypeEditor
[C#]
public abstract class RuleBasePropertyEditor : UITypeEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RuleBasePropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor Members

RuleBasePropertyEditor overview

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleBasePropertyEditor Constructor Initializes a new instance of the RuleBasePropertyEditor class.

Protected Instance Methods

FilterNamedObjects | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl | [TBD]
ProcessDropDownResults | [TBD]

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor Constructor

Initializes a new instance of the RuleBasePropertyEditor class.

[Visual Basic]
Protected Sub New()
[C#]
protected RuleBasePropertyEditor();

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor Methods

The methods of the RuleBasePropertyEditor class are listed below. For a complete list of RuleBasePropertyEditor class members, see the RuleBasePropertyEditor Members topic.

Public Instance Methods

EditValue | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl | [TBD]
ProcessDropDownResults | [TBD]

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


EditValue Method

Constable Authorization Engine 2.0 BETA

RuleBasePropertyEditor.EditValue Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public override object EditValue(ITypeDescriptorContext,IServiceProvider,object);

Inherited from UITypeEditor.

public object EditValue(IServiceProvider,object);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[TBD]

[Visual Basic]
Overrides Overloads Public Function EditValue( _
ByVal context As ITypeDescriptorContext, _
ByVal provider As IServiceProvider, _
ByVal value As Object _
) As Object
[C#]
public override object EditValue(
ITypeDescriptorContext context,
IServiceProvider provider,
object value
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | RuleBasePropertyEditor.EditValue Overload List


RuleBasePropertyEditor.FilterNamedObjects Method

[TBD]

[Visual Basic]
Overridable Protected Function FilterNamedObjects( _
ByVal rule As RuleBase, _
ByVal namedObjects As NamedObjectCollectionBase _
) As ICollection
[C#]
protected virtual ICollection FilterNamedObjects(
RuleBase rule,
NamedObjectCollectionBase namedObjects
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


GetEditStyle Method

Constable Authorization Engine 2.0 BETA

RuleBasePropertyEditor.GetEditStyle Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

Inherited from UITypeEditor.

public UITypeEditorEditStyle GetEditStyle();

[TBD]

public override UITypeEditorEditStyle GetEditStyle(ITypeDescriptorContext);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor.GetEditStyle Method (ITypeDescriptorContext)

[TBD]

[Visual Basic]
Overrides Overloads Public Function GetEditStyle( _
ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
[C#]
public override UITypeEditorEditStyle GetEditStyle(
ITypeDescriptorContext context
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace | RuleBasePropertyEditor.GetEditStyle Overload List


RuleBasePropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
MustOverride Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public abstract NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor.PrepareForDropDownControl Method

[TBD]

[Visual Basic]
Overridable Protected Sub PrepareForDropDownControl( _
ByVal namedObject As NamedObjectBase, _
ByVal picker As DropDownPicker _
)
[C#]
protected virtual void PrepareForDropDownControl(
NamedObjectBase namedObject,
DropDownPicker picker
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


RuleBasePropertyEditor.ProcessDropDownResults Method

[TBD]

[Visual Basic]
Overridable Protected Function ProcessDropDownResults( _
ByVal namedObject As NamedObjectBase, _
ByVal picker As DropDownPicker, _
ByVal canceled As Boolean _
) As Object
[C#]
protected virtual object ProcessDropDownResults(
NamedObjectBase namedObject,
DropDownPicker picker,
bool canceled
);

See Also

RuleBasePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


StatePropertyEditor Class

[TBD]

For a list of all members of this type, see StatePropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.StatePropertyEditor

[Visual Basic]
Public Class StatePropertyEditor
Inherits RuleBasePropertyEditor
[C#]
public class StatePropertyEditor : RuleBasePropertyEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

StatePropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


StatePropertyEditor Members

StatePropertyEditor overview

Public Instance Constructors

StatePropertyEditor Constructor Initializes a new instance of the StatePropertyEditor class.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

StatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


StatePropertyEditor Constructor

Initializes a new instance of the StatePropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public StatePropertyEditor();

See Also

StatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


StatePropertyEditor Methods

The methods of the StatePropertyEditor class are listed below. For a complete list of StatePropertyEditor class members, see the StatePropertyEditor Members topic.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

StatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


StatePropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

StatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


TargetStatePropertyEditor Class

[TBD]

For a list of all members of this type, see TargetStatePropertyEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.TargetStatePropertyEditor

[Visual Basic]
Public Class TargetStatePropertyEditor
Inherits RuleBasePropertyEditor
[C#]
public class TargetStatePropertyEditor : RuleBasePropertyEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Editors

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

TargetStatePropertyEditor Members | LaMarvin.Constable.Design.Editors Namespace


TargetStatePropertyEditor Members

TargetStatePropertyEditor overview

Public Instance Constructors

TargetStatePropertyEditor Constructor Initializes a new instance of the TargetStatePropertyEditor class.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

TargetStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


TargetStatePropertyEditor Constructor

Initializes a new instance of the TargetStatePropertyEditor class.

[Visual Basic]
Public Sub New()
[C#]
public TargetStatePropertyEditor();

See Also

TargetStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


TargetStatePropertyEditor Methods

The methods of the TargetStatePropertyEditor class are listed below. For a complete list of TargetStatePropertyEditor class members, see the TargetStatePropertyEditor Members topic.

Public Instance Methods

EditValue (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from RuleBasePropertyEditor) | Overloaded. [TBD]
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetNamedObject | [TBD]
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

FilterNamedObjects (inherited from RuleBasePropertyEditor) | [TBD]
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PrepareForDropDownControl (inherited from RuleBasePropertyEditor) | [TBD]
ProcessDropDownResults (inherited from RuleBasePropertyEditor) | [TBD]

See Also

TargetStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


TargetStatePropertyEditor.GetNamedObject Method

[TBD]

[Visual Basic]
Overrides Public Function GetNamedObject( _
ByVal rule As RuleBase _
) As NamedObjectBase
[C#]
public override NamedObjectBase GetNamedObject(
RuleBase rule
);

See Also

TargetStatePropertyEditor Class | LaMarvin.Constable.Design.Editors Namespace


LaMarvin.Constable.Design.Fallback

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Fallback Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting fallback-loading of authorization policies containing unavailable policy object types.

Namespace hierarchy

Classes

Class | Description
FallbackAction | [TBD]
FallbackActionRule | [TBD]
FallbackPolicy | [TBD]
FallbackProperty | [TBD]
FallbackPropertyDescriptor | [TBD]
FallbackPropertyRule | [TBD]
FallbackRole | [TBD]
FallbackState | [TBD]
FallbackTypeDescriptor | [TBD]

Interfaces

Interface | Description
IFallbackPropertyOwner | This interface supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.


FallbackAction Class

[TBD]

For a list of all members of this type, see FallbackAction Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Action
LaMarvin.Constable.Design.Fallback.FallbackAction

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackAction
Inherits Action
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackAction : Action, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackAction Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackAction Members

FallbackAction overview

Public Instance Constructors

FallbackAction Overloaded. Initializes a new instance of the FallbackAction class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Action) | Returns the colllection that owns this Action object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

OnExecute (inherited from Action)

See Also

FallbackAction Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackAction Constructor

[TBD]

Overload List

[TBD]

public FallbackAction(string);

[TBD]

public FallbackAction(string,Hashtable,string);

See Also

FallbackAction Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackAction Constructor (String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public FallbackAction(
string id
);

See Also

FallbackAction Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackAction Constructor Overload List


FallbackAction Constructor (String, Hashtable, String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal id As String _
)
[C#]
public FallbackAction(
string originalTypeName,
Hashtable fallbackProperties,
string id
);

See Also

FallbackAction Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackAction Constructor Overload List


FallbackActionRule Class

[TBD]

For a list of all members of this type, see FallbackActionRule Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.ActionRule
LaMarvin.Constable.Design.Fallback.FallbackActionRule

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackActionRule
Inherits ActionRule
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackActionRule : ActionRule, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackActionRule Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackActionRule Members

FallbackActionRule overview

Public Instance Constructors

FallbackActionRule Overloaded. Initializes a new instance of the FallbackActionRule class.

Public Instance Properties

Action (inherited from ActionRule) | Sets or returns the Action instance associated with this rule.
IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner (inherited from ActionRule) | Returns the colllection that owns this ActionRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.
TargetState (inherited from ActionRule) | Gets or sets the state that the Policy will be in after executing the associated Action.

Public Instance Methods

Copy (inherited from ActionRule) | Creates a copy of the action.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ActionRule) | Returns a string representation of the rule's properties.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

OnExecute (inherited from ActionRule) Called by the AuthorizationPolicy as part of executing the action associated with this rule.

See Also

FallbackActionRule Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackActionRule Constructor

[TBD]

Overload List

[TBD]

public FallbackActionRule(Action,Role,State,State);

[TBD]

public FallbackActionRule(string,Hashtable,Action,Role,State,State,bool,bool);

See Also

FallbackActionRule Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackActionRule Constructor (Action, Role, State, State)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State _
)
[C#]
public FallbackActionRule(
Action action,
Role role,
State state,
State targetState
);

See Also

FallbackActionRule Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackActionRule Constructor Overload List


FallbackActionRule Constructor (String, Hashtable, Action, Role, State, State, Boolean, Boolean)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
)
[C#]
public FallbackActionRule(
string originalTypeName,
Hashtable fallbackProperties,
Action action,
Role role,
State state,
State targetState,
bool isVisible,
bool isEnabled
);

See Also

FallbackActionRule Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackActionRule Constructor Overload List


FallbackPolicy Class

[TBD]

For a list of all members of this type, see FallbackPolicy Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.AuthorizationPolicy
LaMarvin.Constable.Design.Fallback.FallbackPolicy

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackPolicy
Inherits AuthorizationPolicy
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackPolicy : AuthorizationPolicy, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPolicy Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackPolicy Members

FallbackPolicy overview

Public Instance Constructors

FallbackPolicy Overloaded. Initializes a new instance of the FallbackPolicy class.

Public Instance Properties

ActionRules (inherited from AuthorizationPolicy) | Gets the collection of all the ActionRule objects defined for the instance.
Actions (inherited from AuthorizationPolicy) | Gets the collection of all the Action objects defined for the instance.
CurrentPrincipal (inherited from AuthorizationPolicy) | Sets or returns the IPrincipal implementation used to resolve role membership.
CurrentState (inherited from AuthorizationPolicy) | Sets or returns the current state of the authorization policy.
Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Properties (inherited from AuthorizationPolicy) | Gets the collection of all the Property objects defined for the instance.
PropertyRules (inherited from AuthorizationPolicy) | Gets the collection of all the PropertyRule objects defined for the instance.
Roles (inherited from AuthorizationPolicy) | Gets the collection of all the Role objects defined for the instance.
States (inherited from AuthorizationPolicy) | Gets the collection of all the State objects defined for the instance.

Public Instance Methods

Clear (inherited from AuthorizationPolicy) | Clears the whole authorization policy contained within this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteAction (inherited from AuthorizationPolicy) | Overloaded. Executes the Action associated with the given action authorization rule.
GetDefinedActionRules (inherited from AuthorizationPolicy) | Returns all the ActionRule objects defined for the current authorization context.
GetDefinedPropertyRules (inherited from AuthorizationPolicy) | Returns all PropertyRule objects defined for the current authorization context.
GetExecutableActionRules (inherited from AuthorizationPolicy) | Returns all the ActionRule objects for actions that are executable in the current authorization context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChangeablePropertyRules (inherited from AuthorizationPolicy) | Return all PropertyRule objects that are changeable in the current authorization context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsActionExecutable (inherited from AuthorizationPolicy) | Overloaded. Returns a value specifying if the action associated with the given rule is executable in the current authorization context.
IsNewRuleValid (inherited from AuthorizationPolicy) | This member supports the component' s implementation and is not intended to be used directly from your code.
IsPropertyChangeable (inherited from AuthorizationPolicy) | Overloaded. Returns a value specifying if the Property associated with the given rule is changeable in the current authorization context.
RaiseAuthorizationContextChangedEvent (inherited from AuthorizationPolicy) | Overloaded. Raises the AuthorizationContextChanged event.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Public Instance Events

ActionExecuted (inherited from AuthorizationPolicy) | Occurs after an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
ActionExecuting (inherited from AuthorizationPolicy) | Occurs before an Action is executed as a result of calling one of the ExecuteAction overloaded methods.
AuthorizationContextChanged (inherited from AuthorizationPolicy) | The event is raised whenever the authorization context of the policy is changed.
InstanceChanged (inherited from AuthorizationPolicy) | The event is raised after a policy object has been changed.
InstanceChanging (inherited from AuthorizationPolicy) | The event is raised before a policy object is changed.
ResolveRoleMembership (inherited from AuthorizationPolicy) | The event is raised as part of the role resolution process.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

CreateAction (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateActionRule (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateProperty (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreatePropertyRule (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateRole (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateState (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
GetExecutableActionRulesInternal (inherited from AuthorizationPolicy) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

FallbackPolicy Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPolicy Constructor

[TBD]

Overload List

[TBD]

public FallbackPolicy(string);

[TBD]

public FallbackPolicy(string,Hashtable,string);

See Also

FallbackPolicy Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPolicy Constructor (String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public FallbackPolicy(
string id
);

See Also

FallbackPolicy Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackPolicy Constructor Overload List


FallbackPolicy Constructor (String, Hashtable, String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal id As String _
)
[C#]
public FallbackPolicy(
string originalTypeName,
Hashtable fallbackProperties,
string id
);

See Also

FallbackPolicy Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackPolicy Constructor Overload List


FallbackProperty Class

[TBD]

For a list of all members of this type, see FallbackProperty Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Property
LaMarvin.Constable.Design.Fallback.FallbackProperty

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackProperty
Inherits Property
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackProperty : Property, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackProperty Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackProperty Members

FallbackProperty overview

Public Instance Constructors

FallbackProperty Overloaded. Initializes a new instance of the FallbackProperty class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Property) | Returns the PropertyCollection instance that owns this Property object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

FallbackProperty Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackProperty Constructor

[TBD]

Overload List

[TBD]

public FallbackProperty(string);

[TBD]

public FallbackProperty(string,Hashtable,string);

See Also

FallbackProperty Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackProperty Constructor (String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public FallbackProperty(
string id
);

See Also

FallbackProperty Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackProperty Constructor Overload List


FallbackProperty Constructor (String, Hashtable, String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal id As String _
)
[C#]
public FallbackProperty(
string originalTypeName,
Hashtable fallbackProperties,
string id
);

See Also

FallbackProperty Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackProperty Constructor Overload List


FallbackPropertyDescriptor Class

[TBD]

For a list of all members of this type, see FallbackPropertyDescriptor Members.

System.Object
System.ComponentModel.MemberDescriptor
System.ComponentModel.PropertyDescriptor
LaMarvin.Constable.Design.Fallback.FallbackPropertyDescriptor

[Visual Basic]
NotInheritable Public Class FallbackPropertyDescriptor
Inherits PropertyDescriptor
[C#]
public sealed class FallbackPropertyDescriptor : PropertyDescriptor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPropertyDescriptor Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor Members

FallbackPropertyDescriptor overview

Public Instance Constructors

FallbackPropertyDescriptor Constructor [TBD]

Public Instance Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute.
ComponentType | [TBD]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description | [TBD]
DesignTimeOnly (inherited from MemberDescriptor) | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute.
DisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window, such as a Properties window.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [TBD]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PropertyType | [TBD]
SerializationVisibility (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute.

Public Instance Methods

AddValueChanged (inherited from PropertyDescriptor) | Enables other objects to be notified when this property changes.
CanResetValue | [TBD]
Equals (inherited from PropertyDescriptor) | Compares this to another object to see if they are equivalent.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from PropertyDescriptor) |
GetChildProperties (inherited from PropertyDescriptor) | Overloaded. Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | [TBD]
RemoveValueChanged (inherited from PropertyDescriptor) | Enables other objects to be notified when this property changes.
ResetValue | [TBD]
SetValue | [TBD]
ShouldSerializeValue | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal owner As IFallbackPropertyOwner, _
ByVal propertyName As String, _
ByVal originalTypeName As String _
)
[C#]
public FallbackPropertyDescriptor(
IFallbackPropertyOwner owner,
string propertyName,
string originalTypeName
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor Properties

The properties of the FallbackPropertyDescriptor class are listed below. For a complete list of FallbackPropertyDescriptor class members, see the FallbackPropertyDescriptor Members topic.

Public Instance Properties

Attributes (inherited from MemberDescriptor) | Gets the collection of attributes for this member.
Category (inherited from MemberDescriptor) | Gets the name of the category to which the member belongs, as specified in the CategoryAttribute.
ComponentType | [TBD]
Converter (inherited from PropertyDescriptor) | Gets the type converter for this property.
Description | [TBD]
DesignTimeOnly (inherited from MemberDescriptor) | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute.
DisplayName (inherited from MemberDescriptor) | Gets the name that can be displayed in a window, such as a Properties window.
IsBrowsable (inherited from MemberDescriptor) | Gets a value indicating whether the member is browsable, as specified in the BrowsableAttribute.
IsLocalizable (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute.
IsReadOnly | [TBD]
Name (inherited from MemberDescriptor) | Gets the name of the member.
PropertyType | [TBD]
SerializationVisibility (inherited from PropertyDescriptor) | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute.

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.ComponentType Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ComponentType As Type
[C#]
public override System.Type ComponentType {get;}

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.Description Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property Description As String
[C#]
public override string Description {get;}

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.IsReadOnly Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property IsReadOnly As Boolean
[C#]
public override bool IsReadOnly {get;}

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.PropertyType Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property PropertyType As Type
[C#]
public override System.Type PropertyType {get;}

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor Methods

The methods of the FallbackPropertyDescriptor class are listed below. For a complete list of FallbackPropertyDescriptor class members, see the FallbackPropertyDescriptor Members topic.

Public Instance Methods

AddValueChanged (inherited from PropertyDescriptor) | Enables other objects to be notified when this property changes.
CanResetValue | [TBD]
Equals (inherited from PropertyDescriptor) | Compares this to another object to see if they are equivalent.
GetEditor (inherited from PropertyDescriptor) | Gets an editor of the specified type.
GetHashCode (inherited from PropertyDescriptor) |
GetChildProperties (inherited from PropertyDescriptor) | Overloaded. Returns a PropertyDescriptorCollection for a given object using a specified array of attributes as a filter.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | [TBD]
RemoveValueChanged (inherited from PropertyDescriptor) | Enables other objects to be notified when this property changes.
ResetValue | [TBD]
SetValue | [TBD]
ShouldSerializeValue | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.CanResetValue Method

[TBD]

[Visual Basic]
Overrides Public Function CanResetValue( _
ByVal component As Object _
) As Boolean
[C#]
public override bool CanResetValue(
object component
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.GetValue Method

[TBD]

[Visual Basic]
Overrides Public Function GetValue( _
ByVal component As Object _
) As Object
[C#]
public override object GetValue(
object component
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.ResetValue Method

[TBD]

[Visual Basic]
Overrides Public Sub ResetValue( _
ByVal component As Object _
)
[C#]
public override void ResetValue(
object component
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.SetValue Method

[TBD]

[Visual Basic]
Overrides Public Sub SetValue( _
ByVal component As Object, _
ByVal value As Object _
)
[C#]
public override void SetValue(
object component,
object value
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyDescriptor.ShouldSerializeValue Method

[TBD]

[Visual Basic]
Overrides Public Function ShouldSerializeValue( _
ByVal component As Object _
) As Boolean
[C#]
public override bool ShouldSerializeValue(
object component
);

See Also

FallbackPropertyDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyRule Class

[TBD]

For a list of all members of this type, see FallbackPropertyRule Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.PropertyRule
LaMarvin.Constable.Design.Fallback.FallbackPropertyRule

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackPropertyRule
Inherits PropertyRule
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackPropertyRule : PropertyRule, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPropertyRule Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyRule Members

FallbackPropertyRule overview

Public Instance Constructors

FallbackPropertyRule Overloaded. Initializes a new instance of the FallbackPropertyRule class.

Public Instance Properties

IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner (inherited from PropertyRule) | Returns the colllection that owns this PropertyRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Property (inherited from PropertyRule) | Sets or returns the Property instance associated with this rule.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from PropertyRule) | Returns a string representation of the rule's properties.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

FallbackPropertyRule Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyRule Constructor

[TBD]

Overload List

[TBD]

public FallbackPropertyRule(Property,Role,State);

[TBD]

public FallbackPropertyRule(string,Hashtable,Property,Role,State,bool,bool);

See Also

FallbackPropertyRule Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackPropertyRule Constructor (Property, Role, State)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State _
)
[C#]
public FallbackPropertyRule(
Property property,
Role role,
State state
);

See Also

FallbackPropertyRule Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackPropertyRule Constructor Overload List


FallbackPropertyRule Constructor (String, Hashtable, Property, Role, State, Boolean, Boolean)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
)
[C#]
public FallbackPropertyRule(
string originalTypeName,
Hashtable fallbackProperties,
Property property,
Role role,
State state,
bool isVisible,
bool isEnabled
);

See Also

FallbackPropertyRule Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackPropertyRule Constructor Overload List


FallbackRole Class

[TBD]

For a list of all members of this type, see FallbackRole Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Design.Fallback.FallbackRole

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackRole
Inherits Role
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackRole : Role, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackRole Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackRole Members

FallbackRole overview

Public Instance Constructors

FallbackRole Overloaded. Initializes a new instance of the FallbackRole class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember (inherited from Role) | Determines whether a principal is member of the role.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

FallbackRole Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackRole Constructor

[TBD]

Overload List

[TBD]

public FallbackRole(string);

[TBD]

public FallbackRole(string,Hashtable,string);

See Also

FallbackRole Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackRole Constructor (String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public FallbackRole(
string id
);

See Also

FallbackRole Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackRole Constructor Overload List


FallbackRole Constructor (String, Hashtable, String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal id As String _
)
[C#]
public FallbackRole(
string originalTypeName,
Hashtable fallbackProperties,
string id
);

See Also

FallbackRole Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackRole Constructor Overload List


FallbackState Class

[TBD]

For a list of all members of this type, see FallbackState Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.State
LaMarvin.Constable.Design.Fallback.FallbackState

[Visual Basic]
<Serializable>
NotInheritable Public Class FallbackState
Inherits State
Implements ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize
[C#]
[Serializable]
public sealed class FallbackState : State, ICustomTypeDescriptor, IFallbackPropertyOwner, IDeserializationCallback, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackState Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackState Members

FallbackState overview

Public Instance Constructors

FallbackState Overloaded. Initializes a new instance of the FallbackState class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from State) | Returns the colllection that owns this State object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

FallbackState Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackState Constructor

[TBD]

Overload List

[TBD]

public FallbackState(string);

[TBD]

public FallbackState(string,Hashtable,string);

See Also

FallbackState Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackState Constructor (String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public FallbackState(
string id
);

See Also

FallbackState Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackState Constructor Overload List


FallbackState Constructor (String, Hashtable, String)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal originalTypeName As String, _
ByVal fallbackProperties As Hashtable, _
ByVal id As String _
)
[C#]
public FallbackState(
string originalTypeName,
Hashtable fallbackProperties,
string id
);

See Also

FallbackState Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackState Constructor Overload List


FallbackTypeDescriptor Class

[TBD]

For a list of all members of this type, see FallbackTypeDescriptor Members.

System.Object
LaMarvin.Constable.Design.Fallback.FallbackTypeDescriptor

[Visual Basic]
Public Class FallbackTypeDescriptor
Implements ICustomTypeDescriptor
[C#]
public class FallbackTypeDescriptor : ICustomTypeDescriptor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackTypeDescriptor Members | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor Members

FallbackTypeDescriptor overview

Public Instance Constructors

FallbackTypeDescriptor Constructor [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributes | [TBD]
GetClassName | [TBD]
GetComponentName | [TBD]
GetConverter | [TBD]
GetDefaultEvent | [TBD]
GetDefaultProperty | [TBD]
GetEditor | [TBD]
GetEvents | Overloaded. [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties | Overloaded. [TBD]
GetPropertyOwner | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal owner As IFallbackPropertyOwner _
)
[C#]
public FallbackTypeDescriptor(
IFallbackPropertyOwner owner
);

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor Methods

The methods of the FallbackTypeDescriptor class are listed below. For a complete list of FallbackTypeDescriptor class members, see the FallbackTypeDescriptor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttributes | [TBD]
GetClassName | [TBD]
GetComponentName | [TBD]
GetConverter | [TBD]
GetDefaultEvent | [TBD]
GetDefaultProperty | [TBD]
GetEditor | [TBD]
GetEvents | Overloaded. [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties | Overloaded. [TBD]
GetPropertyOwner | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetAttributes Method

[TBD]

[Visual Basic]
Overridable Public Function GetAttributes() As AttributeCollection _
Implements ICustomTypeDescriptor.GetAttributes
[C#]
public virtual AttributeCollection GetAttributes();

Implements

ICustomTypeDescriptor.GetAttributes

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetClassName Method

[TBD]

[Visual Basic]
Overridable Public Function GetClassName() As String _
Implements ICustomTypeDescriptor.GetClassName
[C#]
public virtual string GetClassName();

Implements

ICustomTypeDescriptor.GetClassName

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetComponentName Method

[TBD]

[Visual Basic]
Overridable Public Function GetComponentName() As String _
Implements ICustomTypeDescriptor.GetComponentName
[C#]
public virtual string GetComponentName();

Implements

ICustomTypeDescriptor.GetComponentName

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetConverter Method

[TBD]

[Visual Basic]
Overridable Public Function GetConverter() As TypeConverter _
Implements ICustomTypeDescriptor.GetConverter
[C#]
public virtual TypeConverter GetConverter();

Implements

ICustomTypeDescriptor.GetConverter

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetDefaultEvent Method

[TBD]

[Visual Basic]
Overridable Public Function GetDefaultEvent() As EventDescriptor _
Implements ICustomTypeDescriptor.GetDefaultEvent
[C#]
public virtual EventDescriptor GetDefaultEvent();

Implements

ICustomTypeDescriptor.GetDefaultEvent

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetDefaultProperty Method

[TBD]

[Visual Basic]
Overridable Public Function GetDefaultProperty() As PropertyDescriptor _
Implements ICustomTypeDescriptor.GetDefaultProperty
[C#]
public virtual PropertyDescriptor GetDefaultProperty();

Implements

ICustomTypeDescriptor.GetDefaultProperty

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetEditor Method

[TBD]

[Visual Basic]
Overridable Public Function GetEditor( _
ByVal editorBaseType As Type _
) As Object _
Implements ICustomTypeDescriptor.GetEditor
[C#]
public virtual object GetEditor(
Type editorBaseType
);

Implements

ICustomTypeDescriptor.GetEditor

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


GetEvents Method

Constable Authorization Engine 2.0 BETA

FallbackTypeDescriptor.GetEvents Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public EventDescriptorCollection GetEvents();

[TBD]

public virtual EventDescriptorCollection GetEvents(Attribute[]);

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetEvents Method ()

[TBD]

[Visual Basic]
NotOverridable Overloads Public Function GetEvents() As EventDescriptorCollection _
Implements ICustomTypeDescriptor.GetEvents
[C#]
public EventDescriptorCollection GetEvents();

Implements

ICustomTypeDescriptor.GetEvents

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackTypeDescriptor.GetEvents Overload List


FallbackTypeDescriptor.GetEvents Method (Attribute[])

[TBD]

[Visual Basic]
Overridable Overloads Public Function GetEvents( _
ByVal attributes As Attribute() _
) As EventDescriptorCollection _
Implements ICustomTypeDescriptor.GetEvents
[C#]
public virtual EventDescriptorCollection GetEvents(
Attribute[] attributes
);

Implements

ICustomTypeDescriptor.GetEvents

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackTypeDescriptor.GetEvents Overload List


GetProperties Method

Constable Authorization Engine 2.0 BETA

FallbackTypeDescriptor.GetProperties Method

[This is preliminary documentation and subject to change.]

[TBD]

Overload List

[TBD]

public PropertyDescriptorCollection GetProperties();

[TBD]

public virtual PropertyDescriptorCollection GetProperties(Attribute[]);

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


FallbackTypeDescriptor.GetProperties Method ()

[TBD]

[Visual Basic]
NotOverridable Overloads Public Function GetProperties() As PropertyDescriptorCollection _
Implements ICustomTypeDescriptor.GetProperties
[C#]
public PropertyDescriptorCollection GetProperties();

Implements

ICustomTypeDescriptor.GetProperties

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackTypeDescriptor.GetProperties Overload List


FallbackTypeDescriptor.GetProperties Method (Attribute[])

[TBD]

[Visual Basic]
Overridable Overloads Public Function GetProperties( _
ByVal attributes As Attribute() _
) As PropertyDescriptorCollection _
Implements ICustomTypeDescriptor.GetProperties
[C#]
public virtual PropertyDescriptorCollection GetProperties(
Attribute[] attributes
);

Implements

ICustomTypeDescriptor.GetProperties

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace | FallbackTypeDescriptor.GetProperties Overload List


FallbackTypeDescriptor.GetPropertyOwner Method

[TBD]

[Visual Basic]
Overridable Public Function GetPropertyOwner( _
ByVal pd As PropertyDescriptor _
) As Object _
Implements ICustomTypeDescriptor.GetPropertyOwner
[C#]
public virtual object GetPropertyOwner(
PropertyDescriptor pd
);

Implements

ICustomTypeDescriptor.GetPropertyOwner

See Also

FallbackTypeDescriptor Class | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner Interface

This interface supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

For a list of all members of this type, see IFallbackPropertyOwner Members.

[Visual Basic]
Public Interface IFallbackPropertyOwner
[C#]
public interface IFallbackPropertyOwner

Types that implement IFallbackPropertyOwner

Type | Description
FallbackAction | [TBD]
FallbackActionRule | [TBD]
FallbackPolicy | [TBD]
FallbackProperty | [TBD]
FallbackPropertyRule | [TBD]
FallbackRole | [TBD]
FallbackState | [TBD]

Requirements

Namespace: LaMarvin.Constable.Design.Fallback

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

IFallbackPropertyOwner Members | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner Members

IFallbackPropertyOwner overview

Public Instance Properties

OriginalTypeName This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

Public Instance Methods

GetPropertyNames | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
GetPropertyValue | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
IsPropertyReadOnly | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
SetPropertyValue | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner Properties

The properties of the IFallbackPropertyOwner interface are listed below. For a complete list of IFallbackPropertyOwner interface members, see the IFallbackPropertyOwner Members topic.

Public Instance Properties

OriginalTypeName This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner.OriginalTypeName Property

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Property OriginalTypeName As String
[C#]
string OriginalTypeName {get;}

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner Methods

The methods of the IFallbackPropertyOwner interface are listed below. For a complete list of IFallbackPropertyOwner interface members, see the IFallbackPropertyOwner Members topic.

Public Instance Methods

GetPropertyNames | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
GetPropertyValue | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
IsPropertyReadOnly | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
SetPropertyValue | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner.GetPropertyNames Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Function GetPropertyNames() As String()
[C#]
string[] GetPropertyNames();

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner.GetPropertyValue Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Function GetPropertyValue( _
ByVal propertyName As String _
) As Object
[C#]
object GetPropertyValue(
string propertyName
);

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner.IsPropertyReadOnly Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Function IsPropertyReadOnly( _
ByVal propertyName As String _
) As Boolean
[C#]
bool IsPropertyReadOnly(
string propertyName
);

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


IFallbackPropertyOwner.SetPropertyValue Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Sub SetPropertyValue( _
ByVal propertyName As String, _
ByVal propertyValue As Object _
)
[C#]
void SetPropertyValue(
string propertyName,
object propertyValue
);

See Also

IFallbackPropertyOwner Interface | LaMarvin.Constable.Design.Fallback Namespace


LaMarvin.Constable.Design.Forms

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Forms Namespace

[This is preliminary documentation and subject to change.]

Contains various forms and dialogs used throughout the CAZE Design Environment, including the core IPolicyDesignHost implementation - the PolicyDesignForm form.

Namespace hierarchy

Classes

Class | Description
AssemblyFileSelectorForm | [TBD]
ClonePolicyObjectForm | [TBD]
ExceptionDetailsForm | [TBD]
PasteRuleForm | [TBD]
PolicyDesignForm | [TBD]
PolicyStatisticsForm | [TBD]
ShowExceptionForm | [TBD]
TypeInfoSelectorForm | [TBD]


AssemblyFileSelectorForm Class

[TBD]

For a list of all members of this type, see AssemblyFileSelectorForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.AssemblyFileSelectorForm

[Visual Basic]
Public Class AssemblyFileSelectorForm
Inherits Form
[C#]
public class AssemblyFileSelectorForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

AssemblyFileSelectorForm Members | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm Members

AssemblyFileSelectorForm overview

Public Instance Constructors

AssemblyFileSelectorForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
ApplyToAll | [TBD]
AssemblyPath | [TBD]
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Context | [TBD]
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LoadedCustomAssembly | [TBD]
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public AssemblyFileSelectorForm();

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm Properties

The properties of the AssemblyFileSelectorForm class are listed below. For a complete list of AssemblyFileSelectorForm class members, see the AssemblyFileSelectorForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
ApplyToAll | [TBD]
AssemblyPath | [TBD]
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Context | [TBD]
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LoadedCustomAssembly | [TBD]
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm.ApplyToAll Property

[TBD]

[Visual Basic]
Public ReadOnly Property ApplyToAll As Boolean
[C#]
public bool ApplyToAll {get;}

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm.AssemblyPath Property

[TBD]

[Visual Basic]
Public Property AssemblyPath As String
[C#]
public string AssemblyPath {get; set;}

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm.Context Property

[TBD]

[Visual Basic]
Public Property Context As IPolicyLoaderContext
[C#]
public LaMarvin.Constable.Design.IPolicyLoaderContext Context {get; set;}

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm.LoadedCustomAssembly Property

[TBD]

[Visual Basic]
Public ReadOnly Property LoadedCustomAssembly As Assembly
[C#]
public System.Reflection.Assembly LoadedCustomAssembly {get;}

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm Methods

The methods of the AssemblyFileSelectorForm class are listed below. For a complete list of AssemblyFileSelectorForm class members, see the AssemblyFileSelectorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

AssemblyFileSelectorForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


AssemblyFileSelectorForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

AssemblyFileSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace | AssemblyFileSelectorForm.Dispose Overload List


ClonePolicyObjectForm Class

[TBD]

For a list of all members of this type, see ClonePolicyObjectForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.ClonePolicyObjectForm

[Visual Basic]
Public Class ClonePolicyObjectForm
Inherits Form
[C#]
public class ClonePolicyObjectForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ClonePolicyObjectForm Members | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm Members

ClonePolicyObjectForm overview

Public Instance Constructors

ClonePolicyObjectForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CloningHandler | [TBD]
CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal handler As CloningNamedObjectHandler, _
ByVal undoEngine As UndoEngine _
)
[C#]
public ClonePolicyObjectForm(
CloningNamedObjectHandler handler,
UndoEngine undoEngine
);

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm Properties

The properties of the ClonePolicyObjectForm class are listed below. For a complete list of ClonePolicyObjectForm class members, see the ClonePolicyObjectForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CloningHandler | [TBD]
CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm.CloningHandler Property

[TBD]

[Visual Basic]
Protected ReadOnly Property CloningHandler As CloningNamedObjectHandler
[C#]
protected LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler CloningHandler {get;}

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm Methods

The methods of the ClonePolicyObjectForm class are listed below. For a complete list of ClonePolicyObjectForm class members, see the ClonePolicyObjectForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

ClonePolicyObjectForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ClonePolicyObjectForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace | ClonePolicyObjectForm.Dispose Overload List


ClonePolicyObjectForm.OnLoad Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnLoad( _
ByVal e As EventArgs _
)
[C#]
protected override void OnLoad(
EventArgs e
);

See Also

ClonePolicyObjectForm Class | LaMarvin.Constable.Design.Forms Namespace


ExceptionDetailsForm Class

[TBD]

For a list of all members of this type, see ExceptionDetailsForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.ExceptionDetailsForm

[Visual Basic]
NotInheritable Public Class ExceptionDetailsForm
Inherits Form
[C#]
public sealed class ExceptionDetailsForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ExceptionDetailsForm Members | LaMarvin.Constable.Design.Forms Namespace


ExceptionDetailsForm Members

ExceptionDetailsForm overview

Public Instance Constructors

ExceptionDetailsForm Overloaded. Initializes a new instance of the ExceptionDetailsForm class.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Exception | [TBD]
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace


ExceptionDetailsForm Constructor

[TBD]

Overload List

[TBD]

public ExceptionDetailsForm();

[TBD]

public ExceptionDetailsForm(Exception);

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace


ExceptionDetailsForm Constructor ()

[TBD]

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExceptionDetailsForm();

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace | ExceptionDetailsForm Constructor Overload List


ExceptionDetailsForm Constructor (Exception)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal ex As Exception _
)
[C#]
public ExceptionDetailsForm(
Exception ex
);

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace | ExceptionDetailsForm Constructor Overload List


ExceptionDetailsForm Properties

The properties of the ExceptionDetailsForm class are listed below. For a complete list of ExceptionDetailsForm class members, see the ExceptionDetailsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Exception | [TBD]
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace


ExceptionDetailsForm.Exception Property

[TBD]

[Visual Basic]
Public Property Exception As Exception
[C#]
public System.Exception Exception {get; set;}

See Also

ExceptionDetailsForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm Class

[TBD]

For a list of all members of this type, see PasteRuleForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.PasteRuleForm

[Visual Basic]
Public Class PasteRuleForm
Inherits Form
[C#]
public class PasteRuleForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PasteRuleForm Members | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm Members

PasteRuleForm overview

Public Instance Constructors

PasteRuleForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProtectedObjectLabel | [TBD]
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal rule As RuleBase, _
ByVal policy As AuthorizationPolicy, _
ByVal undoEngine As UndoEngine _
)
[C#]
public PasteRuleForm(
RuleBase rule,
AuthorizationPolicy policy,
UndoEngine undoEngine
);

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm Properties

The properties of the PasteRuleForm class are listed below. For a complete list of PasteRuleForm class members, see the PasteRuleForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ProtectedObjectLabel | [TBD]
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm.ProtectedObjectLabel Property

[TBD]

[Visual Basic]
Public Property ProtectedObjectLabel As String
[C#]
public string ProtectedObjectLabel {get; set;}

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm Methods

The methods of the PasteRuleForm class are listed below. For a complete list of PasteRuleForm class members, see the PasteRuleForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

PasteRuleForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PasteRuleForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace | PasteRuleForm.Dispose Overload List


PasteRuleForm.OnLoad Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnLoad( _
ByVal e As EventArgs _
)
[C#]
protected override void OnLoad(
EventArgs e
);

See Also

PasteRuleForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm Class

[TBD]

For a list of all members of this type, see PolicyDesignForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.PolicyDesignForm

[Visual Basic]
Public Class PolicyDesignForm
Inherits Form
Implements IPolicyDesignHost
[C#]
public class PolicyDesignForm : Form, IPolicyDesignHost

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDesignForm Members | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm Members

PolicyDesignForm overview

Public Static (Shared) Methods

GetActiveForms | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
RegisterRemoteOpenRequest | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

Public Instance Constructors

PolicyDesignForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HostCommandManager | [TBD]
HostStatusBar | [TBD]
HostToolBar | [TBD]
HostWindow | [TBD]
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHostMenu | [TBD]
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OpenPolicyFile | [TBD]
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | [TBD]
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed | [TBD]
OnClosing | [TBD]
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyDesignForm();

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm Properties

The properties of the PolicyDesignForm class are listed below. For a complete list of PolicyDesignForm class members, see the PolicyDesignForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
HostCommandManager | [TBD]
HostStatusBar | [TBD]
HostToolBar | [TBD]
HostWindow | [TBD]
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.HostCommandManager Property

[TBD]

[Visual Basic]
NotOverridable Public ReadOnly Property HostCommandManager As CommandManager _
Implements IPolicyDesignHost.HostCommandManager
[C#]
public LaMarvin.Windows.Forms.CommandManagement.CommandManager HostCommandManager {get;}

Implements

IPolicyDesignHost.HostCommandManager

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.HostStatusBar Property

[TBD]

[Visual Basic]
NotOverridable Public ReadOnly Property HostStatusBar As StatusBar _
Implements IPolicyDesignHost.HostStatusBar
[C#]
public System.Windows.Forms.StatusBar HostStatusBar {get;}

Implements

IPolicyDesignHost.HostStatusBar

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.HostToolBar Property

[TBD]

[Visual Basic]
NotOverridable Public ReadOnly Property HostToolBar As ToolBar _
Implements IPolicyDesignHost.HostToolBar
[C#]
public System.Windows.Forms.ToolBar HostToolBar {get;}

Implements

IPolicyDesignHost.HostToolBar

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.HostWindow Property

[TBD]

[Visual Basic]
NotOverridable Public ReadOnly Property HostWindow As IWin32Window _
Implements IPolicyDesignHost.HostWindow
[C#]
public System.Windows.Forms.IWin32Window HostWindow {get;}

Implements

IPolicyDesignHost.HostWindow

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.PolicyDocument Property

[TBD]

[Visual Basic]
Public Property PolicyDocument As PolicyDocument
[C#]
public LaMarvin.Constable.Design.Persistence.PolicyDocument PolicyDocument {get; set;}

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm Methods

The methods of the PolicyDesignForm class are listed below. For a complete list of PolicyDesignForm class members, see the PolicyDesignForm Members topic.

Public Static (Shared) Methods

GetActiveForms | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.
RegisterRemoteOpenRequest | This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHostMenu | [TBD]
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
OpenPolicyFile | [TBD]
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | [TBD]
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed | [TBD]
OnClosing | [TBD]
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

PolicyDesignForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace | PolicyDesignForm.Dispose Overload List


PolicyDesignForm.GetActiveForms Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Function GetActiveForms() As PolicyDesignForm()
[C#]
public static PolicyDesignForm[] GetActiveForms();

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.GetHostMenu Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetHostMenu( _
ByVal item As PolicyDesignHostMenuItem _
) As MenuItem _
Implements IPolicyDesignHost.GetHostMenu
[C#]
public MenuItem GetHostMenu(
PolicyDesignHostMenuItem item
);

Implements

IPolicyDesignHost.GetHostMenu

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.OnClosed Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnClosed( _
ByVal e As EventArgs _
)
[C#]
protected override void OnClosed(
EventArgs e
);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.OnClosing Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnClosing( _
ByVal e As CancelEventArgs _
)
[C#]
protected override void OnClosing(
CancelEventArgs e
);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.OpenPolicyFile Method

[TBD]

[Visual Basic]
Public Sub OpenPolicyFile( _
ByVal path As String _
)
[C#]
public void OpenPolicyFile(
string path
);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.Refresh Method

[TBD]

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyDesignForm.RegisterRemoteOpenRequest Method

This member supports the Constable Authorization Engine Design Environment and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Sub RegisterRemoteOpenRequest( _
ByVal args As String() _
)
[C#]
public static void RegisterRemoteOpenRequest(
string[] args
);

See Also

PolicyDesignForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm Class

[TBD]

For a list of all members of this type, see PolicyStatisticsForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.PolicyStatisticsForm

[Visual Basic]
Public Class PolicyStatisticsForm
Inherits Form
Implements IPolicyDesignExtension
[C#]
public class PolicyStatisticsForm : Form, IPolicyDesignExtension

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyStatisticsForm Members | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm Members

PolicyStatisticsForm overview

Public Instance Constructors

PolicyStatisticsForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Initialize | [TBD]
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | [TBD]
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShutDown | [TBD]
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStatsText | [TBD]
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing | [TBD]
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyStatisticsForm();

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm Properties

The properties of the PolicyStatisticsForm class are listed below. For a complete list of PolicyStatisticsForm class members, see the PolicyStatisticsForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PolicyDocument | [TBD]
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.PolicyDocument Property

[TBD]

[Visual Basic]
NotOverridable Public Property PolicyDocument As PolicyDocument _
Implements IPolicyDesignExtension.PolicyDocument
[C#]
public LaMarvin.Constable.Design.Persistence.PolicyDocument PolicyDocument {get; set;}

Implements

IPolicyDesignExtension.PolicyDocument

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm Methods

The methods of the PolicyStatisticsForm class are listed below. For a complete list of PolicyStatisticsForm class members, see the PolicyStatisticsForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
Initialize | [TBD]
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | [TBD]
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
ShutDown | [TBD]
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStatsText | [TBD]
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing | [TBD]
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

PolicyStatisticsForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace | PolicyStatisticsForm.Dispose Overload List


PolicyStatisticsForm.GetStatsText Method

[TBD]

[Visual Basic]
Overridable Protected Function GetStatsText() As String
[C#]
protected virtual string GetStatsText();

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.Initialize Method

[TBD]

[Visual Basic]
NotOverridable Public Sub Initialize( _
ByVal host As IPolicyDesignHost _
) _
Implements IPolicyDesignExtension.Initialize
[C#]
public void Initialize(
IPolicyDesignHost host
);

Implements

IPolicyDesignExtension.Initialize

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.OnClosing Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnClosing( _
ByVal e As CancelEventArgs _
)
[C#]
protected override void OnClosing(
CancelEventArgs e
);

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.Refresh Method

[TBD]

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


PolicyStatisticsForm.ShutDown Method

[TBD]

[Visual Basic]
NotOverridable Public Sub ShutDown() _
Implements IPolicyDesignExtension.ShutDown
[C#]
public void ShutDown();

Implements

IPolicyDesignExtension.ShutDown

See Also

PolicyStatisticsForm Class | LaMarvin.Constable.Design.Forms Namespace


ShowExceptionForm Class

[TBD]

For a list of all members of this type, see ShowExceptionForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.ShowExceptionForm

[Visual Basic]
NotInheritable Public Class ShowExceptionForm
Inherits Form
[C#]
public sealed class ShowExceptionForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ShowExceptionForm Members | LaMarvin.Constable.Design.Forms Namespace


ShowExceptionForm Members

ShowExceptionForm overview

Public Instance Constructors

ShowExceptionForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

ShowExceptionForm Class | LaMarvin.Constable.Design.Forms Namespace


ShowExceptionForm Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal message As String, _
ByVal ex As Exception _
)
[C#]
public ShowExceptionForm(
string message,
Exception ex
);

See Also

ShowExceptionForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm Class

[TBD]

For a list of all members of this type, see TypeInfoSelectorForm Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.TypeInfoSelectorForm

[Visual Basic]
Public Class TypeInfoSelectorForm
Inherits Form
[C#]
public class TypeInfoSelectorForm : Form

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Forms

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

TypeInfoSelectorForm Members | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm Members

TypeInfoSelectorForm overview

Public Instance Constructors

TypeInfoSelectorForm Constructor [TBD]

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedTypeInfo | [TBD]
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm Constructor

[TBD]

[Visual Basic]
Public Sub New( _
ByVal availableTypeInfos As TypeInfo() _
)
[C#]
public TypeInfoSelectorForm(
TypeInfo[] availableTypeInfos
);

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm Properties

The properties of the TypeInfoSelectorForm class are listed below. For a complete list of TypeInfoSelectorForm class members, see the TypeInfoSelectorForm Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | [To be supplied.]
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedTypeInfo | [TBD]
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm.SelectedTypeInfo Property

[TBD]

[Visual Basic]
Public ReadOnly Property SelectedTypeInfo As TypeInfo
[C#]
public LaMarvin.Design.TypeInfo SelectedTypeInfo {get;}

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm Methods

The methods of the TypeInfoSelectorForm class are listed below. For a complete list of TypeInfoSelectorForm class members, see the TypeInfoSelectorForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad | [TBD]
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from Form) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

TypeInfoSelectorForm.Dispose Method

[This is preliminary documentation and subject to change.]

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


TypeInfoSelectorForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace | TypeInfoSelectorForm.Dispose Overload List


TypeInfoSelectorForm.OnLoad Method

[TBD]

[Visual Basic]
Overrides Protected Sub OnLoad( _
ByVal e As EventArgs _
)
[C#]
protected override void OnLoad(
EventArgs e
);

See Also

TypeInfoSelectorForm Class | LaMarvin.Constable.Design.Forms Namespace


LaMarvin.Constable.Design.Persistence

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Persistence Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting saving and loading authorization policies to / from persistence mediums (for example the file system).

Namespace hierarchy

Classes

Class | Description
FilePolicyStore | Stores and retrieves authorization policies in a file system (.caze files).
PolicyDocument | [TBD]
PolicyLoader | [TBD]
RecentPolicyDocumentEntry | [TBD]
RecentPolicyDocumentList | [TBD]


FilePolicyStore Class

Stores and retrieves authorization policies in a file system (.caze files).

For a list of all members of this type, see FilePolicyStore Members.

System.Object
LaMarvin.Design.Persistence.PersistentStore
LaMarvin.Constable.Design.Persistence.FilePolicyStore

[Visual Basic]
<Serializable>
Public Class FilePolicyStore
Inherits PersistentStore
[C#]
[Serializable]
public class FilePolicyStore : PersistentStore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Persistence

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FilePolicyStore Members | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore Members

FilePolicyStore overview

Public Instance Constructors

FilePolicyStore Constructor Initializes a new instance of the FilePolicyStore class.

Public Instance Methods

CreateEmptyMoniker | Creates an empty FileMoniker.
CreateMoniker | Creates a FileMoniker representing the file identified with the name parameter.
Equals (inherited from PersistentStore) | Determines if the current store equals to the specified store.
GetHashCode (inherited from PersistentStore) | Gets the hash code of this storage instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the policy indetified by the specified moniker.
Open | Prompts the user with a file open dialog allowing one to select a policy file to be loaded.
PromptForMoniker | Prompts the user with a file save dialog allowing one to select a file to which the policy can be saved.
Save | Saves the policy to the file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore Constructor

Initializes a new instance of the FilePolicyStore class.

[Visual Basic]
Public Sub New()
[C#]
public FilePolicyStore();

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore Methods

The methods of the FilePolicyStore class are listed below. For a complete list of FilePolicyStore class members, see the FilePolicyStore Members topic.

Public Instance Methods

CreateEmptyMoniker | Creates an empty FileMoniker.
CreateMoniker | Creates a FileMoniker representing the file identified with the name parameter.
Equals (inherited from PersistentStore) | Determines if the current store equals to the specified store.
GetHashCode (inherited from PersistentStore) | Gets the hash code of this storage instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the policy indetified by the specified moniker.
Open | Prompts the user with a file open dialog allowing one to select a policy file to be loaded.
PromptForMoniker | Prompts the user with a file save dialog allowing one to select a file to which the policy can be saved.
Save | Saves the policy to the file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.CreateEmptyMoniker Method

Creates an empty FileMoniker.

[Visual Basic]
Overrides Public Function CreateEmptyMoniker() As PersistentMoniker
[C#]
public override PersistentMoniker CreateEmptyMoniker();

Return Value

An instance of the FileMoniker class representing a nonexistent file.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.CreateMoniker Method

Creates a FileMoniker representing the file identified with the name parameter.

[Visual Basic]
Overrides Public Function CreateMoniker( _
ByVal name As String _
) As PersistentMoniker
[C#]
public override PersistentMoniker CreateMoniker(
string name
);

Parameters

name
The full path to a policy file.

Return Value

An instance of the FileMoniker class representing the file.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.Load Method

Loads the policy indetified by the specified moniker.

[Visual Basic]
Overrides Public Function Load( _
ByVal moniker As PersistentMoniker, _
ByRef loadedCleanly As Boolean _
) As Object
[C#]
public override object Load(
PersistentMoniker moniker,
ref bool loadedCleanly
);

Parameters

moniker
The moniker representing a file path.
loadedCleanly
Set to true if the policy was loaded without problems. Set to false if there were problems loading the policy. After returning false, the caller should treat the returned policy as dirty and don't overwrite the original file without prompting the user about possible loss of data.

Return Value

An instance of the AuthorizationPolicy loaded from the specified file.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.Open Method

Prompts the user with a file open dialog allowing one to select a policy file to be loaded.

[Visual Basic]
Overrides Public Function Open( _
ByVal dialogOwner As IWin32Window _
) As PersistentMoniker
[C#]
public override PersistentMoniker Open(
IWin32Window dialogOwner
);

Parameters

dialogOwner
The window that should be the owner of the file open dialog or a null reference (Nothing in Visual Basic) if there is no window available.

Return Value

An instance of the FileMoniker class representing the selected policy file.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.PromptForMoniker Method

Prompts the user with a file save dialog allowing one to select a file to which the policy can be saved.

[Visual Basic]
Overrides Public Function PromptForMoniker( _
ByVal dialogOwner As IWin32Window, _
ByVal instance As Object _
) As PersistentMoniker
[C#]
public override PersistentMoniker PromptForMoniker(
IWin32Window dialogOwner,
object instance
);

Parameters

dialogOwner
The window that should be the owner of the file save dialog or a null reference (Nothing in Visual Basic) if there is no window available.
instance
This parameter is currently ignored.

Return Value

An instance of the FileMoniker class representing the file to which a policy can be saved.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


FilePolicyStore.Save Method

Saves the policy to the file.

[Visual Basic]
Overrides Public Sub Save( _
ByVal instance As Object, _
ByVal moniker As PersistentMoniker _
)
[C#]
public override void Save(
object instance,
PersistentMoniker moniker
);

Parameters

instance
An instance of the AuthorizationPolicy class that should be saved to the file.
moniker
An instance of the FileMoniker class representing the file where the policy should be saved.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as the value of the or the parameter.
ArgumentException | The reference isn't a refernce to the AuthorizationPolicy (or a derived) class, or the reference isn't a reference to the FileMoniker (or a derived) class.

See Also

FilePolicyStore Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Class

[TBD]

For a list of all members of this type, see PolicyDocument Members.

System.Object
LaMarvin.Constable.Design.Persistence.PolicyDocument

[Visual Basic]
NotInheritable Public Class PolicyDocument
[C#]
public sealed class PolicyDocument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Persistence

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyDocument Members | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Members

PolicyDocument overview

Public Instance Constructors

PolicyDocument Overloaded. Initializes a new instance of the PolicyDocument class.

Public Instance Properties

IsDirty | [TBD]
LoadedCleanly | [TBD]
PersistentMoniker | [TBD]
PersistentStore | [TBD]
Policy | [TBD]
UndoEngine | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MarkClean | [TBD]
MarkDirty | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

PolicyDocumentChanged [TBD]

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Constructor

[TBD]

Overload List

[TBD]

public PolicyDocument();

[TBD]

public PolicyDocument(PersistentStore);

[TBD]

public PolicyDocument(PersistentStore,AuthorizationPolicy);

[TBD]

public PolicyDocument(PersistentStore,AuthorizationPolicy,PersistentMoniker);

[TBD]

public PolicyDocument(PersistentStore,AuthorizationPolicy,PersistentMoniker,UndoEngine);

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Constructor ()

[TBD]

[Visual Basic]
Overloads Public Sub New()
[C#]
public PolicyDocument();

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace | PolicyDocument Constructor Overload List


PolicyDocument Constructor (PersistentStore)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore _
)
[C#]
public PolicyDocument(
PersistentStore store
);

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace | PolicyDocument Constructor Overload List


PolicyDocument Constructor (PersistentStore, AuthorizationPolicy)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore, _
ByVal policy As AuthorizationPolicy _
)
[C#]
public PolicyDocument(
PersistentStore store,
AuthorizationPolicy policy
);

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace | PolicyDocument Constructor Overload List


PolicyDocument Constructor (PersistentStore, AuthorizationPolicy, PersistentMoniker)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore, _
ByVal policy As AuthorizationPolicy, _
ByVal moniker As PersistentMoniker _
)
[C#]
public PolicyDocument(
PersistentStore store,
AuthorizationPolicy policy,
PersistentMoniker moniker
);

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace | PolicyDocument Constructor Overload List


PolicyDocument Constructor (PersistentStore, AuthorizationPolicy, PersistentMoniker, UndoEngine)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore, _
ByVal policy As AuthorizationPolicy, _
ByVal moniker As PersistentMoniker, _
ByVal undoEngine As UndoEngine _
)
[C#]
public PolicyDocument(
PersistentStore store,
AuthorizationPolicy policy,
PersistentMoniker moniker,
UndoEngine undoEngine
);

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace | PolicyDocument Constructor Overload List


PolicyDocument Properties

The properties of the PolicyDocument class are listed below. For a complete list of PolicyDocument class members, see the PolicyDocument Members topic.

Public Instance Properties

IsDirty | [TBD]
LoadedCleanly | [TBD]
PersistentMoniker | [TBD]
PersistentStore | [TBD]
Policy | [TBD]
UndoEngine | [TBD]

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.IsDirty Property

[TBD]

[Visual Basic]
Public ReadOnly Property IsDirty As Boolean
[C#]
public bool IsDirty {get;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.LoadedCleanly Property

[TBD]

[Visual Basic]
Public Property LoadedCleanly As Boolean
[C#]
public bool LoadedCleanly {get; set;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.PersistentMoniker Property

[TBD]

[Visual Basic]
Public Property PersistentMoniker As PersistentMoniker
[C#]
public LaMarvin.Design.Persistence.PersistentMoniker PersistentMoniker {get; set;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.PersistentStore Property

[TBD]

[Visual Basic]
Public Property PersistentStore As PersistentStore
[C#]
public LaMarvin.Design.Persistence.PersistentStore PersistentStore {get; set;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.Policy Property

[TBD]

[Visual Basic]
Public Property Policy As AuthorizationPolicy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.UndoEngine Property

[TBD]

[Visual Basic]
Public Property UndoEngine As UndoEngine
[C#]
public LaMarvin.ComponentModel.UndoEngine UndoEngine {get; set;}

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Methods

The methods of the PolicyDocument class are listed below. For a complete list of PolicyDocument class members, see the PolicyDocument Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MarkClean | [TBD]
MarkDirty | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.MarkClean Method

[TBD]

[Visual Basic]
Public Sub MarkClean()
[C#]
public void MarkClean();

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.MarkDirty Method

[TBD]

[Visual Basic]
Public Sub MarkDirty()
[C#]
public void MarkDirty();

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument Events

The events of the PolicyDocument class are listed below. For a complete list of PolicyDocument class members, see the PolicyDocument Members topic.

Public Instance Events

PolicyDocumentChanged [TBD]

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyDocument.PolicyDocumentChanged Event

[TBD]

[Visual Basic]
Public Event PolicyDocumentChanged As EventHandler
[C#]
public event EventHandler PolicyDocumentChanged;

See Also

PolicyDocument Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader Class

[TBD]

For a list of all members of this type, see PolicyLoader Members.

System.Object
LaMarvin.Constable.Design.Persistence.PolicyLoader

[Visual Basic]
NotInheritable Public Class PolicyLoader
Implements IPolicyLoaderTypeResolver
[C#]
public sealed class PolicyLoader : IPolicyLoaderTypeResolver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Persistence

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyLoader Members | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader Members

PolicyLoader overview

Public Instance Constructors

PolicyLoader Constructor [TBD]

Public Instance Properties

LoadFallbacked [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyLoader();

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader Properties

The properties of the PolicyLoader class are listed below. For a complete list of PolicyLoader class members, see the PolicyLoader Members topic.

Public Instance Properties

LoadFallbacked [TBD]

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader.LoadFallbacked Property

[TBD]

[Visual Basic]
Public ReadOnly Property LoadFallbacked As Boolean
[C#]
public bool LoadFallbacked {get;}

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader Methods

The methods of the PolicyLoader class are listed below. For a complete list of PolicyLoader class members, see the PolicyLoader Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


PolicyLoader.Load Method

[TBD]

[Visual Basic]
Public Function Load( _
ByVal loadDelegate As Delegate, _
ParamArray loadDelegateArguments As Object() _
) As Object
[C#]
public object Load(
Delegate loadDelegate,
params object[] loadDelegateArguments
);

See Also

PolicyLoader Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry Class

[TBD]

For a list of all members of this type, see RecentPolicyDocumentEntry Members.

System.Object
LaMarvin.Constable.Design.Persistence.RecentPolicyDocumentEntry

[Visual Basic]
<Serializable>
NotInheritable Public Class RecentPolicyDocumentEntry
[C#]
[Serializable]
public sealed class RecentPolicyDocumentEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Persistence

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RecentPolicyDocumentEntry Members | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry Members

RecentPolicyDocumentEntry overview

Public Instance Constructors

RecentPolicyDocumentEntry Overloaded. Initializes a new instance of the RecentPolicyDocumentEntry class.

Public Instance Properties

PersistentMoniker | [TBD]
PersistentStore | [TBD]
Timestamp | [TBD]

Public Instance Methods

Equals | [TBD]
GetHashCode | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry Constructor

[TBD]

Overload List

[TBD]

public RecentPolicyDocumentEntry(PersistentStore,PersistentMoniker);

[TBD]

public RecentPolicyDocumentEntry(PersistentStore,PersistentMoniker,DateTime);

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry Constructor (PersistentStore, PersistentMoniker)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore, _
ByVal moniker As PersistentMoniker _
)
[C#]
public RecentPolicyDocumentEntry(
PersistentStore store,
PersistentMoniker moniker
);

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace | RecentPolicyDocumentEntry Constructor Overload List


RecentPolicyDocumentEntry Constructor (PersistentStore, PersistentMoniker, DateTime)

[TBD]

[Visual Basic]
Overloads Public Sub New( _
ByVal store As PersistentStore, _
ByVal moniker As PersistentMoniker, _
ByVal timestamp As Date _
)
[C#]
public RecentPolicyDocumentEntry(
PersistentStore store,
PersistentMoniker moniker,
DateTime timestamp
);

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace | RecentPolicyDocumentEntry Constructor Overload List


RecentPolicyDocumentEntry Properties

The properties of the RecentPolicyDocumentEntry class are listed below. For a complete list of RecentPolicyDocumentEntry class members, see the RecentPolicyDocumentEntry Members topic.

Public Instance Properties

PersistentMoniker | [TBD]
PersistentStore | [TBD]
Timestamp | [TBD]

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry.PersistentMoniker Property

[TBD]

[Visual Basic]
Public ReadOnly Property PersistentMoniker As PersistentMoniker
[C#]
public LaMarvin.Design.Persistence.PersistentMoniker PersistentMoniker {get;}

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry.PersistentStore Property

[TBD]

[Visual Basic]
Public ReadOnly Property PersistentStore As PersistentStore
[C#]
public LaMarvin.Design.Persistence.PersistentStore PersistentStore {get;}

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry.Timestamp Property

[TBD]

[Visual Basic]
Public Property Timestamp As Date
[C#]
public System.DateTime Timestamp {get; set;}

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry Methods

The methods of the RecentPolicyDocumentEntry class are listed below. For a complete list of RecentPolicyDocumentEntry class members, see the RecentPolicyDocumentEntry Members topic.

Public Instance Methods

Equals | [TBD]
GetHashCode | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry.Equals Method

[TBD]

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentEntry.GetHashCode Method

[TBD]

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

RecentPolicyDocumentEntry Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList Class

[TBD]

For a list of all members of this type, see RecentPolicyDocumentList Members.

System.Object
LaMarvin.Constable.Design.Persistence.RecentPolicyDocumentList

[Visual Basic]
NotInheritable Public Class RecentPolicyDocumentList
[C#]
public sealed class RecentPolicyDocumentList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Persistence

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RecentPolicyDocumentList Members | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList Members

RecentPolicyDocumentList overview

Public Static (Shared) Properties

Instance [TBD]

Public Instance Methods

Clear | [TBD]
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSortedList | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterUsage | [TBD]
Save | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterEntry | [TBD]

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList Properties

The properties of the RecentPolicyDocumentList class are listed below. For a complete list of RecentPolicyDocumentList class members, see the RecentPolicyDocumentList Members topic.

Public Static (Shared) Properties

Instance [TBD]

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.Instance Property

[TBD]

[Visual Basic]
Public Shared ReadOnly Property Instance As RecentPolicyDocumentList
[C#]
public static RecentPolicyDocumentList Instance {get;}

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList Methods

The methods of the RecentPolicyDocumentList class are listed below. For a complete list of RecentPolicyDocumentList class members, see the RecentPolicyDocumentList Members topic.

Public Instance Methods

Clear | [TBD]
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSortedList | [TBD]
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterUsage | [TBD]
Save | [TBD]
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterEntry | [TBD]

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.Clear Method

[TBD]

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.GetSortedList Method

[TBD]

[Visual Basic]
Public Function GetSortedList() As RecentPolicyDocumentEntry()
[C#]
public RecentPolicyDocumentEntry[] GetSortedList();

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.RegisterUsage Method

[TBD]

[Visual Basic]
Public Sub RegisterUsage( _
ByVal document As PolicyDocument _
)
[C#]
public void RegisterUsage(
PolicyDocument document
);

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.Save Method

[TBD]

[Visual Basic]
Public Sub Save()
[C#]
public void Save();

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


RecentPolicyDocumentList.UnregisterEntry Method

[TBD]

[Visual Basic]
Public Sub UnregisterEntry( _
ByVal entry As RecentPolicyDocumentEntry _
)
[C#]
public void UnregisterEntry(
RecentPolicyDocumentEntry entry
);

See Also

RecentPolicyDocumentList Class | LaMarvin.Constable.Design.Persistence Namespace


LaMarvin.Constable.Design.Shell

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Shell Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting the policy design shell executable (caze.exe) implementation.

Namespace hierarchy

Classes

Class | Description
EntryPoint | Contains the entry point of the managed assembly.
InstanceConnector | This class supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.


EntryPoint Class

Contains the entry point of the managed assembly.

For a list of all members of this type, see EntryPoint Members.

System.Object
LaMarvin.Constable.Design.Shell.EntryPoint

[Visual Basic]
NotInheritable Public Class EntryPoint
[C#]
public sealed class EntryPoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Shell

Assembly: caze (in caze.exe)

See Also

EntryPoint Members | LaMarvin.Constable.Design.Shell Namespace


EntryPoint Members

EntryPoint overview

Public Static (Shared) Methods

Main This is the entry point of the managed assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntryPoint Class | LaMarvin.Constable.Design.Shell Namespace


EntryPoint Methods

The methods of the EntryPoint class are listed below. For a complete list of EntryPoint class members, see the EntryPoint Members topic.

Public Static (Shared) Methods

Main This is the entry point of the managed assembly.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EntryPoint Class | LaMarvin.Constable.Design.Shell Namespace


EntryPoint.Main Method

This is the entry point of the managed assembly.

[Visual Basic]
Public Shared Sub Main( _
ByVal args As String() _
)
[C#]
public static void Main(
string[] args
);

Parameters

args
The command line arguments passed to the caze.exe executable.

Remarks

The caze.exe executable recognizes the following command line arguments:

/regserver | Passing the /regserver command line argument causes the caze.exe executable to re-register the .caze file association with the Windows shell. This can be used to repair the .caze file association if it is damaged after CAZE installation.
<file path> | Where <file path> is a full path to a XML file containing CAZE authorization policy, typically with the .caze extension.

See Also

EntryPoint Class | LaMarvin.Constable.Design.Shell Namespace


InstanceConnector Class

This class supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

For a list of all members of this type, see InstanceConnector Members.

System.Object
System.MarshalByRefObject
LaMarvin.Constable.Design.Shell.InstanceConnector

[Visual Basic]
NotInheritable Public Class InstanceConnector
Inherits MarshalByRefObject
[C#]
public sealed class InstanceConnector : MarshalByRefObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Shell

Assembly: caze (in caze.exe)

See Also

InstanceConnector Members | LaMarvin.Constable.Design.Shell Namespace


InstanceConnector Members

InstanceConnector overview

Public Instance Constructors

InstanceConnector Constructor Initializes a new instance of the InstanceConnector class.

Public Instance Methods

Activate | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InstanceConnector Class | LaMarvin.Constable.Design.Shell Namespace


InstanceConnector Constructor

Initializes a new instance of the InstanceConnector class.

[Visual Basic]
Public Sub New()
[C#]
public InstanceConnector();

See Also

InstanceConnector Class | LaMarvin.Constable.Design.Shell Namespace


InstanceConnector Methods

The methods of the InstanceConnector class are listed below. For a complete list of InstanceConnector class members, see the InstanceConnector Members topic.

Public Instance Methods

Activate | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InstanceConnector Class | LaMarvin.Constable.Design.Shell Namespace


InstanceConnector.Activate Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Sub Activate( _
ByVal args As String() _
)
[C#]
public void Activate(
string[] args
);

See Also

InstanceConnector Class | LaMarvin.Constable.Design.Shell Namespace


LaMarvin.Constable.Design.TypeInfos

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.TypeInfos Namespace

[This is preliminary documentation and subject to change.]

Contains type information classes for the types exposed by the CAZE Design Environment.

Namespace hierarchy

Classes

Class | Description
ActionCollectionTypeInfo | [TBD]
ActionRuleCollectionTypeInfo | [TBD]
ActionRuleTypeInfo | [TBD]
ActionTypeInfo | [TBD]
AppDomainTypeInfo | [TBD]
AssemblyTypeInfo | [TBD]
CollectionBaseTypeInfo | [TBD]
ExceptionTypeInfo | [TBD]
FallbackActionRuleTypeInfo | [TBD]
FallbackActionTypeInfo | [TBD]
FallbackPolicyTypeInfo | [TBD]
FallbackPropertyRuleTypeInfo | [TBD]
FallbackPropertyTypeInfo | [TBD]
FallbackRoleTypeInfo | [TBD]
FallbackStateTypeInfo | [TBD]
PolicySimulationViewAdapterTypeInfo | [TBD]
PolicyTypeInfo | [TBD]
PropertyCollectionTypeInfo | [TBD]
PropertyRuleCollectionTypeInfo | [TBD]
PropertyRuleTypeInfo | [TBD]
PropertyTypeInfo | [TBD]
RoleCollectionTypeInfo | [TBD]
RoleTypeInfo | [TBD]
StateCollectionTypeInfo | [TBD]
StateTypeInfo | [TBD]


ActionCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see ActionCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionCollectionTypeInfo

[Visual Basic]
Public Class ActionCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class ActionCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


ActionCollectionTypeInfo Members

ActionCollectionTypeInfo overview

Public Instance Constructors

ActionCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActionCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public ActionCollectionTypeInfo();

See Also

ActionCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see ActionRuleCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionRuleCollectionTypeInfo

[Visual Basic]
Public Class ActionRuleCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class ActionRuleCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionRuleCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleCollectionTypeInfo Members

ActionRuleCollectionTypeInfo overview

Public Instance Constructors

ActionRuleCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActionRuleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public ActionRuleCollectionTypeInfo();

See Also

ActionRuleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleTypeInfo Class

[TBD]

For a list of all members of this type, see ActionRuleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionRuleTypeInfo

[Visual Basic]
Public Class ActionRuleTypeInfo
Inherits TypeInfo
[C#]
public class ActionRuleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionRuleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleTypeInfo Members

ActionRuleTypeInfo overview

Public Instance Constructors

ActionRuleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActionRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionRuleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public ActionRuleTypeInfo();

See Also

ActionRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionTypeInfo Class

[TBD]

For a list of all members of this type, see ActionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionTypeInfo

[Visual Basic]
Public Class ActionTypeInfo
Inherits TypeInfo
[C#]
public class ActionTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ActionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


ActionTypeInfo Members

ActionTypeInfo overview

Public Instance Constructors

ActionTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ActionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public ActionTypeInfo();

See Also

ActionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


AppDomainTypeInfo Class

[TBD]

For a list of all members of this type, see AppDomainTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.AppDomainTypeInfo

[Visual Basic]
Public Class AppDomainTypeInfo
Inherits TypeInfo
[C#]
public class AppDomainTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

AppDomainTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


AppDomainTypeInfo Members

AppDomainTypeInfo overview

Public Instance Constructors

AppDomainTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppDomainTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


AppDomainTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public AppDomainTypeInfo();

See Also

AppDomainTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


AssemblyTypeInfo Class

[TBD]

For a list of all members of this type, see AssemblyTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.AssemblyTypeInfo

[Visual Basic]
Public Class AssemblyTypeInfo
Inherits TypeInfo
[C#]
public class AssemblyTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

AssemblyTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


AssemblyTypeInfo Members

AssemblyTypeInfo overview

Public Instance Constructors

AssemblyTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


AssemblyTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public AssemblyTypeInfo();

See Also

AssemblyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


CollectionBaseTypeInfo Class

[TBD]

For a list of all members of this type, see CollectionBaseTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
Derived types

[Visual Basic]
MustInherit Public Class CollectionBaseTypeInfo
Inherits TypeInfo
[C#]
public abstract class CollectionBaseTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

CollectionBaseTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


CollectionBaseTypeInfo Members

CollectionBaseTypeInfo overview

Public Instance Properties

ItemType | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Constructors

CollectionBaseTypeInfo Constructor [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollectionBaseTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


CollectionBaseTypeInfo Constructor

[TBD]

[Visual Basic]
Protected Sub New( _
ByVal collectionType As Type, _
ByVal itemType As Type, _
ByVal vi As VisualInfo _
)
[C#]
protected CollectionBaseTypeInfo(
Type collectionType,
Type itemType,
VisualInfo vi
);

See Also

CollectionBaseTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


CollectionBaseTypeInfo Properties

The properties of the CollectionBaseTypeInfo class are listed below. For a complete list of CollectionBaseTypeInfo class members, see the CollectionBaseTypeInfo Members topic.

Public Instance Properties

ItemType | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

See Also

CollectionBaseTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


CollectionBaseTypeInfo.ItemType Property

[TBD]

[Visual Basic]
Public ReadOnly Property ItemType As Type
[C#]
public System.Type ItemType {get;}

See Also

CollectionBaseTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ExceptionTypeInfo Class

[TBD]

For a list of all members of this type, see ExceptionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.ExceptionTypeInfo

[Visual Basic]
Public Class ExceptionTypeInfo
Inherits TypeInfo
[C#]
public class ExceptionTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

ExceptionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


ExceptionTypeInfo Members

ExceptionTypeInfo overview

Public Instance Constructors

ExceptionTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExceptionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


ExceptionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public ExceptionTypeInfo();

See Also

ExceptionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionRuleTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackActionRuleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackActionRuleTypeInfo

[Visual Basic]
Public Class FallbackActionRuleTypeInfo
Inherits TypeInfo
[C#]
public class FallbackActionRuleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackActionRuleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionRuleTypeInfo Members

FallbackActionRuleTypeInfo overview

Public Instance Constructors

FallbackActionRuleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackActionRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionRuleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackActionRuleTypeInfo();

See Also

FallbackActionRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackActionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackActionTypeInfo

[Visual Basic]
Public Class FallbackActionTypeInfo
Inherits TypeInfo
[C#]
public class FallbackActionTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackActionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionTypeInfo Members

FallbackActionTypeInfo overview

Public Instance Constructors

FallbackActionTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackActionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackActionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackActionTypeInfo();

See Also

FallbackActionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPolicyTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackPolicyTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPolicyTypeInfo

[Visual Basic]
Public Class FallbackPolicyTypeInfo
Inherits TypeInfo
[C#]
public class FallbackPolicyTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPolicyTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPolicyTypeInfo Members

FallbackPolicyTypeInfo overview

Public Instance Constructors

FallbackPolicyTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackPolicyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPolicyTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackPolicyTypeInfo();

See Also

FallbackPolicyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyRuleTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackPropertyRuleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPropertyRuleTypeInfo

[Visual Basic]
Public Class FallbackPropertyRuleTypeInfo
Inherits TypeInfo
[C#]
public class FallbackPropertyRuleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPropertyRuleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyRuleTypeInfo Members

FallbackPropertyRuleTypeInfo overview

Public Instance Constructors

FallbackPropertyRuleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackPropertyRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyRuleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackPropertyRuleTypeInfo();

See Also

FallbackPropertyRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackPropertyTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPropertyTypeInfo

[Visual Basic]
Public Class FallbackPropertyTypeInfo
Inherits TypeInfo
[C#]
public class FallbackPropertyTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackPropertyTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyTypeInfo Members

FallbackPropertyTypeInfo overview

Public Instance Constructors

FallbackPropertyTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackPropertyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackPropertyTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackPropertyTypeInfo();

See Also

FallbackPropertyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackRoleTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackRoleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackRoleTypeInfo

[Visual Basic]
Public Class FallbackRoleTypeInfo
Inherits TypeInfo
[C#]
public class FallbackRoleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackRoleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackRoleTypeInfo Members

FallbackRoleTypeInfo overview

Public Instance Constructors

FallbackRoleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackRoleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackRoleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackRoleTypeInfo();

See Also

FallbackRoleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackStateTypeInfo Class

[TBD]

For a list of all members of this type, see FallbackStateTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackStateTypeInfo

[Visual Basic]
Public Class FallbackStateTypeInfo
Inherits TypeInfo
[C#]
public class FallbackStateTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

FallbackStateTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackStateTypeInfo Members

FallbackStateTypeInfo overview

Public Instance Constructors

FallbackStateTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FallbackStateTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


FallbackStateTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public FallbackStateTypeInfo();

See Also

FallbackStateTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PolicySimulationViewAdapterTypeInfo Class

[TBD]

For a list of all members of this type, see PolicySimulationViewAdapterTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.PolicySimulationViewAdapterTypeInfo

[Visual Basic]
Public Class PolicySimulationViewAdapterTypeInfo
Inherits TypeInfo
[C#]
public class PolicySimulationViewAdapterTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicySimulationViewAdapterTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PolicySimulationViewAdapterTypeInfo Members

PolicySimulationViewAdapterTypeInfo overview

Public Instance Constructors

PolicySimulationViewAdapterTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolicySimulationViewAdapterTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PolicySimulationViewAdapterTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicySimulationViewAdapterTypeInfo();

See Also

PolicySimulationViewAdapterTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PolicyTypeInfo Class

[TBD]

For a list of all members of this type, see PolicyTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.PolicyTypeInfo

[Visual Basic]
Public Class PolicyTypeInfo
Inherits TypeInfo
[C#]
public class PolicyTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PolicyTypeInfo Members

PolicyTypeInfo overview

Public Instance Constructors

PolicyTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolicyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PolicyTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicyTypeInfo();

See Also

PolicyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see PropertyCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyCollectionTypeInfo

[Visual Basic]
Public Class PropertyCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class PropertyCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyCollectionTypeInfo Members

PropertyCollectionTypeInfo overview

Public Instance Constructors

PropertyCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PropertyCollectionTypeInfo();

See Also

PropertyCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see PropertyRuleCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyRuleCollectionTypeInfo

[Visual Basic]
Public Class PropertyRuleCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class PropertyRuleCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyRuleCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleCollectionTypeInfo Members

PropertyRuleCollectionTypeInfo overview

Public Instance Constructors

PropertyRuleCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyRuleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PropertyRuleCollectionTypeInfo();

See Also

PropertyRuleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleTypeInfo Class

[TBD]

For a list of all members of this type, see PropertyRuleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyRuleTypeInfo

[Visual Basic]
Public Class PropertyRuleTypeInfo
Inherits TypeInfo
[C#]
public class PropertyRuleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyRuleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleTypeInfo Members

PropertyRuleTypeInfo overview

Public Instance Constructors

PropertyRuleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyRuleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PropertyRuleTypeInfo();

See Also

PropertyRuleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyTypeInfo Class

[TBD]

For a list of all members of this type, see PropertyTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyTypeInfo

[Visual Basic]
Public Class PropertyTypeInfo
Inherits TypeInfo
[C#]
public class PropertyTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PropertyTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyTypeInfo Members

PropertyTypeInfo overview

Public Instance Constructors

PropertyTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


PropertyTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PropertyTypeInfo();

See Also

PropertyTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


RoleCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see RoleCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.RoleCollectionTypeInfo

[Visual Basic]
Public Class RoleCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class RoleCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RoleCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


RoleCollectionTypeInfo Members

RoleCollectionTypeInfo overview

Public Instance Constructors

RoleCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RoleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


RoleCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public RoleCollectionTypeInfo();

See Also

RoleCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


RoleTypeInfo Class

[TBD]

For a list of all members of this type, see RoleTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.RoleTypeInfo

[Visual Basic]
Public Class RoleTypeInfo
Inherits TypeInfo
[C#]
public class RoleTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

RoleTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


RoleTypeInfo Members

RoleTypeInfo overview

Public Instance Constructors

RoleTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RoleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


RoleTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public RoleTypeInfo();

See Also

RoleTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


StateCollectionTypeInfo Class

[TBD]

For a list of all members of this type, see StateCollectionTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.StateCollectionTypeInfo

[Visual Basic]
Public Class StateCollectionTypeInfo
Inherits CollectionBaseTypeInfo
[C#]
public class StateCollectionTypeInfo : CollectionBaseTypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

StateCollectionTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


StateCollectionTypeInfo Members

StateCollectionTypeInfo overview

Public Instance Constructors

StateCollectionTypeInfo Constructor [TBD]

Public Instance Properties

ItemType (inherited from CollectionBaseTypeInfo) | [TBD]
Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StateCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


StateCollectionTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public StateCollectionTypeInfo();

See Also

StateCollectionTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


StateTypeInfo Class

[TBD]

For a list of all members of this type, see StateTypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.StateTypeInfo

[Visual Basic]
Public Class StateTypeInfo
Inherits TypeInfo
[C#]
public class StateTypeInfo : TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.TypeInfos

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

StateTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


StateTypeInfo Members

StateTypeInfo overview

Public Instance Constructors

StateTypeInfo Constructor [TBD]

Public Instance Properties

Type (inherited from TypeInfo) | Gets the type this object is associated with..
VisualInfo (inherited from TypeInfo) | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from TypeInfo) | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StateTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


StateTypeInfo Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public StateTypeInfo();

See Also

StateTypeInfo Class | LaMarvin.Constable.Design.TypeInfos Namespace


LaMarvin.Constable.Design.Views

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Views Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting implementation of various authorization policy display strategies called policy view adapters (represented by the PolicyViewAdapter class) and policy simulation views (represented by the IPolicySimulationView interface and the PolicySimulationViewAdapter class).

Namespace hierarchy

Classes

Class | Description
DefaultPolicyViewAdapter | [TBD]
GroupByActionPolicyViewAdapter | [TBD]
GroupByRolePolicyViewAdapter | [TBD]
GroupByRoleThenStatePolicyViewAdapter | [TBD]
GroupByStatePolicyViewAdapter | [TBD]
PolicySimulationViewAdapter | [TBD]
PolicyViewAdapter | Defines a base class for adapting AuthorizationPolicy instances to provide customized views displayed in the InstanceView control.

Enumerations

Enumeration | Description
AuthorizationRuleType | [TBD]


AuthorizationRuleType Enumeration

[TBD]

[Visual Basic]
Public Enum AuthorizationRuleType
[C#]
public enum AuthorizationRuleType

Members

Member Name | Description
Both | [TBD]
ActionRules | [TBD]
PropertyRules | [TBD]

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter Class

[TBD]

For a list of all members of this type, see DefaultPolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.DefaultPolicyViewAdapter

[Visual Basic]
Public Class DefaultPolicyViewAdapter
Inherits PolicyViewAdapter
[C#]
public class DefaultPolicyViewAdapter : PolicyViewAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

DefaultPolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter Members

DefaultPolicyViewAdapter overview

Public Instance Constructors

DefaultPolicyViewAdapter Constructor Initializes a new instance of the DefaultPolicyViewAdapter class.

Public Instance Properties

ActionRules | [TBD]
Actions | [TBD]
ObservedCollectionChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.
Properties | [TBD]
PropertyRules | [TBD]
Roles | [TBD]
States | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter Constructor

Initializes a new instance of the DefaultPolicyViewAdapter class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultPolicyViewAdapter();

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter Properties

The properties of the DefaultPolicyViewAdapter class are listed below. For a complete list of DefaultPolicyViewAdapter class members, see the DefaultPolicyViewAdapter Members topic.

Public Instance Properties

ActionRules | [TBD]
Actions | [TBD]
ObservedCollectionChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.
Properties | [TBD]
PropertyRules | [TBD]
Roles | [TBD]
States | [TBD]

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.ActionRules Property

[TBD]

[Visual Basic]
Public ReadOnly Property ActionRules As ActionRuleCollection
[C#]
public LaMarvin.Constable.Model.ActionRuleCollection ActionRules {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.Actions Property

[TBD]

[Visual Basic]
Public ReadOnly Property Actions As ActionCollection
[C#]
public LaMarvin.Constable.Model.ActionCollection Actions {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.Properties Property

[TBD]

[Visual Basic]
Public ReadOnly Property Properties As PropertyCollection
[C#]
public LaMarvin.Constable.Model.PropertyCollection Properties {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.PropertyRules Property

[TBD]

[Visual Basic]
Public ReadOnly Property PropertyRules As PropertyRuleCollection
[C#]
public LaMarvin.Constable.Model.PropertyRuleCollection PropertyRules {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.Roles Property

[TBD]

[Visual Basic]
Public ReadOnly Property Roles As RoleCollection
[C#]
public LaMarvin.Constable.Model.RoleCollection Roles {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.States Property

[TBD]

[Visual Basic]
Public ReadOnly Property States As StateCollection
[C#]
public LaMarvin.Constable.Model.StateCollection States {get;}

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter Methods

The methods of the DefaultPolicyViewAdapter class are listed below. For a complete list of DefaultPolicyViewAdapter class members, see the DefaultPolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


DefaultPolicyViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

DefaultPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter Class

[TBD]

For a list of all members of this type, see GroupByActionPolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.GroupByActionPolicyViewAdapter

[Visual Basic]
Public Class GroupByActionPolicyViewAdapter
Inherits PolicyViewAdapter
Implements IEnumerable
[C#]
public class GroupByActionPolicyViewAdapter : PolicyViewAdapter, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

GroupByActionPolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter Members

GroupByActionPolicyViewAdapter overview

Public Instance Constructors

GroupByActionPolicyViewAdapter Constructor Initializes a new instance of the GroupByActionPolicyViewAdapter class.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter Constructor

Initializes a new instance of the GroupByActionPolicyViewAdapter class.

[Visual Basic]
Public Sub New()
[C#]
public GroupByActionPolicyViewAdapter();

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter Properties

The properties of the GroupByActionPolicyViewAdapter class are listed below. For a complete list of GroupByActionPolicyViewAdapter class members, see the GroupByActionPolicyViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter.ObservedCollectionChangeSenders Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ObservedCollectionChangeSenders As Object() _
Implements IChangeEventObserver.ObservedCollectionChangeSenders
[C#]
public override object[] ObservedCollectionChangeSenders {get;}

Implements

IChangeEventObserver.ObservedCollectionChangeSenders

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter Methods

The methods of the GroupByActionPolicyViewAdapter class are listed below. For a complete list of GroupByActionPolicyViewAdapter class members, see the GroupByActionPolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter.GetEnumerator Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter.RefreshAdapterCache Method

[TBD]

[Visual Basic]
Overrides Protected Sub RefreshAdapterCache()
[C#]
protected override void RefreshAdapterCache();

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByActionPolicyViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

GroupByActionPolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter Class

[TBD]

For a list of all members of this type, see GroupByRolePolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.GroupByRolePolicyViewAdapter

[Visual Basic]
Public Class GroupByRolePolicyViewAdapter
Inherits PolicyViewAdapter
Implements IEnumerable
[C#]
public class GroupByRolePolicyViewAdapter : PolicyViewAdapter, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

GroupByRolePolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter Members

GroupByRolePolicyViewAdapter overview

Public Instance Constructors

GroupByRolePolicyViewAdapter Constructor Initializes a new instance of the GroupByRolePolicyViewAdapter class.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter Constructor

Initializes a new instance of the GroupByRolePolicyViewAdapter class.

[Visual Basic]
Public Sub New()
[C#]
public GroupByRolePolicyViewAdapter();

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter Properties

The properties of the GroupByRolePolicyViewAdapter class are listed below. For a complete list of GroupByRolePolicyViewAdapter class members, see the GroupByRolePolicyViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter.ObservedCollectionChangeSenders Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ObservedCollectionChangeSenders As Object() _
Implements IChangeEventObserver.ObservedCollectionChangeSenders
[C#]
public override object[] ObservedCollectionChangeSenders {get;}

Implements

IChangeEventObserver.ObservedCollectionChangeSenders

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter Methods

The methods of the GroupByRolePolicyViewAdapter class are listed below. For a complete list of GroupByRolePolicyViewAdapter class members, see the GroupByRolePolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter.GetEnumerator Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRolePolicyViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

GroupByRolePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter Class

[TBD]

For a list of all members of this type, see GroupByRoleThenStatePolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.GroupByRoleThenStatePolicyViewAdapter

[Visual Basic]
Public Class GroupByRoleThenStatePolicyViewAdapter
Inherits PolicyViewAdapter
Implements IEnumerable
[C#]
public class GroupByRoleThenStatePolicyViewAdapter : PolicyViewAdapter, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

GroupByRoleThenStatePolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter Members

GroupByRoleThenStatePolicyViewAdapter overview

Public Instance Constructors

GroupByRoleThenStatePolicyViewAdapter Constructor Initializes a new instance of the GroupByRoleThenStatePolicyViewAdapter class.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter Constructor

Initializes a new instance of the GroupByRoleThenStatePolicyViewAdapter class.

[Visual Basic]
Public Sub New()
[C#]
public GroupByRoleThenStatePolicyViewAdapter();

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter Properties

The properties of the GroupByRoleThenStatePolicyViewAdapter class are listed below. For a complete list of GroupByRoleThenStatePolicyViewAdapter class members, see the GroupByRoleThenStatePolicyViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter.ObservedCollectionChangeSenders Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ObservedCollectionChangeSenders As Object() _
Implements IChangeEventObserver.ObservedCollectionChangeSenders
[C#]
public override object[] ObservedCollectionChangeSenders {get;}

Implements

IChangeEventObserver.ObservedCollectionChangeSenders

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter Methods

The methods of the GroupByRoleThenStatePolicyViewAdapter class are listed below. For a complete list of GroupByRoleThenStatePolicyViewAdapter class members, see the GroupByRoleThenStatePolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache (inherited from PolicyViewAdapter) | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter.GetEnumerator Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByRoleThenStatePolicyViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

GroupByRoleThenStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter Class

[TBD]

For a list of all members of this type, see GroupByStatePolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.GroupByStatePolicyViewAdapter

[Visual Basic]
Public Class GroupByStatePolicyViewAdapter
Inherits PolicyViewAdapter
Implements IEnumerable
[C#]
public class GroupByStatePolicyViewAdapter : PolicyViewAdapter, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

GroupByStatePolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter Members

GroupByStatePolicyViewAdapter overview

Public Instance Constructors

GroupByStatePolicyViewAdapter Constructor Initializes a new instance of the GroupByStatePolicyViewAdapter class.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.
ShowOnlyStatesWithRules | [TBD]
ShowRuleTypes | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter Constructor

Initializes a new instance of the GroupByStatePolicyViewAdapter class.

[Visual Basic]
Public Sub New()
[C#]
public GroupByStatePolicyViewAdapter();

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter Properties

The properties of the GroupByStatePolicyViewAdapter class are listed below. For a complete list of GroupByStatePolicyViewAdapter class members, see the GroupByStatePolicyViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | [TBD]
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy (inherited from PolicyViewAdapter) | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.
ShowOnlyStatesWithRules | [TBD]
ShowRuleTypes | [TBD]

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.ObservedCollectionChangeSenders Property

[TBD]

[Visual Basic]
Overrides Public ReadOnly Property ObservedCollectionChangeSenders As Object() _
Implements IChangeEventObserver.ObservedCollectionChangeSenders
[C#]
public override object[] ObservedCollectionChangeSenders {get;}

Implements

IChangeEventObserver.ObservedCollectionChangeSenders

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.ShowOnlyStatesWithRules Property

[TBD]

[Visual Basic]
Public Property ShowOnlyStatesWithRules As Boolean
[C#]
public bool ShowOnlyStatesWithRules {get; set;}

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.ShowRuleTypes Property

[TBD]

[Visual Basic]
Public Property ShowRuleTypes As AuthorizationRuleType
[C#]
public AuthorizationRuleType ShowRuleTypes {get; set;}

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter Methods

The methods of the GroupByStatePolicyViewAdapter class are listed below. For a complete list of GroupByStatePolicyViewAdapter class members, see the GroupByStatePolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.GetEnumerator Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.RefreshAdapterCache Method

[TBD]

[Visual Basic]
Overrides Protected Sub RefreshAdapterCache()
[C#]
protected override void RefreshAdapterCache();

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


GroupByStatePolicyViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

GroupByStatePolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter Class

[TBD]

For a list of all members of this type, see PolicySimulationViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
LaMarvin.Constable.Design.Views.PolicySimulationViewAdapter

[Visual Basic]
Public Class PolicySimulationViewAdapter
Inherits PolicyViewAdapter
Implements IEnumerable
[C#]
public class PolicySimulationViewAdapter : PolicyViewAdapter, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicySimulationViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter Members

PolicySimulationViewAdapter overview

Public Instance Constructors

PolicySimulationViewAdapter Constructor [TBD]

Public Instance Properties

ObservedCollectionChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy | [TBD]

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Public Instance Events

InstanceChanged (inherited from PolicyViewAdapter) | Occurs when the attached Policy has been changed.
InstanceChanging (inherited from PolicyViewAdapter) | Occurs when the attached Policy is about to be changed.
RefreshAllViews (inherited from PolicyViewAdapter) | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter Constructor

[TBD]

[Visual Basic]
Public Sub New()
[C#]
public PolicySimulationViewAdapter();

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter Properties

The properties of the PolicySimulationViewAdapter class are listed below. For a complete list of PolicySimulationViewAdapter class members, see the PolicySimulationViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders (inherited from PolicyViewAdapter) | Implements the ObservedPropertyChangeSenders property.
Policy | [TBD]

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter.Policy Property

[TBD]

[Visual Basic]
Overrides Public Property Policy As AuthorizationPolicy
[C#]
public override LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter Methods

The methods of the PolicySimulationViewAdapter class are listed below. For a complete list of PolicySimulationViewAdapter class members, see the PolicySimulationViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | [TBD]
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | [TBD]

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews (inherited from PolicyViewAdapter) | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | [TBD]

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter.GetEnumerator Method

[TBD]

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter.RefreshAdapterCache Method

[TBD]

[Visual Basic]
Overrides Protected Sub RefreshAdapterCache()
[C#]
protected override void RefreshAdapterCache();

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicySimulationViewAdapter.ToString Method

[TBD]

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

PolicySimulationViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Class

Defines a base class for adapting AuthorizationPolicy instances to provide customized views displayed in the InstanceView control.

For a list of all members of this type, see PolicyViewAdapter Members.

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter
Derived types

[Visual Basic]
MustInherit Public Class PolicyViewAdapter
Implements IChangeEventSource, IChangeEventObserver
[C#]
public abstract class PolicyViewAdapter : IChangeEventSource, IChangeEventObserver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The PolicyViewAdapter adapts AuthorizationPolicy instances and provides extensibility points to easily customize the policy appearance for the InstanceView control.

The PolicyViewAdapter maintains an AuthorizationPolicy reference (accessible through the Policy property) and it automatically handles the policy's change notification events originated by the Policy and forwards them by raising its own InstanceChanging and InstanceChanged events.

The PolicyViewAdapter also defines the RefreshAllViews event that the Design Environment uses for refreshing multiple views of the same policy (the MVC pattern).

Note The PolicyViewAdapter works in a cached mode meaning that the customized object graph is constructed once upon attaching a new AuthorizationPolicy instance to the adapter (using the Policy property). The object graph should be constructed inside the overriden RefreshAdapterCache method, which is called automatically whenever the associated Policy changes. The method can also be called manually by derived classes to force reconstruction of the adapted view.

Example

The following example implements a custom policy view that displays a flat list of authorization rules. It also implements the ShowPropertyRulesproperty allowing one to choose to view either action authorization rules only, or both, action and property rules:

[C#]
using System;
using System.Diagnostics;
using System.Collections;
using System.ComponentModel;

using LaMarvin.Design;
using LaMarvin.Constable.Design;
using LaMarvin.Constable.Design.Views;

/// <summary>
/// Custom PolicyViewAdapter that displays a flat list of authorization
/// rules. Optionally displays only action rules or both action and property rules.
/// </summary>
public class RulesPolicyViewAdapter : PolicyViewAdapter, IEnumerable
{
  private ArrayList _rules;   // cached list of rules
  private bool _showPropertyRules = true; // whether to show property rules also

  /// <summary>
  /// Returns enumerator over the cached set of rules or an empty enumerator if the
  /// adapter is not associated with a policy.
  /// </summary>
  /// <returns></returns>
  public IEnumerator GetEnumerator()
  {
    if (this._rules != null)
      return this._rules.GetEnumerator();

    return PolicyViewAdapter.EmptyEnumerator;
  }

  /// <summary>
  /// Sets or returns a flag indicating whether the view should show property
  /// rules along with action rules (true), or only action rules (false).
  /// </summary>
  [Category(PolicyViewAdapter.ViewPropertiesCategory)]
  [Description("Sets or returns a flag indicating whether the view should show property rules along with action rules (true), or only action rules (false).")]
  public bool ShowPropertyRules
  {
    get { return this._showPropertyRules; }
    set
    {
      if (this._showPropertyRules != value)
      {
        this._showPropertyRules = value;
        this.RefreshAdapterCache();
        this.OnRefreshAllViews(); // this facilitates refreshing the controls displaying this view
      }
    }
  }

  /// <summary>
  /// Repopulates the set of cached rules from the currently attached policy.
  /// </summary>
  protected override void RefreshAdapterCache()
  {
    this._rules = null;
    if (this.Policy == null)
      return;

    this._rules = new ArrayList(this.Policy.ActionRules);
    if (this._showPropertyRules)
      this._rules.AddRange(this.Policy.PropertyRules);
  }

}

Requirements

Namespace: LaMarvin.Constable.Design.Views

Assembly: LaMarvin.Constable.Design (in LaMarvin.Constable.Design.dll)

See Also

PolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Members

PolicyViewAdapter overview

Public Static (Shared) Fields

EmptyEnumerator | A shared, empty IEnumerator reference useful as a return value from GetEnumerator implementations without attached Policy.
ModelPropertiesCategory | The name of the category for PolicyViewAdapter properties pertaining logically to the attached Policy.
ViewPropertiesCategory | The name of the category for PolicyViewAdapter properties pertaining to the view adapter itself.

Public Instance Properties

ObservedCollectionChangeSenders | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders | Implements the ObservedPropertyChangeSenders property.
Policy | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

InstanceChanged | Occurs when the attached Policy has been changed.
InstanceChanging | Occurs when the attached Policy is about to be changed.
RefreshAllViews | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

Protected Instance Constructors

PolicyViewAdapter Constructor Initializes a new instance of the PolicyViewAdapter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Constructor

Initializes a new instance of the PolicyViewAdapter class.

[Visual Basic]
Protected Sub New()
[C#]
protected PolicyViewAdapter();

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Fields

The fields of the PolicyViewAdapter class are listed below. For a complete list of PolicyViewAdapter class members, see the PolicyViewAdapter Members topic.

Public Static (Shared) Fields

EmptyEnumerator | A shared, empty IEnumerator reference useful as a return value from GetEnumerator implementations without attached Policy.
ModelPropertiesCategory | The name of the category for PolicyViewAdapter properties pertaining logically to the attached Policy.
ViewPropertiesCategory | The name of the category for PolicyViewAdapter properties pertaining to the view adapter itself.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.EmptyEnumerator Field

A shared, empty IEnumerator reference useful as a return value from GetEnumerator implementations without attached Policy.

[Visual Basic]
Public Shared ReadOnly EmptyEnumerator As IEnumerator
[C#]
public static readonly IEnumerator EmptyEnumerator;

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.ModelPropertiesCategory Field

The name of the category for PolicyViewAdapter properties pertaining logically to the attached Policy.

[Visual Basic]
Public Const ModelPropertiesCategory As String = "Model"
[C#]
public const string ModelPropertiesCategory = "Model";

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.ViewPropertiesCategory Field

The name of the category for PolicyViewAdapter properties pertaining to the view adapter itself.

[Visual Basic]
Public Const ViewPropertiesCategory As String = "View"
[C#]
public const string ViewPropertiesCategory = "View";

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Properties

The properties of the PolicyViewAdapter class are listed below. For a complete list of PolicyViewAdapter class members, see the PolicyViewAdapter Members topic.

Public Instance Properties

ObservedCollectionChangeSenders | Implements the ObservedCollectionChangeSenders property.
ObservedPropertyChangeSenders | Implements the ObservedPropertyChangeSenders property.
Policy | Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.ObservedCollectionChangeSenders Property

Implements the ObservedCollectionChangeSenders property.

[Visual Basic]
Overridable Public ReadOnly Property ObservedCollectionChangeSenders As Object() _
Implements IChangeEventObserver.ObservedCollectionChangeSenders
[C#]
public virtual object[] ObservedCollectionChangeSenders {get;}

Implements

IChangeEventObserver.ObservedCollectionChangeSenders

Remarks

This implementation simply returns a null reference (Nothing in Visual Basic).

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.ObservedPropertyChangeSenders Property

Implements the ObservedPropertyChangeSenders property.

[Visual Basic]
Overridable Public ReadOnly Property ObservedPropertyChangeSenders As Object() _
Implements IChangeEventObserver.ObservedPropertyChangeSenders
[C#]
public virtual object[] ObservedPropertyChangeSenders {get;}

Implements

IChangeEventObserver.ObservedPropertyChangeSenders

Remarks

This implementation simply returns a null reference (Nothing in Visual Basic).

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.Policy Property

Sets or returns a reference to the AuthorizationPolicy currently associated with the view adapter.

[Visual Basic]
Overridable Public Property Policy As AuthorizationPolicy
[C#]
public virtual LaMarvin.Constable.AuthorizationPolicy Policy {get; set;}

Remarks

Note The implementation of the property setter automatically calls the RefreshAdapterCache method so your overriden implementation doesn't have to call it.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Methods

The methods of the PolicyViewAdapter class are listed below. For a complete list of PolicyViewAdapter class members, see the PolicyViewAdapter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnRefreshAllViews | Overloaded. Raises the RefreshAllViews event.
RefreshAdapterCache | Derived classes should recreate cached member variables from the currently associated Policy.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


OnRefreshAllViews Method

Constable Authorization Engine 2.0 BETA

PolicyViewAdapter.OnRefreshAllViews Method

[This is preliminary documentation and subject to change.]

Raises the RefreshAllViews event with Empty event arguments.

Overload List

Raises the RefreshAllViews event with Empty event arguments.

protected void OnRefreshAllViews();

Raises the RefreshAllViews event.

protected virtual void OnRefreshAllViews(EventArgs);

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.OnRefreshAllViews Method ()

Raises the RefreshAllViews event with Empty event arguments.

[Visual Basic]
Overloads Protected Sub OnRefreshAllViews()
[C#]
protected void OnRefreshAllViews();

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace | PolicyViewAdapter.OnRefreshAllViews Overload List


PolicyViewAdapter.OnRefreshAllViews Method (EventArgs)

Raises the RefreshAllViews event.

[Visual Basic]
Overridable Overloads Protected Sub OnRefreshAllViews( _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnRefreshAllViews(
EventArgs e
);

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace | PolicyViewAdapter.OnRefreshAllViews Overload List


PolicyViewAdapter.RefreshAdapterCache Method

Derived classes should recreate cached member variables from the currently associated Policy.

[Visual Basic]
Overridable Protected Sub RefreshAdapterCache()
[C#]
protected virtual void RefreshAdapterCache();

Remarks

CAUTION Your code must be prepared to gracefully handle cases when the attached Policy is a null reference (Nothing in Visual Basic).

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter Events

The events of the PolicyViewAdapter class are listed below. For a complete list of PolicyViewAdapter class members, see the PolicyViewAdapter Members topic.

Public Instance Events

InstanceChanged | Occurs when the attached Policy has been changed.
InstanceChanging | Occurs when the attached Policy is about to be changed.
RefreshAllViews | Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.InstanceChanged Event

Occurs when the attached Policy has been changed.

[Visual Basic]
Public Event InstanceChanged As ChangeEventHandler
[C#]
public event ChangeEventHandler InstanceChanged;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

Implements

IChangeEventSource.InstanceChanged

Remarks

The PolicyViewAdapter forwards the AuthorizationPolicy.InstanceChanged by raising this event.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.InstanceChanging Event

Occurs when the attached Policy is about to be changed.

[Visual Basic]
Public Event InstanceChanging As ChangeEventHandler
[C#]
public event ChangeEventHandler InstanceChanging;

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs property provides information specific to this event.

Property | Description
IgnoreNestedChanges | Gets or sets a flag indicating whether nested change notifications resulting from the current notification should be ignored by undo managers listening to change notifications on the given instance.

Implements

IChangeEventSource.InstanceChanging

Remarks

The PolicyViewAdapter forwards the AuthorizationPolicy.InstanceChanging by raising this event.

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


PolicyViewAdapter.RefreshAllViews Event

Occurs when the adapter cache changes indicating that all controls displaying this view should be refreshed.

[Visual Basic]
Public Event RefreshAllViews As EventHandler
[C#]
public event EventHandler RefreshAllViews;

See Also

PolicyViewAdapter Class | LaMarvin.Constable.Design.Views Namespace


LaMarvin.Constable.Model

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Model Namespace

[This is preliminary documentation and subject to change.]

Contains classes that comprise the definition of the authorization policy model defined by the authorization engine - Role, State, Action and Property classes and the associated ActionRule and PropertyRule classes.

There are also the corresponding collection classes and some specialized types defined, like the ComPlusRole and the WindowsRole classes.

Namespace hierarchy

Classes

Class | Description
Action | Defines an action that can be executed by the AuthorizationPolicy.
ActionCollection | Represents a collection Action objects.
ActionRule | Defines the association of an Action with a State and a Role. The association properties represent the result (TargetState) and the visibility (IsVisible) and accessibility (IsEnabled of the associated action.
ActionRuleCollection | Represents a collection of the ActionRule objects.
ComPlusRole | Provides a role implementation that represents a role in the COM+ catalog.
DynamicRole | Provides a role implementation whose membership can be controlled programmatically by setting the IsMemberResult property.
NamedObjectBase | This is the common base class for all the classes that form the definition of an authorization model.
NamedObjectCollectionBase | Provides a base class for all concrete collection classes for descendants of the NamedObjectBase class.
ObjectBase | This is the base class for all classes comprising the AuthorizationPolicy state-based authorization model.
ObjectCollectionBase | Represents a collection NamedObjectBase-derived objects.
Property | Defines an Property that is part of an AuthorizationPolicy.
PropertyCollection | Represents a collection of Property objects.
PropertyRule | Defines the association of a property with a state, set of Roles that can access the property and the accessibility flags: IsVisible and IsEnabled.
PropertyRuleCollection | Represents a collection of PropertyRule objects.
Role | Defines a role that can act on an instance of an AuthorizationPolicy class.
RoleCollection | Represents a collection of Role objects.
RuleBase | Provides a base class for derived classes representing associations (sometimes called tuples) of a given State, role, state-dependent object and the state-dependent object's attributes. The provided ActionRule and PropertyRule classes represent built-in rule objects.
RuleCollectionBase | Provides a base class for all concrete collection classes containing descendants of the RuleBase class.
State | Defines a state in the authorization model.
StateCollection | Represents a collection of State objects.
WindowsRole | Provides a role implementation that represents a windows security group.


Action Class

Defines an action that can be executed by the AuthorizationPolicy.

For a list of all members of this type, see Action Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Action
LaMarvin.Constable.Design.Fallback.FallbackAction

[Visual Basic]
<Serializable>
Public Class Action
Inherits NamedObjectBase
[C#]
[Serializable]
public class Action : NamedObjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

Action Members | LaMarvin.Constable.Model Namespace


Action Members

Action overview

Public Instance Constructors

Action Overloaded. Initializes a new instance of the Action class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the colllection that owns this Action object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute |
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

Action Class | LaMarvin.Constable.Model Namespace


Action Constructor

Initializes a new instance of the Action class with the given Id.

Overload List

Initializes a new instance of the Action class with the given Id.

public Action(string);

Initializes a new instance of the Action class with the given property values.

public Action(string,string);

Initializes a new instance of the Action class with the given property values.

public Action(string,string,string);

See Also

Action Class | LaMarvin.Constable.Model Namespace


Action Constructor (String)

Initializes a new instance of the Action class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public Action(
string id
);

Parameters

id
The Id of the object. Action IDs must be unique for all Action objects contained within a given ActionCollection instance.

See Also

Action Class | LaMarvin.Constable.Model Namespace | Action Constructor Overload List


Action Constructor (String, String)

Initializes a new instance of the Action class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
[C#]
public Action(
string id,
string name
);

Parameters

id
The Id of the object. Action IDs must be unique for all Action objects contained within a given ActionCollection instance.
name
The name of the Action.

See Also

Action Class | LaMarvin.Constable.Model Namespace | Action Constructor Overload List


Action Constructor (String, String, String)

Initializes a new instance of the Action class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal description As String _
)
[C#]
public Action(
string id,
string name,
string description
);

Parameters

id
The Id of the object. Action IDs must be unique for all Action objects contained within a given ActionCollection instance.
name
The name of the Action.
description
The description of the Action.

See Also

Action Class | LaMarvin.Constable.Model Namespace | Action Constructor Overload List


Action Properties

The properties of the Action class are listed below. For a complete list of Action class members, see the Action Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the colllection that owns this Action object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

Action Class | LaMarvin.Constable.Model Namespace


Action.Owner Property

Returns the colllection that owns this Action object.

[Visual Basic]
Public ReadOnly Property Owner As ActionCollection
[C#]
public ActionCollection Owner {get;}

Property Value

Reference to the ActionCollection that owns the current Action object.

See Also

Action Class | LaMarvin.Constable.Model Namespace


Action Methods

The methods of the Action class are listed below. For a complete list of Action class members, see the Action Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute |
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

Action Class | LaMarvin.Constable.Model Namespace


Action.OnExecute Method

[Visual Basic]
Overridable Protected Sub OnExecute( _
ByVal policy As AuthorizationPolicy, _
ByVal rule As ActionRule _
)
[C#]
protected virtual void OnExecute(
AuthorizationPolicy policy,
ActionRule rule
);

Parameters

policy
rule

See Also

Action Class | LaMarvin.Constable.Model Namespace


ActionCollection Class

Represents a collection Action objects.

For a list of all members of this type, see ActionCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.ActionCollection

[Visual Basic]
<Serializable>
Public Class ActionCollection
Inherits NamedObjectCollectionBase
[C#]
[Serializable]
public class ActionCollection : NamedObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ActionCollection Members | LaMarvin.Constable.Model Namespace


ActionCollection Members

ActionCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Retrieves the action based on the action Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds the action to the end of the collection.
AddNew | Creates an instance of the Action class and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Returns the index of the action.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a new action at the specified place in the collection.
Lookup | Find the action with the given Id.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes the action from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ActionCollection Constructor Initializes a new instance of the ActionCollection class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection Constructor

Initializes a new instance of the ActionCollection class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected ActionCollection(
ICollectionUpdater updater
);

Parameters

updater

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection Properties

The properties of the ActionCollection class are listed below. For a complete list of ActionCollection class members, see the ActionCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Retrieves the action based on the action Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


Item Property

Constable Authorization Engine 2.0 BETA

ActionCollection.Item Property

[This is preliminary documentation and subject to change.]

Retrieves the action based on the action's index in the collection.

Overload List

Retrieves the action based on the action's index in the collection.

public virtual Action this[int] {get;}

Retrieves the action based on the action Id.

public virtual Action this[string] {get;}

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.Item Property

Retrieves the action based on the action's index in the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Action
[C#]
public virtual Action this[
int index
] {get;}

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace | ActionCollection.Item Overload List


ActionCollection.Item Property

Retrieves the action based on the action Id.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal actionId As String _
) As Action
[C#]
public virtual Action this[
string actionId
] {get;}

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace | ActionCollection.Item Overload List


ActionCollection Methods

The methods of the ActionCollection class are listed below. For a complete list of ActionCollection class members, see the ActionCollection Members topic.

Public Instance Methods

Add | Adds the action to the end of the collection.
AddNew | Creates an instance of the Action class and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Returns the index of the action.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a new action at the specified place in the collection.
Lookup | Find the action with the given Id.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes the action from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.Add Method

Adds the action to the end of the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal action As Action _
) As Integer
[C#]
public virtual int Add(
Action action
);

Parameters

action
The action being added.

Return Value

The index of the newly added action.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.AddNew Method

Creates an instance of the Action class and adds it to the collection.

[Visual Basic]
Overridable Public Function AddNew( _
ByVal id As String _
) As Action
[C#]
public virtual Action AddNew(
string id
);

Parameters

id
The Id of the new action.

Return Value

Returns a reference to the newly added Action instance.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


IndexOf Method

Constable Authorization Engine 2.0 BETA

ActionCollection.IndexOf Method

[This is preliminary documentation and subject to change.]

Returns the index of the action.

Overload List

Returns the index of the action.

public virtual int IndexOf(Action);

Inherited from NamedObjectCollectionBase.

public int IndexOf(NamedObjectBase);

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.IndexOf Method (Action)

Returns the index of the action.

[Visual Basic]
Overridable Overloads Public Function IndexOf( _
ByVal action As Action _
) As Integer
[C#]
public virtual int IndexOf(
Action action
);

Parameters

action
The action reference.

Return Value

The index of the action within the collection or -1 if the action is not a member of the collection.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace | ActionCollection.IndexOf Overload List


ActionCollection.Insert Method

Inserts a new action at the specified place in the collection.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal action As Action _
)
[C#]
public virtual void Insert(
int index,
Action action
);

Parameters

index
The index where the new action should be placed.
action
The action being inserted.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.Lookup Method

Find the action with the given Id.

[Visual Basic]
Overridable Public Function Lookup( _
ByVal id As String _
) As Action
[C#]
public virtual Action Lookup(
string id
);

Parameters

id
The value of the Id property of the action to be found.

Return Value

A reference to the Action with the given . Returns a null reference (Nothing in Visual Basic) if no action with the given exists in the collection.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionCollection.Remove Method

Removes the action from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal action As Action _
)
[C#]
public virtual void Remove(
Action action
);

Parameters

action
The action to be removed.

See Also

ActionCollection Class | LaMarvin.Constable.Model Namespace


ActionRule Class

Defines the association of an Action with a State and a Role. The association properties represent the result (TargetState) and the visibility (IsVisible) and accessibility (IsEnabled of the associated action.

For a list of all members of this type, see ActionRule Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.ActionRule
LaMarvin.Constable.Design.Fallback.FallbackActionRule

[Visual Basic]
<Serializable>
Public Class ActionRule
Inherits RuleBase
[C#]
[Serializable]
public class ActionRule : RuleBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ActionRule Members | LaMarvin.Constable.Model Namespace


ActionRule Members

ActionRule overview

Public Instance Constructors

ActionRule Overloaded. Initializes a new instance of the ActionRule class.

Public Instance Properties

Action | Sets or returns the Action instance associated with this rule.
IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner | Returns the colllection that owns this ActionRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.
TargetState | Gets or sets the state that the Policy will be in after executing the associated Action.

Public Instance Methods

Copy | Creates a copy of the action.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the rule's properties.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute | Called by the AuthorizationPolicy as part of executing the action associated with this rule.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule Constructor

Initializes a new instance of the ActionRule class.

Overload List

Initializes a new instance of the ActionRule class.

public ActionRule(Action,Role,State,State);

Initializes a new instance of the ActionRule class.

public ActionRule(Action,Role,State,State,bool,bool);

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule Constructor (Action, Role, State, State, Boolean, Boolean)

Initializes a new instance of the ActionRule class.

[Visual Basic]
Overloads Public Sub New( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
)
[C#]
public ActionRule(
Action action,
Role role,
State state,
State targetState,
bool isVisible,
bool isEnabled
);

Parameters

action
The action reference.
role
The role associated with the given action and state.
state
The state with which the action is associated.
targetState
The state of the Policy as a result of executing the action.
isVisible
isEnabled
true if the action can be executed; false otherwise.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace | ActionRule Constructor Overload List


ActionRule Constructor (Action, Role, State, State)

Initializes a new instance of the ActionRule class.

[Visual Basic]
Overloads Public Sub New( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal targetState As State _
)
[C#]
public ActionRule(
Action action,
Role role,
State state,
State targetState
);

Parameters

action
The action reference.
role
The role associated with the given action and state.
state
The state with which the action is associated.
targetState
The state of the Policy as a result of executing the action.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace | ActionRule Constructor Overload List


ActionRule Properties

The properties of the ActionRule class are listed below. For a complete list of ActionRule class members, see the ActionRule Members topic.

Public Instance Properties

Action | Sets or returns the Action instance associated with this rule.
IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner | Returns the colllection that owns this ActionRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.
TargetState | Gets or sets the state that the Policy will be in after executing the associated Action.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.Action Property

Sets or returns the Action instance associated with this rule.

[Visual Basic]
Overridable Public Property Action As Action
[C#]
public virtual Action Action {get; set;}

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.Owner Property

Returns the colllection that owns this ActionRule instance.

[Visual Basic]
Public ReadOnly Property Owner As ActionRuleCollection
[C#]
public ActionRuleCollection Owner {get;}

Property Value

Reference to the ActionRuleCollection that owns the current ActionRule instance.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.TargetState Property

Gets or sets the state that the Policy will be in after executing the associated Action.

[Visual Basic]
Overridable Public Property TargetState As State
[C#]
public virtual State TargetState {get; set;}

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule Methods

The methods of the ActionRule class are listed below. For a complete list of ActionRule class members, see the ActionRule Members topic.

Public Instance Methods

Copy | Creates a copy of the action.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the rule's properties.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute | Called by the AuthorizationPolicy as part of executing the action associated with this rule.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.Copy Method

Creates a copy of the action.

[Visual Basic]
Overridable Public Function Copy( _
ByVal isEnabled As Boolean _
) As ActionRule
[C#]
public virtual ActionRule Copy(
bool isEnabled
);

Parameters

isEnabled
The initial value of the IsEnabled property of the new action.

Return Value

A reference to the newly created action.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.OnExecute Method

Called by the AuthorizationPolicy as part of executing the action associated with this rule.

[Visual Basic]
Overridable Protected Function OnExecute( _
ByVal policy As AuthorizationPolicy _
) As State
[C#]
protected virtual State OnExecute(
AuthorizationPolicy policy
);

Parameters

policy
The AuthorizationPolicy to which this rule belongs.

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRule.ToString Method

Returns a string representation of the rule's properties.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of the rule's properties.

Remarks

The string representation has the following form:

<Action>(<Role>) [<State> -> <TargetState>: IsVisible, IsEnabled]

See Also

ActionRule Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection Class

Represents a collection of the ActionRule objects.

For a list of all members of this type, see ActionRuleCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.RuleCollectionBase
LaMarvin.Constable.Model.ActionRuleCollection

[Visual Basic]
<Serializable>
Public Class ActionRuleCollection
Inherits RuleCollectionBase
[C#]
[Serializable]
public class ActionRuleCollection : RuleCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ActionRuleCollection Members | LaMarvin.Constable.Model Namespace


ActionRuleCollection Members

ActionRuleCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Returns the ActionRule object at the specified index in the collection.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds the rule to the collection.
AddNew | Overloaded. Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId, targetStateId, isVisible and isEnabled flags to the containing AuthorizationPolicy instance.
AddRange (inherited from RuleCollectionBase) | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines if the collection contains the specified rule.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the index of the specified rule in the collection.
Insert | Inserts the rule object at the specified index.
IsNewRuleValid (inherited from RuleCollectionBase) | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
Lookup | Overloaded. Returns an ActionRule object associated with the given Action, Role and State identified by their IDs.
Remove | Removes the specified rule from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ActionRuleCollection Constructor Initializes a new instance of the ActionRuleCollection class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

CreateEmptyClone | Creates a new, empty instance of the ActionRuleCollection.
EnsureNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Lookup | Overloaded. Returns all ActionRule objects associated with the given Action, Role, State and the required values of the IsVisible and IsEnabled flags.
LookupInternal (inherited from RuleCollectionBase) | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection Constructor

Initializes a new instance of the ActionRuleCollection class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected ActionRuleCollection(
ICollectionUpdater updater
);

Parameters

updater

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection Properties

The properties of the ActionRuleCollection class are listed below. For a complete list of ActionRuleCollection class members, see the ActionRuleCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Returns the ActionRule object at the specified index in the collection.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.Item Property

Returns the ActionRule object at the specified index in the collection.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As ActionRule
[C#]
public virtual ActionRule this[
int index
] {get;}

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection Methods

The methods of the ActionRuleCollection class are listed below. For a complete list of ActionRuleCollection class members, see the ActionRuleCollection Members topic.

Public Instance Methods

Add | Adds the rule to the collection.
AddNew | Overloaded. Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId, targetStateId, isVisible and isEnabled flags to the containing AuthorizationPolicy instance.
AddRange (inherited from RuleCollectionBase) | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines if the collection contains the specified rule.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the index of the specified rule in the collection.
Insert | Inserts the rule object at the specified index.
IsNewRuleValid (inherited from RuleCollectionBase) | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
Lookup | Overloaded. Returns an ActionRule object associated with the given Action, Role and State identified by their IDs.
Remove | Removes the specified rule from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateEmptyClone | Creates a new, empty instance of the ActionRuleCollection.
EnsureNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Lookup | Overloaded. Returns all ActionRule objects associated with the given Action, Role, State and the required values of the IsVisible and IsEnabled flags.
LookupInternal (inherited from RuleCollectionBase) | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.Add Method

Adds the rule to the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal rule As ActionRule _
) As Integer
[C#]
public virtual int Add(
ActionRule rule
);

Parameters

rule

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


AddNew Method

Constable Authorization Engine 2.0 BETA

ActionRuleCollection.AddNew Method

[This is preliminary documentation and subject to change.]

Creates and adds a new ActionRule object to the collection for the given actionId, roleId and the one state defined for the containing AuthorizationPolicy instance.

Overload List

Creates and adds a new ActionRule object to the collection for the given actionId, roleId and the one state defined for the containing AuthorizationPolicy instance.

public ActionRule AddNew(string,string);

Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId and targetStateId to the containing AuthorizationPolicy instance.

public virtual ActionRule AddNew(string,string,string,string);

Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId, targetStateId, isVisible and isEnabled flags to the containing AuthorizationPolicy instance.

public virtual ActionRule AddNew(string,string,string,string,bool,bool);

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.AddNew Method (String, String)

Creates and adds a new ActionRule object to the collection for the given actionId, roleId and the one state defined for the containing AuthorizationPolicy instance.

[Visual Basic]
Overloads Public Function AddNew( _
ByVal actionId As String, _
ByVal roleId As String _
) As ActionRule
[C#]
public ActionRule AddNew(
string actionId,
string roleId
);

Parameters

actionId
roleId

Return Value

Remarks

This overload is available only if the containing AuthorizationPolicy instance has exactly one state defined.

Exceptions

Exception Type | Condition
InvalidOperationException | The containing AuthorizationPolicy doesn't have exactly one state defined.

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.AddNew Overload List


ActionRuleCollection.AddNew Method (String, String, String, String)

Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId and targetStateId to the containing AuthorizationPolicy instance.

[Visual Basic]
Overridable Overloads Public Function AddNew( _
ByVal actionId As String, _
ByVal roleId As String, _
ByVal stateId As String, _
ByVal targetStateId As String _
) As ActionRule
[C#]
public virtual ActionRule AddNew(
string actionId,
string roleId,
string stateId,
string targetStateId
);

Parameters

actionId
roleId
stateId
targetStateId

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.AddNew Overload List


ActionRuleCollection.AddNew Method (String, String, String, String, Boolean, Boolean)

Creates and adds a new ActionRule object to the collection for the given actionId, roleId stateId, targetStateId, isVisible and isEnabled flags to the containing AuthorizationPolicy instance.

[Visual Basic]
Overridable Overloads Public Function AddNew( _
ByVal actionId As String, _
ByVal roleId As String, _
ByVal stateId As String, _
ByVal targetStateId As String, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
) As ActionRule
[C#]
public virtual ActionRule AddNew(
string actionId,
string roleId,
string stateId,
string targetStateId,
bool isVisible,
bool isEnabled
);

Parameters

actionId
roleId
stateId
targetStateId
isVisible
isEnabled

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.AddNew Overload List


ActionRuleCollection.Contains Method

Determines if the collection contains the specified rule.

[Visual Basic]
Overridable Public Function Contains( _
ByVal rule As ActionRule _
) As Boolean
[C#]
public virtual bool Contains(
ActionRule rule
);

Parameters

rule

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.CreateEmptyClone Method

Creates a new, empty instance of the ActionRuleCollection.

[Visual Basic]
Overrides Protected Function CreateEmptyClone( _
ByVal updater As ICollectionUpdater _
) As RuleCollectionBase
[C#]
protected override RuleCollectionBase CreateEmptyClone(
ICollectionUpdater updater
);

Parameters

updater

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.IndexOf Method

Returns the index of the specified rule in the collection.

[Visual Basic]
Overridable Public Function IndexOf( _
ByVal rule As ActionRule _
) As Integer
[C#]
public virtual int IndexOf(
ActionRule rule
);

Parameters

rule

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.Insert Method

Inserts the rule object at the specified index.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal rule As ActionRule _
)
[C#]
public virtual void Insert(
int index,
ActionRule rule
);

Parameters

index
rule

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


Lookup Method

Constable Authorization Engine 2.0 BETA

ActionRuleCollection.Lookup Method

[This is preliminary documentation and subject to change.]

Returns all ActionRule objects for the given Action.

Overload List

Returns all ActionRule objects for the given Action.

public virtual ActionRuleCollection Lookup(Action);

Returns an ActionRule object associated with the given Action, Role and State.

public ActionRule Lookup(Action,Role,State);

Returns all ActionRule objects associated with the given Action, Role, State and the required values of the IsVisible and IsEnabled flags.

protected virtual ActionRuleCollection Lookup(Action,Role,State,VisibleOption,EnabledOption);

Returns all ActionRule objects for the given Id.

public ActionRuleCollection Lookup(string);

Returns an ActionRule object associated with the given Action, Role and State identified by their IDs.

public virtual ActionRule Lookup(string,string,string);

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ActionRuleCollection.Lookup Method (Action)

Returns all ActionRule objects for the given Action.

[Visual Basic]
Overridable Overloads Public Function Lookup( _
ByVal action As Action _
) As ActionRuleCollection
[C#]
public virtual ActionRuleCollection Lookup(
Action action
);

Parameters

action

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.Lookup Overload List


ActionRuleCollection.Lookup Method (Action, Role, State)

Returns an ActionRule object associated with the given Action, Role and State.

[Visual Basic]
Overloads Public Function Lookup( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State _
) As ActionRule
[C#]
public ActionRule Lookup(
Action action,
Role role,
State state
);

Parameters

action
role
state

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.Lookup Overload List


ActionRuleCollection.Lookup Method (Action, Role, State, VisibleOption, EnabledOption)

Returns all ActionRule objects associated with the given Action, Role, State and the required values of the IsVisible and IsEnabled flags.

[Visual Basic]
Overridable Overloads Protected Function Lookup( _
ByVal action As Action, _
ByVal role As Role, _
ByVal state As State, _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As ActionRuleCollection
[C#]
protected virtual ActionRuleCollection Lookup(
Action action,
Role role,
State state,
VisibleOption visible,
EnabledOption enabled
);

Parameters

action
role
state
visible
enabled

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.Lookup Overload List


ActionRuleCollection.Lookup Method (String)

Returns all ActionRule objects for the given Id.

[Visual Basic]
Overloads Public Function Lookup( _
ByVal actionId As String _
) As ActionRuleCollection
[C#]
public ActionRuleCollection Lookup(
string actionId
);

Parameters

actionId

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.Lookup Overload List


ActionRuleCollection.Lookup Method (String, String, String)

Returns an ActionRule object associated with the given Action, Role and State identified by their IDs.

[Visual Basic]
Overridable Overloads Public Function Lookup( _
ByVal actionId As String, _
ByVal roleId As String, _
ByVal stateId As String _
) As ActionRule
[C#]
public virtual ActionRule Lookup(
string actionId,
string roleId,
string stateId
);

Parameters

actionId
roleId
stateId

Return Value

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace | ActionRuleCollection.Lookup Overload List


ActionRuleCollection.Remove Method

Removes the specified rule from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal rule As ActionRule _
)
[C#]
public virtual void Remove(
ActionRule rule
);

Parameters

rule

See Also

ActionRuleCollection Class | LaMarvin.Constable.Model Namespace


ComPlusRole Class

Provides a role implementation that represents a role in the COM+ catalog.

For a list of all members of this type, see ComPlusRole Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Model.ComPlusRole

[Visual Basic]
<Serializable>
Public Class ComPlusRole
Inherits Role
[C#]
[Serializable]
public class ComPlusRole : Role

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The implementation delegates to the System.EnterpriseServices.ContextUtil.IsCallerInRole method to check COM+ role membership.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ComPlusRole Members | LaMarvin.Constable.Model Namespace


ComPlusRole Members

ComPlusRole overview

Public Instance Constructors

ComPlusRole Overloaded. Initializes a new instance of the ComPlusRole class.

Public Instance Properties

ComPlusRoleName | Sets or returns the name of the COM+ role that represents membership to this role.
Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Doesn't check if the given principal is member of the role. Instead, calls the System.EnterpriseServices.ContextUtil.IsCallerInRole method passing it the ComPlusRoleName value and returns its return value.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


ComPlusRole Constructor

Initializes a new instance of the ComPlusRole class with the given Id.

Overload List

Initializes a new instance of the ComPlusRole class with the given Id.

public ComPlusRole(string);

Initializes a new instance of the ComPlusRole class with the given Id and a name of the associated COM+ role.

public ComPlusRole(string,string);

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


ComPlusRole Constructor (String)

Initializes a new instance of the ComPlusRole class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public ComPlusRole(
string id
);

Parameters

id
The Id of the object. Role IDs must be unique for all objects contained within a given RoleCollection instance.

Remarks

CAUTION The Name property value must correspond to a role name defined in the COM+ catalog.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace | ComPlusRole Constructor Overload List


ComPlusRole Constructor (String, String)

Initializes a new instance of the ComPlusRole class with the given Id and a name of the associated COM+ role.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal comPlusRoleName As String _
)
[C#]
public ComPlusRole(
string id,
string comPlusRoleName
);

Parameters

id
The Id of the object. Role IDs must be unique for all objects contained within a given RoleCollection instance.
comPlusRoleName
The name of the role as defined in the COM+ catalog.

Remarks

CAUTION If the comPlusRoleName doesn't exist in the COM+ catalog, the IsMember implementation will always return false.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace | ComPlusRole Constructor Overload List


ComPlusRole Properties

The properties of the ComPlusRole class are listed below. For a complete list of ComPlusRole class members, see the ComPlusRole Members topic.

Public Instance Properties

ComPlusRoleName | Sets or returns the name of the COM+ role that represents membership to this role.
Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


ComPlusRole.ComPlusRoleName Property

Sets or returns the name of the COM+ role that represents membership to this role.

[Visual Basic]
Overridable Public Property ComPlusRoleName As String
[C#]
public virtual string ComPlusRoleName {get; set;}

Remarks

If the role doesn't exist in the COM+ catalog, the IsMember method will return always false.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


ComPlusRole Methods

The methods of the ComPlusRole class are listed below. For a complete list of ComPlusRole class members, see the ComPlusRole Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Doesn't check if the given principal is member of the role. Instead, calls the System.EnterpriseServices.ContextUtil.IsCallerInRole method passing it the ComPlusRoleName value and returns its return value.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


ComPlusRole.IsMember Method

Doesn't check if the given principal is member of the role. Instead, calls the System.EnterpriseServices.ContextUtil.IsCallerInRole method passing it the ComPlusRoleName value and returns its return value.

[Visual Basic]
Overrides Public Function IsMember( _
ByVal principal As IPrincipal _
) As Boolean
[C#]
public override bool IsMember(
IPrincipal principal
);

Parameters

principal
The principal reference; not used for membership checks.

Return Value

Returns the value of the System.EnterpriseServices.ContextUtil.IsCallerInRole method call.

Remarks

See Also

ComPlusRole Class | LaMarvin.Constable.Model Namespace


DynamicRole Class

Provides a role implementation whose membership can be controlled programmatically by setting the IsMemberResult property.

For a list of all members of this type, see DynamicRole Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Model.DynamicRole

[Visual Basic]
<Serializable>
Public Class DynamicRole
Inherits Role
[C#]
[Serializable]
public class DynamicRole : Role

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

CAUTION The role is principal-agnostic in the sense that regardless of the principal passed to the IsMember method, the method always returns the IsMemberResult value. If the value is true, the DynamicRole instance behaves like 'everyone' role; any principal (even a null reference (Nothing in Visual Basic)) is member of the role.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

DynamicRole Members | LaMarvin.Constable.Model Namespace


DynamicRole Members

DynamicRole overview

Public Instance Constructors

DynamicRole Overloaded. Initializes a new instance of the DynamicRole class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
IsMemberResult | Sets or returns the value that will be returned by calling the IsMember method.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Doesn't chesk if the given principal is member of the role. Instead, returns the IsMemberResult property value.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


DynamicRole Constructor

Initializes a new instance of the DynamicRole class.

Overload List

Initializes a new instance of the DynamicRole class.

public DynamicRole();

Initializes a new instance of the DynamicRole class with the given Id.

public DynamicRole(string);

Initializes a new instance of the DynamicRole class with the given Id.

public DynamicRole(string,bool);

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


DynamicRole Constructor ()

Initializes a new instance of the DynamicRole class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DynamicRole();

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace | DynamicRole Constructor Overload List


DynamicRole Constructor (String)

Initializes a new instance of the DynamicRole class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public DynamicRole(
string id
);

Parameters

id
The Id of the object. Role IDs must be unique for all objects contained within a given RoleCollection instance.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace | DynamicRole Constructor Overload List


DynamicRole Constructor (String, Boolean)

Initializes a new instance of the DynamicRole class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal isMemberResult As Boolean _
)
[C#]
public DynamicRole(
string id,
bool isMemberResult
);

Parameters

id
The Id of the object. Role IDs must be unique for all objects contained within a given RoleCollection instance.
isMemberResult
The initial value for the IsMemberResult property.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace | DynamicRole Constructor Overload List


DynamicRole Properties

The properties of the DynamicRole class are listed below. For a complete list of DynamicRole class members, see the DynamicRole Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
IsMemberResult | Sets or returns the value that will be returned by calling the IsMember method.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


DynamicRole.IsMemberResult Property

Sets or returns the value that will be returned by calling the IsMember method.

[Visual Basic]
Public Property IsMemberResult As Boolean
[C#]
public bool IsMemberResult {get; set;}

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


DynamicRole Methods

The methods of the DynamicRole class are listed below. For a complete list of DynamicRole class members, see the DynamicRole Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Doesn't chesk if the given principal is member of the role. Instead, returns the IsMemberResult property value.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


DynamicRole.IsMember Method

Doesn't chesk if the given principal is member of the role. Instead, returns the IsMemberResult property value.

[Visual Basic]
Overrides Public Function IsMember( _
ByVal principal As IPrincipal _
) As Boolean
[C#]
public override bool IsMember(
IPrincipal principal
);

Parameters

principal
The principal reference is not used for membership checks. Instead, the IsMemberResult property value is always returned.

Return Value

Returns the value of the IsMemberResult property.

Remarks

CAUTION If the IsMemberResult property value is true, the method returns also true even if you pass a null reference (Nothing in Visual Basic) as the principal argument.

See Also

DynamicRole Class | LaMarvin.Constable.Model Namespace


NamedObjectBase Class

This is the common base class for all the classes that form the definition of an authorization model.

For a list of all members of this type, see NamedObjectBase Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.AuthorizationPolicy
LaMarvin.Constable.Model.Action
LaMarvin.Constable.Model.Property
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Model.State

[Visual Basic]
<Serializable>
MustInherit Public Class NamedObjectBase
Inherits ObjectBase
Implements IComparable
[C#]
[Serializable]
public abstract class NamedObjectBase : ObjectBase, IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

NamedObjectBase Members | LaMarvin.Constable.Model Namespace


NamedObjectBase Members

NamedObjectBase overview

Public Instance Properties

Description | Sets or returns the description of the object.
Id | Sets or returns the unique Id of the object.
Name | Sets or returns the name of the object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the value of the Id property.

Protected Instance Constructors

NamedObjectBase Overloaded. Initializes a new instance of the NamedObjectBase class.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase Constructor

Creates a new instance of the class with the given Id, Name and Description.

Overload List

Creates a new instance of the class with the given Id.

protected NamedObjectBase(string);

Creates a new instance of the class with the given Id, Name and Description.

protected NamedObjectBase(string,string,string);

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase Constructor (String, String, String)

Creates a new instance of the class with the given Id, Name and Description.

[Visual Basic]
Overloads Protected Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal description As String _
)
[C#]
protected NamedObjectBase(
string id,
string name,
string description
);

Parameters

id
The Id of the new instance. The value must not be null and it must be unique within a collection containing the object.
name
The name of the new instance. If the value is , the id value is used.
description

Remarks

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace | NamedObjectBase Constructor Overload List


NamedObjectBase Constructor (String)

Creates a new instance of the class with the given Id.

[Visual Basic]
Overloads Protected Sub New( _
ByVal id As String _
)
[C#]
protected NamedObjectBase(
string id
);

Parameters

id
The Id of the new instance. It must not be null and it must be unique within a collection containing the object.

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace | NamedObjectBase Constructor Overload List


NamedObjectBase Properties

The properties of the NamedObjectBase class are listed below. For a complete list of NamedObjectBase class members, see the NamedObjectBase Members topic.

Public Instance Properties

Description | Sets or returns the description of the object.
Id | Sets or returns the unique Id of the object.
Name | Sets or returns the name of the object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase.Description Property

Sets or returns the description of the object.

[Visual Basic]
Overridable Public Property Description As String
[C#]
public virtual string Description {get; set;}

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase.Id Property

Sets or returns the unique Id of the object.

[Visual Basic]
Overridable Public Property Id As String
[C#]
public virtual string Id {get; set;}

Remarks

The object's Id must be unique for objects contained in a collection.

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase.Name Property

Sets or returns the name of the object.

[Visual Basic]
Overridable Public Property Name As String
[C#]
public virtual string Name {get; set;}

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase Methods

The methods of the NamedObjectBase class are listed below. For a complete list of NamedObjectBase class members, see the NamedObjectBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectBase.ToString Method

Returns the value of the Id property.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The value of the Id property.

Remarks

See Also

NamedObjectBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase Class

Provides a base class for all concrete collection classes for descendants of the NamedObjectBase class.

For a list of all members of this type, see NamedObjectCollectionBase Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.ActionCollection
LaMarvin.Constable.Model.PropertyCollection
LaMarvin.Constable.Model.RoleCollection
LaMarvin.Constable.Model.StateCollection

[Visual Basic]
<Serializable>
MustInherit Public Class NamedObjectCollectionBase
Inherits ObjectCollectionBase
[C#]
[Serializable]
public abstract class NamedObjectCollectionBase : ObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

NamedObjectCollectionBase Members | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase Members

NamedObjectCollectionBase overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines whether the object is in the collection.
ContainsId | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns an index of the in the collection.
IndexOfId | Returns an index of the object with the given .
LookupItemById | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex | Retrieves the object at the given index in the collection.
RemoveAt | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

NamedObjectCollectionBase Constructor Initializes a new instance of the ObjectCollectionBase class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById | Overloaded. Determines whether an object with the given Id is in the collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase Constructor

Initializes a new instance of the ObjectCollectionBase class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected NamedObjectCollectionBase(
ICollectionUpdater updater
);

Parameters

updater

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase Methods

The methods of the NamedObjectCollectionBase class are listed below. For a complete list of NamedObjectCollectionBase class members, see the NamedObjectCollectionBase Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines whether the object is in the collection.
ContainsId | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns an index of the in the collection.
IndexOfId | Returns an index of the object with the given .
LookupItemById | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex | Retrieves the object at the given index in the collection.
RemoveAt | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById | Overloaded. Determines whether an object with the given Id is in the collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.Contains Method

Determines whether the object is in the collection.

[Visual Basic]
Overridable Public Function Contains( _
ByVal obj As NamedObjectBase _
) As Boolean
[C#]
public virtual bool Contains(
NamedObjectBase obj
);

Parameters

obj
The object to locate in the collection.

Return Value

true is the obj is found in the collection; false otherwise.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.ContainsId Method

Determines whether the collection contains an object with the given Id.

[Visual Basic]
Overridable Public Function ContainsId( _
ByVal objectId As String _
) As Boolean
[C#]
public virtual bool ContainsId(
string objectId
);

Parameters

objectId
The Id of the object.

Return Value

true if the collection contains an object with the ; false otherwise.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.IndexOf Method

Returns an index of the in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal instance As NamedObjectBase _
) As Integer
[C#]
public int IndexOf(
NamedObjectBase instance
);

Parameters

instance
The object whose index we're looking for.

Return Value

The index of the if found; -1 otherwise.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.IndexOfId Method

Returns an index of the object with the given .

[Visual Basic]
Public Function IndexOfId( _
ByVal id As String _
) As Integer
[C#]
public int IndexOfId(
string id
);

Parameters

id
The id of the object whose index we're looking for.

Return Value

The index of the object with the given if found; -1 otherwise.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


LookupItemById Method

Constable Authorization Engine 2.0 BETA

NamedObjectCollectionBase.LookupItemById Method

[This is preliminary documentation and subject to change.]

Determines whether an object with the given Id is in the collection.

Overload List

Determines whether an object with the given Id is in the collection.

protected NamedObjectBase LookupItemById(string);

Searches the collections and returns an object with the given Id.

public virtual NamedObjectBase LookupItemById(string,bool);

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.LookupItemById Method (String)

Determines whether an object with the given Id is in the collection.

[Visual Basic]
Overloads Protected Function LookupItemById( _
ByVal id As String _
) As NamedObjectBase
[C#]
protected NamedObjectBase LookupItemById(
string id
);

Parameters

id
The Id of the object to locate in the collection.

Return Value

true is an object with the id is found in the collection; false otherwise.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace | NamedObjectCollectionBase.LookupItemById Overload List


NamedObjectCollectionBase.LookupItemById Method (String, Boolean)

Searches the collections and returns an object with the given Id.

[Visual Basic]
Overridable Overloads Public Function LookupItemById( _
ByVal id As String, _
ByVal throwIfNotFound As Boolean _
) As NamedObjectBase
[C#]
public virtual NamedObjectBase LookupItemById(
string id,
bool throwIfNotFound
);

Parameters

id
The Id of the object being searched.
throwIfNotFound
true to throw a ConstableException if the collection doesn't contain an object with the given . false to return a null reference (Nothing in Visual Basic).

Return Value

A reference to the object with the given , or a null reference (Nothing in Visual Basic) if the object cannot be found and the parameter is set to false.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace | NamedObjectCollectionBase.LookupItemById Overload List


NamedObjectCollectionBase.LookupItemByIndex Method

Retrieves the object at the given index in the collection.

[Visual Basic]
Overridable Public Function LookupItemByIndex( _
ByVal index As Integer _
) As NamedObjectBase
[C#]
public virtual NamedObjectBase LookupItemByIndex(
int index
);

Parameters

index
The index of the object to retrieve.

Return Value

A reference to the object at the given index in the collection.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


RemoveAt Method

Constable Authorization Engine 2.0 BETA

NamedObjectCollectionBase.RemoveAt Method

[This is preliminary documentation and subject to change.]

Removes the object with the given Id from the collection.

Overload List

Inherited from CollectionBase.

public void RemoveAt(int);

Removes the object with the given Id from the collection.

public virtual void RemoveAt(string);

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


NamedObjectCollectionBase.RemoveAt Method (String)

Removes the object with the given Id from the collection.

[Visual Basic]
Overridable Overloads Public Sub RemoveAt( _
ByVal id As String _
)
[C#]
public virtual void RemoveAt(
string id
);

Parameters

id
The Id of the object to be removed from the collection.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace | NamedObjectCollectionBase.RemoveAt Overload List


NamedObjectCollectionBase.ToIdArray Method

Returns an array of Strings with elements set to the Id property values.

[Visual Basic]
Overridable Public Function ToIdArray() As String()
[C#]
public virtual string[] ToIdArray();

Return Value

Array of IDs of the objects in the collection.

Remarks

The method never returns a null reference (Nothing in Visual Basic). If the collection doesn't contain any objects, an empty array is returned.

See Also

NamedObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectBase Class

This is the base class for all classes comprising the AuthorizationPolicy state-based authorization model.

For a list of all members of this type, see ObjectBase Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.RuleBase

[Visual Basic]
<Serializable>
MustInherit Public Class ObjectBase
Implements IChangeEventPropagator
[C#]
[Serializable]
public abstract class ObjectBase : IChangeEventPropagator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ObjectBase Members | LaMarvin.Constable.Model Namespace


ObjectBase Members

ObjectBase overview

Public Instance Properties

Policy Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ObjectBase Constructor Initializes a new instance of the ObjectBase class.

Protected Instance Properties

OwnerInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Called after a property of the object has been changed.
OnPropertyChanging | Called when a property of the object is about to be changed.
PropagateChangedEvent | Propagates the changed event.
PropagateChangingEvent | Propagates the changing event.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase Constructor

Initializes a new instance of the ObjectBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected ObjectBase();

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase Properties

The properties of the ObjectBase class are listed below. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Instance Properties

Policy Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.OwnerInternal Property

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Property OwnerInternal As ObjectCollectionBase
[C#]
protected virtual ObjectCollectionBase OwnerInternal {get; set;}

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.PendingPropertyChangeEventArgs Property

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected ReadOnly Property PendingPropertyChangeEventArgs As PropertyChangeEventArgs
[C#]
protected LaMarvin.ComponentModel.PropertyChangeEventArgs PendingPropertyChangeEventArgs {get;}

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.Policy Property

Gets a reference to the AuthorizationPolicy instance that contains this object.

[Visual Basic]
Public ReadOnly Property Policy As AuthorizationPolicy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get;}

Property Value

A reference to the AuthorizationPolicy instance that contains this object or a null reference (Nothing in Visual Basic) if this object isn't contained in a policy.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase Methods

The methods of the ObjectBase class are listed below. For a complete list of ObjectBase class members, see the ObjectBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged | Called after a property of the object has been changed.
OnPropertyChanging | Called when a property of the object is about to be changed.
PropagateChangedEvent | Propagates the changed event.
PropagateChangingEvent | Propagates the changing event.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.OnPropertyChanged Method

Called after a property of the object has been changed.

[Visual Basic]
Protected Sub OnPropertyChanged()
[C#]
protected void OnPropertyChanged();

Remarks

The method dispatches the 'changed' event corresponding to the previous call to the OnPropertyChanging method.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.OnPropertyChanging Method

Called when a property of the object is about to be changed.

[Visual Basic]
Protected Sub OnPropertyChanging( _
ByVal propertyName As String, _
ByVal oldValue As Object, _
ByVal newValue As Object _
)
[C#]
protected void OnPropertyChanging(
string propertyName,
object oldValue,
object newValue
);

Parameters

propertyName
The name of the property.
oldValue
The old property value.
newValue
The new property value.

Remarks

The implementation creates and caches a new PropertyChangeEventArgs instance and dispatches the event by means of calling the PropagateChangingEvent method. The corresponding 'changed' event should be raised by calling the OnPropertyChanged method after the property's value has been changed. In other word, calls to OnPropertyChanging and OnPropertyChanged method should always be balanced.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.PropagateChangedEvent Method

Propagates the changed event.

[Visual Basic]
Overridable Protected Sub PropagateChangedEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void PropagateChangedEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The originator of the event.
e
The ChangeEventArgs instance containing the event data.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectBase.PropagateChangingEvent Method

Propagates the changing event.

[Visual Basic]
Overridable Protected Sub PropagateChangingEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void PropagateChangingEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The originator of the event.
e
The ChangeEventArgs instance containing the event data.

See Also

ObjectBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase Class

Represents a collection NamedObjectBase-derived objects.

For a list of all members of this type, see ObjectCollectionBase Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.RuleCollectionBase

[Visual Basic]
<Serializable>
MustInherit Public Class ObjectCollectionBase
Inherits ChangeableCollectionBase
Implements IChangeEventPropagator
[C#]
[Serializable]
public abstract class ObjectCollectionBase : ChangeableCollectionBase, IChangeEventPropagator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ObjectCollectionBase Members | LaMarvin.Constable.Model Namespace


ObjectCollectionBase Members

ObjectCollectionBase overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Policy | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ObjectCollectionBase Constructor Initializes a new instance of the ObjectCollectionBase class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged | Called after the collection has been changed.
OnCollectionChanging | Called when the collection is about to be changed.
OnInsert | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent | Propagates the changed event.
PropagateChangingEvent | Propagates the changing event.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase Constructor

Initializes a new instance of the ObjectCollectionBase class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected ObjectCollectionBase(
ICollectionUpdater updater
);

Parameters

updater

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase Properties

The properties of the ObjectCollectionBase class are listed below. For a complete list of ObjectCollectionBase class members, see the ObjectCollectionBase Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Policy | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.PendingCollectionChangeEventArgs Property

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected ReadOnly Property PendingCollectionChangeEventArgs As CollectionChangeEventArgs
[C#]
protected LaMarvin.ComponentModel.CollectionChangeEventArgs PendingCollectionChangeEventArgs {get;}

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.Policy Property

Returns the AuthorizationPolicy with which this instance is associated.

[Visual Basic]
Public ReadOnly Property Policy As AuthorizationPolicy
[C#]
public LaMarvin.Constable.AuthorizationPolicy Policy {get;}

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase Methods

The methods of the ObjectCollectionBase class are listed below. For a complete list of ObjectCollectionBase class members, see the ObjectCollectionBase Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged | Called after the collection has been changed.
OnCollectionChanging | Called when the collection is about to be changed.
OnInsert | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent | Propagates the changed event.
PropagateChangingEvent | Propagates the changing event.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnClear Method

Dispatches an appropriate 'changing' event and calls the base class.

[Visual Basic]
Overrides Protected Sub OnClear()
[C#]
protected override void OnClear();

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnClearComplete Method

Calls the base class and dispatches the appropriate 'changed' event.

[Visual Basic]
Overrides Protected Sub OnClearComplete()
[C#]
protected override void OnClearComplete();

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnCollectionChanged Method

Called after the collection has been changed.

[Visual Basic]
Protected Sub OnCollectionChanged()
[C#]
protected void OnCollectionChanged();

Remarks

The method dispatches the 'changed' event corresponding to the previous call to the OnCollectionChanging method.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnCollectionChanging Method

Called when the collection is about to be changed.

[Visual Basic]
Protected Sub OnCollectionChanging( _
ByVal changeType As CollectionChangeType, _
ByVal itemIndex As Integer, _
ByVal item As Object _
)
[C#]
protected void OnCollectionChanging(
CollectionChangeType changeType,
int itemIndex,
object item
);

Remarks

The implementation creates and caches a new CollectionChangeEventArgs instance and dispatches the event by means of calling the PropagateChangingEvent method. The corresponding 'changed' event should be raised by calling the OnCollectionChanged method after the collection's value has been changed. In other word, calls to OnCollectionChanging and OnCollectionChanged method should always be balanced.

The implementation calls the OnCollectionChanging method in the OnInsert, OnRemove and OnClear methods, and the OnCollectionChanged in the corresponding OnInsertComplete, OnRemoveComplete and OnClearComplete methods

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnInsert Method

Dispatches an appropriate 'changing' event and calls the base class.

[Visual Basic]
Overrides Protected Sub OnInsert( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnInsert(
int index,
object value
);

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnInsertComplete Method

Calls the base class and dispatches the appropriate 'changed' event.

[Visual Basic]
Overrides Protected Sub OnInsertComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnInsertComplete(
int index,
object value
);

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnRemove Method

Dispatches an appropriate 'changing' event and calls the base class.

[Visual Basic]
Overrides Protected Sub OnRemove( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnRemove(
int index,
object value
);

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.OnRemoveComplete Method

Calls the base class and dispatches the appropriate 'changed' event.

[Visual Basic]
Overrides Protected Sub OnRemoveComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnRemoveComplete(
int index,
object value
);

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.PropagateChangedEvent Method

Propagates the changed event.

[Visual Basic]
Overridable Protected Sub PropagateChangedEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void PropagateChangedEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The originator of the event.
e
The ChangeEventArgs instance containing the event data.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


ObjectCollectionBase.PropagateChangingEvent Method

Propagates the changing event.

[Visual Basic]
Overridable Protected Sub PropagateChangingEvent( _
ByVal sender As Object, _
ByVal e As ChangeEventArgs _
)
[C#]
protected virtual void PropagateChangingEvent(
object sender,
ChangeEventArgs e
);

Parameters

sender
The originator of the event.
e
The ChangeEventArgs instance containing the event data.

See Also

ObjectCollectionBase Class | LaMarvin.Constable.Model Namespace


Property Class

Defines an Property that is part of an AuthorizationPolicy.

For a list of all members of this type, see Property Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Property
LaMarvin.Constable.Design.Fallback.FallbackProperty

[Visual Basic]
<Serializable>
Public Class Property
Inherits NamedObjectBase
[C#]
[Serializable]
public class Property : NamedObjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

Property Members | LaMarvin.Constable.Model Namespace


Property Members

Property overview

Public Instance Constructors

Property Overloaded. Initializes a new instance of the Property class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the PropertyCollection instance that owns this Property object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

Property Class | LaMarvin.Constable.Model Namespace


Property Constructor

Initializes a new instance of the Property class with the given Id.

Overload List

Initializes a new instance of the Property class with the given Id.

public Property(string);

Initializes a new instance of the Property class with the given property values.

public Property(string,string);

Initializes a new instance of the Property class with the given property values.

public Property(string,string,string);

See Also

Property Class | LaMarvin.Constable.Model Namespace


Property Constructor (String)

Initializes a new instance of the Property class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public Property(
string id
);

Parameters

id
The Id of the object. Property IDs must be unique for all Property objects contained within a given PropertyCollection instance.

See Also

Property Class | LaMarvin.Constable.Model Namespace | Property Constructor Overload List


Property Constructor (String, String)

Initializes a new instance of the Property class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
[C#]
public Property(
string id,
string name
);

Parameters

id
The Id of the object. Property IDs must be unique for all Property objects contained within a given PropertyCollection instance.
name
The name of the Property.

See Also

Property Class | LaMarvin.Constable.Model Namespace | Property Constructor Overload List


Property Constructor (String, String, String)

Initializes a new instance of the Property class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal description As String _
)
[C#]
public Property(
string id,
string name,
string description
);

Parameters

id
The Id of the object. Property IDs must be unique for all Property objects contained within a given PropertyCollection instance.
name
The name of the Property.
description
The description of the Property.

See Also

Property Class | LaMarvin.Constable.Model Namespace | Property Constructor Overload List


Property Properties

The properties of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the PropertyCollection instance that owns this Property object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

Property Class | LaMarvin.Constable.Model Namespace


Property.Owner Property

Returns the PropertyCollection instance that owns this Property object.

[Visual Basic]
Public ReadOnly Property Owner As PropertyCollection
[C#]
public PropertyCollection Owner {get;}

Property Value

Reference to the PropertyCollection that owns the current Property object, or a null reference (Nothing in Visual Basic) if the object is not contained within a collection.

Remarks

Adding an object to a collection automatically sets the Owner property to refer to the containing collection. Conversely, removing the object from the collection sets the Owner property to a null reference (Nothing in Visual Basic), as the following code fagment illustrates:

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model

Dim Prop As New Property("Name")
Debug.Assert(Prop.Owner Is Nothing)

Dim AuthorizationPolicy As New Policy
Policy.Properties.Add(Prop)
Debug.Assert(Not Prop.Owner Is Nothing)
Debug.Assert(Prop.Owner.Equals(Policy.Properties))

Policy.Properties.Remove(Prop)
Debug.Assert(Prop.Owner Is Nothing)

[C#]
using System;
using System.Diagnostics;
using LaMarvin.Constable;
using LaMarvin.Constable.Model;

Property property = new Property("Name");
Debug.Assert(property.Owner == null);

AuthorizationPolicy policy = new AuthorizationPolicy();
policy.Properties.Add(property);
Debug.Assert(property.Owner != null);
Debug.Assert(property.Owner.Equals(policy.Properties));

policy.Properties.Remove(property);
Debug.Assert(property.Owner == null);

See Also

Property Class | LaMarvin.Constable.Model Namespace


PropertyCollection Class

Represents a collection of Property objects.

For a list of all members of this type, see PropertyCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.PropertyCollection

[Visual Basic]
<Serializable>
Public Class PropertyCollection
Inherits NamedObjectCollectionBase
[C#]
[Serializable]
public class PropertyCollection : NamedObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

PropertyCollection Members | LaMarvin.Constable.Model Namespace


PropertyCollection Members

PropertyCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the property with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds a property to the end of the collection.
AddNew | Creates a new Property and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified property in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a property into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a property from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PropertyCollection Constructor Initializes a new instance of the PropertyCollection class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection Constructor

Initializes a new instance of the PropertyCollection class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected PropertyCollection(
ICollectionUpdater updater
);

Parameters

updater

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection Properties

The properties of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the property with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


Item Property

Constable Authorization Engine 2.0 BETA

PropertyCollection.Item Property

[This is preliminary documentation and subject to change.]

Gets the property with the given index in the collection.

Overload List

Gets the property with the given index in the collection.

public virtual Property this[int] {get;}

Gets the property with the given Id.

public virtual Property this[string] {get;}

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection.Item Property

Gets the property with the given index in the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Property
[C#]
public virtual Property this[
int index
] {get;}

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace | PropertyCollection.Item Overload List


PropertyCollection.Item Property

Gets the property with the given Id.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal propertyId As String _
) As Property
[C#]
public virtual Property this[
string propertyId
] {get;}

Exceptions

Exception Type | Condition
ConstableException | A Property with the given is not in the collection.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace | PropertyCollection.Item Overload List


PropertyCollection Methods

The methods of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Instance Methods

Add | Adds a property to the end of the collection.
AddNew | Creates a new Property and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified property in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a property into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a property from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection.Add Method

Adds a property to the end of the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal property As Property _
) As Integer
[C#]
public virtual int Add(
Property property
);

Parameters

property
The property to be added.

Return Value

The index of the added property.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection.AddNew Method

Creates a new Property and adds it to the collection.

[Visual Basic]
Overridable Public Function AddNew( _
ByVal id As String _
) As Property
[C#]
public virtual Property AddNew(
string id
);

Parameters

id
The Id of the new property.

Return Value

A reference to the newly created property.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


IndexOf Method

Constable Authorization Engine 2.0 BETA

PropertyCollection.IndexOf Method

[This is preliminary documentation and subject to change.]

Gets the index of the specified property in the collection.

Overload List

Inherited from NamedObjectCollectionBase.

public int IndexOf(NamedObjectBase);

Gets the index of the specified property in the collection.

public virtual int IndexOf(Property);

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection.IndexOf Method (Property)

Gets the index of the specified property in the collection.

[Visual Basic]
Overridable Overloads Public Function IndexOf( _
ByVal property As Property _
) As Integer
[C#]
public virtual int IndexOf(
Property property
);

Parameters

property
The property to locate in the collection.

Return Value

The zero-based index of the property within the collection, if found; otherwise, -1.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace | PropertyCollection.IndexOf Overload List


PropertyCollection.Insert Method

Inserts a property into the collection.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal property As Property _
)
[C#]
public virtual void Insert(
int index,
Property property
);

Parameters

index
The index where the property is to be inserted.
property
The property being inserted into the collection.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyCollection.Remove Method

Removes a property from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal property As Property _
)
[C#]
public virtual void Remove(
Property property
);

Parameters

property
The property to be removed from the collection.

See Also

PropertyCollection Class | LaMarvin.Constable.Model Namespace


PropertyRule Class

Defines the association of a property with a state, set of Roles that can access the property and the accessibility flags: IsVisible and IsEnabled.

For a list of all members of this type, see PropertyRule Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.PropertyRule
LaMarvin.Constable.Design.Fallback.FallbackPropertyRule

[Visual Basic]
<Serializable>
Public Class PropertyRule
Inherits RuleBase
[C#]
[Serializable]
public class PropertyRule : RuleBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

PropertyRule Members | LaMarvin.Constable.Model Namespace


PropertyRule Members

PropertyRule overview

Public Instance Constructors

PropertyRule Overloaded. Initializes a new instance of the PropertyRule class.

Public Instance Properties

IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner | Returns the colllection that owns this PropertyRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Property | Sets or returns the Property instance associated with this rule.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the rule's properties.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule Constructor

Initializes a new instance of the PropertyRule class.

Overload List

Initializes a new instance of the PropertyRule class.

public PropertyRule(Property,Role,State);

Initializes a new instance of the PropertyRule class.

public PropertyRule(Property,Role,State,bool,bool);

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule Constructor (Property, Role, State, Boolean, Boolean)

Initializes a new instance of the PropertyRule class.

[Visual Basic]
Overloads Public Sub New( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
)
[C#]
public PropertyRule(
Property property,
Role role,
State state,
bool isVisible,
bool isEnabled
);

Parameters

property
The property reference.
role
The role associated with the given property and state.
state
The state with which the property is associated.
isVisible
true if the property should be visible; false otherwise.
isEnabled
true if the property can be modified; false otherwise.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace | PropertyRule Constructor Overload List


PropertyRule Constructor (Property, Role, State)

Initializes a new instance of the PropertyRule class.

[Visual Basic]
Overloads Public Sub New( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State _
)
[C#]
public PropertyRule(
Property property,
Role role,
State state
);

Parameters

property
The property reference.
role
The role associated with the given property and state.
state
The state with which the property is associated.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace | PropertyRule Constructor Overload List


PropertyRule Properties

The properties of the PropertyRule class are listed below. For a complete list of PropertyRule class members, see the PropertyRule Members topic.

Public Instance Properties

IsEnabled (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible (inherited from RuleBase) | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
Owner | Returns the colllection that owns this PropertyRule instance.
OwnerBase (inherited from RuleBase) | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
Property | Sets or returns the Property instance associated with this rule.
ProtectedObject (inherited from RuleBase) | Sets or returns the object protected by this rule.
Role (inherited from RuleBase) | Sets or returns the Role associated with this authorization rule.
State (inherited from RuleBase) | Sets or returns the State associated with this authorization rule.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule.Owner Property

Returns the colllection that owns this PropertyRule instance.

[Visual Basic]
Public ReadOnly Property Owner As PropertyRuleCollection
[C#]
public PropertyRuleCollection Owner {get;}

Property Value

Reference to the PropertyRuleCollection that owns the current PropertyRule instance.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule.Property Property

Sets or returns the Property instance associated with this rule.

[Visual Basic]
Overridable Public Property Property As Property
[C#]
public virtual Property Property {get; set;}

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule Methods

The methods of the PropertyRule class are listed below. For a complete list of PropertyRule class members, see the PropertyRule Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the rule's properties.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRule.ToString Method

Returns a string representation of the rule's properties.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

A string representation of the rule's properties.

Remarks

The string representation has the following form:

<Property>(<Role>) [<State> <IsVisible>, <IsEnabled>]

See Also

PropertyRule Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection Class

Represents a collection of PropertyRule objects.

For a list of all members of this type, see PropertyRuleCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.RuleCollectionBase
LaMarvin.Constable.Model.PropertyRuleCollection

[Visual Basic]
<Serializable>
Public Class PropertyRuleCollection
Inherits RuleCollectionBase
[C#]
[Serializable]
public class PropertyRuleCollection : RuleCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

PropertyRuleCollection Members | LaMarvin.Constable.Model Namespace


PropertyRuleCollection Members

PropertyRuleCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Gets the PropertyRule at the given index.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds a PropertyRule to the collection.
AddNew | Overloaded. Creates and adds a new PropertyRule object to the collection.
AddRange (inherited from RuleCollectionBase) | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines if the collection contains the specified rule.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the specified PropertyRule in the collection.
Insert | Inserts a PropertyRule into the collection.
IsNewRuleValid (inherited from RuleCollectionBase) | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
Lookup | Overloaded. Returns all PropertyRule objects associated with the given property and state objects.
Remove | Removes a PropertyRule from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PropertyRuleCollection Constructor Initializes a new instance of the PropertyRuleCollection class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

CreateEmptyClone | Creates a new, empty instance of the PropertyRuleCollection class.
EnsureNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Lookup | Overloaded. Finds all PropertyRule objects satisfying the specified search criteria.
LookupInternal (inherited from RuleCollectionBase) | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection Constructor

Initializes a new instance of the PropertyRuleCollection class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected PropertyRuleCollection(
ICollectionUpdater updater
);

Parameters

updater

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection Properties

The properties of the PropertyRuleCollection class are listed below. For a complete list of PropertyRuleCollection class members, see the PropertyRuleCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Gets the PropertyRule at the given index.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.Item Property

Gets the PropertyRule at the given index.

[Visual Basic]
Overridable Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As PropertyRule
[C#]
public virtual PropertyRule this[
int index
] {get;}

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection Methods

The methods of the PropertyRuleCollection class are listed below. For a complete list of PropertyRuleCollection class members, see the PropertyRuleCollection Members topic.

Public Instance Methods

Add | Adds a PropertyRule to the collection.
AddNew | Overloaded. Creates and adds a new PropertyRule object to the collection.
AddRange (inherited from RuleCollectionBase) | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains | Determines if the collection contains the specified rule.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Gets the index of the specified PropertyRule in the collection.
Insert | Inserts a PropertyRule into the collection.
IsNewRuleValid (inherited from RuleCollectionBase) | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
Lookup | Overloaded. Returns all PropertyRule objects associated with the given property and state objects.
Remove | Removes a PropertyRule from the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateEmptyClone | Creates a new, empty instance of the PropertyRuleCollection class.
EnsureNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible (inherited from RuleCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Lookup | Overloaded. Finds all PropertyRule objects satisfying the specified search criteria.
LookupInternal (inherited from RuleCollectionBase) | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.Add Method

Adds a PropertyRule to the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal rule As PropertyRule _
) As Integer
[C#]
public virtual int Add(
PropertyRule rule
);

Parameters

rule
The rule to be added to the collection.

Return Value

The index of the added rule in the collection.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


AddNew Method

Constable Authorization Engine 2.0 BETA

PropertyRuleCollection.AddNew Method

[This is preliminary documentation and subject to change.]

Creates and adds a new PropertyRule object to the collection for the given propertyId, roleId and the one state defined for the containing AuthorizationPolicy instance.

Overload List

Creates and adds a new PropertyRule object to the collection for the given propertyId, roleId and the one state defined for the containing AuthorizationPolicy instance.

public PropertyRule AddNew(string,string);

Creates and adds a new PropertyRule object to the collection.

public virtual PropertyRule AddNew(string,string,string);

Creates and adds a new PropertyRule object to the collection.

public virtual PropertyRule AddNew(string,string,string,bool,bool);

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.AddNew Method (String, String)

Creates and adds a new PropertyRule object to the collection for the given propertyId, roleId and the one state defined for the containing AuthorizationPolicy instance.

[Visual Basic]
Overloads Public Function AddNew( _
ByVal propertyId As String, _
ByVal roleId As String _
) As PropertyRule
[C#]
public PropertyRule AddNew(
string propertyId,
string roleId
);

Parameters

propertyId
The Id of the property to be associated with the new PropertyRule.
roleId
The Id of the role to be associated with the new PropertyRule.

Return Value

A reference to the newly created PropertyRule.

Remarks

This overload is available only if the containing AuthorizationPolicy instance has exactly one state defined.

Exceptions

Exception Type | Condition
InvalidOperationException | The containing AuthorizationPolicy doesn't have exactly one state defined.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.AddNew Overload List


PropertyRuleCollection.AddNew Method (String, String, String)

Creates and adds a new PropertyRule object to the collection.

[Visual Basic]
Overridable Overloads Public Function AddNew( _
ByVal propertyId As String, _
ByVal roleId As String, _
ByVal stateId As String _
) As PropertyRule
[C#]
public virtual PropertyRule AddNew(
string propertyId,
string roleId,
string stateId
);

Parameters

propertyId
The Id of the property to be associated with the newly created rule.
roleId
The Id of the role to be associated with the newly created rule.
stateId
The Id of the state to be associated with the newly created rule.

Return Value

Returns a reference to the newly created PropertyRule object.

Remarks

The string identifiers must refere to valid objects that are already contained in the Properties, Roles and States collections in the containgin AuthorizationPolicy instance.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.AddNew Overload List


PropertyRuleCollection.AddNew Method (String, String, String, Boolean, Boolean)

Creates and adds a new PropertyRule object to the collection.

[Visual Basic]
Overridable Overloads Public Function AddNew( _
ByVal propertyId As String, _
ByVal roleId As String, _
ByVal stateId As String, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
) As PropertyRule
[C#]
public virtual PropertyRule AddNew(
string propertyId,
string roleId,
string stateId,
bool isVisible,
bool isEnabled
);

Parameters

propertyId
The Id of the property to be associated with the newly created rule.
roleId
The Id of the role to be associated with the newly created rule.
stateId
The Id of the state to be associated with the newly created rule.
isVisible
The initial value for the IsVisible property of the newly created rule.
isEnabled
The initial value for the IsEnabled property of the newly created rule.

Return Value

Returns a reference to the newly created PropertyRule object.

Remarks

The string identifiers must refere to valid objects that are already contained in the Properties, Roles and States collections in the containgin AuthorizationPolicy instance.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.AddNew Overload List


PropertyRuleCollection.Contains Method

Determines if the collection contains the specified rule.

[Visual Basic]
Overridable Public Function Contains( _
ByVal rule As PropertyRule _
) As Boolean
[C#]
public virtual bool Contains(
PropertyRule rule
);

Parameters

rule
The rule being searched for.

Return Value

true if the rule is in the collection; false otherwise.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.CreateEmptyClone Method

Creates a new, empty instance of the PropertyRuleCollection class.

[Visual Basic]
Overrides Protected Function CreateEmptyClone( _
ByVal updater As ICollectionUpdater _
) As RuleCollectionBase
[C#]
protected override RuleCollectionBase CreateEmptyClone(
ICollectionUpdater updater
);

Parameters

updater
The ICollectionUpdater implementation to be associated with the returned collection.

Return Value

A reference to the newly created PropertyRuleCollection instance.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.IndexOf Method

Gets the index of the specified PropertyRule in the collection.

[Visual Basic]
Overridable Public Function IndexOf( _
ByVal rule As PropertyRule _
) As Integer
[C#]
public virtual int IndexOf(
PropertyRule rule
);

Parameters

rule
The PropertyRule to locate in the collection.

Return Value

The index of the rule if found; -1 otherwise.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.Insert Method

Inserts a PropertyRule into the collection.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal rule As PropertyRule _
)
[C#]
public virtual void Insert(
int index,
PropertyRule rule
);

Parameters

index
The index in the collection where the rule should be inserted.
rule
The PropertyRule to be inserted into the collection.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


Lookup Method

Constable Authorization Engine 2.0 BETA

PropertyRuleCollection.Lookup Method

[This is preliminary documentation and subject to change.]

Returns all PropertyRule objects associated with the given property.

Overload List

Returns all PropertyRule objects associated with the given property.

public PropertyRuleCollection Lookup(Property);

Returns the PropertyRule object associated with the given property, role and state.

public virtual PropertyRule Lookup(Property,Role,State);

Finds all PropertyRule objects satisfying the specified search criteria.

protected virtual PropertyRuleCollection Lookup(Property,Role,State,VisibleOption,EnabledOption);

Returns all PropertyRule objects associated with the given property and state objects.

public virtual PropertyRuleCollection Lookup(Property,State);

Returns the PropertyRule object associated with the given property, role and state.

public virtual PropertyRule Lookup(string,string,string);

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


PropertyRuleCollection.Lookup Method (Property)

Returns all PropertyRule objects associated with the given property.

[Visual Basic]
Overloads Public Function Lookup( _
ByVal property As Property _
) As PropertyRuleCollection
[C#]
public PropertyRuleCollection Lookup(
Property property
);

Parameters

property
The Property being searched for.

Return Value

Collection of PropertyRule objects with the Property reference equal to the property argument value.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.Lookup Overload List


PropertyRuleCollection.Lookup Method (Property, Role, State)

Returns the PropertyRule object associated with the given property, role and state.

[Visual Basic]
Overridable Overloads Public Function Lookup( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State _
) As PropertyRule
[C#]
public virtual PropertyRule Lookup(
Property property,
Role role,
State state
);

Parameters

property
The property being searched for.
role
The role being searched for.
state
The state being searched for.

Return Value

The PropertyRule if found; a null reference (Nothing in Visual Basic) otherwise.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.Lookup Overload List


PropertyRuleCollection.Lookup Method (Property, Role, State, VisibleOption, EnabledOption)

Finds all PropertyRule objects satisfying the specified search criteria.

[Visual Basic]
Overridable Overloads Protected Function Lookup( _
ByVal property As Property, _
ByVal role As Role, _
ByVal state As State, _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As PropertyRuleCollection
[C#]
protected virtual PropertyRuleCollection Lookup(
Property property,
Role role,
State state,
VisibleOption visible,
EnabledOption enabled
);

Parameters

property
The property that the returned property rules should be associated with.
role
The role that the returned property rules should be associated with.
state
The state that the returned property rules should be associated with.
visible
The required setting of the IsVisible property for the returned property rules.
enabled
The required setting of the IsEnabled property for the returned property rules.

Return Value

A collection of property rule objects satisfying the search criteria.

Remarks

Passing a null reference (Nothing in Visual Basic) as a value of the property, role or state argument means that the argument isn't part of the lookup criteria. For example passing a null reference (Nothing in Visual Basic) as a value of the role argument returns all property authorization rules regardless of their Role property values.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.Lookup Overload List


PropertyRuleCollection.Lookup Method (Property, State)

Returns all PropertyRule objects associated with the given property and state objects.

[Visual Basic]
Overridable Overloads Public Function Lookup( _
ByVal property As Property, _
ByVal state As State _
) As PropertyRuleCollection
[C#]
public virtual PropertyRuleCollection Lookup(
Property property,
State state
);

Parameters

property
The property being searched for.
state
The state being searched for.

Return Value

Collection of PropertyRule objects with the Property reference equal to the property argument value and the State reference equal to the state argument value.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.Lookup Overload List


PropertyRuleCollection.Lookup Method (String, String, String)

Returns the PropertyRule object associated with the given property, role and state.

[Visual Basic]
Overridable Overloads Public Function Lookup( _
ByVal propertyId As String, _
ByVal roleId As String, _
ByVal stateId As String _
) As PropertyRule
[C#]
public virtual PropertyRule Lookup(
string propertyId,
string roleId,
string stateId
);

Parameters

propertyId
roleId
stateId

Return Value

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace | PropertyRuleCollection.Lookup Overload List


PropertyRuleCollection.Remove Method

Removes a PropertyRule from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal rule As PropertyRule _
)
[C#]
public virtual void Remove(
PropertyRule rule
);

Parameters

rule
The rule to be removed from the collection.

See Also

PropertyRuleCollection Class | LaMarvin.Constable.Model Namespace


Role Class

Defines a role that can act on an instance of an AuthorizationPolicy class.

For a list of all members of this type, see Role Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Design.Fallback.FallbackRole
LaMarvin.Constable.Model.ComPlusRole
LaMarvin.Constable.Model.DynamicRole
LaMarvin.Constable.Model.WindowsRole

[Visual Basic]
<Serializable>
Public Class Role
Inherits NamedObjectBase
[C#]
[Serializable]
public class Role : NamedObjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

Role Members | LaMarvin.Constable.Model Namespace


Role Members

Role overview

Public Instance Constructors

Role Overloaded. Initializes a new instance of the Role class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Determines whether a principal is member of the role.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

Role Class | LaMarvin.Constable.Model Namespace


Role Constructor

Initializes a new instance of the Role class with the given Id.

Overload List

Initializes a new instance of the Role class with the given Id.

public Role(string);

Initializes a new instance of the Role class with the given property values.

public Role(string,string);

Initializes a new instance of the Role class with the given property values.

public Role(string,string,string);

See Also

Role Class | LaMarvin.Constable.Model Namespace


Role Constructor (String)

Initializes a new instance of the Role class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public Role(
string id
);

Parameters

id
The Id of the object. Role IDs must be unique for all Role objects contained within a given RoleCollection instance.

See Also

Role Class | LaMarvin.Constable.Model Namespace | Role Constructor Overload List


Role Constructor (String, String)

Initializes a new instance of the Role class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
[C#]
public Role(
string id,
string name
);

Parameters

id
The Id of the object. Role IDs must be unique for all Role objects contained within a given RoleCollection instance.
name
The name of the Role.

See Also

Role Class | LaMarvin.Constable.Model Namespace | Role Constructor Overload List


Role Constructor (String, String, String)

Initializes a new instance of the Role class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal description As String _
)
[C#]
public Role(
string id,
string name,
string description
);

Parameters

id
The Id of the role. Role IDs must be unique for all Role objects contained within a given RoleCollection instance.
name
The name of the Role.
description
The description of the Role.

See Also

Role Class | LaMarvin.Constable.Model Namespace | Role Constructor Overload List


Role Properties

The properties of the Role class are listed below. For a complete list of Role class members, see the Role Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

Role Class | LaMarvin.Constable.Model Namespace


Role.Owner Property

Returns the RoleCollection instance that owns this Role object.

[Visual Basic]
Public ReadOnly Property Owner As RoleCollection
[C#]
public RoleCollection Owner {get;}

Property Value

Reference to the RoleCollection that owns the current Role object, or if the object is not contained within a collection.

Remarks

Adding an object to a collection automatically sets the Owner property to refer to the containing collection. Conversely, remving the object from the collection sets the Owner property to a null reference (Nothing in Visual Basic).

See Also

Role Class | LaMarvin.Constable.Model Namespace


Role Methods

The methods of the Role class are listed below. For a complete list of Role class members, see the Role Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Determines whether a principal is member of the role.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

Role Class | LaMarvin.Constable.Model Namespace


Role.IsMember Method

Determines whether a principal is member of the role.

[Visual Basic]
Overridable Public Function IsMember( _
ByVal principal As IPrincipal _
) As Boolean
[C#]
public virtual bool IsMember(
IPrincipal principal
);

Parameters

principal
The principal whose role membership is to be determined.

Return Value

Returns true if the principal is member of the role, otherwise returns false.

Remarks

The default implementation simply calls the IsInRole method on the passed-in principal reference with the role argument set to Role.Id.

You can override the implementation in a derived class if you want to achieve more sophisticated membership checking. See the WindowsRole.IsMember method documentation for an example.

See Also

Role Class | LaMarvin.Constable.Model Namespace


RoleCollection Class

Represents a collection of Role objects.

For a list of all members of this type, see RoleCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.RoleCollection

[Visual Basic]
<Serializable>
Public Class RoleCollection
Inherits NamedObjectCollectionBase
[C#]
[Serializable]
public class RoleCollection : NamedObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

RoleCollection Members | LaMarvin.Constable.Model Namespace


RoleCollection Members

RoleCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the role with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds a role to the end of the collection.
AddNew | Creates a new Role and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified role in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a role into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a role from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RoleCollection Constructor Initializes a new instance of the RoleCollection class with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection Constructor

Initializes a new instance of the RoleCollection class with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected RoleCollection(
ICollectionUpdater updater
);

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection Properties

The properties of the RoleCollection class are listed below. For a complete list of RoleCollection class members, see the RoleCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the role with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


Item Property

Constable Authorization Engine 2.0 BETA

RoleCollection.Item Property

[This is preliminary documentation and subject to change.]

Gets the role with the given index in the collection.

Overload List

Gets the role with the given index in the collection.

public virtual Role this[int] {get;}

Gets the role with the given Id.

public virtual Role this[string] {get;}

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection.Item Property

Gets the role with the given index in the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Role
[C#]
public virtual Role this[
int index
] {get;}

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace | RoleCollection.Item Overload List


RoleCollection.Item Property

Gets the role with the given Id.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal roleId As String _
) As Role
[C#]
public virtual Role this[
string roleId
] {get;}

Exceptions

Exception Type | Condition
ConstableException | A Role with the given is not in the collection.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace | RoleCollection.Item Overload List


RoleCollection Methods

The methods of the RoleCollection class are listed below. For a complete list of RoleCollection class members, see the RoleCollection Members topic.

Public Instance Methods

Add | Adds a role to the end of the collection.
AddNew | Creates a new Role and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified role in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a role into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a role from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection.Add Method

Adds a role to the end of the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal role As Role _
) As Integer
[C#]
public virtual int Add(
Role role
);

Parameters

role
The role to be added.

Return Value

The index of the added role.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection.AddNew Method

Creates a new Role and adds it to the collection.

[Visual Basic]
Overridable Public Function AddNew( _
ByVal id As String _
) As Role
[C#]
public virtual Role AddNew(
string id
);

Parameters

id
The Id of the new role.

Return Value

A reference to the newly created role.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


IndexOf Method

Constable Authorization Engine 2.0 BETA

RoleCollection.IndexOf Method

[This is preliminary documentation and subject to change.]

Gets the index of the specified role in the collection.

Overload List

Inherited from NamedObjectCollectionBase.

public int IndexOf(NamedObjectBase);

Gets the index of the specified role in the collection.

public virtual int IndexOf(Role);

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection.IndexOf Method (Role)

Gets the index of the specified role in the collection.

[Visual Basic]
Overridable Overloads Public Function IndexOf( _
ByVal role As Role _
) As Integer
[C#]
public virtual int IndexOf(
Role role
);

Parameters

role
The role to locate in the collection.

Return Value

The zero-based index of the role within the collection, if found; otherwise, -1.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace | RoleCollection.IndexOf Overload List


RoleCollection.Insert Method

Inserts a role into the collection.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal role As Role _
)
[C#]
public virtual void Insert(
int index,
Role role
);

Parameters

index
The index where the role is to be inserted.
role
The role being inserted into the collection.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RoleCollection.Remove Method

Removes a role from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal role As Role _
)
[C#]
public virtual void Remove(
Role role
);

Parameters

role
The role to be removed from the collection.

See Also

RoleCollection Class | LaMarvin.Constable.Model Namespace


RuleBase Class

Provides a base class for derived classes representing associations (sometimes called tuples) of a given State, role, state-dependent object and the state-dependent object's attributes.

The provided ActionRule and PropertyRule classes represent built-in rule objects.

For a list of all members of this type, see RuleBase Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.ActionRule
LaMarvin.Constable.Model.PropertyRule

[Visual Basic]
<Serializable>
MustInherit Public Class RuleBase
Inherits ObjectBase
[C#]
[Serializable]
public abstract class RuleBase : ObjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

RuleBase Members | LaMarvin.Constable.Model Namespace


RuleBase Members

RuleBase overview

Public Instance Properties

IsEnabled | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
OwnerBase | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
ProtectedObject | Sets or returns the object protected by this rule.
Role | Sets or returns the Role associated with this authorization rule.
State | Sets or returns the State associated with this authorization rule.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleBase Constructor Initializes a new instance of the derived class with the given state and role.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase Constructor

Initializes a new instance of the derived class with the given state and role.

[Visual Basic]
Protected Sub New( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State, _
ByVal isVisible As Boolean, _
ByVal isEnabled As Boolean _
)
[C#]
protected RuleBase(
NamedObjectBase protectedObject,
Role role,
State state,
bool isVisible,
bool isEnabled
);

Parameters

protectedObject
role
The associated role.
state
The associated state.
isVisible
The initial value of the IsVisible property.
isEnabled

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase Properties

The properties of the RuleBase class are listed below. For a complete list of RuleBase class members, see the RuleBase Members topic.

Public Instance Properties

IsEnabled | Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.
IsVisible | Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.
OwnerBase | Returns the base class reference for the collection that owns this RuleBase-derived instance.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
ProtectedObject | Sets or returns the object protected by this rule.
Role | Sets or returns the Role associated with this authorization rule.
State | Sets or returns the State associated with this authorization rule.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.IsEnabled Property

Gets or sets a flag indicating whether the protected object can be accessed by the associated role. The value is true if the protected object can be accessed; false otherwise.

[Visual Basic]
Overridable Public Property IsEnabled As Boolean
[C#]
public virtual bool IsEnabled {get; set;}

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.IsVisible Property

Gets or sets a flag indicating whether the protected object should be visible for the associated role. The value is true if the object should be visible; false otherwise.

[Visual Basic]
Overridable Public Property IsVisible As Boolean
[C#]
public virtual bool IsVisible {get; set;}

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.OwnerBase Property

Returns the base class reference for the collection that owns this RuleBase-derived instance.

[Visual Basic]
Public ReadOnly Property OwnerBase As RuleCollectionBase
[C#]
public RuleCollectionBase OwnerBase {get;}

Property Value

Reference to the RuleCollectionBase-derived collection that owns the current RuleBase-derived instance.

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.ProtectedObject Property

Sets or returns the object protected by this rule.

[Visual Basic]
Overridable Public Property ProtectedObject As NamedObjectBase
[C#]
public virtual NamedObjectBase ProtectedObject {get; set;}

Remarks

This property allows one to treat RuleBase-derived classes polymorphically. In other words, the property is an alias for the strongly typed ActionRule.Action property, or the PropertyRule.Property property.

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.Role Property

Sets or returns the Role associated with this authorization rule.

[Visual Basic]
Overridable Public Property Role As Role
[C#]
public virtual Role Role {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | An attempt was made to set the property to a a null reference (Nothing in Visual Basic) value.
DuplicateAuthorizationRuleException | An attempt was made to set the property to a Role instance that would make this authorization rule duplicate.
ConstableException | The Role instance being set cannot be associated with the authorization rule for some other reason; most likely the Role instance belongs to a different AuthorizationPolicy, or it doesn't belong to any AuthorizationPolicy at all.

Example

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

Public Class RuleBaseSetRoleSample

  '''
  ''' Demonstrates the new capability of directly associating an existing
  ''' authorization rule with a new role by setting the ActionRule.Role
  ''' (or PropertyRule.Role) property.
  '''
  Public Shared Sub Main()
    ' Set up a simple authorization policy programmatically.
    Dim policy As New AuthorizationPolicy
    policy.States.AddNew("Default")

    ' These are our two roles.
    Dim userRole As Role = policy.Roles.AddNew("User")
    Dim adminRole As Role = policy.Roles.AddNew("Admin")

    ' Actions will be Logoff - available to both roles.
    policy.Actions.AddNew("Logoff")
    policy.ActionRules.AddNew("Logoff", "User")
    policy.ActionRules.AddNew("Logoff", "Admin")

    ' The Shutdown action is initially available only to Admin.
    policy.Actions.AddNew("Shutdown")
    Dim shutdownRule As ActionRule = policy.ActionRules.AddNew("Shutdown", "Admin")

    ' Now associate the policy with a principal in the User role and assert
    ' some obvious facts about the policy.
    policy.CurrentPrincipal = New ExtendedPrincipal(New GenericIdentity("John Doe"), New String() {"User"})
    Debug.Assert(policy.IsActionExecutable("Logoff"))
    Debug.Assert(Not policy.IsActionExecutable("Shutdown"))

    ' Now associate the Shutdown action rule with the User role and check
    ' it is now executable.
    shutdownRule.Role = userRole
    Debug.Assert(policy.IsActionExecutable("Shutdown"))
  End Sub

End Class

[C#]
using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

public class RuleBaseSetRoleSample
{

  ///
  /// Demonstrates the new capability of directly associating an existing
  /// authorization rule with a new role by setting the ActionRule.Role
  /// (or PropertyRule.Role) property.
  ///
  public static void Main()
  {
    // Set up a simple authorization policy programmatically.
    AuthorizationPolicy policy = new AuthorizationPolicy();
    policy.States.AddNew("Default");

    // These are our two roles.
    Role userRole = policy.Roles.AddNew("User");
    Role adminRole = policy.Roles.AddNew("Admin");

    // Actions will be Logoff - available to both roles.
    policy.Actions.AddNew("Logoff");
    policy.ActionRules.AddNew("Logoff", "User");
    policy.ActionRules.AddNew("Logoff", "Admin");

    // The Shutdown action is initially available only to Admin.
    policy.Actions.AddNew("Shutdown");
    ActionRule shutdownRule = policy.ActionRules.AddNew("Shutdown", "Admin");

    // Now associate the policy with a principal in the User role and assert
    // some obvious facts about the policy.
    policy.CurrentPrincipal = new ExtendedPrincipal(new GenericIdentity("John Doe"), new string[] {"User"});
    Debug.Assert(policy.IsActionExecutable("Logoff"));
    Debug.Assert(!policy.IsActionExecutable("Shutdown"));

    // Now associate the Shutdown action rule with the User role and check
    // it is now executable.
    shutdownRule.Role = userRole;
    Debug.Assert(policy.IsActionExecutable("Shutdown"));
  }
}

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleBase.State Property

Sets or returns the State associated with this authorization rule.

[Visual Basic]
Overridable Public Property State As State
[C#]
public virtual State State {get; set;}

Example

[Visual Basic]
Imports System
Imports System.Diagnostics
Imports System.Security.Principal

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

Public Class RuleBaseSetStateSample

  '''
  ''' Demonstrates the new capability of directly associating an existing
  ''' authorization rule with a new state by setting the ActionRule.State
  ''' or PropertyRule.State properties.
  '''
  Public Shared Sub Main()
    ' Set up a simple authorization policy programmatically.
    Dim policy As AuthorizationPolicy = New AuthorizationPolicy("battleshipGame")
    policy.Description = "FMI see the Battleships game at http://www.miniclip.com/"

    ' The game roles.
    policy.Roles.AddNew("User")
    policy.Roles.AddNew("Computer")

    ' The game states.
    policy.States.AddNew("shipDeployment") ' initial state - deploying ships on the board
    policy.States.AddNew("startedUserMove") ' game has been started, the user should move As
    policy.States.AddNew("startedComputerMove") ' game has been started, the computer should move As
    policy.States.AddNew("wonByUser") ' the game has been won by the user As
    policy.States.AddNew("wonByComputer") ' the game has been won by the computer As

    ' These are the game actions.
    policy.Actions.AddNew("Start")
    policy.Actions.AddNew("Move")
    policy.Actions.AddNew("Stop")

    ' The initial state is shipDeployment; the Computer starts the game by executing the Start action.
    policy.ActionRules.AddNew("Start", "Computer", "shipDeployment", "startedUserMove")

    ' The game is in progress; the Move action executed by the Computer transitions the game from
    ' the startedComputerMove state to the startedUserMove state.
    policy.ActionRules.AddNew("Move", "Computer", "startedComputerMove", "startedUserMove")

    ' The game is in progress; the Move action executed by the User transitions the game from
    ' the startedUserMove state to the startedComputerMove state.
    policy.ActionRules.AddNew("Move", "User", "startedUserMove", "startedComputerMove")

    ' The Computer decides who wins the game and ends it by executing the Stop action
    ' while the game is running (i.e. is in the startedUserMove or startedComputerMove states).
    policy.ActionRules.AddNew("Stop", "Computer", "startedUserMove", "wonByUser")
    policy.ActionRules.AddNew("Stop", "Computer", "startedComputerMove", "wonByComputer")

    ' Our principals representing the User and Computer roles.
    Dim user As IPrincipal =  New GenericPrincipal(New GenericIdentity("Jack User"),new String(){"User"})
    Dim computer As IPrincipal =  New GenericPrincipal(New GenericIdentity("Compaq nx7010"),new String(){"Computer"})

    ' The Computer starts the game.
    policy.CurrentState = policy.States("shipDeployment")
    policy.CurrentPrincipal = computer
    policy.ExecuteAction("Start")

    ' Now the User should move; the Computer cannot.
    Debug.Assert(Not policy.IsActionExecutable("Move"))
    policy.CurrentPrincipal = user
    policy.ExecuteAction("Move")

    ' Now the Computer should move; the User cannot.
    Debug.Assert(Not policy.IsActionExecutable("Move"))

    ' Now it gets a bit tricky:
    ' We're in the startedComputerMove state and the current principal is still the User.
    ' We'll dynamically change the rule for the Move command executed by the User to be
    ' allowed even in the startedComputerMove state.
    Dim moveUserRule As ActionRule = policy.ActionRules.Lookup("Move", "User", "startedUserMove")
    moveUserRule.State = policy.States("startedComputerMove")
    Debug.Assert(policy.IsActionExecutable("Move"))
    policy.ExecuteAction("Move")
  End Sub
End Class

[C#]
using System;
using System.Diagnostics;
using System.Security.Principal;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

public class RuleBaseSetStateSample
{

  ///
  /// Demonstrates the new capability of directly associating an existing
  /// authorization rule with a new state by setting the ActionRule.State
  /// or PropertyRule.State properties.
  ///
  public static void Main()
  {
    // Set up a simple authorization policy programmatically.
    AuthorizationPolicy policy = new AuthorizationPolicy("battleshipGame");
    policy.Description = @"FMI see the Battleships game at http://www.miniclip.com/";

    // The game roles.
    policy.Roles.AddNew("User");
    policy.Roles.AddNew("Computer");

    // The game states.
    policy.States.AddNew("shipDeployment"); // initial state - deploying ships on the board
    policy.States.AddNew("startedUserMove");  // game has been started, the user should move
    policy.States.AddNew("startedComputerMove"); // game has been started, the computer should move
    policy.States.AddNew("wonByUser");  // the game has been won by the user
    policy.States.AddNew("wonByComputer");  // the game has been won by the computer

    // These are the game actions.
    policy.Actions.AddNew("Start");
    policy.Actions.AddNew("Move");
    policy.Actions.AddNew("Stop");

    // The initial state is shipDeployment; the Computer starts the game by executing the Start action.
    policy.ActionRules.AddNew("Start", "Computer", "shipDeployment", "startedUserMove");

    // The game is in progress; the Move action executed by the Computer transitions the game from
    // the startedComputerMove state to the startedUserMove state.
    policy.ActionRules.AddNew("Move", "Computer", "startedComputerMove", "startedUserMove");

    // The game is in progress; the Move action executed by the User transitions the game from
    // the startedUserMove state to the startedComputerMove state.
    policy.ActionRules.AddNew("Move", "User", "startedUserMove", "startedComputerMove");

    // The Computer decides who wins the game and ends it by executing the Stop action
    // while the game is running (i.e. is in the startedUserMove or startedComputerMove states).
    policy.ActionRules.AddNew("Stop", "Computer", "startedUserMove", "wonByUser");
    policy.ActionRules.AddNew("Stop", "Computer", "startedComputerMove", "wonByComputer");

    // Our principals representing the User and Computer roles.
    IPrincipal user = new GenericPrincipal(new GenericIdentity("Jack User"), new string[]{"User"});
    IPrincipal computer = new GenericPrincipal(new GenericIdentity("Compaq nx7010"), new string[]{"Computer"});

    // The Computer starts the game.
    policy.CurrentState = policy.States["shipDeployment"];
    policy.CurrentPrincipal = computer;
    policy.ExecuteAction("Start");

    // Now the User should move; the Computer cannot.
    Debug.Assert(!policy.IsActionExecutable("Move"));
    policy.CurrentPrincipal = user;
    policy.ExecuteAction("Move");

    // Now the Computer should move; the User cannot.
    Debug.Assert(!policy.IsActionExecutable("Move"));

    // Now it gets a bit tricky:
    // We're in the startedComputerMove state and the current principal is still the User.
    // We'll dynamically change the rule for the Move command executed by the User to be
    // allowed even in the startedComputerMove state.
    ActionRule moveUserRule = policy.ActionRules.Lookup("Move", "User", "startedUserMove");
    moveUserRule.State = policy.States["startedComputerMove"];
    Debug.Assert(policy.IsActionExecutable("Move"));
    policy.ExecuteAction("Move");
  }
}

See Also

RuleBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase Class

Provides a base class for all concrete collection classes containing descendants of the RuleBase class.

For a list of all members of this type, see RuleCollectionBase Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.RuleCollectionBase
LaMarvin.Constable.Model.ActionRuleCollection
LaMarvin.Constable.Model.PropertyRuleCollection

[Visual Basic]
<Serializable>
MustInherit Public Class RuleCollectionBase
Inherits ObjectCollectionBase
[C#]
[Serializable]
public abstract class RuleCollectionBase : ObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

RuleCollectionBase Members | LaMarvin.Constable.Model Namespace


RuleCollectionBase Members

RuleCollectionBase overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

AddRange | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNewRuleValid | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleCollectionBase Constructor Initializes a new instance of the RuleCollectionBase class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

CreateEmptyClone | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
LookupInternal | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase Constructor

Initializes a new instance of the RuleCollectionBase class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected RuleCollectionBase(
ICollectionUpdater updater
);

Parameters

updater

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase Methods

The methods of the RuleCollectionBase class are listed below. For a complete list of RuleCollectionBase class members, see the RuleCollectionBase Members topic.

Public Instance Methods

AddRange | Adds a collection of RuleBase descendants to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNewRuleValid | The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateEmptyClone | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
EnsureNewRuleValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsNewRuleDuplicate | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRuleObjectPolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsNewRulePolicyOwnershipValid | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
IsRuleFeasible | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
LookupInternal | Overloaded. Finds all rule objects satisfying the specified criteria.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.AddRange Method

Adds a collection of RuleBase descendants to the collection.

[Visual Basic]
Public Sub AddRange( _
ByVal rules As ICollection _
)
[C#]
public void AddRange(
ICollection rules
);

Parameters

rules
The collection of rules to be added to this collection.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.CreateEmptyClone Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
MustOverride Protected Function CreateEmptyClone( _
ByVal updater As ICollectionUpdater _
) As RuleCollectionBase
[C#]
protected abstract RuleCollectionBase CreateEmptyClone(
ICollectionUpdater updater
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.EnsureNewRuleObjectPolicyOwnershipValid Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub EnsureNewRuleObjectPolicyOwnershipValid( _
ByVal newObject As NamedObjectBase _
)
[C#]
protected void EnsureNewRuleObjectPolicyOwnershipValid(
NamedObjectBase newObject
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.EnsureNewRuleValid Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Sub EnsureNewRuleValid( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
)
[C#]
protected void EnsureNewRuleValid(
NamedObjectBase protectedObject,
Role role,
State state
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.IsNewRuleDuplicate Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function IsNewRuleDuplicate( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
) As Boolean
[C#]
protected bool IsNewRuleDuplicate(
NamedObjectBase protectedObject,
Role role,
State state
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.IsNewRuleObjectPolicyOwnershipValid Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function IsNewRuleObjectPolicyOwnershipValid( _
ByVal newObject As ObjectBase _
) As Boolean
[C#]
protected bool IsNewRuleObjectPolicyOwnershipValid(
ObjectBase newObject
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.IsNewRulePolicyOwnershipValid Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Protected Function IsNewRulePolicyOwnershipValid( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
) As Boolean
[C#]
protected bool IsNewRulePolicyOwnershipValid(
NamedObjectBase protectedObject,
Role role,
State state
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.IsNewRuleValid Method

The method checks whether a new authorization rule defined by the parameters can be safely added to the collection.

[Visual Basic]
Public Function IsNewRuleValid( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
) As Boolean
[C#]
public bool IsNewRuleValid(
NamedObjectBase protectedObject,
Role role,
State state
);

Parameters

protectedObject
A reference to an Action or a Property to be associated with the new authorization rule.
role
A reference to a Role to be associated with the new authorization rule.
state
A reference to a State to be associated with the new authorization rule.

Return Value

true if the authorization rule can be added to the collection; false otherwise.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.IsRuleFeasible Method

This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function IsRuleFeasible( _
ByVal rule As RuleBase, _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As Boolean
[C#]
protected virtual bool IsRuleFeasible(
RuleBase rule,
VisibleOption visible,
EnabledOption enabled
);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


LookupInternal Method

Constable Authorization Engine 2.0 BETA

RuleCollectionBase.LookupInternal Method

[This is preliminary documentation and subject to change.]

Finds all rule objects satisfying the specified criteria.

Overload List

Finds all rule objects satisfying the specified criteria.

protected RuleCollectionBase LookupInternal(NamedObjectBase,Role,State);

Finds all rule objects satisfying the specified criteria.

protected virtual RuleCollectionBase LookupInternal(NamedObjectBase,Role,State,VisibleOption,EnabledOption);

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace


RuleCollectionBase.LookupInternal Method (NamedObjectBase, Role, State)

Finds all rule objects satisfying the specified criteria.

[Visual Basic]
Overloads Protected Function LookupInternal( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State _
) As RuleCollectionBase
[C#]
protected RuleCollectionBase LookupInternal(
NamedObjectBase protectedObject,
Role role,
State state
);

Parameters

protectedObject
The protected object.
role
The role that the returned rules should be associated with.
state
The state that the returned rules should be associated with.

Return Value

A collection of rule objects satisfying the search criteria.

Remarks

Please see the LookupInternal overload for more information.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace | RuleCollectionBase.LookupInternal Overload List


RuleCollectionBase.LookupInternal Method (NamedObjectBase, Role, State, VisibleOption, EnabledOption)

Finds all rule objects satisfying the specified criteria.

[Visual Basic]
Overridable Overloads Protected Function LookupInternal( _
ByVal protectedObject As NamedObjectBase, _
ByVal role As Role, _
ByVal state As State, _
ByVal visible As VisibleOption, _
ByVal enabled As EnabledOption _
) As RuleCollectionBase
[C#]
protected virtual RuleCollectionBase LookupInternal(
NamedObjectBase protectedObject,
Role role,
State state,
VisibleOption visible,
EnabledOption enabled
);

Parameters

protectedObject
The protected object.
role
The role that the returned rules should be associated with.
state
The state that the returned rules should be associated with.
visible
The required setting of the IsVisible property for the returned rules.
enabled
The required setting of the IsEnabled property for the returned rules.

Return Value

A collection of rule objects satisfying the search criteria.

Remarks

Passing a null reference (Nothing in Visual Basic) as a value of the protectedObject, role or state argument means that the argument isn't part of the lookup criteria. For example passing a null reference (Nothing in Visual Basic) as a value of the role argument returns all authorization rules regardless of their Role property values.

See Also

RuleCollectionBase Class | LaMarvin.Constable.Model Namespace | RuleCollectionBase.LookupInternal Overload List


State Class

Defines a state in the authorization model.

For a list of all members of this type, see State Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.State
LaMarvin.Constable.Design.Fallback.FallbackState

[Visual Basic]
<Serializable>
Public Class State
Inherits NamedObjectBase
[C#]
[Serializable]
public class State : NamedObjectBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

State Members | LaMarvin.Constable.Model Namespace


State Members

State overview

Public Instance Constructors

State Overloaded. Initializes a new instance of the State class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the colllection that owns this State object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.

See Also

State Class | LaMarvin.Constable.Model Namespace


State Constructor

Initializes a new instance of the State class with the given Id.

Overload List

Initializes a new instance of the State class with the given Id.

public State(string);

Initializes a new instance of the State class with the given property values.

public State(string,string);

Initializes a new instance of the State class with the given property values.

public State(string,string,string);

See Also

State Class | LaMarvin.Constable.Model Namespace


State Constructor (String)

Initializes a new instance of the State class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public State(
string id
);

Parameters

id
The Id of the object. State IDs must be unique for all state objects contained within a given StateCollection instance.

See Also

State Class | LaMarvin.Constable.Model Namespace | State Constructor Overload List


State Constructor (String, String)

Initializes a new instance of the State class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
[C#]
public State(
string id,
string name
);

Parameters

id
The Id of the object. State IDs must be unique for all state objects contained within a given StateCollection instance.
name
The name of the state.

See Also

State Class | LaMarvin.Constable.Model Namespace | State Constructor Overload List


State Constructor (String, String, String)

Initializes a new instance of the State class with the given property values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal description As String _
)
[C#]
public State(
string id,
string name,
string description
);

Parameters

id
The Id of the object. State IDs must be unique for all state objects contained within a given StateCollection instance.
name
The name of the state.
description
The description of the state.

See Also

State Class | LaMarvin.Constable.Model Namespace | State Constructor Overload List


State Properties

The properties of the State class are listed below. For a complete list of State class members, see the State Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner | Returns the colllection that owns this State object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

State Class | LaMarvin.Constable.Model Namespace


State.Owner Property

Returns the colllection that owns this State object.

[Visual Basic]
Public ReadOnly Property Owner As StateCollection
[C#]
public StateCollection Owner {get;}

Property Value

Reference to the StateCollection that owns the current State object.

See Also

State Class | LaMarvin.Constable.Model Namespace


StateCollection Class

Represents a collection of State objects.

For a list of all members of this type, see StateCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.ComponentModel.ChangeableCollectionBase
LaMarvin.Constable.Model.ObjectCollectionBase
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.StateCollection

[Visual Basic]
<Serializable>
Public Class StateCollection
Inherits NamedObjectCollectionBase
[C#]
[Serializable]
public class StateCollection : NamedObjectCollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

StateCollection Members | LaMarvin.Constable.Model Namespace


StateCollection Members

StateCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the state with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Public Instance Methods

Add | Adds a state to the end of the collection.
AddNew | Creates a new State and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified state in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a state into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a state from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

StateCollection Constructor Initializes a new instance of the StateCollection class and associates it with the given ICollectionUpdater implementation.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection Constructor

Initializes a new instance of the StateCollection class and associates it with the given ICollectionUpdater implementation.

[Visual Basic]
Protected Sub New( _
ByVal updater As ICollectionUpdater _
)
[C#]
protected StateCollection(
ICollectionUpdater updater
);

Parameters

updater

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection Properties

The properties of the StateCollection class are listed below. For a complete list of StateCollection class members, see the StateCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
IsClearAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether the Clear method is currently allowed.
IsInsertAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether an Insert (or Add) operation is currently allowed.
IsRemoveAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Remove operation (or the RemoveAt method call) is currently allowed.
IsSetAllowed (inherited from ChangeableCollectionBase) | Gets a flag indicating whether a Set operation is currently allowed.
Item | Overloaded. Gets the state with the given Id.
Policy (inherited from ObjectCollectionBase) | Returns the AuthorizationPolicy with which this instance is associated.

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
PendingCollectionChangeEventArgs (inherited from ObjectCollectionBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
Updater (inherited from ChangeableCollectionBase) | Sets or returns the associated ICollectionUpdater object.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


Item Property

Constable Authorization Engine 2.0 BETA

StateCollection.Item Property

[This is preliminary documentation and subject to change.]

Gets the state with the given index in the collection.

Overload List

Gets the state with the given index in the collection.

public virtual State this[int] {get;}

Gets the state with the given Id.

public virtual State this[string] {get;}

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection.Item Property

Gets the state with the given index in the collection.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As State
[C#]
public virtual State this[
int index
] {get;}

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace | StateCollection.Item Overload List


StateCollection.Item Property

Gets the state with the given Id.

[Visual Basic]
Overridable Overloads Public Default ReadOnly Property Item( _
ByVal stateId As String _
) As State
[C#]
public virtual State this[
string stateId
] {get;}

Exceptions

Exception Type | Condition
ConstableException | A State with the given is not in the collection.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace | StateCollection.Item Overload List


StateCollection Methods

The methods of the StateCollection class are listed below. For a complete list of StateCollection class members, see the StateCollection Members topic.

Public Instance Methods

Add | Adds a state to the end of the collection.
AddNew | Creates a new State and adds it to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains (inherited from NamedObjectCollectionBase) | Determines whether the object is in the collection.
ContainsId (inherited from NamedObjectCollectionBase) | Determines whether the collection contains an object with the given Id.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Overloaded. Gets the index of the specified state in the collection.
IndexOf (inherited from NamedObjectCollectionBase) | Overloaded. Returns an index of the in the collection.
IndexOfId (inherited from NamedObjectCollectionBase) | Returns an index of the object with the given .
Insert | Inserts a state into the collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
LookupItemByIndex (inherited from NamedObjectCollectionBase) | Retrieves the object at the given index in the collection.
Remove | Removes a state from the collection.
RemoveAt (inherited from NamedObjectCollectionBase) | Overloaded. Removes the object with the given Id from the collection.
RemoveAt (inherited from CollectionBase) | Overloaded. Removes the element at the specified index of the CollectionBase instance.
ToIdArray (inherited from NamedObjectCollectionBase) | Returns an array of Strings with elements set to the Id property values.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LookupItemById (inherited from NamedObjectCollectionBase) | Overloaded. Searches the collections and returns an object with the given Id.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnClearComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnCollectionChanged (inherited from ObjectCollectionBase) | Called after the collection has been changed.
OnCollectionChanging (inherited from ObjectCollectionBase) | Called when the collection is about to be changed.
OnInsert (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnInsertComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnRemove (inherited from ObjectCollectionBase) | Dispatches an appropriate 'changing' event and calls the base class.
OnRemoveComplete (inherited from ObjectCollectionBase) | Calls the base class and dispatches the appropriate 'changed' event.
OnSet (inherited from ChangeableCollectionBase) | Calls the OnSet method implementation of the associated Updater object.
OnSetComplete (inherited from ChangeableCollectionBase) | Calls the OnSetComplete method implementation of the associated Updater object.
OnValidate (inherited from ChangeableCollectionBase) | Calls the OnValidate method implementation of the associated Updater object.
PropagateChangedEvent (inherited from ObjectCollectionBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectCollectionBase) | Propagates the changing event.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection.Add Method

Adds a state to the end of the collection.

[Visual Basic]
Overridable Public Function Add( _
ByVal state As State _
) As Integer
[C#]
public virtual int Add(
State state
);

Parameters

state
The state to be added.

Return Value

The index of the added state.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection.AddNew Method

Creates a new State and adds it to the collection.

[Visual Basic]
Overridable Public Function AddNew( _
ByVal id As String _
) As State
[C#]
public virtual State AddNew(
string id
);

Parameters

id
The Id of the new state.

Return Value

A reference to the newly created state.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


IndexOf Method

Constable Authorization Engine 2.0 BETA

StateCollection.IndexOf Method

[This is preliminary documentation and subject to change.]

Gets the index of the specified state in the collection.

Overload List

Inherited from NamedObjectCollectionBase.

public int IndexOf(NamedObjectBase);

Gets the index of the specified state in the collection.

public virtual int IndexOf(State);

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection.IndexOf Method (State)

Gets the index of the specified state in the collection.

[Visual Basic]
Overridable Overloads Public Function IndexOf( _
ByVal state As State _
) As Integer
[C#]
public virtual int IndexOf(
State state
);

Parameters

state
The state to locate in the collection.

Return Value

The zero-based index of the state within the collection, if found; otherwise, -1.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace | StateCollection.IndexOf Overload List


StateCollection.Insert Method

Inserts a state into the collection.

[Visual Basic]
Overridable Public Sub Insert( _
ByVal index As Integer, _
ByVal state As State _
)
[C#]
public virtual void Insert(
int index,
State state
);

Parameters

index
The index where the state is to be inserted.
state
The state being inserted into the collection.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


StateCollection.Remove Method

Removes a state from the collection.

[Visual Basic]
Overridable Public Sub Remove( _
ByVal state As State _
)
[C#]
public virtual void Remove(
State state
);

Parameters

state
The state to be removed from the collection.

See Also

StateCollection Class | LaMarvin.Constable.Model Namespace


WindowsRole Class

Provides a role implementation that represents a windows security group.

For a list of all members of this type, see WindowsRole Members.

System.Object
LaMarvin.Constable.Model.ObjectBase
LaMarvin.Constable.Model.NamedObjectBase
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Model.WindowsRole

[Visual Basic]
<Serializable>
Public Class WindowsRole
Inherits Role
[C#]
[Serializable]
public class WindowsRole : Role

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The class uses the WindowsGroupName property value for role membership checks.

Requirements

Namespace: LaMarvin.Constable.Model

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

WindowsRole Members | LaMarvin.Constable.Model Namespace


WindowsRole Members

WindowsRole overview

Public Static (Shared) Fields

DomainSubstitutionString | The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the UserDomainName property at runtime.
MachineSubstitutionString | The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the MachineName property at runtime.

Public Instance Constructors

WindowsRole Overloaded. Initializes a new instance of the WindowsRole class.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
WindowsGroupName | Sets or returns the name of the windows security group that is used to check membership to this role.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Checks if the given principal is member of the WindowsGroupName windows security group.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.
ResolveWindowsGroupNameSubstitutions | Replaces the substitution string with current values.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole Constructor

Initializes a new instance of the WindowsRole class with default values.

Overload List

Initializes a new instance of the WindowsRole class with default values.

public WindowsRole(string);

Initializes a new instance of the WindowsRole class with the given Id.

public WindowsRole(string,string);

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole Constructor (String)

Initializes a new instance of the WindowsRole class with default values.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String _
)
[C#]
public WindowsRole(
string id
);

Parameters

id
The Id of the role. Role IDs must be unique for all objects contained within a given RoleCollection instance.

Remarks

All the members except Id are set to empty strings.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace | WindowsRole Constructor Overload List


WindowsRole Constructor (String, String)

Initializes a new instance of the WindowsRole class with the given Id.

[Visual Basic]
Overloads Public Sub New( _
ByVal id As String, _
ByVal windowsGroupName As String _
)
[C#]
public WindowsRole(
string id,
string windowsGroupName
);

Parameters

id
The Id of the object. Role IDs must be unique for all objects contained within a given RoleCollection instance.
windowsGroupName
The name of the windows security group whose membership will be used to define membership within this role.

Remarks

The windowsGroupName can contains substitution strings. See WindowsGroupName for more details.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace | WindowsRole Constructor Overload List


WindowsRole Fields

The fields of the WindowsRole class are listed below. For a complete list of WindowsRole class members, see the WindowsRole Members topic.

Public Static (Shared) Fields

DomainSubstitutionString | The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the UserDomainName property at runtime.
MachineSubstitutionString | The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the MachineName property at runtime.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole.DomainSubstitutionString Field

The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the UserDomainName property at runtime.

[Visual Basic]
Public Const DomainSubstitutionString As String = "{DOMAIN}"
[C#]
public const string DomainSubstitutionString = "{DOMAIN}";

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole.MachineSubstitutionString Field

The domain substitution string that can be specified as part of the WindowsGroupName. Replaced by the value of the MachineName property at runtime.

[Visual Basic]
Public Const MachineSubstitutionString As String = "{MACHINE}"
[C#]
public const string MachineSubstitutionString = "{MACHINE}";

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole Properties

The properties of the WindowsRole class are listed below. For a complete list of WindowsRole class members, see the WindowsRole Members topic.

Public Instance Properties

Description (inherited from NamedObjectBase) | Sets or returns the description of the object.
Id (inherited from NamedObjectBase) | Sets or returns the unique Id of the object.
Name (inherited from NamedObjectBase) | Sets or returns the name of the object.
Owner (inherited from Role) | Returns the RoleCollection instance that owns this Role object.
Policy (inherited from ObjectBase) | Gets a reference to the AuthorizationPolicy instance that contains this object.
WindowsGroupName | Sets or returns the name of the windows security group that is used to check membership to this role.

Protected Instance Properties

OwnerInternal (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.
PendingPropertyChangeEventArgs (inherited from ObjectBase) | This member supports the Constable Authorization Engine (CAZE) infrastructure and is not intended to be used directly from your code.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole.WindowsGroupName Property

Sets or returns the name of the windows security group that is used to check membership to this role.

[Visual Basic]
Overridable Public Property WindowsGroupName As String
[C#]
public virtual string WindowsGroupName {get; set;}

Remarks

The group name can contain the following substitution strings:

  • {MACHINE} will be replaced by the machine name where the code runs (MachineName).
  • {DOMAIN} will be replaced by the current user's domain name (UserDomainName).
See IsInRole for more information.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole Methods

The methods of the WindowsRole class are listed below. For a complete list of WindowsRole class members, see the WindowsRole Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsMember | Checks if the given principal is member of the WindowsGroupName windows security group.
ToString (inherited from NamedObjectBase) | Returns the value of the Id property.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnPropertyChanged (inherited from ObjectBase) | Called after a property of the object has been changed.
OnPropertyChanging (inherited from ObjectBase) | Called when a property of the object is about to be changed.
PropagateChangedEvent (inherited from ObjectBase) | Propagates the changed event.
PropagateChangingEvent (inherited from ObjectBase) | Propagates the changing event.
ResolveWindowsGroupNameSubstitutions | Replaces the substitution string with current values.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole.IsMember Method

Checks if the given principal is member of the WindowsGroupName windows security group.

[Visual Basic]
Overrides Public Function IsMember( _
ByVal principal As IPrincipal _
) As Boolean
[C#]
public override bool IsMember(
IPrincipal principal
);

Parameters

principal
The principal reference.

Return Value

Returns true is the principal is member of the associated windows group; false otherwise.

Remarks

If the principal is not an instance of the WindowsPrincipal class, the method returns false.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


WindowsRole.ResolveWindowsGroupNameSubstitutions Method

Replaces the substitution string with current values.

[Visual Basic]
Overridable Protected Function ResolveWindowsGroupNameSubstitutions( _
ByVal name As String _
) As String
[C#]
protected virtual string ResolveWindowsGroupNameSubstitutions(
string name
);

Parameters

name
The name of the windows group whose substitution strings have to be replaced.

Return Value

Returns name with substitution strings replaced by the corresponding current values.

Remarks

The substitutions are case insensitive.

See Also

WindowsRole Class | LaMarvin.Constable.Model Namespace


LaMarvin.Constable.Principal

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Principal Namespace

[This is preliminary documentation and subject to change.]

The namespace contains custom IPrincipal implementations useful for authorization policy testing and extensions.

Namespace hierarchy

Classes

Class | Description
DynamicPrincipal | Provides an implementation of the IPrincipal interface whose role membership can be controlled by setting the IsInRoleResult property.
ExtendedPrincipal | Provides an implementation of the IPrincipal interface with dynamic list of roles.


DynamicPrincipal Class

Provides an implementation of the IPrincipal interface whose role membership can be controlled by setting the IsInRoleResult property.

For a list of all members of this type, see DynamicPrincipal Members.

System.Object
LaMarvin.Constable.Principal.DynamicPrincipal

[Visual Basic]
<Serializable>
Public Class DynamicPrincipal
Implements IPrincipal
[C#]
[Serializable]
public class DynamicPrincipal : IPrincipal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is useful primarily for testing scenarios, where you can achieve principals in all roles / no roles with a simple setting of the IsInRoleResult property.

Example

The following example populates a very simple authorization model, associates the model with an "almighty" principal (who is member of all roles) and then asserts some implied facts. The principal is the turned to an "infirm" principal and once again, some implied facts are asserted.

[Visual Basic]
Imports System
Imports System.Diagnostics

Imports LaMarvin.Constable
Imports LaMarvin.Constable.Model
Imports LaMarvin.Constable.Principal

' Create and populate the policy.
Dim policy As New AuthorizationPolicy
policy.States.AddNew("")  ' default state
policy.Roles.AddNew("User")
policy.Roles.AddNew("Admin")
policy.Actions.AddNew("LogOff")
policy.Actions.AddNew("ShutDown")
policy.ActionRules.AddNew("LogOff", "User")
policy.ActionRules.AddNew("LogOff", "Admin")
policy.ActionRules.AddNew("ShutDown", "Admin")

' Associate the model with an "almighty" principal
policy.CurrentPrincipal = New DynamicPrincipal(True)
Debug.Assert(policy.IsActionExecutable("LogOff"))
Debug.Assert(policy.IsActionExecutable("ShutDown"))

' Make the principal "infirm" :-)
DirectCast(policy.CurrentPrincipal, DynamicPrincipal).IsInRoleResult = False
Debug.Assert(Not policy.IsActionExecutable("LogOff"))
Debug.Assert(Not policy.IsActionExecutable("ShutDown"))

[C#]
using System;
using System.Diagnostics;

using LaMarvin.Constable;
using LaMarvin.Constable.Model;
using LaMarvin.Constable.Principal;

// Create and populate the policy.
AuthorizationPolicy policy = new AuthorizationPolicy();
policy.States.AddNew("");  // default state
policy.Roles.AddNew("User");
policy.Roles.AddNew("Admin");
policy.Actions.AddNew("LogOff");
policy.Actions.AddNew("ShutDown");
policy.ActionRules.AddNew("LogOff", "User");
policy.ActionRules.AddNew("LogOff", "Admin");
policy.ActionRules.AddNew("ShutDown", "Admin");

// Associate the model with an "almighty" principal
policy.CurrentPrincipal = new DynamicPrincipal(true);
Debug.Assert(policy.IsActionExecutable("LogOff"));
Debug.Assert(policy.IsActionExecutable("ShutDown"));

// Make the principal "infirm" :-)
((DynamicPrincipal)policy.CurrentPrincipal).IsInRoleResult = false;
Debug.Assert(!policy.IsActionExecutable("LogOff"));
Debug.Assert(!policy.IsActionExecutable("ShutDown"));

Requirements

Namespace: LaMarvin.Constable.Principal

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

DynamicPrincipal Members | LaMarvin.Constable.Principal Namespace


DynamicPrincipal Members

DynamicPrincipal overview

Public Instance Constructors

DynamicPrincipal Overloaded. Initializes a new instance of the DynamicPrincipal class.

Public Instance Properties

Identity | Gets the associated IIdentity of this principal.
IsInRoleResult | Sets or returns a flag that determines the return value of the IsInRole method.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInRole | Returns the value of the IsInRoleResult property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal Constructor

Initializes a new instance of the DynamicPrincipal object.

Overload List

Initializes a new instance of the DynamicPrincipal object with the current WindowsIdentity and the IsInRoleResult property set to false.

public DynamicPrincipal();

Initializes a new instance of the DynamicPrincipal object with the current WindowsIdentity and the IsInRoleResult property set to the isInRoleResult value.

public DynamicPrincipal(bool);

Initializes a new instance of the DynamicPrincipal object with the given identity and the IsInRoleResult property set to the false.

public DynamicPrincipal(IIdentity);

Initializes a new instance of the DynamicPrincipal object.

public DynamicPrincipal(IIdentity,bool);

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal Constructor (IIdentity, Boolean)

Initializes a new instance of the DynamicPrincipal object.

[Visual Basic]
Overloads Public Sub New( _
ByVal identity As IIdentity, _
ByVal isInRoleResult As Boolean _
)
[C#]
public DynamicPrincipal(
IIdentity identity,
bool isInRoleResult
);

Parameters

identity
The IIdentity implementation to associate with the current instance.
isInRoleResult
The initial value for the IsInRoleResult property.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as a value of the identity argument.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace | DynamicPrincipal Constructor Overload List


DynamicPrincipal Constructor ()

Initializes a new instance of the DynamicPrincipal object with the current WindowsIdentity and the IsInRoleResult property set to false.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DynamicPrincipal();

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace | DynamicPrincipal Constructor Overload List


DynamicPrincipal Constructor (IIdentity)

Initializes a new instance of the DynamicPrincipal object with the given identity and the IsInRoleResult property set to the false.

[Visual Basic]
Overloads Public Sub New( _
ByVal identity As IIdentity _
)
[C#]
public DynamicPrincipal(
IIdentity identity
);

Parameters

identity
The IIdentity implementation to associate with the current instance.

Exceptions

Exception Type | Condition
ArgumentNullException | A a null reference (Nothing in Visual Basic) was passed as a value of the identity argument.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace | DynamicPrincipal Constructor Overload List


DynamicPrincipal Constructor (Boolean)

Initializes a new instance of the DynamicPrincipal object with the current WindowsIdentity and the IsInRoleResult property set to the isInRoleResult value.

[Visual Basic]
Overloads Public Sub New( _
ByVal isInRoleResult As Boolean _
)
[C#]
public DynamicPrincipal(
bool isInRoleResult
);

Parameters

isInRoleResult
The initial value for the IsInRoleResult property.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace | DynamicPrincipal Constructor Overload List


DynamicPrincipal Properties

The properties of the DynamicPrincipal class are listed below. For a complete list of DynamicPrincipal class members, see the DynamicPrincipal Members topic.

Public Instance Properties

Identity | Gets the associated IIdentity of this principal.
IsInRoleResult | Sets or returns a flag that determines the return value of the IsInRole method.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal.Identity Property

Gets the associated IIdentity of this principal.

[Visual Basic]
Overridable Public ReadOnly Property Identity As IIdentity _
Implements IPrincipal.Identity
[C#]
public virtual System.Security.Principal.IIdentity Identity {get;}

Implements

IPrincipal.Identity

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal.IsInRoleResult Property

Sets or returns a flag that determines the return value of the IsInRole method.

[Visual Basic]
Overridable Public Property IsInRoleResult As Boolean
[C#]
public virtual bool IsInRoleResult {get; set;}

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal Methods

The methods of the DynamicPrincipal class are listed below. For a complete list of DynamicPrincipal class members, see the DynamicPrincipal Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInRole | Returns the value of the IsInRoleResult property.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


DynamicPrincipal.IsInRole Method

Returns the value of the IsInRoleResult property.

[Visual Basic]
Overridable Public Function IsInRole( _
ByVal role As String _
) As Boolean _
Implements IPrincipal.IsInRole
[C#]
public virtual bool IsInRole(
string role
);

Parameters

role
The role name is not used by this implementation.

Return Value

The value of the IsInRoleResult property.

Implements

IPrincipal.IsInRole

See Also

DynamicPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal Class

Provides an implementation of the IPrincipal interface with dynamic list of roles.

For a list of all members of this type, see ExtendedPrincipal Members.

System.Object
LaMarvin.Constable.Principal.ExtendedPrincipal

[Visual Basic]
<Serializable>
NotInheritable Public Class ExtendedPrincipal
Implements IPrincipal
[C#]
[Serializable]
public sealed class ExtendedPrincipal : IPrincipal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example illustrates how the class can be used to implement custom role resolution mechanisms:

[Visual Basic]
' This creates a new ExtendedPrincipal associated with the current
' user's windows identity.
Dim principal As ExtendedPrincipal = New ExtendedPrincipal(WindowsIdentity.GetCurrent())

' The principal has no explicit roles defined, so the following assert
' must be true:
Debug.Assert(Not principal.IsInRole("User"))

' Let's add the principal to the User role and verify membership.
principal.Roles.AddNew("User")
Debug.Assert(principal.IsInRole("User"))

' Now replace the User role with a WindowsRole, which maps to the
' local users Windows group.
principal.Roles.RemoveAt("User")
principal.Roles.Add(New WindowsRole("User", "BUILTIN\Users"))

' The following statement actually checks membership in the
' local users Windows group. This possible because the ExtendedPrincipal
' is associated with a WindowsIdentity and the User role is an instance
' of the WindowsRole class.
Debug.Assert(principal.IsInRole("User"))

[C#]
// This creates a new ExtendedPrincipal associated with the current
// user's windows identity.
ExtendedPrincipal principal = new ExtendedPrincipal(WindowsIdentity.GetCurrent());

// The principal has no explicit roles defined, so the following assert
// must be true:
Debug.Assert(!principal.IsInRole("User"));

// Let's add the principal to the User role and verify membership.
principal.Roles.AddNew("User");
Debug.Assert(principal.IsInRole("User"));

// Now replace the User role with a WindowsRole, which maps to the
// local users Windows group.
principal.Roles.RemoveAt("User");
principal.Roles.Add(new WindowsRole("User", @"BUILTIN\Users"));

// The following statement actually checks membership in the
// local users Windows group. This possible because the ExtendedPrincipal
// is associated with a WindowsIdentity and the User role is an instance
// of the WindowsRole class.
Debug.Assert(principal.IsInRole("User"));

Requirements

Namespace: LaMarvin.Constable.Principal

Assembly: LaMarvin.Constable (in LaMarvin.Constable.dll)

See Also

ExtendedPrincipal Members | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal Members

ExtendedPrincipal overview

Public Instance Constructors

ExtendedPrincipal Overloaded. Initializes a new instance of the ExtendedPrincipal class.

Public Instance Properties

Identity | Gets the associated IIdentity of this principal.
Roles | Gets the collection of Roles of the principal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInRole | Determines whether the principal is in the given role.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal Constructor

Initializes a new instance of the ExtendedPrincipal class.

Overload List

Initializes a new instance of the ExtendedPrincipal class.

public ExtendedPrincipal();

Initializes a new instance of the ExtendedPrincipal class with the given identity.

public ExtendedPrincipal(IIdentity);

Initializes a new instance of the ExtendedPrincipal class with the given identity and a set of roles.

public ExtendedPrincipal(IIdentity,string[]);

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal Constructor ()

Initializes a new instance of the ExtendedPrincipal class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ExtendedPrincipal();

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace | ExtendedPrincipal Constructor Overload List


ExtendedPrincipal Constructor (IIdentity)

Initializes a new instance of the ExtendedPrincipal class with the given identity.

[Visual Basic]
Overloads Public Sub New( _
ByVal identity As IIdentity _
)
[C#]
public ExtendedPrincipal(
IIdentity identity
);

Parameters

identity

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace | ExtendedPrincipal Constructor Overload List


ExtendedPrincipal Constructor (IIdentity, String[])

Initializes a new instance of the ExtendedPrincipal class with the given identity and a set of roles.

[Visual Basic]
Overloads Public Sub New( _
ByVal identity As IIdentity, _
ByVal roles As String() _
)
[C#]
public ExtendedPrincipal(
IIdentity identity,
string[] roles
);

Parameters

identity
roles

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace | ExtendedPrincipal Constructor Overload List


ExtendedPrincipal Properties

The properties of the ExtendedPrincipal class are listed below. For a complete list of ExtendedPrincipal class members, see the ExtendedPrincipal Members topic.

Public Instance Properties

Identity | Gets the associated IIdentity of this principal.
Roles | Gets the collection of Roles of the principal.

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal.Identity Property

Gets the associated IIdentity of this principal.

[Visual Basic]
NotOverridable Public ReadOnly Property Identity As IIdentity _
Implements IPrincipal.Identity
[C#]
public System.Security.Principal.IIdentity Identity {get;}

Implements

IPrincipal.Identity

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal.Roles Property

Gets the collection of Roles of the principal.

[Visual Basic]
Public ReadOnly Property Roles As RoleCollection
[C#]
public LaMarvin.Constable.Model.RoleCollection Roles {get;}

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal Methods

The methods of the ExtendedPrincipal class are listed below. For a complete list of ExtendedPrincipal class members, see the ExtendedPrincipal Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInRole | Determines whether the principal is in the given role.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


ExtendedPrincipal.IsInRole Method

Determines whether the principal is in the given role.

[Visual Basic]
NotOverridable Public Function IsInRole( _
ByVal role As String _
) As Boolean _
Implements IPrincipal.IsInRole
[C#]
public bool IsInRole(
string role
);

Parameters

role
The Id of the role whose membership is to be determined.

Return Value

true is the ExtendedPrincipal is member of the role; false otherwise.

Implements

IPrincipal.IsInRole

See Also

ExtendedPrincipal Class | LaMarvin.Constable.Principal Namespace


LaMarvin.Data

Constable Authorization Engine 2.0 BETA

LaMarvin.Data Namespace

[This is preliminary documentation and subject to change.]

Exposes types helping to implement application's data access layers connecting to Microsoft SQL Server databases.

Namespace hierarchy

Classes

Class | Description
DataBase | Provides a base class for implementing data access layer (DAL) components connecting to Microsoft SQL Server databases.
DataHelper | Commonly used conversion methods useful when working with databases.


DataBase Class

Provides a base class for implementing data access layer (DAL) components connecting to Microsoft SQL Server databases.

For a list of all members of this type, see DataBase Members.

System.Object
System.MarshalByRefObject
LaMarvin.Data.DataBase

[Visual Basic]
Public Class DataBase
Inherits MarshalByRefObject
Implements IDisposable
[C#]
public class DataBase : MarshalByRefObject, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Data

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

DataBase Members | LaMarvin.Data Namespace


DataBase Members

DataBase overview

Public Instance Constructors

DataBase Constructor Initializes a new instance of a DataBase-derived class.

Public Instance Properties

Connection | Returns a reference to the underlying SqlConnection object.
Transaction | Returns a reference to the underlying SqlTransaction object.

Public Instance Methods

Commit | Commits the transaction (if any) and disposes of the instance.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateStoredProcedureCommand | Creates and initializes a new command that executes a stored procedure.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillDataSet | Executes the command and returns a DataSet filled by the resultset(s) generated by the command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Rollback | Rollbacks the transaction (if any) and disposes of the instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsDisposed Returns a flag indiciating whether this instance has been disposed.

Protected Instance Methods

DisposeManagedResources | Disposes mamanged resources allocated by this instance.
DisposeUnmanagedResources | Disposes unmamanged resources allocated by this instance.
Finalize | Finalizes the instance by disposing unmanaged resources, if neccessary.
CheckDisposed | If the instance has been disposed, throws the ObjectDisposedException.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase Constructor

Initializes a new instance of a DataBase-derived class.

[Visual Basic]
Public Sub New( _
ByVal connectionString As String, _
ByVal startTransaction As Boolean _
)
[C#]
public DataBase(
string connectionString,
bool startTransaction
);

Parameters

connectionString
A valid conection string for connecting to a Microsoft SQL Server databae.
startTransaction
true if a transaction should be started; false otherwise.

Remarks

If a transaction is started, it always uses the Serializable isolation level.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase Properties

The properties of the DataBase class are listed below. For a complete list of DataBase class members, see the DataBase Members topic.

Public Instance Properties

Connection | Returns a reference to the underlying SqlConnection object.
Transaction | Returns a reference to the underlying SqlTransaction object.

Protected Instance Properties

IsDisposed Returns a flag indiciating whether this instance has been disposed.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.Connection Property

Returns a reference to the underlying SqlConnection object.

[Visual Basic]
Public ReadOnly Property Connection As SqlConnection
[C#]
public System.Data.SqlClient.SqlConnection Connection {get;}

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.IsDisposed Property

Returns a flag indiciating whether this instance has been disposed.

[Visual Basic]
Protected ReadOnly Property IsDisposed As Boolean
[C#]
protected bool IsDisposed {get;}

Property Value

true if this instance has been disposed; false otherwise.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.Transaction Property

Returns a reference to the underlying SqlTransaction object.

[Visual Basic]
Public ReadOnly Property Transaction As SqlTransaction
[C#]
public System.Data.SqlClient.SqlTransaction Transaction {get;}

Property Value

A valid reference to the active SqlTransaction or a null reference (Nothing in Visual Basic) if a transaction has not been started.

See Also

DataBase Class | LaMarvin.Data Namespace | ctor


DataBase Methods

The methods of the DataBase class are listed below. For a complete list of DataBase class members, see the DataBase Members topic.

Public Instance Methods

Commit | Commits the transaction (if any) and disposes of the instance.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateStoredProcedureCommand | Creates and initializes a new command that executes a stored procedure.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FillDataSet | Executes the command and returns a DataSet filled by the resultset(s) generated by the command.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Rollback | Rollbacks the transaction (if any) and disposes of the instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

DisposeManagedResources | Disposes mamanged resources allocated by this instance.
DisposeUnmanagedResources | Disposes unmamanged resources allocated by this instance.
Finalize | Finalizes the instance by disposing unmanaged resources, if neccessary.
CheckDisposed | If the instance has been disposed, throws the ObjectDisposedException.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.Commit Method

Commits the transaction (if any) and disposes of the instance.

[Visual Basic]
Public Sub Commit()
[C#]
public void Commit();

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.CreateStoredProcedureCommand Method

Creates and initializes a new command that executes a stored procedure.

[Visual Basic]
Public Function CreateStoredProcedureCommand( _
ByVal procedureName As String, _
ParamArray args As Object() _
) As SqlCommand
[C#]
public SqlCommand CreateStoredProcedureCommand(
string procedureName,
params object[] args
);

Parameters

procedureName
The name of the stored procedure to be invoked using the underlying Connection.
args
An array of argument name, argument value pairs to be passed to the stored procedure.

Return Value

Returns an initialized SqlCommand instance.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.DisposeManagedResources Method

Disposes mamanged resources allocated by this instance.

[Visual Basic]
Overridable Protected Sub DisposeManagedResources()
[C#]
protected virtual void DisposeManagedResources();

Remarks

CAUTION If you override this method, always call the base class implementation, otherwise you might leak database connections!

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.DisposeUnmanagedResources Method

Disposes unmamanged resources allocated by this instance.

[Visual Basic]
Overridable Protected Sub DisposeUnmanagedResources()
[C#]
protected virtual void DisposeUnmanagedResources();

Remarks

This implementation doesn't allocate any unmanaged resources, so this method does nothing.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.FillDataSet Method

Executes the command and returns a DataSet filled by the resultset(s) generated by the command.

[Visual Basic]
Public Function FillDataSet( _
ByVal cmd As SqlCommand _
) As DataSet
[C#]
public DataSet FillDataSet(
SqlCommand cmd
);

Parameters

cmd
The SqlCommand to be executed.

Return Value

Returns a new DataSet instance populated by the cmd.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.Finalize Method

Finalizes the instance by disposing unmanaged resources, if neccessary.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

Remarks

CAUTION In DEBUG builds, the finalizer will Assert if you've forgotten to call the Commit, Rollback or the Dispose method after using it.

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.CheckDisposed Method

If the instance has been disposed, throws the ObjectDisposedException.

[Visual Basic]
Protected Sub CheckDisposed()
[C#]
protected void CheckDisposed();

See Also

DataBase Class | LaMarvin.Data Namespace


DataBase.Rollback Method

Rollbacks the transaction (if any) and disposes of the instance.

[Visual Basic]
Public Sub Rollback()
[C#]
public void Rollback();

See Also

DataBase Class | LaMarvin.Data Namespace


DataHelper Class

Commonly used conversion methods useful when working with databases.

For a list of all members of this type, see DataHelper Members.

System.Object
LaMarvin.Data.DataHelper

[Visual Basic]
NotInheritable Public Class DataHelper
[C#]
public sealed class DataHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Data

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

DataHelper Members | LaMarvin.Data Namespace


DataHelper Members

DataHelper overview

Public Static (Shared) Methods

IntFromDB | Overloaded. Safely converts an integer value read from database.
StringFromDB | Overloaded. Safely converts a string value read from database.
StringToDB | Converts a a null reference (Nothing in Visual Basic) string reference to a DBNull value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DataHelper Class | LaMarvin.Data Namespace


DataHelper Methods

The methods of the DataHelper class are listed below. For a complete list of DataHelper class members, see the DataHelper Members topic.

Public Static (Shared) Methods

IntFromDB | Overloaded. Safely converts an integer value read from database.
StringFromDB | Overloaded. Safely converts a string value read from database.
StringToDB | Converts a a null reference (Nothing in Visual Basic) string reference to a DBNull value.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DataHelper Class | LaMarvin.Data Namespace


IntFromDB Method

Constable Authorization Engine 2.0 BETA

DataHelper.IntFromDB Method

[This is preliminary documentation and subject to change.]

Safely converts an integer value read from database.

Overload List

Safely converts an integer value read from database.

public static int IntFromDB(object);

Safely converts an integer value read from database.

public static int IntFromDB(object,int);

See Also

DataHelper Class | LaMarvin.Data Namespace


DataHelper.IntFromDB Method (Object)

Safely converts an integer value read from database.

[Visual Basic]
Overloads Public Shared Function IntFromDB( _
ByVal i As Object _
) As Integer
[C#]
public static int IntFromDB(
object i
);

Parameters

i

Return Value

See Also

DataHelper Class | LaMarvin.Data Namespace | DataHelper.IntFromDB Overload List


DataHelper.IntFromDB Method (Object, Int32)

Safely converts an integer value read from database.

[Visual Basic]
Overloads Public Shared Function IntFromDB( _
ByVal i As Object, _
ByVal defaultValue As Integer _
) As Integer
[C#]
public static int IntFromDB(
object i,
int defaultValue
);

Parameters

i
defaultValue

Return Value

See Also

DataHelper Class | LaMarvin.Data Namespace | DataHelper.IntFromDB Overload List


StringFromDB Method

Constable Authorization Engine 2.0 BETA

DataHelper.StringFromDB Method

[This is preliminary documentation and subject to change.]

Safely converts a string value read from database.

Overload List

Safely converts a string value read from database.

public static string StringFromDB(object);

Safely converts a string value read from database.

public static string StringFromDB(object,string);

See Also

DataHelper Class | LaMarvin.Data Namespace


DataHelper.StringFromDB Method (Object)

Safely converts a string value read from database.

[Visual Basic]
Overloads Public Shared Function StringFromDB( _
ByVal str As Object _
) As String
[C#]
public static string StringFromDB(
object str
);

Parameters

str

Return Value

See Also

DataHelper Class | LaMarvin.Data Namespace | DataHelper.StringFromDB Overload List


DataHelper.StringFromDB Method (Object, String)

Safely converts a string value read from database.

[Visual Basic]
Overloads Public Shared Function StringFromDB( _
ByVal str As Object, _
ByVal defaultValue As String _
) As String
[C#]
public static string StringFromDB(
object str,
string defaultValue
);

Parameters

str
defaultValue

Return Value

See Also

DataHelper Class | LaMarvin.Data Namespace | DataHelper.StringFromDB Overload List


DataHelper.StringToDB Method

Converts a a null reference (Nothing in Visual Basic) string reference to a DBNull value.

[Visual Basic]
Public Shared Function StringToDB( _
ByVal str As Object _
) As Object
[C#]
public static object StringToDB(
object str
);

Parameters

str

Return Value

See Also

DataHelper Class | LaMarvin.Data Namespace


LaMarvin.Design

Constable Authorization Engine 2.0 BETA

LaMarvin.Design Namespace

[This is preliminary documentation and subject to change.]

The namespace contains the central Context static (Shared in Visual Basic) class and supporting types.

Namespace hierarchy

Classes

Class | Description
Context | This is a central repository of design-related objects and metadata used by various parts of the LaMarvin design infrastructure.
Context.Registry | Provides methods for registering and unregistering TypeInfo objects describing types usable for the design infrastructure.
InstanceDesignerVerb | Represents a DesignerVerb associated with an object.
TypeInfo | Contains additional metadata describing a Type that are not part of the TypeDescriptor infrastructure.
UserCancelledException | The exception is thrown by the design infrastructure if the user cancels an operation.
VisualInfo | Summarizes properties that describe displayable programmatic entities.

Interfaces

Interface | Description
ICustomInstanceEntryDisplay | The interface represents a contract used by the InstanceView control to customize the appearance of objects from the associated object graph (RootInstance).
IDesignApplicationHost | This interface supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

Delegates

Delegate | Description
Context.AssemblyFilterDelegate | Defines a signature for methods that can be passed to the GetAvailableTypes method to filter the set of assemblies traversed by the method.
Context.TypeFilterDelegate | Defines a signature for methods that can be passed to the GetAvailableTypes method to filter the set of types traversed by the method.

Enumerations

Enumeration | Description
InstanceEntryDisplayProperties | Specifies which display-related properties exposed by an ICustomInstanceEntryDisplay implementation should be used to customize the appearance of an entry in the InstanceView control.


Context Class

This is a central repository of design-related objects and metadata used by various parts of the LaMarvin design infrastructure.

For a list of all members of this type, see Context Members.

System.Object
LaMarvin.Design.Context

[Visual Basic]
NotInheritable Public Class Context
[C#]
public sealed class Context

Thread Safety

This type is not safe for multithreaded operations.

Remarks

The Context class subsumes the following functionality:

  • Shared image list.
  • Registry for TypeInfo objects.
  • Type enumeration and filtering.

The SmallImageList property represents an image list that is shared by all LaMarvin design controls. The images in the list are identified by arbitrary keys. You can add images to the shared list by using the AddSmallImage and GetResourceImage methods. You can remove shared images by calling the RemoveSmallImage method. You can map image keys to indexes in the image list by using the GetSmallImageIndex method.

The Context class maintains a table of TypeInfo objects keyed by the corresponding Type reference. You can register and unregister TypeInfo objects by calling the RegisterTypeInfo and UnregisterTypeInfo methods. You can retrieve registered TypeInfo objects by calling the GetTypeInfo overloaded method. TypeInfo objects are also registered automatically when querying for types decorated by the TypeInfoAttribute attribute.

The GetAvailableTypes and GetAvailableTypeInfos methods represent a flexible mechanism for enumerating and filtering types according to arbitrary criteria.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

Context Members | LaMarvin.Design Namespace


Context Members

Context overview

Public Static (Shared) Properties

DefaultLargeTypeImage | Returns the default large (32x32) image.
DefaultSmallTypeImage | Returns the default small (16x16) image.
DesignHost | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
SmallImageList | Returns a reference to the image list shared by all controls in the current AppDomain.

Public Static (Shared) Methods

AddSmallImage | Adds the image to the shared SmallImageList.Images collection.
GetAvailablePublicCreatableTypeInfos | Returns an array of TypeInfo objects representing public, non-abstract types compatible with the baseType available in the current AppDomain.
GetAvailablePublicCreatableTypes | Returns an array of public, non-abstract types compatible with the baseType available in the current AppDomain.
GetAvailableTypeInfos | Gets an array of TypeInfo objects for types that match the specified typeFilter from assemblies that match the specified assemblyFilter.
GetAvailableTypes | Gets the types that match the specified typeFilter from assemblies that match the specified assemblyFilter.
GetResourceImage | Overloaded. Loads the specified image resource from the specified resource assembly.
GetResourceSmallImageIndex | Gets the index of the small resource image.
GetSmallImageIndex | Gets the index of the image in the SmallImageList.Images collection.
GetSmallImageIndexForType | Gets the index of the small type image in the SmallImageList.Images collection.
GetTypeInfo | Overloaded. Gets a TypeInfo object describing the given type
IsNonSystemAssemblyFilter | Determines if the assembly is not one of the .NET Framework system assemblies.
IsPublicCreatableTypeFilter | Determines if the currentType is public, non-abstract type compatible with the baseType.
PreloadAssembly | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
RemoveSmallImage | Removes the image with the specified key from the shared SmallImageList.Images collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Context Class | LaMarvin.Design Namespace


Context Properties

The properties of the Context class are listed below. For a complete list of Context class members, see the Context Members topic.

Public Static (Shared) Properties

DefaultLargeTypeImage | Returns the default large (32x32) image.
DefaultSmallTypeImage | Returns the default small (16x16) image.
DesignHost | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
SmallImageList | Returns a reference to the image list shared by all controls in the current AppDomain.

See Also

Context Class | LaMarvin.Design Namespace


Context.DefaultLargeTypeImage Property

Returns the default large (32x32) image.

[Visual Basic]
Public Shared ReadOnly Property DefaultLargeTypeImage As Image
[C#]
public static System.Drawing.Image DefaultLargeTypeImage {get;}

See Also

Context Class | LaMarvin.Design Namespace


Context.DefaultSmallTypeImage Property

Returns the default small (16x16) image.

[Visual Basic]
Public Shared ReadOnly Property DefaultSmallTypeImage As Image
[C#]
public static System.Drawing.Image DefaultSmallTypeImage {get;}

See Also

Context Class | LaMarvin.Design Namespace


Context.DesignHost Property

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Property DesignHost As IDesignApplicationHost
[C#]
public static IDesignApplicationHost DesignHost {get; set;}

See Also

Context Class | LaMarvin.Design Namespace


Context.SmallImageList Property

Returns a reference to the image list shared by all controls in the current AppDomain.

[Visual Basic]
Public Shared ReadOnly Property SmallImageList As ImageList
[C#]
public static System.Windows.Forms.ImageList SmallImageList {get;}

Remarks

CAUTION You shouldn't manipulate the SmallImageList.Images image collection directly. Instead, you should use the Context class methods AddSmallImage, GetResourceImage and RemoveSmallImage to manage images in the collection.

See Also

Context Class | LaMarvin.Design Namespace


Context Methods

The methods of the Context class are listed below. For a complete list of Context class members, see the Context Members topic.

Public Static (Shared) Methods

AddSmallImage | Adds the image to the shared SmallImageList.Images collection.
GetAvailablePublicCreatableTypeInfos | Returns an array of TypeInfo objects representing public, non-abstract types compatible with the baseType available in the current AppDomain.
GetAvailablePublicCreatableTypes | Returns an array of public, non-abstract types compatible with the baseType available in the current AppDomain.
GetAvailableTypeInfos | Gets an array of TypeInfo objects for types that match the specified typeFilter from assemblies that match the specified assemblyFilter.
GetAvailableTypes | Gets the types that match the specified typeFilter from assemblies that match the specified assemblyFilter.
GetResourceImage | Overloaded. Loads the specified image resource from the specified resource assembly.
GetResourceSmallImageIndex | Gets the index of the small resource image.
GetSmallImageIndex | Gets the index of the image in the SmallImageList.Images collection.
GetSmallImageIndexForType | Gets the index of the small type image in the SmallImageList.Images collection.
GetTypeInfo | Overloaded. Gets a TypeInfo object describing the given type
IsNonSystemAssemblyFilter | Determines if the assembly is not one of the .NET Framework system assemblies.
IsPublicCreatableTypeFilter | Determines if the currentType is public, non-abstract type compatible with the baseType.
PreloadAssembly | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
RemoveSmallImage | Removes the image with the specified key from the shared SmallImageList.Images collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Context Class | LaMarvin.Design Namespace


Context.AddSmallImage Method

Adds the image to the shared SmallImageList.Images collection.

[Visual Basic]
Public Shared Function AddSmallImage( _
ByVal image As Image, _
ByVal imageKey As Object _
) As Integer
[C#]
public static int AddSmallImage(
Image image,
object imageKey
);

Parameters

image
The image to be added.
imageKey
The key of the image.

Return Value

Returns the index of the image in the SmallImageList.Images collection.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetAvailablePublicCreatableTypeInfos Method

Returns an array of TypeInfo objects representing public, non-abstract types compatible with the baseType available in the current AppDomain.

[Visual Basic]
Public Shared Function GetAvailablePublicCreatableTypeInfos( _
ByVal baseType As Type _
) As TypeInfo()
[C#]
public static TypeInfo[] GetAvailablePublicCreatableTypeInfos(
Type baseType
);

Parameters

baseType
The base type.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetAvailablePublicCreatableTypes Method

Returns an array of public, non-abstract types compatible with the baseType available in the current AppDomain.

[Visual Basic]
Public Shared Function GetAvailablePublicCreatableTypes( _
ByVal baseType As Type _
) As Type()
[C#]
public static Type[] GetAvailablePublicCreatableTypes(
Type baseType
);

Parameters

baseType
The base type.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetAvailableTypeInfos Method

Gets an array of TypeInfo objects for types that match the specified typeFilter from assemblies that match the specified assemblyFilter.

[Visual Basic]
Public Shared Function GetAvailableTypeInfos( _
ByVal baseType As Type, _
ByVal assemblyFilter As AssemblyFilterDelegate, _
ByVal typeFilter As TypeFilterDelegate _
) As TypeInfo()
[C#]
public static TypeInfo[] GetAvailableTypeInfos(
Type baseType,
AssemblyFilterDelegate assemblyFilter,
TypeFilterDelegate typeFilter
);

Parameters

baseType
The base type with which the found types should be compatible.
assemblyFilter
The assembly filter.
typeFilter
The type filter.

Return Value

Array of TypeInfos matching the specified typeFilter in assemblies that match the assemblyFilter.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetAvailableTypes Method

Gets the types that match the specified typeFilter from assemblies that match the specified assemblyFilter.

[Visual Basic]
Public Shared Function GetAvailableTypes( _
ByVal baseType As Type, _
ByVal assemblyFilter As AssemblyFilterDelegate, _
ByVal typeFilter As TypeFilterDelegate _
) As Type()
[C#]
public static Type[] GetAvailableTypes(
Type baseType,
AssemblyFilterDelegate assemblyFilter,
TypeFilterDelegate typeFilter
);

Parameters

baseType
The base type with which the found types should be compatible.
assemblyFilter
The assembly filter.
typeFilter
The type filter.

Return Value

Array of Types matching the specified typeFilter in assemblies that match the specified assemblyFilter.

See Also

Context Class | LaMarvin.Design Namespace


GetResourceImage Method

Constable Authorization Engine 2.0 BETA

Context.GetResourceImage Method

[This is preliminary documentation and subject to change.]

Loads the specified image resource from the calling assembly.

Overload List

Loads the specified image resource from the calling assembly.

public static Image GetResourceImage(string);

Loads the specified image resource from the specified resource assembly.

public static Image GetResourceImage(string,Assembly);

See Also

Context Class | LaMarvin.Design Namespace


Context.GetResourceImage Method (String)

Loads the specified image resource from the calling assembly.

[Visual Basic]
Overloads Public Shared Function GetResourceImage( _
ByVal resourceId As String _
) As Image
[C#]
public static Image GetResourceImage(
string resourceId
);

Parameters

resourceId
The ID of the image resource in the calling assembly.

Return Value

A reference to the loaded Image.

See Also

Context Class | LaMarvin.Design Namespace | Context.GetResourceImage Overload List


Context.GetResourceImage Method (String, Assembly)

Loads the specified image resource from the specified resource assembly.

[Visual Basic]
Overloads Public Shared Function GetResourceImage( _
ByVal resourceId As String, _
ByVal resourceAssembly As Assembly _
) As Image
[C#]
public static Image GetResourceImage(
string resourceId,
Assembly resourceAssembly
);

Parameters

resourceId
The ID of the image resource in the resourceAssembly assembly.
resourceAssembly
The assembly that contains the image resource.

Return Value

A reference to the loaded Image.

See Also

Context Class | LaMarvin.Design Namespace | Context.GetResourceImage Overload List


Context.GetResourceSmallImageIndex Method

Gets the index of the small resource image.

[Visual Basic]
Public Shared Function GetResourceSmallImageIndex( _
ByVal resourceId As String _
) As Integer
[C#]
public static int GetResourceSmallImageIndex(
string resourceId
);

Parameters

resourceId
The ID of the image resource.

Return Value

The index of the image in the SmallImageList collection.

Remarks

The resourceId is used as the image key for the resource image. If the image isn't loaded, the method automatically loads the image from the calling assembly's manifest and adds it to the SmallImageList.Images collection under the resourceId key.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetSmallImageIndex Method

Gets the index of the image in the SmallImageList.Images collection.

[Visual Basic]
Public Shared Function GetSmallImageIndex( _
ByVal imageKey As Object _
) As Integer
[C#]
public static int GetSmallImageIndex(
object imageKey
);

Parameters

imageKey
The image key.

Return Value

The index of the image in the SmallImageList.Images collection greater than or equal to zero. Returns -1 if no image with the specified key exists in the collection.

See Also

Context Class | LaMarvin.Design Namespace


Context.GetSmallImageIndexForType Method

Gets the index of the small type image in the SmallImageList.Images collection.

[Visual Basic]
Public Shared Function GetSmallImageIndexForType( _
ByVal type As Type _
) As Integer
[C#]
public static int GetSmallImageIndexForType(
Type type
);

Parameters

type
The Type reference used as the image key.

Return Value

The index of the image in the SmallImageList.Images collection greater than or equal to zero. Returns -1 if no image for the type exists in the collection.

See Also

Context Class | LaMarvin.Design Namespace


GetTypeInfo Method

Constable Authorization Engine 2.0 BETA

Context.GetTypeInfo Method

Gets a TypeInfo object describing the given type

Overload List

Gets a TypeInfo object describing the type of the given instance.

public static TypeInfo GetTypeInfo(object);

Gets a TypeInfo object describing the given type.

public static TypeInfo GetTypeInfo(Type);

See Also

Context Class | LaMarvin.Design Namespace


Context.GetTypeInfo Method (Object)

Gets a TypeInfo object describing the type of the given instance.

[Visual Basic]
Overloads Public Shared Function GetTypeInfo( _
ByVal instance As Object _
) As TypeInfo
[C#]
public static TypeInfo GetTypeInfo(
object instance
);

Parameters

instance
The instance whose type's TypeInfo object the caller wants to retrieve.

Return Value

A TypeInfo object describing the type of the instance.

See Also

Context Class | LaMarvin.Design Namespace | Context.GetTypeInfo Overload List


Context.GetTypeInfo Method (Type)

Gets a TypeInfo object describing the given type.

[Visual Basic]
Overloads Public Shared Function GetTypeInfo( _
ByVal type As Type _
) As TypeInfo
[C#]
public static TypeInfo GetTypeInfo(
Type type
);

Parameters

type
The requested type.

Return Value

A reference to a TypeInfo object describing the requested type.

Remarks

If a TypeInfo object for the requested type isn't already registered, the implementation will register it automatically by examining the TypeInfoAttribute attribute associated with the type. If the type doesn't have the TypeInfoAttribute attribute applied to it, a default TypeInfo object is created and registered for the type automatically. This method always returns a valid TypeInfo object and it never returns a null reference (Nothing in Visual Basic). You can safely use the method like this:

[C#]
this.PictureBox1.Image = Context.GetTypeInfo(typeof(Form)).VisualInfo.SmallImage;

[Visual Basic]
Me.PictureBox1.Image = Context.GetTypeInfo(gettype(Form)).VisualInfo.SmallImage

See Also

Context Class | LaMarvin.Design Namespace | Context.GetTypeInfo Overload List


Context.IsNonSystemAssemblyFilter Method

Determines if the assembly is not one of the .NET Framework system assemblies.

[Visual Basic]
Public Shared Function IsNonSystemAssemblyFilter( _
ByVal assembly As Assembly, _
ByVal baseType As Type _
) As Boolean
[C#]
public static bool IsNonSystemAssemblyFilter(
Assembly assembly,
Type baseType
);

Parameters

assembly
The assembly to be checked.
baseType
The base type for the enumeration.

Return Value

true if the assembly is not one of the .NET Framework system assemblies; otherwise false.

Remarks

This method is often used as the Context.AssemblyFilterDelegate passed to the GetAvailableTypes method.

See Also

Context Class | LaMarvin.Design Namespace


Context.IsPublicCreatableTypeFilter Method

Determines if the currentType is public, non-abstract type compatible with the baseType.

[Visual Basic]
Public Shared Function IsPublicCreatableTypeFilter( _
ByVal assembly As Assembly, _
ByVal baseType As Type, _
ByVal currentType As Type _
) As Boolean
[C#]
public static bool IsPublicCreatableTypeFilter(
Assembly assembly,
Type baseType,
Type currentType
);

Parameters

assembly
The assembly containing the currentType.
baseType
The base type.
currentType
The currently enumerated type.

Return Value

true if the currentType is a public, non-abstract type compatible with the baseType; otherwise false.

Remarks

This method is often used as the Context.TypeFilterDelegate passed to the GetAvailableTypes method.

See Also

Context Class | LaMarvin.Design Namespace


Context.PreloadAssembly Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Function PreloadAssembly( _
ByVal dllPath As String _
) As Assembly
[C#]
public static Assembly PreloadAssembly(
string dllPath
);

See Also

Context Class | LaMarvin.Design Namespace


Context.RemoveSmallImage Method

Removes the image with the specified key from the shared SmallImageList.Images collection.

[Visual Basic]
Public Shared Function RemoveSmallImage( _
ByVal imageKey As Object _
) As Image
[C#]
public static Image RemoveSmallImage(
object imageKey
);

Parameters

imageKey
The key of the image to be removed.

Return Value

Returns a reference to the image that has been removed. Returns a null reference (Nothing in Visual Basic) if the SmallImageList.Images collection doesn't contain an image with the specified key.

See Also

Context Class | LaMarvin.Design Namespace


Context.AssemblyFilterDelegate Delegate

Defines a signature for methods that can be passed to the GetAvailableTypes method to filter the set of assemblies traversed by the method.

[Visual Basic]
Public Delegate Function Context.AssemblyFilterDelegate( _
ByVal assembly As Assembly, _
ByVal baseType As Type _
) As Boolean
[C#]
public delegate bool Context.AssemblyFilterDelegate(
Assembly assembly,
Type baseType
);

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

LaMarvin.Design Namespace


Context.Registry Class

Provides methods for registering and unregistering TypeInfo objects describing types usable for the design infrastructure.

For a list of all members of this type, see Context.Registry Members.

System.Object
LaMarvin.Design.Context.Registry

[Visual Basic]
NotInheritable Public Class Context.Registry
[C#]
public sealed class Context.Registry

Thread Safety

This type is not safe for multithreaded operations.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

Context.Registry Members | LaMarvin.Design Namespace


Context.Registry Members

Context.Registry overview

Public Static (Shared) Methods

GetRegisteredTypeInfos | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
RegisterTypeInfo | Adds the TypeInfo object to the registry.
UnregisterTypeInfo | Overloaded. Removes the type info from the registry.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Context.Registry Class | LaMarvin.Design Namespace


Context.Registry Methods

The methods of the Context.Registry class are listed below. For a complete list of Context.Registry class members, see the Context.Registry Members topic.

Public Static (Shared) Methods

GetRegisteredTypeInfos | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
RegisterTypeInfo | Adds the TypeInfo object to the registry.
UnregisterTypeInfo | Overloaded. Removes the type info from the registry.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Context.Registry Class | LaMarvin.Design Namespace


Context.Registry.GetRegisteredTypeInfos Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Public Shared Function GetRegisteredTypeInfos() As TypeInfo()
[C#]
public static TypeInfo[] GetRegisteredTypeInfos();

See Also

Context.Registry Class | LaMarvin.Design Namespace


Context.Registry.RegisterTypeInfo Method

Adds the TypeInfo object to the registry.

[Visual Basic]
Public Shared Sub RegisterTypeInfo( _
ByVal info As TypeInfo _
)
[C#]
public static void RegisterTypeInfo(
TypeInfo info
);

Parameters

info
The TypeInfo object to be added to the registry.

Remarks

The TypeInfo object is registered under the Type it describes. If a TypeInfo object under the type has already been registered, this method replaces the previously registered TypeInfo with the info instance.

See Also

Context.Registry Class | LaMarvin.Design Namespace


UnregisterTypeInfo Method

Constable Authorization Engine 2.0 BETA

Context.Registry.UnregisterTypeInfo Method

[This is preliminary documentation and subject to change.]

Removes the type info from the registry.

Overload List

Removes the type info from the registry.

public static void UnregisterTypeInfo(TypeInfo);

Removes a TypeInfo object for the specified type from the registry.

public static void UnregisterTypeInfo(Type);

See Also

Context.Registry Class | LaMarvin.Design Namespace


Context.Registry.UnregisterTypeInfo Method (TypeInfo)

Removes the type info from the registry.

[Visual Basic]
Overloads Public Shared Sub UnregisterTypeInfo( _
ByVal info As TypeInfo _
)
[C#]
public static void UnregisterTypeInfo(
TypeInfo info
);

Parameters

info
The TypeInfo object to be removed from the registry.

See Also

Context.Registry Class | LaMarvin.Design Namespace | Context.Registry.UnregisterTypeInfo Overload List


Context.Registry.UnregisterTypeInfo Method (Type)

Removes a TypeInfo object for the specified type from the registry.

[Visual Basic]
Overloads Public Shared Sub UnregisterTypeInfo( _
ByVal type As Type _
)
[C#]
public static void UnregisterTypeInfo(
Type type
);

Parameters

type
The Type of the object to be removed from the registry.

See Also

Context.Registry Class | LaMarvin.Design Namespace | Context.Registry.UnregisterTypeInfo Overload List


Context.TypeFilterDelegate Delegate

Defines a signature for methods that can be passed to the GetAvailableTypes method to filter the set of types traversed by the method.

[Visual Basic]
Public Delegate Function Context.TypeFilterDelegate( _
ByVal assembly As Assembly, _
ByVal baseType As Type, _
ByVal currentType As Type _
) As Boolean
[C#]
public delegate bool Context.TypeFilterDelegate(
Assembly assembly,
Type baseType,
Type currentType
);

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

LaMarvin.Design Namespace


ICustomInstanceEntryDisplay Interface

The interface represents a contract used by the InstanceView control to customize the appearance of objects from the associated object graph (RootInstance).

For a list of all members of this type, see ICustomInstanceEntryDisplay Members.

[Visual Basic]
Public Interface ICustomInstanceEntryDisplay
[C#]
public interface ICustomInstanceEntryDisplay

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

ICustomInstanceEntryDisplay Members | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay Members

ICustomInstanceEntryDisplay overview

Public Instance Properties

BackColor | Gets the background color that should be used to display this instance in the InstanceView control.
ForeColor | Gets the foreground color that should be used to display this instance in the InstanceView control.
ImageIndex | Gets the index of an image (from the SmallImageList) that should be displayed in the InstanceView control for this instance.
SelectedImageIndex | Gets the index of a selected image (from the SmallImageList) that should be displayed in the InstanceView control for this instance when it's selected.
Text | Gets the text that should be displayed in the InstanceView control for this instance.
UsedProperties | Returns a combination of flags specifying which other properties of the implemented interface should be honored by the InstanceView control.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay Properties

The properties of the ICustomInstanceEntryDisplay interface are listed below. For a complete list of ICustomInstanceEntryDisplay interface members, see the ICustomInstanceEntryDisplay Members topic.

Public Instance Properties

BackColor | Gets the background color that should be used to display this instance in the InstanceView control.
ForeColor | Gets the foreground color that should be used to display this instance in the InstanceView control.
ImageIndex | Gets the index of an image (from the SmallImageList) that should be displayed in the InstanceView control for this instance.
SelectedImageIndex | Gets the index of a selected image (from the SmallImageList) that should be displayed in the InstanceView control for this instance when it's selected.
Text | Gets the text that should be displayed in the InstanceView control for this instance.
UsedProperties | Returns a combination of flags specifying which other properties of the implemented interface should be honored by the InstanceView control.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.BackColor Property

Gets the background color that should be used to display this instance in the InstanceView control.

[Visual Basic]
Property BackColor As Color
[C#]
System.Drawing.Color BackColor {get;}

Remarks

The value of this property is only considered when the UsedProperties mask has the BackColor bit set.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.ForeColor Property

Gets the foreground color that should be used to display this instance in the InstanceView control.

[Visual Basic]
Property ForeColor As Color
[C#]
System.Drawing.Color ForeColor {get;}

Remarks

The value of this property is only considered when the UsedProperties mask has the ForeColor bit set.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.ImageIndex Property

Gets the index of an image (from the SmallImageList) that should be displayed in the InstanceView control for this instance.

[Visual Basic]
Property ImageIndex As Integer
[C#]
int ImageIndex {get;}

Remarks

The value of this property is only considered when the UsedProperties mask has the ImageIndex bit set.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.SelectedImageIndex Property

Gets the index of a selected image (from the SmallImageList) that should be displayed in the InstanceView control for this instance when it's selected.

[Visual Basic]
Property SelectedImageIndex As Integer
[C#]
int SelectedImageIndex {get;}

Remarks

The value of this property is only considered when the UsedProperties mask has the SelectedImageIndex bit set.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.Text Property

Gets the text that should be displayed in the InstanceView control for this instance.

[Visual Basic]
Property Text As String
[C#]
string Text {get;}

Remarks

The value of this property is only considered when the UsedProperties mask has the Text bit set.

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


ICustomInstanceEntryDisplay.UsedProperties Property

Returns a combination of flags specifying which other properties of the implemented interface should be honored by the InstanceView control.

[Visual Basic]
Property UsedProperties As InstanceEntryDisplayProperties
[C#]
InstanceEntryDisplayProperties UsedProperties {get;}

See Also

ICustomInstanceEntryDisplay Interface | LaMarvin.Design Namespace


IDesignApplicationHost Interface

This interface supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

For a list of all members of this type, see IDesignApplicationHost Members.

[Visual Basic]
Public Interface IDesignApplicationHost
[C#]
public interface IDesignApplicationHost

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

IDesignApplicationHost Members | LaMarvin.Design Namespace


IDesignApplicationHost Members

IDesignApplicationHost overview

Public Instance Properties

CanExit | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
ExitMenuCaption | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

Public Instance Methods

Exit This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


IDesignApplicationHost Properties

The properties of the IDesignApplicationHost interface are listed below. For a complete list of IDesignApplicationHost interface members, see the IDesignApplicationHost Members topic.

Public Instance Properties

CanExit | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
ExitMenuCaption | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


IDesignApplicationHost.CanExit Property

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Property CanExit As Boolean
[C#]
bool CanExit {get;}

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


IDesignApplicationHost.ExitMenuCaption Property

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Property ExitMenuCaption As String
[C#]
string ExitMenuCaption {get;}

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


IDesignApplicationHost Methods

The methods of the IDesignApplicationHost interface are listed below. For a complete list of IDesignApplicationHost interface members, see the IDesignApplicationHost Members topic.

Public Instance Methods

Exit This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


IDesignApplicationHost.Exit Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Sub Exit()
[C#]
void Exit();

See Also

IDesignApplicationHost Interface | LaMarvin.Design Namespace


InstanceDesignerVerb Class

Represents a DesignerVerb associated with an object.

For a list of all members of this type, see InstanceDesignerVerb Members.

System.Object
System.ComponentModel.Design.MenuCommand
System.ComponentModel.Design.DesignerVerb
LaMarvin.Design.InstanceDesignerVerb

[Visual Basic]
NotInheritable Public Class InstanceDesignerVerb
Inherits DesignerVerb
[C#]
public sealed class InstanceDesignerVerb : DesignerVerb

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

InstanceDesignerVerb Members | LaMarvin.Design Namespace


InstanceDesignerVerb Members

InstanceDesignerVerb overview

Public Instance Constructors

InstanceDesignerVerb Overloaded. Initializes a new instance of the InstanceDesignerVerb class.

Public Instance Properties

CommandID (inherited from MenuCommand) | Gets the CommandID associated with this menu command.
Enabled (inherited from MenuCommand) | Gets a value indicating whether this menu item is available.
Checked (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is checked.
Instance | Gets the associated instance.
OleStatus (inherited from MenuCommand) | Gets the OLE command status code for this menu item.
SelectedChildren | Gets the collection of selected child objects of the Instance.
Supported (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is supported.
Text (inherited from DesignerVerb) | Gets the text description that describes the verb command on the menu.
Visible (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is visible.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Invoke (inherited from MenuCommand) | Invokes the command.
ToString (inherited from DesignerVerb) |

Public Instance Events

CommandChanged (inherited from MenuCommand) Occurs when the menu command changes.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace


InstanceDesignerVerb Constructor

Initializes a new instance of the InstanceDesignerVerb class.

Overload List

Initializes a new instance of the InstanceDesignerVerb class.

public InstanceDesignerVerb(string,EventHandler,CommandID,object,ICollection);

Initializes a new instance of the InstanceDesignerVerb class.

public InstanceDesignerVerb(string,EventHandler,object);

Initializes a new instance of the InstanceDesignerVerb class.

public InstanceDesignerVerb(string,EventHandler,object,ICollection);

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace


InstanceDesignerVerb Constructor (String, EventHandler, Object, ICollection)

Initializes a new instance of the InstanceDesignerVerb class.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal handler As EventHandler, _
ByVal instance As Object, _
ByVal selectedChildren As ICollection _
)
[C#]
public InstanceDesignerVerb(
string text,
EventHandler handler,
object instance,
ICollection selectedChildren
);

Parameters

text
The text of the verb.
handler
The handler ibnvoked when the verb is clicked.
instance
The associated instance.
selectedChildren
The collection of selected child objects.

Remarks

The selectedChildren collection is only valid if the associated Instance is a collection.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace | InstanceDesignerVerb Constructor Overload List


InstanceDesignerVerb Constructor (String, EventHandler, Object)

Initializes a new instance of the InstanceDesignerVerb class.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal handler As EventHandler, _
ByVal instance As Object _
)
[C#]
public InstanceDesignerVerb(
string text,
EventHandler handler,
object instance
);

Parameters

text
The text of the verb.
handler
The handler ibnvoked when the verb is clicked.
instance
The associated instance.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace | InstanceDesignerVerb Constructor Overload List


InstanceDesignerVerb Constructor (String, EventHandler, CommandID, Object, ICollection)

Initializes a new instance of the InstanceDesignerVerb class.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal handler As EventHandler, _
ByVal startCommandID As CommandID, _
ByVal instance As Object, _
ByVal selectedChildren As ICollection _
)
[C#]
public InstanceDesignerVerb(
string text,
EventHandler handler,
CommandID startCommandID,
object instance,
ICollection selectedChildren
);

Parameters

text
The text of the verb.
handler
The handler ibnvoked when the verb is clicked.
startCommandID
The starting command ID for this verb.
instance
The associated instance.
selectedChildren
The collection of selected child objects.

Remarks

The selectedChildren collection is only valid if the associated Instance is a collection.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace | InstanceDesignerVerb Constructor Overload List


InstanceDesignerVerb Properties

The properties of the InstanceDesignerVerb class are listed below. For a complete list of InstanceDesignerVerb class members, see the InstanceDesignerVerb Members topic.

Public Instance Properties

CommandID (inherited from MenuCommand) | Gets the CommandID associated with this menu command.
Enabled (inherited from MenuCommand) | Gets a value indicating whether this menu item is available.
Checked (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is checked.
Instance | Gets the associated instance.
OleStatus (inherited from MenuCommand) | Gets the OLE command status code for this menu item.
SelectedChildren | Gets the collection of selected child objects of the Instance.
Supported (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is supported.
Text (inherited from DesignerVerb) | Gets the text description that describes the verb command on the menu.
Visible (inherited from MenuCommand) | Gets or sets a value indicating whether this menu item is visible.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace


InstanceDesignerVerb.Instance Property

Gets the associated instance.

[Visual Basic]
Public ReadOnly Property Instance As Object
[C#]
public object Instance {get;}

Property Value

The instance reference.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace


InstanceDesignerVerb.SelectedChildren Property

Gets the collection of selected child objects of the Instance.

[Visual Basic]
Public ReadOnly Property SelectedChildren As ICollection
[C#]
public System.Collections.ICollection SelectedChildren {get;}

Property Value

The collection of selected child objects.

See Also

InstanceDesignerVerb Class | LaMarvin.Design Namespace


InstanceEntryDisplayProperties Enumeration

Specifies which display-related properties exposed by an ICustomInstanceEntryDisplay implementation should be used to customize the appearance of an entry in the InstanceView control.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum InstanceEntryDisplayProperties
[C#]
public enum InstanceEntryDisplayProperties

Members

Member Name | Description | Value
None | No display-related property of the ICustomInstanceEntryDisplay implementation should be used (the InstanceView control will behave as if there is no implementation of the ICustomInstanceEntryDisplay interface. | 0
Text | The Text property should be used. | 1
ImageIndex | The ImageIndex property should be used. | 2
SelectedImageIndex | The SelectedImageIndex property should be used. | 4
ForeColor | The ForeColor property should be used. | 8
BackColor | The BackColor property should be used. | 16
All | All display-related properties of the ICustomInstanceEntryDisplay implementation should be used. | 255

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

LaMarvin.Design Namespace


TypeInfo Class

Contains additional metadata describing a Type that are not part of the TypeDescriptor infrastructure.

For a list of all members of this type, see TypeInfo Members.

System.Object
LaMarvin.Design.TypeInfo
Derived types

[Visual Basic]
Public Class TypeInfo
[C#]
public class TypeInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

TypeInfo Members | LaMarvin.Design Namespace


TypeInfo Members

TypeInfo overview

Public Instance Constructors

TypeInfo Constructor Initializes a new instance of the TypeInfo class with the given Type and VisualInfo.

Public Instance Properties

Type | Gets the type this object is associated with..
VisualInfo | Gets or sets the VisualInfo associated with this instance.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo Constructor

Initializes a new instance of the TypeInfo class with the given Type and VisualInfo.

[Visual Basic]
Public Sub New( _
ByVal type As Type, _
ByVal visualInfo As VisualInfo _
)
[C#]
public TypeInfo(
Type type,
VisualInfo visualInfo
);

Parameters

type
The type to associate this TypeInfo instance with.
visualInfo
The VisualInfo instance to associate with the type.

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo Properties

The properties of the TypeInfo class are listed below. For a complete list of TypeInfo class members, see the TypeInfo Members topic.

Public Instance Properties

Type | Gets the type this object is associated with..
VisualInfo | Gets or sets the VisualInfo associated with this instance.

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo.Type Property

Gets the type this object is associated with..

[Visual Basic]
Public ReadOnly Property Type As Type
[C#]
public System.Type Type {get;}

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo.VisualInfo Property

Gets or sets the VisualInfo associated with this instance.

[Visual Basic]
Overridable Public Property VisualInfo As VisualInfo
[C#]
public virtual VisualInfo VisualInfo {get; set;}

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo Methods

The methods of the TypeInfo class are listed below. For a complete list of TypeInfo class members, see the TypeInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns the Name property value.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeInfo Class | LaMarvin.Design Namespace


TypeInfo.ToString Method

Returns the Name property value.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

TypeInfo Class | LaMarvin.Design Namespace


UserCancelledException Class

The exception is thrown by the design infrastructure if the user cancels an operation.

For a list of all members of this type, see UserCancelledException Members.

System.Object
System.Exception
LaMarvin.Design.UserCancelledException

[Visual Basic]
<Serializable>
Public Class UserCancelledException
Inherits Exception
[C#]
[Serializable]
public class UserCancelledException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

UserCancelledException Members | LaMarvin.Design Namespace


UserCancelledException Members

UserCancelledException overview

Public Instance Constructors

UserCancelledException Overloaded. Initializes a new instance of the UserCancelledException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

UserCancelledException Overloaded. Initializes a new instance of the UserCancelledException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserCancelledException Class | LaMarvin.Design Namespace


UserCancelledException Constructor

Initializes a new instance of the UserCancelledException class.

Overload List

Initializes a new instance of the UserCancelledException class.

public UserCancelledException();

Initializes a new instance of the UserCancelledException class for deserialization.

protected UserCancelledException(SerializationInfo,StreamingContext);

Initializes a new instance of the UserCancelledException class with the given message.

public UserCancelledException(string);

Initializes a new instance of the UserCancelledException class with the given message and an inner Exception.

public UserCancelledException(string,Exception);

See Also

UserCancelledException Class | LaMarvin.Design Namespace


UserCancelledException Constructor ()

Initializes a new instance of the UserCancelledException class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public UserCancelledException();

See Also

UserCancelledException Class | LaMarvin.Design Namespace | UserCancelledException Constructor Overload List


UserCancelledException Constructor (String)

Initializes a new instance of the UserCancelledException class with the given message.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String _
)
[C#]
public UserCancelledException(
string message
);

See Also

UserCancelledException Class | LaMarvin.Design Namespace | UserCancelledException Constructor Overload List


UserCancelledException Constructor (String, Exception)

Initializes a new instance of the UserCancelledException class with the given message and an inner Exception.

[Visual Basic]
Overloads Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
public UserCancelledException(
string message,
Exception innerException
);

See Also

UserCancelledException Class | LaMarvin.Design Namespace | UserCancelledException Constructor Overload List


UserCancelledException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the UserCancelledException class for deserialization.

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected UserCancelledException(
SerializationInfo info,
StreamingContext context
);

See Also

UserCancelledException Class | LaMarvin.Design Namespace | UserCancelledException Constructor Overload List


VisualInfo Class

Summarizes properties that describe displayable programmatic entities.

For a list of all members of this type, see VisualInfo Members.

System.Object
LaMarvin.Design.VisualInfo

[Visual Basic]
Public Class VisualInfo
[C#]
public class VisualInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

VisualInfo Members | LaMarvin.Design Namespace


VisualInfo Members

VisualInfo overview

Public Instance Constructors

VisualInfo Overloaded. Initializes a new instance of the VisualInfo class.

Public Instance Properties

Description | Gets or sets the description of the object.
LargeImage | Gets or sets the large image of the object.
Name | Gets or sets the name of the object.
SmallImage | Gets or sets the small image of the object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo Constructor

Initializes a new instance of the VisualInfo class with default property values.

Overload List

Initializes a new instance of the VisualInfo class with default property values.

public VisualInfo();

Initializes a new instance of the VisualInfo class with the given name.

public VisualInfo(string);

Initializes a new instance of the VisualInfo class with the given name and description.

public VisualInfo(string,string);

Initializes a new instance of the VisualInfo class with the given name, description and smallImage.

public VisualInfo(string,string,Image);

Initializes a new instance of the VisualInfo class with the given name, description, smallImage and largeImage images.

public VisualInfo(string,string,Image,Image);

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo Constructor ()

Initializes a new instance of the VisualInfo class with default property values.

[Visual Basic]
Overloads Public Sub New()
[C#]
public VisualInfo();

See Also

VisualInfo Class | LaMarvin.Design Namespace | VisualInfo Constructor Overload List


VisualInfo Constructor (String)

Initializes a new instance of the VisualInfo class with the given name.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String _
)
[C#]
public VisualInfo(
string name
);

Parameters

name
The name.

See Also

VisualInfo Class | LaMarvin.Design Namespace | VisualInfo Constructor Overload List


VisualInfo Constructor (String, String)

Initializes a new instance of the VisualInfo class with the given name and description.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal description As String _
)
[C#]
public VisualInfo(
string name,
string description
);

Parameters

name
The name.
description
The description.

See Also

VisualInfo Class | LaMarvin.Design Namespace | VisualInfo Constructor Overload List


VisualInfo Constructor (String, String, Image)

Initializes a new instance of the VisualInfo class with the given name, description and smallImage.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal description As String, _
ByVal smallImage As Image _
)
[C#]
public VisualInfo(
string name,
string description,
Image smallImage
);

Parameters

name
The name.
description
The description.
smallImage
The small image.

See Also

VisualInfo Class | LaMarvin.Design Namespace | VisualInfo Constructor Overload List


VisualInfo Constructor (String, String, Image, Image)

Initializes a new instance of the VisualInfo class with the given name, description, smallImage and largeImage images.

[Visual Basic]
Overloads Public Sub New( _
ByVal name As String, _
ByVal description As String, _
ByVal smallImage As Image, _
ByVal largeImage As Image _
)
[C#]
public VisualInfo(
string name,
string description,
Image smallImage,
Image largeImage
);

Parameters

name
The name.
description
The description.
smallImage
The small image.
largeImage
The large image.

See Also

VisualInfo Class | LaMarvin.Design Namespace | VisualInfo Constructor Overload List


VisualInfo Properties

The properties of the VisualInfo class are listed below. For a complete list of VisualInfo class members, see the VisualInfo Members topic.

Public Instance Properties

Description | Gets or sets the description of the object.
LargeImage | Gets or sets the large image of the object.
Name | Gets or sets the name of the object.
SmallImage | Gets or sets the small image of the object.

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo.Description Property

Gets or sets the description of the object.

[Visual Basic]
Overridable Public Property Description As String
[C#]
public virtual string Description {get; set;}

Property Value

The description.

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo.LargeImage Property

Gets or sets the large image of the object.

[Visual Basic]
Overridable Public Property LargeImage As Image
[C#]
public virtual System.Drawing.Image LargeImage {get; set;}

Property Value

The large image.

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo.Name Property

Gets or sets the name of the object.

[Visual Basic]
Overridable Public Property Name As String
[C#]
public virtual string Name {get; set;}

Property Value

The name.

See Also

VisualInfo Class | LaMarvin.Design Namespace


VisualInfo.SmallImage Property

Gets or sets the small image of the object.

[Visual Basic]
Overridable Public Property SmallImage As Image
[C#]
public virtual System.Drawing.Image SmallImage {get; set;}

Property Value

The small image.

See Also

VisualInfo Class | LaMarvin.Design Namespace


LaMarvin.Design.Clipboard

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Clipboard Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting implementation of strongly-typed clipboard operations.

Namespace hierarchy

Classes

Class | Description
AppClipboard | Provides services for application-oriented, strongly-typed, pluggable clipboard operations.
ClipboardHandler | Provides a default implementation of the IClipboardHandler interface.

Interfaces

Interface | Description
IClipboardHandler | Defines a contract for handling clipboard operations pluggable into the AppClipboard infrastructure.


AppClipboard Class

Provides services for application-oriented, strongly-typed, pluggable clipboard operations.

For a list of all members of this type, see AppClipboard Members.

System.Object
LaMarvin.Design.Clipboard.AppClipboard

[Visual Basic]
NotInheritable Public Class AppClipboard
[C#]
public sealed class AppClipboard

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

AppClipboard provides an infrastructure for associating IClipboardHandler implementations with types. The IClipboardHandler implementations provide functionality specific for the given type while AppClipboard provides the common logic and a central place for clipboard-related functionality.

Note AppClipboard doesn't replace the system clipboard (represented by the Clipboard class). Instead, it provides type-specific, extensible infrastructure built on top of the Clipboard services.

Requirements

Namespace: LaMarvin.Design.Clipboard

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

AppClipboard Members | LaMarvin.Design.Clipboard Namespace


AppClipboard Members

AppClipboard overview

Public Static (Shared) Methods

CanCopy | Determines whether the instance can be copied to the system clipboard.
CanCut | Determines whether the instance can be cut and placed onto the system clipboard.
CanPaste | Overloaded. Determines whether the specified target can paste the instance currently on the clipboard.
Copy | Copies the instance to the system clipboard.
Cut | Cuts the instance from its container and places it onto the system clipboard.
GetDescriptionForPaste | Gets the description for potential paste operation.
GetHandler | Overloaded. Gets the IClipboardHandler implementation registered for the given type.
Paste | Pastes the instance currently on the clipboard and puts it into the target container.
RegisterHandler | Registers a IClipboardHandler implementation for the specified type of objects.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


AppClipboard Methods

The methods of the AppClipboard class are listed below. For a complete list of AppClipboard class members, see the AppClipboard Members topic.

Public Static (Shared) Methods

CanCopy | Determines whether the instance can be copied to the system clipboard.
CanCut | Determines whether the instance can be cut and placed onto the system clipboard.
CanPaste | Overloaded. Determines whether the specified target can paste the instance currently on the clipboard.
Copy | Copies the instance to the system clipboard.
Cut | Cuts the instance from its container and places it onto the system clipboard.
GetDescriptionForPaste | Gets the description for potential paste operation.
GetHandler | Overloaded. Gets the IClipboardHandler implementation registered for the given type.
Paste | Pastes the instance currently on the clipboard and puts it into the target container.
RegisterHandler | Registers a IClipboardHandler implementation for the specified type of objects.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


AppClipboard.CanCopy Method

Determines whether the instance can be copied to the system clipboard.

[Visual Basic]
Public Shared Function CanCopy( _
ByVal instance As Object _
) As Boolean
[C#]
public static bool CanCopy(
object instance
);

Parameters

instance
The instance to be copied.

Return Value

true if the instance can be copied; false otherwise.

Remarks

An instance can be put onto clipboard if the instance is serializable and there is an IClipboardHandler registered for the instance's type.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | RegisterHandler


AppClipboard.CanCut Method

Determines whether the instance can be cut and placed onto the system clipboard.

[Visual Basic]
Public Shared Function CanCut( _
ByVal instance As Object _
) As Boolean
[C#]
public static bool CanCut(
object instance
);

Parameters

instance
The instance to be cut.

Return Value

true if the instance can be cut; false otherwise.

Remarks

An instance can be put onto clipboard if the instance is serializable and there is an IClipboardHandler registered for the instance's type.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | RegisterHandler


CanPaste Method

Constable Authorization Engine 2.0 BETA

AppClipboard.CanPaste Method

[This is preliminary documentation and subject to change.]

Determines whether the specified target can paste the instance currently on the clipboard.

Overload List

Determines whether the specified target can paste the instance currently on the clipboard.

public static bool CanPaste(object);

Determines whether the specified target can paste the instance currently on the clipboard.

public static bool CanPaste(object,ref bool);

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


AppClipboard.CanPaste Method (Object)

Determines whether the specified target can paste the instance currently on the clipboard.

[Visual Basic]
Overloads Public Shared Function CanPaste( _
ByVal target As Object _
) As Boolean
[C#]
public static bool CanPaste(
object target
);

Parameters

target
The target container where to put the pasted object.

Return Value

true if the current object on the clipboard can be pasted to the target container; false otherwise.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | AppClipboard.CanPaste Overload List


AppClipboard.CanPaste Method (Object, Boolean)

Determines whether the specified target can paste the instance currently on the clipboard.

[Visual Basic]
Overloads Public Shared Function CanPaste( _
ByVal target As Object, _
ByRef willPromptUser As Boolean _
) As Boolean
[C#]
public static bool CanPaste(
object target,
ref bool willPromptUser
);

Parameters

target
The target container where to put the pasted object.
willPromptUser
A flag indicating whether a future Paste operation will potentially display a dialog.

Return Value

true if the current object on the clipboard can be pasted to the target container; false otherwise.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | AppClipboard.CanPaste Overload List


AppClipboard.Copy Method

Copies the instance to the system clipboard.

[Visual Basic]
Public Shared Sub Copy( _
ByVal instance As Object _
)
[C#]
public static void Copy(
object instance
);

Parameters

instance
The instance to be copied.

Exceptions

Exception Type | Condition
InvalidOperationException | The instance isn't serializable or there is no IClipboardHandler registered for the instance's type or any of its base types.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | RegisterHandler


AppClipboard.Cut Method

Cuts the instance from its container and places it onto the system clipboard.

[Visual Basic]
Public Shared Sub Cut( _
ByVal instance As Object _
)
[C#]
public static void Cut(
object instance
);

Parameters

instance
The instance to be cut.

Exceptions

Exception Type | Condition
InvalidOperationException | The instance isn't serializable or there is no IClipboardHandler registered for the instance's type or any of its base types.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | RegisterHandler


AppClipboard.GetDescriptionForPaste Method

Gets the description for potential paste operation.

[Visual Basic]
Public Shared Function GetDescriptionForPaste() As String
[C#]
public static string GetDescriptionForPaste();

Return Value

Returns a type name of the object that is currently on the clipboard and can be handled by any of the currently registered IClipboardHandlers. Returns an empty string if a Paste operation connot be currently performed.

Remarks

This method never returns a null reference (Nothing in Visual Basic).

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


GetHandler Method

Constable Authorization Engine 2.0 BETA

AppClipboard.GetHandler Method

[This is preliminary documentation and subject to change.]

Gets the IClipboardHandler implementation registered for the instance.

Overload List

Gets the IClipboardHandler implementation registered for the instance.

public static IClipboardHandler GetHandler(object);

Gets the IClipboardHandler implementation registered for the given type.

public static IClipboardHandler GetHandler(Type);

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


AppClipboard.GetHandler Method (Object)

Gets the IClipboardHandler implementation registered for the instance.

[Visual Basic]
Overloads Public Shared Function GetHandler( _
ByVal instance As Object _
) As IClipboardHandler
[C#]
public static IClipboardHandler GetHandler(
object instance
);

Parameters

instance
The instance whose type the requested handler supports.

Return Value

A reference to the IClipboardHandler implementation for the requested instance's type, or a null reference (Nothing in Visual Basic) if there is no handler registered for the type.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | AppClipboard.GetHandler Overload List


AppClipboard.GetHandler Method (Type)

Gets the IClipboardHandler implementation registered for the given type.

[Visual Basic]
Overloads Public Shared Function GetHandler( _
ByVal type As Type _
) As IClipboardHandler
[C#]
public static IClipboardHandler GetHandler(
Type type
);

Parameters

type
The type of objects the requested handler supports.

Return Value

A reference to the IClipboardHandler implementation for the requested type, or a null reference (Nothing in Visual Basic) if there is no handler registered for the type.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace | AppClipboard.GetHandler Overload List


AppClipboard.Paste Method

Pastes the instance currently on the clipboard and puts it into the target container.

[Visual Basic]
Public Shared Function Paste( _
ByVal target As Object _
) As Object
[C#]
public static object Paste(
object target
);

Parameters

target
The target container.

Return Value

Returns a reference to the object that has been pasted.

Remarks

The method makes a copy of the object on the clipboard and puts the copied object into the target container. The original clipboard object remains on the clipboard for further paste operations (until it's replaced by putting another object onto the clipboard).

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


AppClipboard.RegisterHandler Method

Registers a IClipboardHandler implementation for the specified type of objects.

[Visual Basic]
Public Shared Sub RegisterHandler( _
ByVal type As Type, _
ByVal handler As IClipboardHandler _
)
[C#]
public static void RegisterHandler(
Type type,
IClipboardHandler handler
);

Parameters

type
The type of objects the handler supports.
handler
The clipboard handler.

See Also

AppClipboard Class | LaMarvin.Design.Clipboard Namespace


ClipboardHandler Class

Provides a default implementation of the IClipboardHandler interface.

For a list of all members of this type, see ClipboardHandler Members.

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.PolicyClipboardHandler
LaMarvin.Constable.Design.Clipboard.RuleBaseClipboardHandler

[Visual Basic]
MustInherit Public Class ClipboardHandler
Implements IClipboardHandler
[C#]
public abstract class ClipboardHandler : IClipboardHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Typically, derived classes override only the abstract (MustInherit in Visual Basic) CutPerformed and Paste methods.

Requirements

Namespace: LaMarvin.Design.Clipboard

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

ClipboardHandler Members | LaMarvin.Design.Clipboard Namespace


ClipboardHandler Members

ClipboardHandler overview

Public Instance Methods

CanCopy | Implements the CanCopy interface method.
CanCut | Implements the CanCut interface method.
CanPaste | Implements the CanPaste interface method.
CopyPerformed | Implements the CopyPerformed interface method.
CutPerformed | Defines the CutPerformed interface method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Defines the Paste interface method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ClipboardHandler Constructor Initializes a new instance of the ClipboardHandler class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace


ClipboardHandler Constructor

Initializes a new instance of the ClipboardHandler class.

[Visual Basic]
Protected Sub New()
[C#]
protected ClipboardHandler();

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace


ClipboardHandler Methods

The methods of the ClipboardHandler class are listed below. For a complete list of ClipboardHandler class members, see the ClipboardHandler Members topic.

Public Instance Methods

CanCopy | Implements the CanCopy interface method.
CanCut | Implements the CanCut interface method.
CanPaste | Implements the CanPaste interface method.
CopyPerformed | Implements the CopyPerformed interface method.
CutPerformed | Defines the CutPerformed interface method.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Paste | Defines the Paste interface method.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace


ClipboardHandler.CanCopy Method

Implements the CanCopy interface method.

[Visual Basic]
Overridable Public Function CanCopy( _
ByVal instance As Object _
) As Boolean _
Implements IClipboardHandler.CanCopy
[C#]
public virtual bool CanCopy(
object instance
);

Parameters

instance
The instance to be copied.

Return Value

Always returns true signaling the instance can be copied.

Implements

IClipboardHandler.CanCopy

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CanCopy


ClipboardHandler.CanCut Method

Implements the CanCut interface method.

[Visual Basic]
Overridable Public Function CanCut( _
ByVal instance As Object _
) As Boolean _
Implements IClipboardHandler.CanCut
[C#]
public virtual bool CanCut(
object instance
);

Parameters

instance
The instance to be cut.

Return Value

Always returns true signaling the instance can be cut.

Implements

IClipboardHandler.CanCut

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CanCut


ClipboardHandler.CanPaste Method

Implements the CanPaste interface method.

[Visual Basic]
Overridable Public Function CanPaste( _
ByVal instance As Object, _
ByVal target As Object, _
ByRef willPromptUser As Boolean _
) As Boolean _
Implements IClipboardHandler.CanPaste
[C#]
public virtual bool CanPaste(
object instance,
object target,
ref bool willPromptUser
);

Parameters

instance
The instance to be pasted.
target
The target container where to put the instance.
willPromptUser
An output flag indicating whether a future Paste operation will potentially display a dialog.

Return Value

Always returns true signaling the instance can be pasted.

Implements

IClipboardHandler.CanPaste

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CanPaste


ClipboardHandler.CopyPerformed Method

Implements the CopyPerformed interface method.

[Visual Basic]
Overridable Public Sub CopyPerformed( _
ByVal instance As Object _
) _
Implements IClipboardHandler.CopyPerformed
[C#]
public virtual void CopyPerformed(
object instance
);

Parameters

instance
The instance that has been copied.

Implements

IClipboardHandler.CopyPerformed

Remarks

The implementation does nothing.

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CopyPerformed


ClipboardHandler.CutPerformed Method

Defines the CutPerformed interface method.

[Visual Basic]
MustOverride Public Sub CutPerformed( _
ByVal instance As Object _
) _
Implements IClipboardHandler.CutPerformed
[C#]
public abstract void CutPerformed(
object instance
);

Parameters

instance
The instance that has been cut.

Implements

IClipboardHandler.CutPerformed

Remarks

Derived classes must override this method and actually remove the specified instance from its container.

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CutPerformed


ClipboardHandler.Paste Method

Defines the Paste interface method.

[Visual Basic]
MustOverride Public Sub Paste( _
ByVal instance As Object, _
ByVal target As Object _
) _
Implements IClipboardHandler.Paste
[C#]
public abstract void Paste(
object instance,
object target
);

Parameters

instance
The instance to be pasted.
target
The target container where to put the instance.

Implements

IClipboardHandler.Paste

Remarks

Derived classes must override this method and actually add the specified instance the target container.

See Also

ClipboardHandler Class | LaMarvin.Design.Clipboard Namespace | CutPerformed


IClipboardHandler Interface

Defines a contract for handling clipboard operations pluggable into the AppClipboard infrastructure.

For a list of all members of this type, see IClipboardHandler Members.

[Visual Basic]
Public Interface IClipboardHandler
[C#]
public interface IClipboardHandler

Types that implement IClipboardHandler

Type | Description
ActionClipboardHandler | Provides the IClipboardHandler implementation for Action-compatible types.
ActionRuleClipboardHandler | Provides the IClipboardHandler implementation for ActionRule-compatible types.
NamedObjectClipboardHandler | Provides the common IClipboardHandler implementation for NamedObjectBase-derived classes.
PolicyClipboardHandler | Provides the IClipboardHandler implementation for AuthorizationPolicy-compatible types.
PropertyClipboardHandler | Provides the IClipboardHandler implementation for Property-compatible types.
PropertyRuleRuleClipboardHandler | Provides the IClipboardHandler implementation for PropertyRule-compatible types.
RoleClipboardHandler | Provides the IClipboardHandler implementation for Role-compatible types.
RuleBaseClipboardHandler | Provides the common IClipboardHandler implementation for RuleBase-derived classes.
StateClipboardHandler | Provides the IClipboardHandler implementation for State-compatible types.
ClipboardHandler | Provides a default implementation of the IClipboardHandler interface.

Remarks

If a type wants to support AppClipboard services, it must be serializable and an implementation of the IClipboardHandler interface must be registered with the AppClipboard class (by calling the RegisterHandler method).

Note Most of the time, implementations need to actually implement only the CutPerformed and Paste methods; other methods are just boilerplate code. The default interface implementation is the ClipboardHandler abstract (MustInherit in Visual Basic) class that implements the boilerplate code and defines the two methods as abstract (MustInherit in Visual Basic).

Requirements

Namespace: LaMarvin.Design.Clipboard

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

IClipboardHandler Members | LaMarvin.Design.Clipboard Namespace


IClipboardHandler Members

IClipboardHandler overview

Public Instance Methods

CanCopy | Implementations should return a flag indicating whether the specified instance can be copied to the system clipboard.
CanCut | Implementations should return a flag indicating whether the specified instance can be cut from the container ans copied to the system clipboard.
CanPaste | Implementations should return a flag indicating whether the specified instance can be pasted into the specified target container.
CopyPerformed | Informs the implementation that the instance has been copied to the system clipboard.
CutPerformed | Informs the implementation that the instance has been cut and placed onto the system clipboard.
Paste | Implementations should paste the specified instance into the specified target container.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler Methods

The methods of the IClipboardHandler interface are listed below. For a complete list of IClipboardHandler interface members, see the IClipboardHandler Members topic.

Public Instance Methods

CanCopy | Implementations should return a flag indicating whether the specified instance can be copied to the system clipboard.
CanCut | Implementations should return a flag indicating whether the specified instance can be cut from the container ans copied to the system clipboard.
CanPaste | Implementations should return a flag indicating whether the specified instance can be pasted into the specified target container.
CopyPerformed | Informs the implementation that the instance has been copied to the system clipboard.
CutPerformed | Informs the implementation that the instance has been cut and placed onto the system clipboard.
Paste | Implementations should paste the specified instance into the specified target container.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.CanCopy Method

Implementations should return a flag indicating whether the specified instance can be copied to the system clipboard.

[Visual Basic]
Function CanCopy( _
ByVal instance As Object _
) As Boolean
[C#]
bool CanCopy(
object instance
);

Parameters

instance
The instance to be copied.

Return Value

true if the instance can be copied; false otherwise.

Remarks

Implementations can safely assume that the passed-in instance is not a null reference (Nothing in Visual Basic) and they can also safely cast the instance to the type for which the implementation is registered.

Most implementations simply return true from the method.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.CanCut Method

Implementations should return a flag indicating whether the specified instance can be cut from the container ans copied to the system clipboard.

[Visual Basic]
Function CanCut( _
ByVal instance As Object _
) As Boolean
[C#]
bool CanCut(
object instance
);

Parameters

instance
The instance to be cut.

Return Value

true if the instance can be cut; false otherwise.

Remarks

Implementations can safely assume that the passed-in instance is not a null reference (Nothing in Visual Basic) and they can also safely cast the instance to the type for which the implementation is registered.

Most implementations simply return true from the method.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.CanPaste Method

Implementations should return a flag indicating whether the specified instance can be pasted into the specified target container.

[Visual Basic]
Function CanPaste( _
ByVal instance As Object, _
ByVal target As Object, _
ByRef willPromptUser As Boolean _
) As Boolean
[C#]
bool CanPaste(
object instance,
object target,
ref bool willPromptUser
);

Parameters

instance
The instance to be pasted.
target
The target container where to put the instance.
willPromptUser
An output flag indicating whether a future Paste operation will potentially display a dialog.

Return Value

true if the instance can be pasted into the specified target container; false otherwise.

Remarks

Implementations can safely assume that the passed-in instance is not a null reference (Nothing in Visual Basic) and they can also safely cast the instance to the type for which the implementation is registered.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.CopyPerformed Method

Informs the implementation that the instance has been copied to the system clipboard.

[Visual Basic]
Sub CopyPerformed( _
ByVal instance As Object _
)
[C#]
void CopyPerformed(
object instance
);

Parameters

instance
The instance that has been copied.

Remarks

CAUTION The instance itself isn't put onto the clipboard; instead the instance is serialized and the serialized copy is put onto the clipboard.
Note Implementations typically don't have to do anything in this method.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.CutPerformed Method

Informs the implementation that the instance has been cut and placed onto the system clipboard.

[Visual Basic]
Sub CutPerformed( _
ByVal instance As Object _
)
[C#]
void CutPerformed(
object instance
);

Parameters

instance
The instance that has been cut.

Remarks

Note The implementation is responsible for actually removing the instance from the container where it resides.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


IClipboardHandler.Paste Method

Implementations should paste the specified instance into the specified target container.

[Visual Basic]
Sub Paste( _
ByVal instance As Object, _
ByVal target As Object _
)
[C#]
void Paste(
object instance,
object target
);

Parameters

instance
The instance to be pasted.
target
The target container where to put the instance.

Remarks

Implementations can safely assume that the passed-in instance is not a null reference (Nothing in Visual Basic) and they can also safely cast the instance to the type for which the implementation is registered.

CAUTION It is the sole responsibility of the implementation to actually add the instance to the target container.

See Also

IClipboardHandler Interface | LaMarvin.Design.Clipboard Namespace


LaMarvin.Design.Controls

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Controls Namespace

[This is preliminary documentation and subject to change.]

Contains various controls used throughout the LaMarvin Design Framework infrastructure.

Namespace hierarchy

Classes

Class | Description
AutoLinkLabel | A LinkLabel control descendant that automatically recognizes and processes HTML anchor (<a>) tags.
DesignerVerbsView | Represents a panel displaying DesignerVerbs as clickable hypelinks.
DropDownPicker | Represents a drop-down selector suitable for UITypeEditor implementations.
InstanceView | Implements a TreeView-like control for displaying arbitrary object graphs.
InstanceView.InstanceEntry | Represents a single node displayed in the InstanceView.
InstanceView.PropertyEntry | Implements an entry representing a property of an object displayed in the InstanceView.
KeyboardDrivenCheckedListBox | Implements a CheckedListBox that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.
KeyboardDrivenListBox | Implements a ListBox that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.
KeyboardDrivenTreeView | Implements a TreeView that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.


AutoLinkLabel Class

A LinkLabel control descendant that automatically recognizes and processes HTML anchor (<a>) tags.

For a list of all members of this type, see AutoLinkLabel Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.Label
System.Windows.Forms.LinkLabel
LaMarvin.Design.Controls.AutoLinkLabel

[Visual Basic]
NotInheritable Public Class AutoLinkLabel
Inherits LinkLabel
[C#]
public sealed class AutoLinkLabel : LinkLabel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Only the href attribute of the <a> tag is recognized and it must always be enclosed in double quotes, for example:

[Visual Basic]
Me.AutoLinkLabel1.Text = "<a href=""mailto:palo@lamarvin.com"">Click here</a> to email me."

[C#]
this.autoLinkLabel1.Text = @"<a href=""mailto:palo@lamarvin.com"">Click here</a> to email me."

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

AutoLinkLabel Members | LaMarvin.Design.Controls Namespace


AutoLinkLabel Members

AutoLinkLabel overview

Public Instance Constructors

AutoLinkLabel Constructor Initializes a new instance of the AutoLinkLabel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLinkColor (inherited from LinkLabel) | Gets or sets the color used to display an active link.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisabledLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a disabled link.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkArea (inherited from LinkLabel) | Gets or sets the range in the text to treat as a link.
LinkBehavior (inherited from LinkLabel) | Gets or sets a value that represents the behavior of a link.
LinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a normal link.
Links (inherited from LinkLabel) | Gets the collection of links contained within the LinkLabel.
LinkVisited (inherited from LinkLabel) | Gets or sets a value indicating whether a link should be displayed as though it were visited.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed in the control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisitedLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a link that that has been previously visited.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Label) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Label) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Label) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Label) |
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Label) |
KeyPress (inherited from Label) |
KeyUp (inherited from Label) |
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LinkClicked (inherited from LinkLabel) | Occurs when a link is clicked within the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Label) |
TextAlignChanged (inherited from Label) | Occurs when the value of the TextAlign property has changed.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

AutoLinkLabel Class | LaMarvin.Design.Controls Namespace


AutoLinkLabel Constructor

Initializes a new instance of the AutoLinkLabel class.

[Visual Basic]
Public Sub New()
[C#]
public AutoLinkLabel();

See Also

AutoLinkLabel Class | LaMarvin.Design.Controls Namespace


AutoLinkLabel Properties

The properties of the AutoLinkLabel class are listed below. For a complete list of AutoLinkLabel class members, see the AutoLinkLabel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLinkColor (inherited from LinkLabel) | Gets or sets the color used to display an active link.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoSize (inherited from Label) | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Label) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Label) | Gets or sets the border style for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisabledLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a disabled link.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FlatStyle (inherited from Label) | Gets or sets the flat style appearance of the label control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from Label) | Gets or sets the image that is displayed on a Label.
ImageAlign (inherited from Label) | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex (inherited from Label) | Gets or sets the index value of the image displayed on the Label.
ImageList (inherited from Label) | Gets or sets the ImageList that contains the images to display in the Label control.
ImeMode (inherited from Label) |
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkArea (inherited from LinkLabel) | Gets or sets the range in the text to treat as a link.
LinkBehavior (inherited from LinkLabel) | Gets or sets a value that represents the behavior of a link.
LinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a normal link.
Links (inherited from LinkLabel) | Gets the collection of links contained within the LinkLabel.
LinkVisited (inherited from LinkLabel) | Gets or sets a value indicating whether a link should be displayed as though it were visited.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from Label) | Gets the preferred height of the control.
PreferredWidth (inherited from Label) | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Label) |
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | Gets or sets the text displayed in the control.
TextAlign (inherited from Label) | Gets or sets the alignment of text in the label.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseMnemonic (inherited from Label) | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisitedLinkColor (inherited from LinkLabel) | Gets or sets the color used when displaying a link that that has been previously visited.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

AutoLinkLabel Class | LaMarvin.Design.Controls Namespace


AutoLinkLabel.Text Property

Gets or sets the text displayed in the control.

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

Property Value

The text with embedded HTML anchor tags.

Remarks

Setting the property automatically processes embedded HTML anchor tags and generates appropriate links.

CAUTION If setting the Text property to a string containing embedded anchor tags, the anchor tags are removed and only the content of the tags (the text between the opening <a> and closing </a> tags) is retained. Therefore the Text property might return a value that is different from the value it was set to.

See Also

AutoLinkLabel Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView Class

Represents a panel displaying DesignerVerbs as clickable hypelinks.

For a list of all members of this type, see DesignerVerbsView Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
LaMarvin.Design.Controls.DesignerVerbsView

[Visual Basic]
NotInheritable Public Class DesignerVerbsView
Inherits Control
[C#]
public sealed class DesignerVerbsView : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

DesignerVerbsView Members | LaMarvin.Design.Controls Namespace


DesignerVerbsView Members

DesignerVerbsView overview

Public Instance Constructors

DesignerVerbsView Constructor Initializes a new instance of the DesignerVerbsView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesignerVerbs | Gets or sets the collection of designer verbs to be displayed in the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself with the current set of DesignerVerbs.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView Constructor

Initializes a new instance of the DesignerVerbsView class.

[Visual Basic]
Public Sub New()
[C#]
public DesignerVerbsView();

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView Properties

The properties of the DesignerVerbsView class are listed below. For a complete list of DesignerVerbsView class members, see the DesignerVerbsView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle | Gets or sets the border style.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesignerVerbs | Gets or sets the collection of designer verbs to be displayed in the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView.BorderStyle Property

Gets or sets the border style.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}

Property Value

The border style.

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView.DesignerVerbs Property

Gets or sets the collection of designer verbs to be displayed in the control.

[Visual Basic]
Public Property DesignerVerbs As DesignerVerbCollection
[C#]
public System.ComponentModel.Design.DesignerVerbCollection DesignerVerbs {get; set;}

Property Value

The designer verbs collection.

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView Methods

The methods of the DesignerVerbsView class are listed below. For a complete list of DesignerVerbsView class members, see the DesignerVerbsView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself with the current set of DesignerVerbs.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DesignerVerbsView.Refresh Method

Forces the control to invalidate its client area and immediately redraw itself with the current set of DesignerVerbs.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

DesignerVerbsView Class | LaMarvin.Design.Controls Namespace


DropDownPicker Class

Represents a drop-down selector suitable for UITypeEditor implementations.

For a list of all members of this type, see DropDownPicker Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
LaMarvin.Design.Controls.DropDownPicker

[Visual Basic]
NotInheritable Public Class DropDownPicker
Inherits ContainerControl
[C#]
public sealed class DropDownPicker : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

DropDownPicker Members | LaMarvin.Design.Controls Namespace


DropDownPicker Members

DropDownPicker overview

Public Instance Constructors

DropDownPicker Constructor Initializes a new instance of the DropDownPicker class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Items | Gets or sets the collection of items to be displayed in the drop-down list.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem | Gets or sets the selected item.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemClicked | Occurs when an item in the drop-down list is clicked.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker Constructor

Initializes a new instance of the DropDownPicker class.

[Visual Basic]
Public Sub New()
[C#]
public DropDownPicker();

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker Properties

The properties of the DropDownPicker class are listed below. For a complete list of DropDownPicker class members, see the DropDownPicker Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Items | Gets or sets the collection of items to be displayed in the drop-down list.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SelectedItem | Gets or sets the selected item.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker.Items Property

Gets or sets the collection of items to be displayed in the drop-down list.

[Visual Basic]
Public Property Items As ICollection
[C#]
public System.Collections.ICollection Items {get; set;}

Property Value

The collection of items.

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker.SelectedItem Property

Gets or sets the selected item.

[Visual Basic]
Public Property SelectedItem As Object
[C#]
public object SelectedItem {get; set;}

Property Value

The selected item.

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker Events

The events of the DropDownPicker class are listed below. For a complete list of DropDownPicker class members, see the DropDownPicker Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemClicked | Occurs when an item in the drop-down list is clicked.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker.EnterPressed Event

Occurs when the user presses the Enter key.

[Visual Basic]
Public Event EnterPressed As KeyEventHandler
[C#]
public event KeyEventHandler EnterPressed;

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker.EscapePressed Event

Occurs when the user presses the Escape key.

[Visual Basic]
Public Event EscapePressed As KeyEventHandler
[C#]
public event KeyEventHandler EscapePressed;

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


DropDownPicker.ItemClicked Event

Occurs when an item in the drop-down list is clicked.

[Visual Basic]
Public Event ItemClicked As EventHandler
[C#]
public event EventHandler ItemClicked;

See Also

DropDownPicker Class | LaMarvin.Design.Controls Namespace


InstanceView Class

Implements a TreeView-like control for displaying arbitrary object graphs.

For a list of all members of this type, see InstanceView Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
LaMarvin.Design.Controls.InstanceView

[Visual Basic]
NotInheritable Public Class InstanceView
Inherits ContainerControl
[C#]
public sealed class InstanceView : ContainerControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

InstanceView Members | LaMarvin.Design.Controls Namespace


InstanceView Members

InstanceView overview

Public Instance Constructors

InstanceView Constructor Initializes a new instance of the InstanceView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsEmpty | Determines whether the view contains any entries.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
ManuallyFlushedUpdates | Sets or returns a flags indicating whether the control should repaint itself or wait for the host to call the FlushUpdates method.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootEntry | Returns an InstanceView.InstanceEntry reference representing the RootInstance associated with the control.
RootInstance | Sets or returns the root of an object graph displayed in the control.
SelectedEntry | Sets or returns the InstanceView.InstanceEntry that should be selected in the control.
SelectedInstance | Sets or returns the instance that appears as selected in the control.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CollapseAll | Collapses all entries of the view.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll | Expands all entries of the view.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FlushUpdates | Forces the control to be repainted if there are any pending updates.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelectedNodeText | Returns the text of the currently selected node, or an empty string if no node is currently selected.
GetTotalEntriesCount | Returns the total number of entries displayed in the control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Reconstructs the control display by requerying the associated RootInstance.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Occurs when the SelectedInstance value has changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView Constructor

Initializes a new instance of the InstanceView class.

[Visual Basic]
Public Sub New()
[C#]
public InstanceView();

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView Properties

The properties of the InstanceView class are listed below. For a complete list of InstanceView class members, see the InstanceView Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsEmpty | Determines whether the view contains any entries.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
ManuallyFlushedUpdates | Sets or returns a flags indicating whether the control should repaint itself or wait for the host to call the FlushUpdates method.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
RootEntry | Returns an InstanceView.InstanceEntry reference representing the RootInstance associated with the control.
RootInstance | Sets or returns the root of an object graph displayed in the control.
SelectedEntry | Sets or returns the InstanceView.InstanceEntry that should be selected in the control.
SelectedInstance | Sets or returns the instance that appears as selected in the control.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

[Visual Basic]
Overrides Public Property AllowDrop As Boolean
[C#]
public override bool AllowDrop {get; set;}

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.ContextMenu Property

Gets or sets the shortcut menu associated with the control.

[Visual Basic]
Overrides Public Property ContextMenu As ContextMenu
[C#]
public override System.Windows.Forms.ContextMenu ContextMenu {get; set;}

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.IsEmpty Property

Determines whether the view contains any entries.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}

Property Value

true if this instance is empty; otherwise false.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.ManuallyFlushedUpdates Property

Sets or returns a flags indicating whether the control should repaint itself or wait for the host to call the FlushUpdates method.

[Visual Basic]
Public Property ManuallyFlushedUpdates As Boolean
[C#]
public bool ManuallyFlushedUpdates {get; set;}

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.RootEntry Property

Returns an InstanceView.InstanceEntry reference representing the RootInstance associated with the control.

[Visual Basic]
Public ReadOnly Property RootEntry As InstanceEntry
[C#]
public InstanceView.InstanceEntry RootEntry {get;}

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.RootInstance Property

Sets or returns the root of an object graph displayed in the control.

[Visual Basic]
Public Property RootInstance As Object
[C#]
public object RootInstance {get; set;}

Remarks

If the RootInstance supports change notifications (by implementing the IChangeEventSource interface), the control automatically hooks the change events and repaints itself upon change. In this case, you don't need to manually refresh the control if the associated object graph changes.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.SelectedEntry Property

Sets or returns the InstanceView.InstanceEntry that should be selected in the control.

[Visual Basic]
Public Property SelectedEntry As InstanceEntry
[C#]
public InstanceView.InstanceEntry SelectedEntry {get; set;}

Remarks

Setting the SelectedEntry property also affects the value of the SelectedInstance property and vice versa.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.SelectedInstance Property

Sets or returns the instance that appears as selected in the control.

[Visual Basic]
Public Property SelectedInstance As Object
[C#]
public object SelectedInstance {get; set;}

Remarks

Setting the SelectedInstance property also affects the value of the SelectedEntry property and vice versa.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView Methods

The methods of the InstanceView class are listed below. For a complete list of InstanceView class members, see the InstanceView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CollapseAll | Collapses all entries of the view.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll | Expands all entries of the view.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FlushUpdates | Forces the control to be repainted if there are any pending updates.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelectedNodeText | Returns the text of the currently selected node, or an empty string if no node is currently selected.
GetTotalEntriesCount | Returns the total number of entries displayed in the control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh | Reconstructs the control display by requerying the associated RootInstance.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.CollapseAll Method

Collapses all entries of the view.

[Visual Basic]
Public Sub CollapseAll()
[C#]
public void CollapseAll();

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.ExpandAll Method

Expands all entries of the view.

[Visual Basic]
Public Sub ExpandAll()
[C#]
public void ExpandAll();

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.FlushUpdates Method

Forces the control to be repainted if there are any pending updates.

[Visual Basic]
Public Sub FlushUpdates()
[C#]
public void FlushUpdates();

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.GetSelectedNodeText Method

Returns the text of the currently selected node, or an empty string if no node is currently selected.

[Visual Basic]
Public Function GetSelectedNodeText() As String
[C#]
public string GetSelectedNodeText();

Return Value

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.GetTotalEntriesCount Method

Returns the total number of entries displayed in the control.

[Visual Basic]
Public Function GetTotalEntriesCount() As Integer
[C#]
public int GetTotalEntriesCount();

Return Value

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.Refresh Method

Reconstructs the control display by requerying the associated RootInstance.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView Events

The events of the InstanceView class are listed below. For a complete list of InstanceView class members, see the InstanceView Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectionChanged | Occurs when the SelectedInstance value has changed.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.EnterPressed Event

Occurs when the user presses the Enter key.

[Visual Basic]
Public Event EnterPressed As KeyEventHandler
[C#]
public event KeyEventHandler EnterPressed;

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.EscapePressed Event

Occurs when the user presses the Escape key.

[Visual Basic]
Public Event EscapePressed As KeyEventHandler
[C#]
public event KeyEventHandler EscapePressed;

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.SelectionChanged Event

Occurs when the SelectedInstance value has changed.

[Visual Basic]
Public Event SelectionChanged As EventHandler
[C#]
public event EventHandler SelectionChanged;

See Also

InstanceView Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry Class

Represents a single node displayed in the InstanceView.

For a list of all members of this type, see InstanceView.InstanceEntry Members.

System.Object
LaMarvin.Design.Controls.InstanceView.InstanceEntry
LaMarvin.Design.Controls.InstanceView.PropertyEntry

[Visual Basic]
Public Class InstanceView.InstanceEntry
[C#]
public class InstanceView.InstanceEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

InstanceView.InstanceEntry Members | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry Members

InstanceView.InstanceEntry overview

Public Instance Properties

Instance | Gets the object that this InstanceView.InstanceEntry represents.
Parent | Gets the InstanceView.InstanceEntry that is the parent of this entry.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand | Expands the node representing this entry.
ExpandAll | Expands the node and all subnodes of this entry.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refreshes this entry by requerying properties of the associated Instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry Properties

The properties of the InstanceView.InstanceEntry class are listed below. For a complete list of InstanceView.InstanceEntry class members, see the InstanceView.InstanceEntry Members topic.

Public Instance Properties

Instance | Gets the object that this InstanceView.InstanceEntry represents.
Parent | Gets the InstanceView.InstanceEntry that is the parent of this entry.

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry.Instance Property

Gets the object that this InstanceView.InstanceEntry represents.

[Visual Basic]
Public ReadOnly Property Instance As Object
[C#]
public object Instance {get;}

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry.Parent Property

Gets the InstanceView.InstanceEntry that is the parent of this entry.

[Visual Basic]
Public ReadOnly Property Parent As InstanceEntry
[C#]
public InstanceView.InstanceEntry Parent {get;}

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry Methods

The methods of the InstanceView.InstanceEntry class are listed below. For a complete list of InstanceView.InstanceEntry class members, see the InstanceView.InstanceEntry Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand | Expands the node representing this entry.
ExpandAll | Expands the node and all subnodes of this entry.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refreshes this entry by requerying properties of the associated Instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry.Expand Method

Expands the node representing this entry.

[Visual Basic]
Public Sub Expand()
[C#]
public void Expand();

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry.ExpandAll Method

Expands the node and all subnodes of this entry.

[Visual Basic]
Public Sub ExpandAll()
[C#]
public void ExpandAll();

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.InstanceEntry.Refresh Method

Refreshes this entry by requerying properties of the associated Instance.

[Visual Basic]
Overridable Public Sub Refresh()
[C#]
public virtual void Refresh();

See Also

InstanceView.InstanceEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry Class

Implements an entry representing a property of an object displayed in the InstanceView.

For a list of all members of this type, see InstanceView.PropertyEntry Members.

System.Object
LaMarvin.Design.Controls.InstanceView.InstanceEntry
LaMarvin.Design.Controls.InstanceView.PropertyEntry

[Visual Basic]
Public Class InstanceView.PropertyEntry
Inherits InstanceEntry
[C#]
public class InstanceView.PropertyEntry : InstanceEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

PropertyEntries are created by the InstanceView for properties that are decorated with the ExpandablePropertyAttribute attribute.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

InstanceView.PropertyEntry Members | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry Members

InstanceView.PropertyEntry overview

Public Instance Properties

Instance (inherited from InstanceEntry) | Gets the object that this InstanceView.InstanceEntry represents.
Parent (inherited from InstanceEntry) | Gets the InstanceView.InstanceEntry that is the parent of this entry.
PropertyDescriptor | Gets the PropertyDescriptor for the property this instance is representing.
PropertyTarget | Gets the owner of the property this instance is representing.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from InstanceEntry) | Expands the node representing this entry.
ExpandAll (inherited from InstanceEntry) | Expands the node and all subnodes of this entry.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refreshes this entry by requerying properties of the associated Instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry Properties

The properties of the InstanceView.PropertyEntry class are listed below. For a complete list of InstanceView.PropertyEntry class members, see the InstanceView.PropertyEntry Members topic.

Public Instance Properties

Instance (inherited from InstanceEntry) | Gets the object that this InstanceView.InstanceEntry represents.
Parent (inherited from InstanceEntry) | Gets the InstanceView.InstanceEntry that is the parent of this entry.
PropertyDescriptor | Gets the PropertyDescriptor for the property this instance is representing.
PropertyTarget | Gets the owner of the property this instance is representing.

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry.PropertyDescriptor Property

Gets the PropertyDescriptor for the property this instance is representing.

[Visual Basic]
Public ReadOnly Property PropertyDescriptor As PropertyDescriptor
[C#]
public System.ComponentModel.PropertyDescriptor PropertyDescriptor {get;}

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry.PropertyTarget Property

Gets the owner of the property this instance is representing.

[Visual Basic]
Public ReadOnly Property PropertyTarget As Object
[C#]
public object PropertyTarget {get;}

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry Methods

The methods of the InstanceView.PropertyEntry class are listed below. For a complete list of InstanceView.PropertyEntry class members, see the InstanceView.PropertyEntry Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Expand (inherited from InstanceEntry) | Expands the node representing this entry.
ExpandAll (inherited from InstanceEntry) | Expands the node and all subnodes of this entry.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refreshes this entry by requerying properties of the associated Instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


InstanceView.PropertyEntry.Refresh Method

Refreshes this entry by requerying properties of the associated Instance.

[Visual Basic]
Overrides Public Sub Refresh()
[C#]
public override void Refresh();

See Also

InstanceView.PropertyEntry Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox Class

Implements a CheckedListBox that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.

For a list of all members of this type, see KeyboardDrivenCheckedListBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
System.Windows.Forms.CheckedListBox
LaMarvin.Design.Controls.KeyboardDrivenCheckedListBox

[Visual Basic]
Public Class KeyboardDrivenCheckedListBox
Inherits CheckedListBox
[C#]
public class KeyboardDrivenCheckedListBox : CheckedListBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

KeyboardDrivenCheckedListBox Members | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox Members

KeyboardDrivenCheckedListBox overview

Public Instance Constructors

KeyboardDrivenCheckedListBox Constructor Initializes a new instance of the KeyboardDrivenCheckedListBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from CheckedListBox) |
DisplayMember (inherited from CheckedListBox) |
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from CheckedListBox) |
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
CheckedIndices (inherited from CheckedListBox) | Collection of checked indexes in this CheckedListBox .
CheckedItems (inherited from CheckedListBox) | Collection of checked items in this CheckedListBox .
CheckOnClick (inherited from CheckedListBox) | Gets or sets a value indicating whether the check box should be toggled when an item is selected.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from CheckedListBox) |
Items (inherited from CheckedListBox) | Gets the collection of items in this CheckedListBox.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from CheckedListBox) | Gets or sets a value specifying the selection mode.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
ThreeDCheckBoxes (inherited from CheckedListBox) | Gets or sets a value indicating whether the check boxes display as Flat or Normal in appearance.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from CheckedListBox) |
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemChecked (inherited from CheckedListBox) | Returns a value indicating whether the specified item is checked.
GetItemCheckState (inherited from CheckedListBox) | Returns a value indicating the check state of the current item.
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetItemChecked (inherited from CheckedListBox) | Sets the item at the specified index to Checked .
SetItemCheckState (inherited from CheckedListBox) | Sets the check state of the item at the specified index.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from CheckedListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from CheckedListBox) |
DisplayMemberChanged (inherited from CheckedListBox) |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from CheckedListBox) |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemCheck (inherited from CheckedListBox) | Occurs when the checked state of an item changes.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from CheckedListBox) |
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from CheckedListBox) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from CheckedListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from CheckedListBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from CheckedListBox) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from CheckedListBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from CheckedListBox) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from CheckedListBox) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from CheckedListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from CheckedListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from ListBox) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemCheck (inherited from CheckedListBox) |
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from CheckedListBox) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from CheckedListBox) |
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from CheckedListBox) | Raises the SelectedIndexChanged event.
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from CheckedListBox) |
WndProc (inherited from CheckedListBox) |

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox Constructor

Initializes a new instance of the KeyboardDrivenCheckedListBox class.

[Visual Basic]
Public Sub New()
[C#]
public KeyboardDrivenCheckedListBox();

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox Methods

The methods of the KeyboardDrivenCheckedListBox class are listed below. For a complete list of KeyboardDrivenCheckedListBox class members, see the KeyboardDrivenCheckedListBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemChecked (inherited from CheckedListBox) | Returns a value indicating whether the specified item is checked.
GetItemCheckState (inherited from CheckedListBox) | Returns a value indicating the check state of the current item.
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetItemChecked (inherited from CheckedListBox) | Sets the item at the specified index to Checked .
SetItemCheckState (inherited from CheckedListBox) | Sets the check state of the item at the specified index.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from CheckedListBox) |
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from CheckedListBox) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from CheckedListBox) |
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from CheckedListBox) |
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from CheckedListBox) |
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from CheckedListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from CheckedListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from ListBox) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemCheck (inherited from CheckedListBox) |
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from CheckedListBox) |
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from CheckedListBox) |
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from CheckedListBox) | Raises the SelectedIndexChanged event.
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from CheckedListBox) |
WndProc (inherited from CheckedListBox) |

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox.OnEnterPressed Method

Raises the EnterPressed event.

[Visual Basic]
Overridable Protected Sub OnEnterPressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEnterPressed(
KeyEventArgs e
);

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox.OnEscapePressed Method

Raises the EscapePressed event.

[Visual Basic]
Overridable Protected Sub OnEscapePressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEscapePressed(
KeyEventArgs e
);

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox.ProcessDialogKey Method

Overrides the method by handling the Enter and Escape keys and raising the appropriate events.

[Visual Basic]
Overrides Protected Function ProcessDialogKey( _
ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessDialogKey(
Keys keyData
);

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox Events

The events of the KeyboardDrivenCheckedListBox class are listed below. For a complete list of KeyboardDrivenCheckedListBox class members, see the KeyboardDrivenCheckedListBox Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from CheckedListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from CheckedListBox) |
DisplayMemberChanged (inherited from CheckedListBox) |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from CheckedListBox) |
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemCheck (inherited from CheckedListBox) | Occurs when the checked state of an item changes.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from CheckedListBox) |
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from CheckedListBox) |
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox.EnterPressed Event

Occurs when the user presses the Enter key.

[Visual Basic]
Public Event EnterPressed As KeyEventHandler
[C#]
public event KeyEventHandler EnterPressed;

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenCheckedListBox.EscapePressed Event

Occurs when the user presses the Escape key.

[Visual Basic]
Public Event EscapePressed As KeyEventHandler
[C#]
public event KeyEventHandler EscapePressed;

See Also

KeyboardDrivenCheckedListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox Class

Implements a ListBox that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.

For a list of all members of this type, see KeyboardDrivenListBox Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
LaMarvin.Design.Controls.KeyboardDrivenListBox

[Visual Basic]
Public Class KeyboardDrivenListBox
Inherits ListBox
[C#]
public class KeyboardDrivenListBox : ListBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

KeyboardDrivenListBox Members | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox Members

KeyboardDrivenListBox overview

Public Instance Constructors

KeyboardDrivenListBox Constructor Initializes a new instance of the KeyboardDrivenListBox class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from ListBox) |
BackgroundImage (inherited from ListBox) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from ListBox) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
ColumnWidth (inherited from ListBox) | Gets or sets the width of columns in a multicolumn ListBox.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl .
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DrawMode (inherited from ListBox) | Gets or sets the drawing mode for the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from ListBox) |
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent (inherited from ListBox) | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar (inherited from ListBox) | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
IntegralHeight (inherited from ListBox) | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from ListBox) | Gets or sets the height of an item in the ListBox .
Items (inherited from ListBox) | Gets the items of the ListBox .
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MultiColumn (inherited from ListBox) | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from ListBox) | Gets the combined height of all items in the ListBox .
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from ListBox) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
ScrollAlwaysVisible (inherited from ListBox) | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex (inherited from ListBox) | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndices (inherited from ListBox) | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem (inherited from ListBox) | Gets or sets the currently selected item in the ListBox .
SelectedItems (inherited from ListBox) | Gets a collection containing the currently selected items in the ListBox .
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode (inherited from ListBox) | Gets or sets the method in which items are selected in the ListBox .
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from ListBox) | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from ListBox) | Gets or searches for the text of the currently selected item in the ListBox .
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex (inherited from ListBox) | Gets or sets the index of the first visible item in the ListBox .
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseTabStops (inherited from ListBox) | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from ListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ListBox) | Occurs when a visual aspect of an owner-drawn ListBox changes.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ListBox) | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ListBox) |
DataManager (inherited from ListControl) | Gets the CurrencyManager associated with this control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from ListBox) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from ListBox) | Creates a new instance of the item collection.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ListBox) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from ListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from ListBox) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ListBox) | Raises the MeasureItem event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from ListBox) |
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from ListBox) |
WndProc (inherited from ListBox) |

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox Constructor

Initializes a new instance of the KeyboardDrivenListBox class.

[Visual Basic]
Public Sub New()
[C#]
public KeyboardDrivenListBox();

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox Methods

The methods of the KeyboardDrivenListBox class are listed below. For a complete list of KeyboardDrivenListBox class members, see the KeyboardDrivenListBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from ListBox) | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSelected (inherited from ListBox) | Unselects all items in the ListBox .
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from ListBox) | Resumes painting the ListBox control after painting is suspended by the BeginUpdatemethod.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
FindString (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that starts with the specified string.
FindStringExact (inherited from ListBox) | Overloaded. Finds the first item in the ListBox that exactly matches the specified string.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemHeight (inherited from ListBox) | Returns the height of an item in the ListBox .
GetItemRectangle (inherited from ListBox) | Returns the bounding rectangle for an item in the ListBox .
GetItemText (inherited from ListControl) | Returns the text representation of the specified item.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSelected (inherited from ListBox) | Returns a value indicating whether the specified item is selected.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
IndexFromPoint (inherited from ListBox) | Overloaded. Returns the zero-based index of the item at the specified coordinates.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from ListBox) |
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetSelected (inherited from ListBox) | Selects or clears the selection for the specified item in a ListBox .
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from ListBox) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AddItemsCore (inherited from ListBox) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
CreateItemCollection (inherited from ListBox) | Creates a new instance of the item collection.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
FilterItemOnProperty (inherited from ListControl) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from ListControl) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from ListControl) |
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDataSourceChanged (inherited from ListBox) |
OnDisplayMemberChanged (inherited from ListBox) |
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnDrawItem (inherited from ListBox) | Raises the DrawItem event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from ListBox) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from ListBox) |
OnHandleDestroyed (inherited from ListBox) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from ListBox) |
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMeasureItem (inherited from ListBox) | Raises the MeasureItem event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from ListBox) |
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from ListBox) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSelectedIndexChanged (inherited from ListBox) |
OnSelectedValueChanged (inherited from ListBox) |
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueMemberChanged (inherited from ListControl) | Raises the ValueMemberChanged event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
RefreshItem (inherited from ListBox) |
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from ListBox) |
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetItemCore (inherited from ListBox) |
SetItemsCore (inherited from ListBox) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
Sort (inherited from ListBox) | Sorts the items in the ListBox alphabetically.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WmReflectCommand (inherited from ListBox) |
WndProc (inherited from ListBox) |

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox.OnEnterPressed Method

Raises the EnterPressed event.

[Visual Basic]
Overridable Protected Sub OnEnterPressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEnterPressed(
KeyEventArgs e
);

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox.OnEscapePressed Method

Raises the EscapePressed event.

[Visual Basic]
Overridable Protected Sub OnEscapePressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEscapePressed(
KeyEventArgs e
);

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox.ProcessDialogKey Method

Overrides the method by handling the Enter and Escape keys and raising the appropriate events.

[Visual Basic]
Overrides Protected Function ProcessDialogKey( _
ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessDialogKey(
Keys keyData
);

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox Events

The events of the KeyboardDrivenListBox class are listed below. For a complete list of KeyboardDrivenListBox class members, see the KeyboardDrivenListBox Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from ListBox) |
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from ListBox) |
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
DataSourceChanged (inherited from ListControl) | Occurs when the DataSource changes.
DisplayMemberChanged (inherited from ListControl) | Occurs when the DisplayMember property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawItem (inherited from ListBox) | Occurs when a visual aspect of an owner-drawn ListBox changes.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Occurs when the user presses the Enter key.
EscapePressed | Occurs when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MeasureItem (inherited from ListBox) | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from ListBox) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SelectedIndexChanged (inherited from ListBox) | Occurs when the SelectedIndex property has changed.
SelectedValueChanged (inherited from ListControl) | Occurs when the SelectedValue property changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from ListBox) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueMemberChanged (inherited from ListControl) | Occurs when the ValueMember property changes.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox.EnterPressed Event

Occurs when the user presses the Enter key.

[Visual Basic]
Public Event EnterPressed As KeyEventHandler
[C#]
public event KeyEventHandler EnterPressed;

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenListBox.EscapePressed Event

Occurs when the user presses the Escape key.

[Visual Basic]
Public Event EscapePressed As KeyEventHandler
[C#]
public event KeyEventHandler EscapePressed;

See Also

KeyboardDrivenListBox Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView Class

Implements a TreeView that handles the Enter and Escape keys and raises the corresponding EnterPressed and EscapePressed events, respectively.

For a list of all members of this type, see KeyboardDrivenTreeView Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TreeView
LaMarvin.Design.Controls.KeyboardDrivenTreeView

[Visual Basic]
Public Class KeyboardDrivenTreeView
Inherits TreeView
[C#]
public class KeyboardDrivenTreeView : TreeView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Controls

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

KeyboardDrivenTreeView Members | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView Members

KeyboardDrivenTreeView overview

Public Instance Constructors

KeyboardDrivenTreeView Constructor Initializes a new instance of the KeyboardDrivenTreeView class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from TreeView) |
BackgroundImage (inherited from TreeView) |
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from TreeView) | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from TreeView) |
FullRowSelect (inherited from TreeView) | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TreeView) | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking (inherited from TreeView) | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
CheckBoxes (inherited from TreeView) | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
ImageIndex (inherited from TreeView) | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList (inherited from TreeView) | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from TreeView) | Gets or sets the distance to indent each of the child tree node levels.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
ItemHeight (inherited from TreeView) | Gets or sets the height of each tree node in the tree view control.
LabelEdit (inherited from TreeView) | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes (inherited from TreeView) | Gets the collection of tree nodes that are assigned to the tree view control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator (inherited from TreeView) | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Scrollable (inherited from TreeView) | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex (inherited from TreeView) | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode (inherited from TreeView) | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus (inherited from TreeView) | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines (inherited from TreeView) | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Sorted (inherited from TreeView) | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from TreeView) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopNode (inherited from TreeView) | Gets the first fully-visible tree node in the tree view control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
VisibleCount (inherited from TreeView) | Gets the number of tree nodes that can be fully visible in the tree view control.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Raised when the user presses the Enter key.
EscapePressed | Raise when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from TreeView) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from TreeView) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetItemRenderStyles (inherited from TreeView) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView Constructor

Initializes a new instance of the KeyboardDrivenTreeView class.

[Visual Basic]
Public Sub New()
[C#]
public KeyboardDrivenTreeView();

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView Methods

The methods of the KeyboardDrivenTreeView class are listed below. For a complete list of KeyboardDrivenTreeView class members, see the KeyboardDrivenTreeView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BeginUpdate (inherited from TreeView) | Disables any redrawing of the tree view.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CollapseAll (inherited from TreeView) | Collapses all the tree nodes.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
EndUpdate (inherited from TreeView) | Enables the redrawing of the tree view.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandAll (inherited from TreeView) | Expands all the tree nodes.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetNodeAt (inherited from TreeView) | Overloaded. Retrieves the tree node that is at the specified point.
GetNodeCount (inherited from TreeView) | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from TreeView) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from TreeView) |
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from TreeView) | Overloaded.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetItemRenderStyles (inherited from TreeView) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from TreeView) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnAfterCollapse (inherited from TreeView) | Raises the AfterCollapse event.
OnAfterExpand (inherited from TreeView) | Raises the AfterExpand event.
OnAfterCheck (inherited from TreeView) | Raises the AfterCheck event.
OnAfterLabelEdit (inherited from TreeView) | Raises the AfterLabelEdit event.
OnAfterSelect (inherited from TreeView) | Raises the AfterSelect event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBeforeCollapse (inherited from TreeView) | Raises the BeforeCollapse event.
OnBeforeExpand (inherited from TreeView) | Raises the BeforeExpand event.
OnBeforeCheck (inherited from TreeView) | Raises the BeforeCheck event.
OnBeforeLabelEdit (inherited from TreeView) | Raises the BeforeLabelEdit event.
OnBeforeSelect (inherited from TreeView) | Raises the BeforeSelect event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnEnterPressed | Raises the EnterPressed event.
OnEscapePressed | Raises the EscapePressed event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from TreeView) |
OnHandleDestroyed (inherited from TreeView) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnItemDrag (inherited from TreeView) | Raises the ItemDrag event.
OnKeyDown (inherited from TreeView) |
OnKeyPress (inherited from TreeView) |
OnKeyUp (inherited from TreeView) |
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey | Overrides the method by handling the Enter and Escape keys and raising the appropriate events.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyMessage (inherited from Control) | Processes a keyboard message.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc | This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.OnEnterPressed Method

Raises the EnterPressed event.

[Visual Basic]
Overridable Protected Sub OnEnterPressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEnterPressed(
KeyEventArgs e
);

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.OnEscapePressed Method

Raises the EscapePressed event.

[Visual Basic]
Overridable Protected Sub OnEscapePressed( _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnEscapePressed(
KeyEventArgs e
);

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.OnMouseDown Method

Raises the MouseDown event.

[Visual Basic]
Overrides Protected Sub OnMouseDown( _
ByVal e As MouseEventArgs _
)
[C#]
protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e
A MouseEventArgs that contains the event data.

Remarks

Contrary to the TreeView ancestor, the right mouse click also changes the selected node just like the left mouse click.

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.ProcessDialogKey Method

Overrides the method by handling the Enter and Escape keys and raising the appropriate events.

[Visual Basic]
Overrides Protected Function ProcessDialogKey( _
ByVal keyData As Keys _
) As Boolean
[C#]
protected override bool ProcessDialogKey(
Keys keyData
);

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.WndProc Method

This member supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overrides Protected Sub WndProc( _
ByRef m As Message _
)
[C#]
protected override void WndProc(
ref Message m
);

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView Events

The events of the KeyboardDrivenTreeView class are listed below. For a complete list of KeyboardDrivenTreeView class members, see the KeyboardDrivenTreeView Members topic.

Public Instance Events

AfterCollapse (inherited from TreeView) | Occurs after the tree node is collapsed.
AfterExpand (inherited from TreeView) | Occurs after the tree node is expanded.
AfterCheck (inherited from TreeView) | Occurs after the tree node check box is checked.
AfterLabelEdit (inherited from TreeView) | Occurs after the tree node label text is edited.
AfterSelect (inherited from TreeView) | Occurs after the tree node is selected.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from TreeView) |
BeforeCollapse (inherited from TreeView) | Occurs before the tree node is collapsed.
BeforeExpand (inherited from TreeView) | Occurs before the tree node is expanded.
BeforeCheck (inherited from TreeView) | Occurs before the tree node check box is checked.
BeforeLabelEdit (inherited from TreeView) | Occurs before the tree node label text is edited.
BeforeSelect (inherited from TreeView) | Occurs before the tree node is selected.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
EnterPressed | Raised when the user presses the Enter key.
EscapePressed | Raise when the user presses the Escape key.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when an item is dragged into the tree view control.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from TreeView) |
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from TreeView) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.EnterPressed Event

Raised when the user presses the Enter key.

[Visual Basic]
Public Event EnterPressed As KeyEventHandler
[C#]
public event KeyEventHandler EnterPressed;

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


KeyboardDrivenTreeView.EscapePressed Event

Raise when the user presses the Escape key.

[Visual Basic]
Public Event EscapePressed As KeyEventHandler
[C#]
public event KeyEventHandler EscapePressed;

See Also

KeyboardDrivenTreeView Class | LaMarvin.Design.Controls Namespace


LaMarvin.Design.Persistence

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Persistence Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting document-like persistence mechanisms used by the design infrastructure.

Namespace hierarchy

Classes

Class | Description
FileMoniker | Implements a moniker representing a file in the file system.
PersistentMoniker | Defines a name representing a unique location in a storage namespace of the corresponding PersistentStore implementation.
PersistentStore | Represents a contract for a storage engine that is able load, save and uniquely identify documents.


FileMoniker Class

Implements a moniker representing a file in the file system.

For a list of all members of this type, see FileMoniker Members.

System.Object
LaMarvin.Design.Persistence.PersistentMoniker
LaMarvin.Design.Persistence.FileMoniker

[Visual Basic]
<Serializable>
Public Class FileMoniker
Inherits PersistentMoniker
[C#]
[Serializable]
public class FileMoniker : PersistentMoniker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Persistence

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

FileMoniker Members | LaMarvin.Design.Persistence Namespace


FileMoniker Members

FileMoniker overview

Public Instance Constructors

FileMoniker Overloaded. Initializes a new instance of the FileMoniker class.

Public Instance Properties

DisplayName | Returns the display name of the file this moniker represents.
IsEmpty | Return true if the moniker is empty; false otherwise.
Name | Returns the full path to the file this instance represents.
Path | Sets or returns the path to the file this moniker represents.

Public Instance Methods

Equals (inherited from PersistentMoniker) | Persistent monikers base their equality on their type and the value of the Name property.
GetHashCode (inherited from PersistentMoniker) | Gets the hash code of this moniker.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeEmpty | Marks this file moniker as empty.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker Constructor

Initializes a new instance of the FileMoniker class as an empty moniker.

Overload List

Initializes a new instance of the FileMoniker class as an empty moniker.

public FileMoniker();

Initializes a new instance of the FileMoniker class for the specified path.

public FileMoniker(string);

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker Constructor ()

Initializes a new instance of the FileMoniker class as an empty moniker.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileMoniker();

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace | FileMoniker Constructor Overload List


FileMoniker Constructor (String)

Initializes a new instance of the FileMoniker class for the specified path.

[Visual Basic]
Overloads Public Sub New( _
ByVal path As String _
)
[C#]
public FileMoniker(
string path
);

Parameters

path
The path to the file that this moniker represents.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace | FileMoniker Constructor Overload List


FileMoniker Properties

The properties of the FileMoniker class are listed below. For a complete list of FileMoniker class members, see the FileMoniker Members topic.

Public Instance Properties

DisplayName | Returns the display name of the file this moniker represents.
IsEmpty | Return true if the moniker is empty; false otherwise.
Name | Returns the full path to the file this instance represents.
Path | Sets or returns the path to the file this moniker represents.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker.DisplayName Property

Returns the display name of the file this moniker represents.

[Visual Basic]
Overrides Public ReadOnly Property DisplayName As String
[C#]
public override string DisplayName {get;}

Remarks

If the path to the file is longer that 60 characters, the display name is shortened by excluding the intermediary directory names as neccessary.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker.IsEmpty Property

Return true if the moniker is empty; false otherwise.

[Visual Basic]
Overrides Public ReadOnly Property IsEmpty As Boolean
[C#]
public override bool IsEmpty {get;}

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker.Name Property

Returns the full path to the file this instance represents.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker.Path Property

Sets or returns the path to the file this moniker represents.

[Visual Basic]
Public Property Path As String
[C#]
public string Path {get; set;}

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker Methods

The methods of the FileMoniker class are listed below. For a complete list of FileMoniker class members, see the FileMoniker Members topic.

Public Instance Methods

Equals (inherited from PersistentMoniker) | Persistent monikers base their equality on their type and the value of the Name property.
GetHashCode (inherited from PersistentMoniker) | Gets the hash code of this moniker.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeEmpty | Marks this file moniker as empty.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


FileMoniker.MakeEmpty Method

Marks this file moniker as empty.

[Visual Basic]
Overrides Public Sub MakeEmpty()
[C#]
public override void MakeEmpty();

Remarks

The Path property isn't affected by calling this method.

See Also

FileMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker Class

Defines a name representing a unique location in a storage namespace of the corresponding PersistentStore implementation.

For a list of all members of this type, see PersistentMoniker Members.

System.Object
LaMarvin.Design.Persistence.PersistentMoniker
LaMarvin.Design.Persistence.FileMoniker

[Visual Basic]
<Serializable>
MustInherit Public Class PersistentMoniker
[C#]
[Serializable]
public abstract class PersistentMoniker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Persistence

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

PersistentMoniker Members | LaMarvin.Design.Persistence Namespace


PersistentMoniker Members

PersistentMoniker overview

Public Instance Properties

DisplayName | Derived classes should return the name of the moniker that can be displayed to the user.
IsEmpty | Derived classes should return true if the moniker is empty; false otherwise.
Name | Derived classes should return the unique name of the moniker.

Public Instance Methods

Equals | Persistent monikers base their equality on their type and the value of the Name property.
GetHashCode | Gets the hash code of this moniker.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeEmpty | Derived classes should make the moniker empty (i.e. the IsEmpty property should return true after calling this method).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PersistentMoniker Constructor Initializes a new instance of the PersistentMoniker class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker Constructor

Initializes a new instance of the PersistentMoniker class.

[Visual Basic]
Protected Sub New()
[C#]
protected PersistentMoniker();

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker Properties

The properties of the PersistentMoniker class are listed below. For a complete list of PersistentMoniker class members, see the PersistentMoniker Members topic.

Public Instance Properties

DisplayName | Derived classes should return the name of the moniker that can be displayed to the user.
IsEmpty | Derived classes should return true if the moniker is empty; false otherwise.
Name | Derived classes should return the unique name of the moniker.

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.DisplayName Property

Derived classes should return the name of the moniker that can be displayed to the user.

[Visual Basic]
MustOverride Public ReadOnly Property DisplayName As String
[C#]
public abstract string DisplayName {get;}

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.IsEmpty Property

Derived classes should return true if the moniker is empty; false otherwise.

[Visual Basic]
MustOverride Public ReadOnly Property IsEmpty As Boolean
[C#]
public abstract bool IsEmpty {get;}

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.Name Property

Derived classes should return the unique name of the moniker.

[Visual Basic]
MustOverride Public ReadOnly Property Name As String
[C#]
public abstract string Name {get;}

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker Methods

The methods of the PersistentMoniker class are listed below. For a complete list of PersistentMoniker class members, see the PersistentMoniker Members topic.

Public Instance Methods

Equals | Persistent monikers base their equality on their type and the value of the Name property.
GetHashCode | Gets the hash code of this moniker.
GetType (inherited from Object) | Gets the Type of the current instance.
MakeEmpty | Derived classes should make the moniker empty (i.e. the IsEmpty property should return true after calling this method).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.Equals Method

Persistent monikers base their equality on their type and the value of the Name property.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The other PersistentMoniker instance to compare this instance to.

Return Value

true if the current instance is of the same type and has the same Name property value as ; false otherwise.

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.GetHashCode Method

Gets the hash code of this moniker.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentMoniker.MakeEmpty Method

Derived classes should make the moniker empty (i.e. the IsEmpty property should return true after calling this method).

[Visual Basic]
MustOverride Public Sub MakeEmpty()
[C#]
public abstract void MakeEmpty();

See Also

PersistentMoniker Class | LaMarvin.Design.Persistence Namespace


PersistentStore Class

Represents a contract for a storage engine that is able load, save and uniquely identify documents.

For a list of all members of this type, see PersistentStore Members.

System.Object
LaMarvin.Design.Persistence.PersistentStore
LaMarvin.Constable.Design.Persistence.FilePolicyStore

[Visual Basic]
<Serializable>
MustInherit Public Class PersistentStore
[C#]
[Serializable]
public abstract class PersistentStore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Design.Persistence

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

PersistentStore Members | LaMarvin.Design.Persistence Namespace


PersistentStore Members

PersistentStore overview

Public Instance Methods

CreateEmptyMoniker | Derived classes should create a moniker representing a nonexistent (unnamed) document.
CreateMoniker | Derived classes should create a moniker representing the specified string name.
Equals | Determines if the current store equals to the specified store.
GetHashCode | Gets the hash code of this storage instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Derived classes should load the document identified by the specified moniker and return an object that represents the document in memory.
Open | Derived classes should override this method to display a dialog allowing the user to select a document from the underlying store.
PromptForMoniker | Derived classes should display a dialog allowing the user to select a name for a new document into which the specified instance can be saved.
Save | Derived classes should save the specified instance to a document identified by the specified moniker.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PersistentStore Constructor Initializes a new instance of the PersistentStore class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore Constructor

Initializes a new instance of the PersistentStore class.

[Visual Basic]
Protected Sub New()
[C#]
protected PersistentStore();

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore Methods

The methods of the PersistentStore class are listed below. For a complete list of PersistentStore class members, see the PersistentStore Members topic.

Public Instance Methods

CreateEmptyMoniker | Derived classes should create a moniker representing a nonexistent (unnamed) document.
CreateMoniker | Derived classes should create a moniker representing the specified string name.
Equals | Determines if the current store equals to the specified store.
GetHashCode | Gets the hash code of this storage instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Derived classes should load the document identified by the specified moniker and return an object that represents the document in memory.
Open | Derived classes should override this method to display a dialog allowing the user to select a document from the underlying store.
PromptForMoniker | Derived classes should display a dialog allowing the user to select a name for a new document into which the specified instance can be saved.
Save | Derived classes should save the specified instance to a document identified by the specified moniker.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.CreateEmptyMoniker Method

Derived classes should create a moniker representing a nonexistent (unnamed) document.

[Visual Basic]
MustOverride Public Function CreateEmptyMoniker() As PersistentMoniker
[C#]
public abstract PersistentMoniker CreateEmptyMoniker();

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.CreateMoniker Method

Derived classes should create a moniker representing the specified string name.

[Visual Basic]
MustOverride Public Function CreateMoniker( _
ByVal name As String _
) As PersistentMoniker
[C#]
public abstract PersistentMoniker CreateMoniker(
string name
);

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.Equals Method

Determines if the current store equals to the specified store.

[Visual Basic]
Overrides Public Function Equals( _
ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
object obj
);

Parameters

obj
The other PersistentStore instance to compare this instance to.

Return Value

true if the current isstance is of the same type as ; false otherwise.

Remarks

Persistent stores should be stateless because their equality is based on their types.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.GetHashCode Method

Gets the hash code of this storage instance.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Remarks

Returns the hash code of the underlying Type.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.Load Method

Derived classes should load the document identified by the specified moniker and return an object that represents the document in memory.

[Visual Basic]
MustOverride Public Function Load( _
ByVal moniker As PersistentMoniker, _
ByRef loadedCleanly As Boolean _
) As Object
[C#]
public abstract object Load(
PersistentMoniker moniker,
ref bool loadedCleanly
);

Parameters

moniker
The moniker identifying the document to be loaded from the underying storage.
loadedCleanly
A flag indicating whether the document was loaded without problems.

Return Value

A reference to the in-memory representation of the document.

Remarks

The implementation should set the loadedCleanly parameter to true if the document was loaded without problems. The parameter should be set to false if there were some problems loading the document and the user shouldn't be able to later overwrite the document without prompting.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.Open Method

Derived classes should override this method to display a dialog allowing the user to select a document from the underlying store.

[Visual Basic]
MustOverride Public Function Open( _
ByVal dialogOwner As IWin32Window _
) As PersistentMoniker
[C#]
public abstract PersistentMoniker Open(
IWin32Window dialogOwner
);

Parameters

dialogOwner
The owner of the selection dialog.

Return Value

A reference to the selected document represented by the PersistentMoniker or a null reference (Nothing in Visual Basic) if the user cancelled the selection.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.PromptForMoniker Method

Derived classes should display a dialog allowing the user to select a name for a new document into which the specified instance can be saved.

[Visual Basic]
MustOverride Public Function PromptForMoniker( _
ByVal dialogOwner As IWin32Window, _
ByVal instance As Object _
) As PersistentMoniker
[C#]
public abstract PersistentMoniker PromptForMoniker(
IWin32Window dialogOwner,
object instance
);

Parameters

dialogOwner
The owner of the displayed dialog.
instance
The instance for which the user is selecting a storage location.

Return Value

A reference to a PersistentMoniker representing the location where the document can be saved or a null reference (Nothing in Visual Basic) if the user cancelled the selection.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


PersistentStore.Save Method

Derived classes should save the specified instance to a document identified by the specified moniker.

[Visual Basic]
MustOverride Public Sub Save( _
ByVal instance As Object, _
ByVal moniker As PersistentMoniker _
)
[C#]
public abstract void Save(
object instance,
PersistentMoniker moniker
);

Parameters

instance
The instance to be saved.
moniker
The moniker identifying the document in the underlying storage.

See Also

PersistentStore Class | LaMarvin.Design.Persistence Namespace


LaMarvin.Remoting

Constable Authorization Engine 2.0 BETA

LaMarvin.Remoting Namespace

[This is preliminary documentation and subject to change.]

Defines types used for flexible, loosely-typed remoting configurations.

Namespace hierarchy

Classes

Class | Description
DataServerBase | Provides a base class for remote server implementations that access an Microsoft SQL Server database.
ServerBase | Provides a base class for remote server implementations.
ServerProxy | Serves as a proxy to local or remote IRemoteServer implementation.

Interfaces

Interface | Description
IRemoteServer | Defines a contract for loosely-typed remote server invocations.


DataServerBase Class

Provides a base class for remote server implementations that access an Microsoft SQL Server database.

For a list of all members of this type, see DataServerBase Members.

System.Object
System.MarshalByRefObject
LaMarvin.Remoting.ServerBase
LaMarvin.Remoting.DataServerBase

[Visual Basic]
MustInherit Public Class DataServerBase
Inherits ServerBase
[C#]
public abstract class DataServerBase : ServerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Remoting

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

DataServerBase Members | LaMarvin.Remoting Namespace


DataServerBase Members

DataServerBase overview

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

DataServerBase Constructor Initializes a new instance of the DataServerBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataBase | Returns a reference to the underlying DataBase instance initialized in the InitializeDataBase method.
InitializeDataBase | The derived class should initialize and return a valid database connection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveArgumentTypes (inherited from ServerBase) | Resolves argument types for the given argument values.
ServerMethodEntryNotTransacted | Starts the execution of a public method that doesn't require transactions.
ServerMethodEntryTransacted | Starts the execution of a public method requiring transactional semantics.
ServerMethodEntyNotTransacted |
ServerMethodExitFailure | Ends the unsuccessful execution of a public method and rolls back the transaction (if any).
ServerMethodExitInternal | This member supports the LaMarvin.Common library infrastructure and is not intended to be used directly from your code.
ServerMethodExitSuccess | Overloaded. Ends the successful execution of a public method and commits the transaction (if any).

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase Constructor

Initializes a new instance of the DataServerBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected DataServerBase();

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase Methods

The methods of the DataServerBase class are listed below. For a complete list of DataServerBase class members, see the DataServerBase Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetDataBase | Returns a reference to the underlying DataBase instance initialized in the InitializeDataBase method.
InitializeDataBase | The derived class should initialize and return a valid database connection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveArgumentTypes (inherited from ServerBase) | Resolves argument types for the given argument values.
ServerMethodEntryNotTransacted | Starts the execution of a public method that doesn't require transactions.
ServerMethodEntryTransacted | Starts the execution of a public method requiring transactional semantics.
ServerMethodEntyNotTransacted |
ServerMethodExitFailure | Ends the unsuccessful execution of a public method and rolls back the transaction (if any).
ServerMethodExitInternal | This member supports the LaMarvin.Common library infrastructure and is not intended to be used directly from your code.
ServerMethodExitSuccess | Overloaded. Ends the successful execution of a public method and commits the transaction (if any).

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.GetDataBase Method

Returns a reference to the underlying DataBase instance initialized in the InitializeDataBase method.

[Visual Basic]
Protected Function GetDataBase() As DataBase
[C#]
protected DataBase GetDataBase();

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.InitializeDataBase Method

The derived class should initialize and return a valid database connection.

[Visual Basic]
MustOverride Protected Function InitializeDataBase( _
ByVal startTransaction As Boolean _
) As DataBase
[C#]
protected abstract DataBase InitializeDataBase(
bool startTransaction
);

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodEntryNotTransacted Method

Starts the execution of a public method that doesn't require transactions.

[Visual Basic]
Overridable Protected Sub ServerMethodEntryNotTransacted()
[C#]
protected virtual void ServerMethodEntryNotTransacted();

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodEntryTransacted Method

Starts the execution of a public method requiring transactional semantics.

[Visual Basic]
Overridable Protected Sub ServerMethodEntryTransacted()
[C#]
protected virtual void ServerMethodEntryTransacted();

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodEntyNotTransacted Method

[Visual Basic]
Overridable Protected Sub ServerMethodEntyNotTransacted()
[C#]
protected virtual void ServerMethodEntyNotTransacted();

Remarks

CAUTION This is a deprecated method that was incorrectly named (missing 'r' in the Entry word). It was replaced with the ServerMethodEntryNotTransacted correctly named method that is called by this, now deprecated method, to ensure backward compatibility.

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodExitFailure Method

Ends the unsuccessful execution of a public method and rolls back the transaction (if any).

[Visual Basic]
Overridable Protected Sub ServerMethodExitFailure( _
ByVal ex As Exception _
)
[C#]
protected virtual void ServerMethodExitFailure(
Exception ex
);

Parameters

ex

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodExitInternal Method

This member supports the LaMarvin.Common library infrastructure and is not intended to be used directly from your code.

[Visual Basic]
Overridable Protected Function ServerMethodExitInternal( _
ByVal ex As Exception, _
ByVal returnValue As Object _
) As Object
[C#]
protected virtual object ServerMethodExitInternal(
Exception ex,
object returnValue
);

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


ServerMethodExitSuccess Method

Constable Authorization Engine 2.0 BETA

DataServerBase.ServerMethodExitSuccess Method

[This is preliminary documentation and subject to change.]

Ends the successful execution of a public method and commits the transaction (if any).

Overload List

Ends the successful execution of a public method and commits the transaction (if any).

protected void ServerMethodExitSuccess();

Ends the successful execution of a public method and commits the transaction (if any).

protected bool ServerMethodExitSuccess(bool);

Ends the successful execution of a public method and commits the transaction (if any).

protected DataSet ServerMethodExitSuccess(DataSet);

Ends the successful execution of a public method and commits the transaction (if any).

protected int ServerMethodExitSuccess(int);

Ends the successful execution of a public method and commits the transaction (if any).

protected object ServerMethodExitSuccess(object);

See Also

DataServerBase Class | LaMarvin.Remoting Namespace


DataServerBase.ServerMethodExitSuccess Method ()

Ends the successful execution of a public method and commits the transaction (if any).

[Visual Basic]
Overloads Protected Sub ServerMethodExitSuccess()
[C#]
protected void ServerMethodExitSuccess();

See Also

DataServerBase Class | LaMarvin.Remoting Namespace | DataServerBase.ServerMethodExitSuccess Overload List


DataServerBase.ServerMethodExitSuccess Method (Boolean)

Ends the successful execution of a public method and commits the transaction (if any).

[Visual Basic]
Overloads Protected Function ServerMethodExitSuccess( _
ByVal returnValue As Boolean _
) As Boolean
[C#]
protected bool ServerMethodExitSuccess(
bool returnValue
);

Parameters

returnValue

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace | DataServerBase.ServerMethodExitSuccess Overload List


DataServerBase.ServerMethodExitSuccess Method (DataSet)

Ends the successful execution of a public method and commits the transaction (if any).

[Visual Basic]
Overloads Protected Function ServerMethodExitSuccess( _
ByVal returnValue As DataSet _
) As DataSet
[C#]
protected DataSet ServerMethodExitSuccess(
DataSet returnValue
);

Parameters

returnValue

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace | DataServerBase.ServerMethodExitSuccess Overload List


DataServerBase.ServerMethodExitSuccess Method (Int32)

Ends the successful execution of a public method and commits the transaction (if any).

[Visual Basic]
Overloads Protected Function ServerMethodExitSuccess( _
ByVal returnValue As Integer _
) As Integer
[C#]
protected int ServerMethodExitSuccess(
int returnValue
);

Parameters

returnValue

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace | DataServerBase.ServerMethodExitSuccess Overload List


DataServerBase.ServerMethodExitSuccess Method (Object)

Ends the successful execution of a public method and commits the transaction (if any).

[Visual Basic]
Overloads Protected Function ServerMethodExitSuccess( _
ByVal returnValue As Object _
) As Object
[C#]
protected object ServerMethodExitSuccess(
object returnValue
);

Parameters

returnValue

Return Value

See Also

DataServerBase Class | LaMarvin.Remoting Namespace | DataServerBase.ServerMethodExitSuccess Overload List


IRemoteServer Interface

Defines a contract for loosely-typed remote server invocations.

For a list of all members of this type, see IRemoteServer Members.

[Visual Basic]
Public Interface IRemoteServer
[C#]
public interface IRemoteServer

Types that implement IRemoteServer

Type | Description
DataServerBase | Provides a base class for remote server implementations that access an Microsoft SQL Server database.
ServerBase | Provides a base class for remote server implementations.
ServerProxy | Serves as a proxy to local or remote IRemoteServer implementation.

Requirements

Namespace: LaMarvin.Remoting

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

IRemoteServer Members | LaMarvin.Remoting Namespace


IRemoteServer Members

IRemoteServer overview

Public Instance Methods

Invoke The implementation should invoke a public instance method with the given arguments.

See Also

IRemoteServer Interface | LaMarvin.Remoting Namespace


IRemoteServer Methods

The methods of the IRemoteServer interface are listed below. For a complete list of IRemoteServer interface members, see the IRemoteServer Members topic.

Public Instance Methods

Invoke The implementation should invoke a public instance method with the given arguments.

See Also

IRemoteServer Interface | LaMarvin.Remoting Namespace


IRemoteServer.Invoke Method

The implementation should invoke a public instance method with the given arguments.

[Visual Basic]
Function Invoke( _
ByVal method As String, _
ByVal args As Object() _
) As Object
[C#]
object Invoke(
string method,
object[] args
);

Parameters

method
The name of the method exposed by the implementing class.
args
The array of arguments accepted by the method.

Return Value

See Also

IRemoteServer Interface | LaMarvin.Remoting Namespace


ServerBase Class

Provides a base class for remote server implementations.

For a list of all members of this type, see ServerBase Members.

System.Object
System.MarshalByRefObject
LaMarvin.Remoting.ServerBase
LaMarvin.Remoting.DataServerBase

[Visual Basic]
MustInherit Public Class ServerBase
Inherits MarshalByRefObject
Implements IRemoteServer
[C#]
public abstract class ServerBase : MarshalByRefObject, IRemoteServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The class implements the IRemoteServer interface by forwarding the call to the appropriate public instance method exposed by the derived classes.

Requirements

Namespace: LaMarvin.Remoting

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ServerBase Members | LaMarvin.Remoting Namespace


ServerBase Members

ServerBase overview

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ServerBase Constructor Initializes a new instance of the derived class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveArgumentTypes | Resolves argument types for the given argument values.

See Also

ServerBase Class | LaMarvin.Remoting Namespace


ServerBase Constructor

Initializes a new instance of the derived class.

[Visual Basic]
Protected Sub New()
[C#]
protected ServerBase();

See Also

ServerBase Class | LaMarvin.Remoting Namespace


ServerBase Methods

The methods of the ServerBase class are listed below. For a complete list of ServerBase class members, see the ServerBase Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ResolveArgumentTypes | Resolves argument types for the given argument values.

See Also

ServerBase Class | LaMarvin.Remoting Namespace


ServerBase.ResolveArgumentTypes Method

Resolves argument types for the given argument values.

[Visual Basic]
Overridable Protected Sub ResolveArgumentTypes( _
ByVal method As String, _
ByVal args As Object(), _
ByVal argTypes As Type() _
)
[C#]
protected virtual void ResolveArgumentTypes(
string method,
object[] args,
Type[] argTypes
);

Parameters

method
The name of the method that was passed to the calling Invoke method for which argument types should be resolved.
args
The input array of argument values as passed to the Invoke method.
argTypes
The array of Type objects for the corresponding args array.

Remarks

The two argument arrays are parallel and they're guaranteed to have at least one element.

The base implementation simply calls the GetType method on the elements of the args. You'll have to override the method if you need to pass a null reference (Nothing in Visual Basic) as method arguments, or if you need to perform more sophisticated type conversions.

Exceptions

Exception Type | Condition
ArgumentNullException | a null reference (Nothing in Visual Basic) was encountered in the args array.

See Also

ServerBase Class | LaMarvin.Remoting Namespace


ServerProxy Class

Serves as a proxy to local or remote IRemoteServer implementation.

For a list of all members of this type, see ServerProxy Members.

System.Object
LaMarvin.Remoting.ServerProxy

[Visual Basic]
Public Class ServerProxy
Implements IRemoteServer
[C#]
public class ServerProxy : IRemoteServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Remoting

Assembly: LaMarvin.Common (in LaMarvin.Common.dll)

See Also

ServerProxy Members | LaMarvin.Remoting Namespace


ServerProxy Members

ServerProxy overview

Public Instance Constructors

ServerProxy Overloaded. Initializes a new instance of the ServerProxy class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Invoke | Overloaded. Forwards the method call to the wrapped IRemoteServer implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

RemoteServer Returns a reference to the wrapped IRemoteServer implementation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


ServerProxy Constructor

Initializes a new instance of the ServerProxy class.

Overload List

Initializes a new instance of the ServerProxy class wrapping the specified IRemoteServer implementation.

public ServerProxy(IRemoteServer);

Initializes a new instance of the ServerProxy class.

public ServerProxy(string);

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


ServerProxy Constructor (String)

Initializes a new instance of the ServerProxy class.

[Visual Basic]
Overloads Public Sub New( _
ByVal serverUrlOrTypeName As String _
)
[C#]
public ServerProxy(
string serverUrlOrTypeName
);

Parameters

serverUrlOrTypeName
The value of the argument can be either an URL identifying a remote server that implements the IRemoteServer interface. Or it can by an assembly-qualified type name implementing the IRemoteServer interface available in the current AppDomain.

Remarks

The following example shows hou you can initialize a new instance of the ServerProxy class connecting it to a remote IRemoteServer implementation:

[Visual Basic]
[Visual Basic]
Imports LaMarvin.Remoting
Imports System.Data

Dim proxy As New ServerProxy("http://localhost/daserver.rem")
Dim documents As DataSet = DirectCast(proxy.Invoke("GetDocuments"), DataSet)

[C#]
using LaMarvin.Remoting;
using System.Data;

ServerProxy proxy = new ServerProxy(@"http://localhost/daserver.rem");
DataSet documents = (DataSet)proxy.Invoke("GetDocuments");

See Also

ServerProxy Class | LaMarvin.Remoting Namespace | ServerProxy Constructor Overload List


ServerProxy Constructor (IRemoteServer)

Initializes a new instance of the ServerProxy class wrapping the specified IRemoteServer implementation.

[Visual Basic]
Overloads Public Sub New( _
ByVal server As IRemoteServer _
)
[C#]
public ServerProxy(
IRemoteServer server
);

Parameters

server

Exceptions

Exception Type | Condition
ArgumentNullException | a null reference (Nothing in Visual Basic) was passed as the value of the server argument.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace | ServerProxy Constructor Overload List


ServerProxy Properties

The properties of the ServerProxy class are listed below. For a complete list of ServerProxy class members, see the ServerProxy Members topic.

Protected Instance Properties

RemoteServer Returns a reference to the wrapped IRemoteServer implementation.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


ServerProxy.RemoteServer Property

Returns a reference to the wrapped IRemoteServer implementation.

[Visual Basic]
Protected ReadOnly Property RemoteServer As IRemoteServer
[C#]
protected IRemoteServer RemoteServer {get;}

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


ServerProxy Methods

The methods of the ServerProxy class are listed below. For a complete list of ServerProxy class members, see the ServerProxy Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Invoke | Overloaded. Forwards the method call to the wrapped IRemoteServer implementation.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


Invoke Method

Constable Authorization Engine 2.0 BETA

ServerProxy.Invoke Method

[This is preliminary documentation and subject to change.]

Forwards the method call to the wrapped IRemoteServer implementation.

Overload List

Forwards the method call to the wrapped IRemoteServer implementation.

public object Invoke(string);

Forwards the method call to the wrapped IRemoteServer implementation.

public virtual object Invoke(string,object[]);

See Also

ServerProxy Class | LaMarvin.Remoting Namespace


ServerProxy.Invoke Method (String)

Forwards the method call to the wrapped IRemoteServer implementation.

[Visual Basic]
Overloads Public Function Invoke( _
ByVal method As String _
) As Object
[C#]
public object Invoke(
string method
);

Parameters

method
The name of the public method exposed by the wrapped IRemoteServer implementation. The method's signature shouldn't take any arguments.

Return Value

Returns the value returned by the method.

Exceptions

Exception Type | Condition
TargetInvocationException | The method generated an exception. The exception is accessible by means of the InnerException property.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace | ServerProxy.Invoke Overload List


ServerProxy.Invoke Method (String, Object[])

Forwards the method call to the wrapped IRemoteServer implementation.

[Visual Basic]
Overridable Overloads Public Function Invoke( _
ByVal method As String, _
ByVal args As Object() _
) As Object _
Implements IRemoteServer.Invoke
[C#]
public virtual object Invoke(
string method,
object[] args
);

Parameters

method
The name of the public method exposed by the wrapped IRemoteServer implementation.
args
The arguments of the method.

Return Value

Returns the value returned by the method.

Implements

IRemoteServer.Invoke

Exceptions

Exception Type | Condition
TargetInvocationException | The method generated an exception. The exception is accessible by means of the InnerException property.

See Also

ServerProxy Class | LaMarvin.Remoting Namespace | ServerProxy.Invoke Overload List


LaMarvin.Windows.Forms

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms Namespace

[This is preliminary documentation and subject to change.]

Contains types supporting seamless System.Windows.Forms namespace integration.

Namespace hierarchy

Classes

Class | Description
ControlLayoutRestorer | This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.
DelayedEventDispatcher | This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.


ControlLayoutRestorer Class

This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

For a list of all members of this type, see ControlLayoutRestorer Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
LaMarvin.Windows.Forms.ControlLayoutRestorer

[Visual Basic]
NotInheritable Public Class ControlLayoutRestorer
Inherits Component
Implements IExtenderProvider, ISupportInitialize
[C#]
public sealed class ControlLayoutRestorer : Component, IExtenderProvider, ISupportInitialize

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

ControlLayoutRestorer Members | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer Members

ControlLayoutRestorer overview

Public Instance Constructors

ControlLayoutRestorer Overloaded. Initializes a new instance of the ControlLayoutRestorer class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
LayoutVersion | Gets or sets the layout version.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetRestoreLayout | Gets the flag indicating whether the specified control should have its layout restored.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetRestoreLayout | Sets the flag indicating whether the specified control should have its layout restored.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer Constructor

Initializes a new instance of the ControlLayoutRestorer class.

Overload List

Initializes a new instance of the ControlLayoutRestorer class.

public ControlLayoutRestorer();

Initializes a new instance of the ControlLayoutRestorer class.

public ControlLayoutRestorer(IContainer);

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer Constructor (IContainer)

Initializes a new instance of the ControlLayoutRestorer class.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public ControlLayoutRestorer(
IContainer container
);

Parameters

container
The container.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace | ControlLayoutRestorer Constructor Overload List


ControlLayoutRestorer Constructor ()

Initializes a new instance of the ControlLayoutRestorer class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ControlLayoutRestorer();

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace | ControlLayoutRestorer Constructor Overload List


ControlLayoutRestorer Properties

The properties of the ControlLayoutRestorer class are listed below. For a complete list of ControlLayoutRestorer class members, see the ControlLayoutRestorer Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
LayoutVersion | Gets or sets the layout version.
Site (inherited from Component) | Gets or sets the ISite of the Component.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer.LayoutVersion Property

Gets or sets the layout version.

[Visual Basic]
Public Property LayoutVersion As Integer
[C#]
public int LayoutVersion {get; set;}

Property Value

The layout version.

Remarks

Layouts should be versioned if an updated layout of the host cannot be restored from the persisted previous-version layout.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer Methods

The methods of the ControlLayoutRestorer class are listed below. For a complete list of ControlLayoutRestorer class members, see the ControlLayoutRestorer Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetRestoreLayout | Gets the flag indicating whether the specified control should have its layout restored.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetRestoreLayout | Sets the flag indicating whether the specified control should have its layout restored.
ToString (inherited from Component) |

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer.GetRestoreLayout Method

Gets the flag indicating whether the specified control should have its layout restored.

[Visual Basic]
Public Function GetRestoreLayout( _
ByVal control As Control _
) As Boolean
[C#]
public bool GetRestoreLayout(
Control control
);

Parameters

control
The control reference.

Return Value

true if the control's layout should be restored; otherwise false.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


ControlLayoutRestorer.SetRestoreLayout Method

Sets the flag indicating whether the specified control should have its layout restored.

[Visual Basic]
Public Sub SetRestoreLayout( _
ByVal control As Control, _
ByVal value As Boolean _
)
[C#]
public void SetRestoreLayout(
Control control,
bool value
);

Parameters

control
The control reference.
value
true if the control's layout should be restored; otherwise false.

See Also

ControlLayoutRestorer Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher Class

This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

For a list of all members of this type, see DelayedEventDispatcher Members.

System.Object
LaMarvin.Windows.Forms.DelayedEventDispatcher

[Visual Basic]
NotInheritable Public Class DelayedEventDispatcher
[C#]
public sealed class DelayedEventDispatcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note This is an adapted version of the code accompanying the article Delayed event handling for WinForms applications.

Requirements

Namespace: LaMarvin.Windows.Forms

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

DelayedEventDispatcher Members | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher Members

DelayedEventDispatcher overview

Public Instance Constructors

DelayedEventDispatcher Overloaded. Initializes a new instance of the DelayedEventDispatcher class.

Public Instance Properties

Delay | Sets or returns the interval the associated event has to be delayed.
DelayEnabled | Sets or returns a flag indicating whether the delayed event handling feature is active.
DelayMouseEvents | Sets or returns a flag indicating whether the delayed event handling feature is active for events caused by mouse input.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterAuthenticEvent | Registers the authentic event.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher Constructor

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate.

Overload List

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate.

public DelayedEventDispatcher(Delegate);

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate and the amount of milliseconds the event has to be postponed.

public DelayedEventDispatcher(Delegate,int);

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate and the amount of milliseconds the event has to be postponed.

public DelayedEventDispatcher(Delegate,int,bool);

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher Constructor (Delegate)

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate.

[Visual Basic]
Overloads Public Sub New( _
ByVal processEventDelegate As Delegate _
)
[C#]
public DelayedEventDispatcher(
Delegate processEventDelegate
);

Parameters

processEventDelegate
The delegate that actually raises or processes the delayed event.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace | DelayedEventDispatcher Constructor Overload List


DelayedEventDispatcher Constructor (Delegate, Int32)

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate and the amount of milliseconds the event has to be postponed.

[Visual Basic]
Overloads Public Sub New( _
ByVal processEventDelegate As Delegate, _
ByVal delayMilliseconds As Integer _
)
[C#]
public DelayedEventDispatcher(
Delegate processEventDelegate,
int delayMilliseconds
);

Parameters

processEventDelegate
The delegate that actually raises or processes the delayed event.
delayMilliseconds
The number of milliseconds the event has to be postponed.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace | DelayedEventDispatcher Constructor Overload List


DelayedEventDispatcher Constructor (Delegate, Int32, Boolean)

Initializes a new instance of the DelayedEventDispatcher class with the specified event delegate and the amount of milliseconds the event has to be postponed.

[Visual Basic]
Overloads Public Sub New( _
ByVal processEventDelegate As Delegate, _
ByVal delayMilliseconds As Integer, _
ByVal delayMouseEvents As Boolean _
)
[C#]
public DelayedEventDispatcher(
Delegate processEventDelegate,
int delayMilliseconds,
bool delayMouseEvents
);

Parameters

processEventDelegate
The delegate that actually raises or processes the delayed event.
delayMilliseconds
The number of milliseconds the event has to be postponed.
delayMouseEvents
The flag indicates whether events should be delayed for events caused by mouse input.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace | DelayedEventDispatcher Constructor Overload List


DelayedEventDispatcher Properties

The properties of the DelayedEventDispatcher class are listed below. For a complete list of DelayedEventDispatcher class members, see the DelayedEventDispatcher Members topic.

Public Instance Properties

Delay | Sets or returns the interval the associated event has to be delayed.
DelayEnabled | Sets or returns a flag indicating whether the delayed event handling feature is active.
DelayMouseEvents | Sets or returns a flag indicating whether the delayed event handling feature is active for events caused by mouse input.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher.Delay Property

Sets or returns the interval the associated event has to be delayed.

[Visual Basic]
Public Property Delay As TimeSpan
[C#]
public System.TimeSpan Delay {get; set;}

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher.DelayEnabled Property

Sets or returns a flag indicating whether the delayed event handling feature is active.

[Visual Basic]
Public Property DelayEnabled As Boolean
[C#]
public bool DelayEnabled {get; set;}

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher.DelayMouseEvents Property

Sets or returns a flag indicating whether the delayed event handling feature is active for events caused by mouse input.

[Visual Basic]
Public Property DelayMouseEvents As Boolean
[C#]
public bool DelayMouseEvents {get; set;}

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher Methods

The methods of the DelayedEventDispatcher class are listed below. For a complete list of DelayedEventDispatcher class members, see the DelayedEventDispatcher Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RegisterAuthenticEvent | Registers the authentic event.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


DelayedEventDispatcher.RegisterAuthenticEvent Method

Registers the authentic event.

[Visual Basic]
Public Sub RegisterAuthenticEvent( _
ByVal sender As Object, _
ByVal args As EventArgs _
)
[C#]
public void RegisterAuthenticEvent(
object sender,
EventArgs args
);

Parameters

sender
The sender of the event.
args
The EventArgs instance containing the event data.

See Also

DelayedEventDispatcher Class | LaMarvin.Windows.Forms Namespace


LaMarvin.Windows.Forms.CommandManagement

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.CommandManagement Namespace

Namespace hierarchy

Classes

Class | Description
ButtonAdapter |
ButtonAdapter.Factory |
Command |
CommandCollection |
CommandEventArgs |
CommandManager |
ExecuteExceptionEventArgs |
MenuItemAdapter |
MenuItemAdapter.Factory |
ToolbarButtonAdapter |
ToolbarButtonAdapter.Factory |
UIAdapterServices |

Interfaces

Interface | Description
IExecuteExceptionHandler |
IUIElementAdapter |
IUIElementAdapterFactory |

Delegates

Delegate | Description
CommandEventHandler |
ExecuteExceptionEventHandler |


ButtonAdapter Class

For a list of all members of this type, see ButtonAdapter Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.ButtonAdapter

[Visual Basic]
Public Class ButtonAdapter
Implements IUIElementAdapter, IDisposable
[C#]
public class ButtonAdapter : IUIElementAdapter, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

ButtonAdapter Members | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter Members

ButtonAdapter overview

Public Instance Properties

Command
UIElement

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter Properties

The properties of the ButtonAdapter class are listed below. For a complete list of ButtonAdapter class members, see the ButtonAdapter Members topic.

Public Instance Properties

Command
UIElement

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Command Property

[Visual Basic]
NotOverridable Public ReadOnly Property Command As Command _
Implements IUIElementAdapter.Command
[C#]
public Command Command {get;}

Implements

IUIElementAdapter.Command

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.UIElement Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElement As Object _
Implements IUIElementAdapter.UIElement
[C#]
public object UIElement {get;}

Implements

IUIElementAdapter.UIElement

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter Methods

The methods of the ButtonAdapter class are listed below. For a complete list of ButtonAdapter class members, see the ButtonAdapter Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.UpdateUIElementDisplay Method

[Visual Basic]
NotOverridable Public Sub UpdateUIElementDisplay() _
Implements IUIElementAdapter.UpdateUIElementDisplay
[C#]
public void UpdateUIElementDisplay();

Implements

IUIElementAdapter.UpdateUIElementDisplay

See Also

ButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Factory Class

For a list of all members of this type, see ButtonAdapter.Factory Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.ButtonAdapter.Factory

[Visual Basic]
Public Class ButtonAdapter.Factory
Implements IUIElementAdapterFactory
[C#]
public class ButtonAdapter.Factory : IUIElementAdapterFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

ButtonAdapter.Factory Members | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Factory Members

ButtonAdapter.Factory overview

Public Instance Constructors

ButtonAdapter.Factory Constructor Initializes a new instance of the ButtonAdapter.Factory class.

Public Instance Properties

UIElementType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Factory Constructor

Initializes a new instance of the ButtonAdapter.Factory class.

[Visual Basic]
Public Sub New()
[C#]
public ButtonAdapter.Factory();

See Also

ButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Factory Properties

The properties of the ButtonAdapter.Factory class are listed below. For a complete list of ButtonAdapter.Factory class members, see the ButtonAdapter.Factory Members topic.

Public Instance Properties

UIElementType

See Also

ButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ButtonAdapter.Factory.UIElementType Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElementType As Type _
Implements IUIElementAdapterFactory.UIElementType
[C#]
public System.Type UIElementType {get;}

Implements

IUIElementAdapterFactory.UIElementType

See Also

ButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Class

For a list of all members of this type, see Command Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
LaMarvin.Windows.Forms.CommandManagement.Command

[Visual Basic]
Public Class Command
Inherits Component
[C#]
public class Command : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

Command Members | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Members

Command overview

Public Instance Constructors

Command Overloaded. Initializes a new instance of the Command class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled |
GroupName |
Checked |
Name |
SharedImageKey |
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text |
Visible |

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Public Instance Events

CommandExecuted |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
Owner |

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute |

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Constructor

Initializes a new instance of the Command class.

Overload List

Initializes a new instance of the Command class.

public Command();

public Command(IContainer);

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Constructor ()

Initializes a new instance of the Command class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Command();

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace | Command Constructor Overload List


Command Constructor (IContainer)

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public Command(
IContainer container
);

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace | Command Constructor Overload List


Command Properties

The properties of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
Enabled |
GroupName |
Checked |
Name |
SharedImageKey |
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text |
Visible |

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
Owner |

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Enabled Property

[Visual Basic]
Overridable Public Property Enabled As Boolean
[C#]
public virtual bool Enabled {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.GroupName Property

[Visual Basic]
Overridable Public Property GroupName As String
[C#]
public virtual string GroupName {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Checked Property

[Visual Basic]
Overridable Public Property Checked As Boolean
[C#]
public virtual bool Checked {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Name Property

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Owner Property

[Visual Basic]
Protected Property Owner As Object
[C#]
protected object Owner {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.SharedImageKey Property

[Visual Basic]
Overridable Public Property SharedImageKey As String
[C#]
public virtual string SharedImageKey {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Text Property

[Visual Basic]
Overridable Public Property Text As String
[C#]
public virtual string Text {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Visible Property

[Visual Basic]
Overridable Public Property Visible As Boolean
[C#]
public virtual bool Visible {get; set;}

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Methods

The methods of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |

Protected Instance Methods

Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnExecute |

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.Execute Method

[Visual Basic]
Overridable Public Sub Execute()
[C#]
public virtual void Execute();

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.HandleExecuteException Method

[Visual Basic]
Overridable Protected Sub HandleExecuteException( _
ByVal ex As Exception _
)
[C#]
protected virtual void HandleExecuteException(
Exception ex
);

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.OnExecute Method

[Visual Basic]
Overridable Protected Sub OnExecute()
[C#]
protected virtual void OnExecute();

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command Events

The events of the Command class are listed below. For a complete list of Command class members, see the Command Members topic.

Public Instance Events

CommandExecuted |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


Command.CommandExecuted Event

[Visual Basic]
Public Event CommandExecuted As CommandEventHandler
[C#]
public event CommandEventHandler CommandExecuted;

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs property provides information specific to this event.

Property | Description
Command |

See Also

Command Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Class

For a list of all members of this type, see CommandCollection Members.

System.Object
System.Collections.CollectionBase
LaMarvin.Windows.Forms.CommandManagement.CommandCollection

[Visual Basic]
Public Class CommandCollection
Inherits CollectionBase
Implements IExecuteExceptionHandler
[C#]
public class CommandCollection : CollectionBase, IExecuteExceptionHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandCollection Members | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Members

CommandCollection overview

Public Instance Constructors

CommandCollection Constructor Initializes a new instance of the CommandCollection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

Public Instance Methods

Add |
AddRange |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandAdded
CommandRemoved
CommandsCleared

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
Owner |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear |
OnClearComplete |
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete |
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete |
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Constructor

Initializes a new instance of the CommandCollection class.

[Visual Basic]
Public Sub New()
[C#]
public CommandCollection();

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Properties

The properties of the CommandCollection class are listed below. For a complete list of CommandCollection class members, see the CommandCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Item |

Protected Instance Properties

InnerList (inherited from CollectionBase) | Gets an ArrayList containing the list of elements in the CollectionBase instance.
List (inherited from CollectionBase) | Gets an IList containing the list of elements in the CollectionBase instance.
Owner |

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.Item Property

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Command
[C#]
public Command this[
int index
] {get;}

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.Owner Property

[Visual Basic]
Protected Property Owner As Object
[C#]
protected object Owner {get; set;}

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Methods

The methods of the CommandCollection class are listed below. For a complete list of CommandCollection class members, see the CommandCollection Members topic.

Public Instance Methods

Add |
AddRange |
Clear (inherited from CollectionBase) | Removes all objects from the CollectionBase instance.
Contains |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from CollectionBase) | Returns an enumerator that can iterate through the CollectionBase instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove |
RemoveAt (inherited from CollectionBase) | Removes the element at the specified index of the CollectionBase instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnClear |
OnClearComplete |
OnInsert (inherited from CollectionBase) | Performs additional custom processes before inserting a new element into the CollectionBase instance.
OnInsertComplete |
OnRemove (inherited from CollectionBase) | Performs additional custom processes when removing an element from the CollectionBase instance.
OnRemoveComplete |
OnSet (inherited from CollectionBase) | Performs additional custom processes before setting a value in the CollectionBase instance.
OnSetComplete (inherited from CollectionBase) | Performs additional custom processes after setting a value in the CollectionBase instance.
OnValidate (inherited from CollectionBase) | Performs additional custom processes when validating a value.

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.Add Method

[Visual Basic]
Public Function Add( _
ByVal cmd As Command _
) As Integer
[C#]
public int Add(
Command cmd
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.AddRange Method

[Visual Basic]
Public Sub AddRange( _
ByVal cmds As Command() _
)
[C#]
public void AddRange(
Command[] cmds
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.Contains Method

[Visual Basic]
Public Function Contains( _
ByVal cmd As Command _
) As Boolean
[C#]
public bool Contains(
Command cmd
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.HandleExecuteException Method

[Visual Basic]
Overridable Protected Sub HandleExecuteException( _
ByVal ex As Exception _
) _
Implements IExecuteExceptionHandler.HandleExecuteException
[C#]
protected virtual void HandleExecuteException(
Exception ex
);

Implements

IExecuteExceptionHandler.HandleExecuteException

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.OnClear Method

[Visual Basic]
Overrides Protected Sub OnClear()
[C#]
protected override void OnClear();

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.OnClearComplete Method

[Visual Basic]
Overrides Protected Sub OnClearComplete()
[C#]
protected override void OnClearComplete();

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.OnInsertComplete Method

[Visual Basic]
Overrides Protected Sub OnInsertComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnInsertComplete(
int index,
object value
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.OnRemoveComplete Method

[Visual Basic]
Overrides Protected Sub OnRemoveComplete( _
ByVal index As Integer, _
ByVal value As Object _
)
[C#]
protected override void OnRemoveComplete(
int index,
object value
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.Remove Method

[Visual Basic]
Public Sub Remove( _
ByVal cmd As Command _
)
[C#]
public void Remove(
Command cmd
);

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection Events

The events of the CommandCollection class are listed below. For a complete list of CommandCollection class members, see the CommandCollection Members topic.

Public Instance Events

CommandAdded
CommandRemoved
CommandsCleared

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.CommandAdded Event

[Visual Basic]
Public Event CommandAdded As CommandEventHandler
[C#]
public event CommandEventHandler CommandAdded;

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs property provides information specific to this event.

Property | Description
Command |

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.CommandRemoved Event

[Visual Basic]
Public Event CommandRemoved As CommandEventHandler
[C#]
public event CommandEventHandler CommandRemoved;

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs property provides information specific to this event.

Property | Description
Command |

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandCollection.CommandsCleared Event

[Visual Basic]
Public Event CommandsCleared As EventHandler
[C#]
public event EventHandler CommandsCleared;

See Also

CommandCollection Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventArgs Class

For a list of all members of this type, see CommandEventArgs Members.

System.Object
System.EventArgs
LaMarvin.Windows.Forms.CommandManagement.CommandEventArgs

[Visual Basic]
Public Class CommandEventArgs
Inherits EventArgs
[C#]
public class CommandEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandEventArgs Members | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventArgs Members

CommandEventArgs overview

Public Instance Constructors

CommandEventArgs Constructor

Public Instance Properties

Command

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventArgs Constructor

[Visual Basic]
Public Sub New( _
ByVal cmd As Command _
)
[C#]
public CommandEventArgs(
Command cmd
);

Parameters

cmd

See Also

CommandEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventArgs Properties

The properties of the CommandEventArgs class are listed below. For a complete list of CommandEventArgs class members, see the CommandEventArgs Members topic.

Public Instance Properties

Command

See Also

CommandEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventArgs.Command Property

[Visual Basic]
Public ReadOnly Property Command As Command
[C#]
public Command Command {get;}

See Also

CommandEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandEventHandler Delegate

[Visual Basic]
Public Delegate Sub CommandEventHandler( _
ByVal sender As Object, _
ByVal e As CommandEventArgs _
)
[C#]
public delegate void CommandEventHandler(
object sender,
CommandEventArgs e
);

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Class

For a list of all members of this type, see CommandManager Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
LaMarvin.Windows.Forms.CommandManagement.CommandManager

[Visual Basic]
Public Class CommandManager
Inherits Component
Implements IExtenderProvider, ISupportInitialize, IExecuteExceptionHandler
[C#]
public class CommandManager : Component, IExtenderProvider, ISupportInitialize, IExecuteExceptionHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandManager Members | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Members

CommandManager overview

Public Static (Shared) Methods

RegisterKnownUIElementFactories

Public Instance Constructors

CommandManager Constructor Initializes a new instance of the CommandManager class.

Public Instance Properties

Commands |
Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EnableCommands |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommand |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
CheckCommands |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetCommand |
ShowCommands |
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
ExecuteException |
RefreshCommandState |

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

CanExtend |
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Constructor

Initializes a new instance of the CommandManager class.

[Visual Basic]
Public Sub New()
[C#]
public CommandManager();

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Properties

The properties of the CommandManager class are listed below. For a complete list of CommandManager class members, see the CommandManager Members topic.

Public Instance Properties

Commands |
Container (inherited from Component) | Gets the IContainer that contains the Component.
Site (inherited from Component) | Gets or sets the ISite of the Component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.Commands Property

[Visual Basic]
Public Property Commands As CommandCollection
[C#]
public CommandCollection Commands {get; set;}

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Methods

The methods of the CommandManager class are listed below. For a complete list of CommandManager class members, see the CommandManager Members topic.

Public Static (Shared) Methods

RegisterKnownUIElementFactories

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EnableCommands |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCommand |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
CheckCommands |
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
SetCommand |
ShowCommands |
ToString (inherited from Component) |

Protected Instance Methods

CanExtend |
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
HandleExecuteException |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.CanExtend Method

[Visual Basic]
Overridable Protected Function CanExtend( _
ByVal extendee As Object _
) As Boolean _
Implements IExtenderProvider.CanExtend
[C#]
protected virtual bool CanExtend(
object extendee
);

Implements

IExtenderProvider.CanExtend

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.EnableCommands Method

[Visual Basic]
Public Sub EnableCommands( _
ByVal groupName As String, _
ByVal enabled As Boolean _
)
[C#]
public void EnableCommands(
string groupName,
bool enabled
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.GetCommand Method

[Visual Basic]
Public Function GetCommand( _
ByVal uiElement As Object _
) As Command
[C#]
public Command GetCommand(
object uiElement
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.HandleExecuteException Method

[Visual Basic]
Overridable Protected Sub HandleExecuteException( _
ByVal ex As Exception _
) _
Implements IExecuteExceptionHandler.HandleExecuteException
[C#]
protected virtual void HandleExecuteException(
Exception ex
);

Implements

IExecuteExceptionHandler.HandleExecuteException

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.CheckCommands Method

[Visual Basic]
Public Sub CheckCommands( _
ByVal groupName As String, _
ByVal checked As Boolean _
)
[C#]
public void CheckCommands(
string groupName,
bool checked
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.RegisterKnownUIElementFactories Method

[Visual Basic]
Public Shared Sub RegisterKnownUIElementFactories( _
ByVal assm As Assembly _
)
[C#]
public static void RegisterKnownUIElementFactories(
Assembly assm
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.SetCommand Method

[Visual Basic]
Public Sub SetCommand( _
ByVal uiElement As Object, _
ByVal cmd As Command _
)
[C#]
public void SetCommand(
object uiElement,
Command cmd
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.ShowCommands Method

[Visual Basic]
Public Sub ShowCommands( _
ByVal groupName As String, _
ByVal visible As Boolean _
)
[C#]
public void ShowCommands(
string groupName,
bool visible
);

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager Events

The events of the CommandManager class are listed below. For a complete list of CommandManager class members, see the CommandManager Members topic.

Public Instance Events

Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
ExecuteException |
RefreshCommandState |

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.ExecuteException Event

[Visual Basic]
Public Event ExecuteException As ExecuteExceptionEventHandler
[C#]
public event ExecuteExceptionEventHandler ExecuteException;

Event Data

The event handler receives an argument of type ExecuteExceptionEventArgs containing data related to this event. The following ExecuteExceptionEventArgs properties provide information specific to this event.

Property | Description
Exception |
Handled |

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


CommandManager.RefreshCommandState Event

[Visual Basic]
Public Event RefreshCommandState As EventHandler
[C#]
public event EventHandler RefreshCommandState;

See Also

CommandManager Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs Class

For a list of all members of this type, see ExecuteExceptionEventArgs Members.

System.Object
System.EventArgs
LaMarvin.Windows.Forms.CommandManagement.ExecuteExceptionEventArgs

[Visual Basic]
Public Class ExecuteExceptionEventArgs
Inherits EventArgs
[C#]
public class ExecuteExceptionEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

ExecuteExceptionEventArgs Members | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs Members

ExecuteExceptionEventArgs overview

Public Instance Constructors

ExecuteExceptionEventArgs Constructor

Public Instance Properties

Exception
Handled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExecuteExceptionEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs Constructor

[Visual Basic]
Public Sub New( _
ByVal ex As Exception, _
ByVal handled As Boolean _
)
[C#]
public ExecuteExceptionEventArgs(
Exception ex,
bool handled
);

See Also

ExecuteExceptionEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs Properties

The properties of the ExecuteExceptionEventArgs class are listed below. For a complete list of ExecuteExceptionEventArgs class members, see the ExecuteExceptionEventArgs Members topic.

Public Instance Properties

Exception
Handled

See Also

ExecuteExceptionEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs.Exception Property

[Visual Basic]
Public ReadOnly Property Exception As Exception
[C#]
public System.Exception Exception {get;}

See Also

ExecuteExceptionEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventArgs.Handled Property

[Visual Basic]
Public Property Handled As Boolean
[C#]
public bool Handled {get; set;}

See Also

ExecuteExceptionEventArgs Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ExecuteExceptionEventHandler Delegate

[Visual Basic]
Public Delegate Sub ExecuteExceptionEventHandler( _
ByVal sender As Object, _
ByVal e As ExecuteExceptionEventArgs _
)
[C#]
public delegate void ExecuteExceptionEventHandler(
object sender,
ExecuteExceptionEventArgs e
);

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

LaMarvin.Windows.Forms.CommandManagement Namespace


IExecuteExceptionHandler Interface

For a list of all members of this type, see IExecuteExceptionHandler Members.

[Visual Basic]
Public Interface IExecuteExceptionHandler
[C#]
public interface IExecuteExceptionHandler

Types that implement IExecuteExceptionHandler

Type | Description
CommandCollection |
CommandManager |

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

IExecuteExceptionHandler Members | LaMarvin.Windows.Forms.CommandManagement Namespace


IExecuteExceptionHandler Members

IExecuteExceptionHandler overview

Public Instance Methods

HandleExecuteException

See Also

IExecuteExceptionHandler Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IExecuteExceptionHandler Methods

The methods of the IExecuteExceptionHandler interface are listed below. For a complete list of IExecuteExceptionHandler interface members, see the IExecuteExceptionHandler Members topic.

Public Instance Methods

HandleExecuteException

See Also

IExecuteExceptionHandler Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IExecuteExceptionHandler.HandleExecuteException Method

[Visual Basic]
Sub HandleExecuteException( _
ByVal ex As Exception _
)
[C#]
void HandleExecuteException(
Exception ex
);

Parameters

ex

See Also

IExecuteExceptionHandler Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter Interface

For a list of all members of this type, see IUIElementAdapter Members.

[Visual Basic]
Public Interface IUIElementAdapter
[C#]
public interface IUIElementAdapter

Types that implement IUIElementAdapter

Type | Description
ButtonAdapter |
MenuItemAdapter |
ToolbarButtonAdapter |

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

IUIElementAdapter Members | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter Members

IUIElementAdapter overview

Public Instance Properties

Command
UIElement

Public Instance Methods

UpdateUIElementDisplay

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter Properties

The properties of the IUIElementAdapter interface are listed below. For a complete list of IUIElementAdapter interface members, see the IUIElementAdapter Members topic.

Public Instance Properties

Command
UIElement

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter.Command Property

[Visual Basic]
Property Command As Command
[C#]
Command Command {get;}

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter.UIElement Property

[Visual Basic]
Property UIElement As Object
[C#]
object UIElement {get;}

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter Methods

The methods of the IUIElementAdapter interface are listed below. For a complete list of IUIElementAdapter interface members, see the IUIElementAdapter Members topic.

Public Instance Methods

UpdateUIElementDisplay

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapter.UpdateUIElementDisplay Method

[Visual Basic]
Sub UpdateUIElementDisplay()
[C#]
void UpdateUIElementDisplay();

See Also

IUIElementAdapter Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory Interface

For a list of all members of this type, see IUIElementAdapterFactory Members.

[Visual Basic]
Public Interface IUIElementAdapterFactory
[C#]
public interface IUIElementAdapterFactory

Types that implement IUIElementAdapterFactory

Type | Description
ButtonAdapter.Factory |
MenuItemAdapter.Factory |
ToolbarButtonAdapter.Factory |

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

IUIElementAdapterFactory Members | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory Members

IUIElementAdapterFactory overview

Public Instance Properties

UIElementType

Public Instance Methods

CreateAdapter

See Also

IUIElementAdapterFactory Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory Properties

The properties of the IUIElementAdapterFactory interface are listed below. For a complete list of IUIElementAdapterFactory interface members, see the IUIElementAdapterFactory Members topic.

Public Instance Properties

UIElementType

See Also

IUIElementAdapterFactory Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory.UIElementType Property

[Visual Basic]
Property UIElementType As Type
[C#]
System.Type UIElementType {get;}

See Also

IUIElementAdapterFactory Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory Methods

The methods of the IUIElementAdapterFactory interface are listed below. For a complete list of IUIElementAdapterFactory interface members, see the IUIElementAdapterFactory Members topic.

Public Instance Methods

CreateAdapter

See Also

IUIElementAdapterFactory Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


IUIElementAdapterFactory.CreateAdapter Method

[Visual Basic]
Function CreateAdapter( _
ByVal cmd As Command, _
ByVal uiElement As Object _
) As IUIElementAdapter
[C#]
IUIElementAdapter CreateAdapter(
Command cmd,
object uiElement
);

Parameters

cmd
uiElement

See Also

IUIElementAdapterFactory Interface | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter Class

For a list of all members of this type, see MenuItemAdapter Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.MenuItemAdapter

[Visual Basic]
Public Class MenuItemAdapter
Implements IUIElementAdapter, IDisposable
[C#]
public class MenuItemAdapter : IUIElementAdapter, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

MenuItemAdapter Members | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter Members

MenuItemAdapter overview

Public Instance Properties

Command
UIElement

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter Properties

The properties of the MenuItemAdapter class are listed below. For a complete list of MenuItemAdapter class members, see the MenuItemAdapter Members topic.

Public Instance Properties

Command
UIElement

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Command Property

[Visual Basic]
NotOverridable Public ReadOnly Property Command As Command _
Implements IUIElementAdapter.Command
[C#]
public Command Command {get;}

Implements

IUIElementAdapter.Command

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.UIElement Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElement As Object _
Implements IUIElementAdapter.UIElement
[C#]
public object UIElement {get;}

Implements

IUIElementAdapter.UIElement

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter Methods

The methods of the MenuItemAdapter class are listed below. For a complete list of MenuItemAdapter class members, see the MenuItemAdapter Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.UpdateUIElementDisplay Method

[Visual Basic]
NotOverridable Public Sub UpdateUIElementDisplay() _
Implements IUIElementAdapter.UpdateUIElementDisplay
[C#]
public void UpdateUIElementDisplay();

Implements

IUIElementAdapter.UpdateUIElementDisplay

See Also

MenuItemAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Factory Class

For a list of all members of this type, see MenuItemAdapter.Factory Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.MenuItemAdapter.Factory

[Visual Basic]
Public Class MenuItemAdapter.Factory
Implements IUIElementAdapterFactory
[C#]
public class MenuItemAdapter.Factory : IUIElementAdapterFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

MenuItemAdapter.Factory Members | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Factory Members

MenuItemAdapter.Factory overview

Public Instance Constructors

MenuItemAdapter.Factory Constructor Initializes a new instance of the MenuItemAdapter.Factory class.

Public Instance Properties

UIElementType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MenuItemAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Factory Constructor

Initializes a new instance of the MenuItemAdapter.Factory class.

[Visual Basic]
Public Sub New()
[C#]
public MenuItemAdapter.Factory();

See Also

MenuItemAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Factory Properties

The properties of the MenuItemAdapter.Factory class are listed below. For a complete list of MenuItemAdapter.Factory class members, see the MenuItemAdapter.Factory Members topic.

Public Instance Properties

UIElementType

See Also

MenuItemAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


MenuItemAdapter.Factory.UIElementType Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElementType As Type _
Implements IUIElementAdapterFactory.UIElementType
[C#]
public System.Type UIElementType {get;}

Implements

IUIElementAdapterFactory.UIElementType

See Also

MenuItemAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter Class

For a list of all members of this type, see ToolbarButtonAdapter Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.ToolbarButtonAdapter

[Visual Basic]
Public Class ToolbarButtonAdapter
Implements IUIElementAdapter, ISupportInitialize, IDisposable
[C#]
public class ToolbarButtonAdapter : IUIElementAdapter, ISupportInitialize, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

ToolbarButtonAdapter Members | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter Members

ToolbarButtonAdapter overview

Public Instance Constructors

ToolbarButtonAdapter Constructor Initializes a new instance of the ToolbarButtonAdapter class.

Public Instance Properties

Command
UIElement

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter Constructor

Initializes a new instance of the ToolbarButtonAdapter class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ToolbarButtonAdapter();

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter Properties

The properties of the ToolbarButtonAdapter class are listed below. For a complete list of ToolbarButtonAdapter class members, see the ToolbarButtonAdapter Members topic.

Public Instance Properties

Command
UIElement

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Command Property

[Visual Basic]
NotOverridable Public ReadOnly Property Command As Command _
Implements IUIElementAdapter.Command
[C#]
public Command Command {get;}

Implements

IUIElementAdapter.Command

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.UIElement Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElement As Object _
Implements IUIElementAdapter.UIElement
[C#]
public object UIElement {get;}

Implements

IUIElementAdapter.UIElement

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter Methods

The methods of the ToolbarButtonAdapter class are listed below. For a complete list of ToolbarButtonAdapter class members, see the ToolbarButtonAdapter Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateUIElementDisplay |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.UpdateUIElementDisplay Method

[Visual Basic]
NotOverridable Public Sub UpdateUIElementDisplay() _
Implements IUIElementAdapter.UpdateUIElementDisplay
[C#]
public void UpdateUIElementDisplay();

Implements

IUIElementAdapter.UpdateUIElementDisplay

See Also

ToolbarButtonAdapter Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Factory Class

For a list of all members of this type, see ToolbarButtonAdapter.Factory Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.ToolbarButtonAdapter.Factory

[Visual Basic]
Public Class ToolbarButtonAdapter.Factory
Implements IUIElementAdapterFactory
[C#]
public class ToolbarButtonAdapter.Factory : IUIElementAdapterFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

ToolbarButtonAdapter.Factory Members | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Factory Members

ToolbarButtonAdapter.Factory overview

Public Instance Constructors

ToolbarButtonAdapter.Factory Constructor Initializes a new instance of the ToolbarButtonAdapter.Factory class.

Public Instance Properties

UIElementType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Factory Constructor

Initializes a new instance of the ToolbarButtonAdapter.Factory class.

[Visual Basic]
Public Sub New()
[C#]
public ToolbarButtonAdapter.Factory();

See Also

ToolbarButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Factory Properties

The properties of the ToolbarButtonAdapter.Factory class are listed below. For a complete list of ToolbarButtonAdapter.Factory class members, see the ToolbarButtonAdapter.Factory Members topic.

Public Instance Properties

UIElementType

See Also

ToolbarButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


ToolbarButtonAdapter.Factory.UIElementType Property

[Visual Basic]
NotOverridable Public ReadOnly Property UIElementType As Type _
Implements IUIElementAdapterFactory.UIElementType
[C#]
public System.Type UIElementType {get;}

Implements

IUIElementAdapterFactory.UIElementType

See Also

ToolbarButtonAdapter.Factory Class | LaMarvin.Windows.Forms.CommandManagement Namespace


UIAdapterServices Class

For a list of all members of this type, see UIAdapterServices Members.

System.Object
LaMarvin.Windows.Forms.CommandManagement.UIAdapterServices

[Visual Basic]
Public Class UIAdapterServices
[C#]
public class UIAdapterServices

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

UIAdapterServices Members | LaMarvin.Windows.Forms.CommandManagement Namespace


UIAdapterServices Members

UIAdapterServices overview

Public Static (Shared) Methods

CheckUIElementType

Public Instance Constructors

UIAdapterServices Constructor Initializes a new instance of the UIAdapterServices class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UIAdapterServices Class | LaMarvin.Windows.Forms.CommandManagement Namespace


UIAdapterServices Constructor

Initializes a new instance of the UIAdapterServices class.

[Visual Basic]
Public Sub New()
[C#]
public UIAdapterServices();

See Also

UIAdapterServices Class | LaMarvin.Windows.Forms.CommandManagement Namespace


UIAdapterServices Methods

The methods of the UIAdapterServices class are listed below. For a complete list of UIAdapterServices class members, see the UIAdapterServices Members topic.

Public Static (Shared) Methods

CheckUIElementType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UIAdapterServices Class | LaMarvin.Windows.Forms.CommandManagement Namespace


UIAdapterServices.CheckUIElementType Method

[Visual Basic]
Public Shared Sub CheckUIElementType( _
ByVal uiElement As Object, _
ByVal type As Type _
)
[C#]
public static void CheckUIElementType(
object uiElement,
Type type
);

See Also

UIAdapterServices Class | LaMarvin.Windows.Forms.CommandManagement Namespace


LaMarvin.Windows.Forms.CommandManagement.Design

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.CommandManagement.Design Namespace

Namespace hierarchy

Classes

Class | Description
CommandCollectionEditor |
CommandDesigner |
CommandManagerDesigner |


CommandCollectionEditor Class

For a list of all members of this type, see CommandCollectionEditor Members.

System.Object
System.Drawing.Design.UITypeEditor
System.ComponentModel.Design.CollectionEditor
LaMarvin.Windows.Forms.CommandManagement.Design.CommandCollectionEditor

[Visual Basic]
Public Class CommandCollectionEditor
Inherits CollectionEditor
[C#]
public class CommandCollectionEditor : CollectionEditor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement.Design

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandCollectionEditor Members | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor Members

CommandCollectionEditor overview

Public Instance Constructors

CommandCollectionEditor Constructor Initializes a new instance of the CommandCollectionEditor class.

Public Instance Methods

EditValue (inherited from CollectionEditor) | Overloaded. Edits the value of the specified object using the specified service provider and context.
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from CollectionEditor) | Overloaded. Gets the edit style used by the EditValue method.
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

CollectionItemType (inherited from CollectionEditor) | Gets the data type of each item in the collection.
CollectionType (inherited from CollectionEditor) | Gets the data type of the collection object.
Context (inherited from CollectionEditor) | Gets a type descriptor that indicates the current context.
HelpTopic (inherited from CollectionEditor) | Gets the Help keyword to display the Help topic or topic list for when the editor's dialog Help button or the F1 key is pressed.
NewItemTypes (inherited from CollectionEditor) | Gets the available types of items that can be created for this collection.

Protected Instance Methods

CanRemoveInstance (inherited from CollectionEditor) | Indicates whether original members of the collection can be removed.
CanSelectMultipleInstances (inherited from CollectionEditor) | Indicates whether multiple collection items can be selected at once.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to display and edit the current collection.
CreateCollectionItemType |
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the specified collection item type.
CreateNewItemTypes |
DestroyInstance (inherited from CollectionEditor) | Destroys the specified instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetItems (inherited from CollectionEditor) | Gets an array of objects containing the specified collection.
GetService (inherited from CollectionEditor) | Gets the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems |
ShowHelp (inherited from CollectionEditor) | Displays the default Help topic for the collection editor.

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor Constructor

Initializes a new instance of the CommandCollectionEditor class.

[Visual Basic]
Public Sub New()
[C#]
public CommandCollectionEditor();

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor Methods

The methods of the CommandCollectionEditor class are listed below. For a complete list of CommandCollectionEditor class members, see the CommandCollectionEditor Members topic.

Public Instance Methods

EditValue (inherited from CollectionEditor) | Overloaded. Edits the value of the specified object using the specified service provider and context.
EditValue (inherited from UITypeEditor) | Overloaded. Edits the value of the specified object using the editor style indicated by GetEditStyle.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEditStyle (inherited from CollectionEditor) | Overloaded. Gets the edit style used by the EditValue method.
GetEditStyle (inherited from UITypeEditor) | Overloaded. Gets the editor style used by the EditValue method.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPaintValueSupported (inherited from UITypeEditor) | Overloaded. Indicates whether the specified context supports painting a representation of an object's value within the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintValue (inherited from UITypeEditor) | Overloaded. Paints a representation of the value of an object using the specified PaintValueEventArgs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CanRemoveInstance (inherited from CollectionEditor) | Indicates whether original members of the collection can be removed.
CanSelectMultipleInstances (inherited from CollectionEditor) | Indicates whether multiple collection items can be selected at once.
CreateCollectionForm (inherited from CollectionEditor) | Creates a new form to display and edit the current collection.
CreateCollectionItemType |
CreateInstance (inherited from CollectionEditor) | Creates a new instance of the specified collection item type.
CreateNewItemTypes |
DestroyInstance (inherited from CollectionEditor) | Destroys the specified instance of the object.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetItems (inherited from CollectionEditor) | Gets an array of objects containing the specified collection.
GetService (inherited from CollectionEditor) | Gets the requested service, if it is available.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetItems |
ShowHelp (inherited from CollectionEditor) | Displays the default Help topic for the collection editor.

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor.CreateCollectionItemType Method

[Visual Basic]
Overrides Protected Function CreateCollectionItemType() As Type
[C#]
protected override Type CreateCollectionItemType();

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor.CreateNewItemTypes Method

[Visual Basic]
Overrides Protected Function CreateNewItemTypes() As Type()
[C#]
protected override Type[] CreateNewItemTypes();

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandCollectionEditor.SetItems Method

[Visual Basic]
Overrides Protected Function SetItems( _
ByVal editValue As Object, _
ByVal value As Object() _
) As Object
[C#]
protected override object SetItems(
object editValue,
object[] value
);

See Also

CommandCollectionEditor Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandDesigner Class

For a list of all members of this type, see CommandDesigner Members.

System.Object
System.ComponentModel.Design.ComponentDesigner
LaMarvin.Windows.Forms.CommandManagement.Design.CommandDesigner

[Visual Basic]
Public Class CommandDesigner
Inherits ComponentDesigner
[C#]
public class CommandDesigner : ComponentDesigner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement.Design

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandDesigner Members | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandDesigner Members

CommandDesigner overview

Public Instance Constructors

CommandDesigner Constructor Initializes a new instance of the CommandDesigner class.

Public Instance Properties

AssociatedComponents (inherited from ComponentDesigner) | Gets the collection of components associated with the component managed by the designer.
Component (inherited from ComponentDesigner) | Gets the component this designer is designing.
Verbs (inherited from ComponentDesigner) | Gets the design-time verbs supported by the component that is associated with the designer.

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults (inherited from ComponentDesigner) | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InheritanceAttribute (inherited from ComponentDesigner) | Gets an attribute that indicates the type of inheritance of the associated component.
Inherited (inherited from ComponentDesigner) | Gets a value indicating whether this component is inherited.
ShadowProperties (inherited from ComponentDesigner) | Gets a collection of property values that override user settings.

Protected Instance Methods

Dispose | Overloaded.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false)before the object is reclaimed by garbage collection.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the designer's component's design mode site.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor .
PreFilterProperties (inherited from ComponentDesigner) | Allows a designer to add to the set of properties that it exposes through a TypeDescriptor .
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandDesigner Constructor

Initializes a new instance of the CommandDesigner class.

[Visual Basic]
Public Sub New()
[C#]
public CommandDesigner();

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandDesigner Methods

The methods of the CommandDesigner class are listed below. For a complete list of CommandDesigner class members, see the CommandDesigner Members topic.

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults (inherited from ComponentDesigner) | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false)before the object is reclaimed by garbage collection.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the designer's component's design mode site.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor .
PreFilterProperties (inherited from ComponentDesigner) | Allows a designer to add to the set of properties that it exposes through a TypeDescriptor .
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

CommandDesigner.Dispose Method

[This is preliminary documentation and subject to change.]

Overload List

Inherited from ComponentDesigner.

public void Dispose();

protected override void Dispose(bool);

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandDesigner.Dispose Method (Boolean)

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace | CommandDesigner.Dispose Overload List


CommandDesigner.Initialize Method

[Visual Basic]
Overrides Public Sub Initialize( _
ByVal component As IComponent _
) _
Implements IDesigner.Initialize
[C#]
public override void Initialize(
IComponent component
);

Implements

IDesigner.Initialize

See Also

CommandDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner Class

For a list of all members of this type, see CommandManagerDesigner Members.

System.Object
System.ComponentModel.Design.ComponentDesigner
LaMarvin.Windows.Forms.CommandManagement.Design.CommandManagerDesigner

[Visual Basic]
Public Class CommandManagerDesigner
Inherits ComponentDesigner
[C#]
public class CommandManagerDesigner : ComponentDesigner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.CommandManagement.Design

Assembly: LaMarvin.Windows.Forms.CommandManagement (in LaMarvin.Windows.Forms.CommandManagement.dll)

See Also

CommandManagerDesigner Members | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner Members

CommandManagerDesigner overview

Public Instance Constructors

CommandManagerDesigner Constructor Initializes a new instance of the CommandManagerDesigner class.

Public Instance Properties

AssociatedComponents (inherited from ComponentDesigner) | Gets the collection of components associated with the component managed by the designer.
Component (inherited from ComponentDesigner) | Gets the component this designer is designing.
Verbs |

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults (inherited from ComponentDesigner) | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

InheritanceAttribute (inherited from ComponentDesigner) | Gets an attribute that indicates the type of inheritance of the associated component.
Inherited (inherited from ComponentDesigner) | Gets a value indicating whether this component is inherited.
ShadowProperties (inherited from ComponentDesigner) | Gets a collection of property values that override user settings.

Protected Instance Methods

Dispose | Overloaded.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false)before the object is reclaimed by garbage collection.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the designer's component's design mode site.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor .
PreFilterProperties (inherited from ComponentDesigner) | Allows a designer to add to the set of properties that it exposes through a TypeDescriptor .
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner Constructor

Initializes a new instance of the CommandManagerDesigner class.

[Visual Basic]
Public Sub New()
[C#]
public CommandManagerDesigner();

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner Properties

The properties of the CommandManagerDesigner class are listed below. For a complete list of CommandManagerDesigner class members, see the CommandManagerDesigner Members topic.

Public Instance Properties

AssociatedComponents (inherited from ComponentDesigner) | Gets the collection of components associated with the component managed by the designer.
Component (inherited from ComponentDesigner) | Gets the component this designer is designing.
Verbs |

Protected Instance Properties

InheritanceAttribute (inherited from ComponentDesigner) | Gets an attribute that indicates the type of inheritance of the associated component.
Inherited (inherited from ComponentDesigner) | Gets a value indicating whether this component is inherited.
ShadowProperties (inherited from ComponentDesigner) | Gets a collection of property values that override user settings.

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner.Verbs Property

[Visual Basic]
Overrides Public ReadOnly Property Verbs As DesignerVerbCollection _
Implements IDesigner.Verbs
[C#]
public override System.ComponentModel.Design.DesignerVerbCollection Verbs {get;}

Implements

IDesigner.Verbs

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner Methods

The methods of the CommandManagerDesigner class are listed below. For a complete list of CommandManagerDesigner class members, see the CommandManagerDesigner Members topic.

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Overloaded. Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults (inherited from ComponentDesigner) | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded.
Finalize (inherited from ComponentDesigner) | Attempts to free resources by calling Dispose(false)before the object is reclaimed by garbage collection.
GetService (inherited from ComponentDesigner) | Attempts to retrieve the specified type of service from the designer's component's design mode site.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Gets the InheritanceAttribute of the specified ComponentDesigner.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PostFilterAttributes (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of attributes that it exposes through a TypeDescriptor.
PostFilterEvents (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of events that it exposes through a TypeDescriptor.
PostFilterProperties (inherited from ComponentDesigner) | Allows a designer to change or remove items from the set of properties that it exposes through a TypeDescriptor.
PreFilterAttributes (inherited from ComponentDesigner) | Allows a designer to add to the set of attributes that it exposes through a TypeDescriptor.
PreFilterEvents (inherited from ComponentDesigner) | Allows a designer to add to the set of events that it exposes through a TypeDescriptor .
PreFilterProperties (inherited from ComponentDesigner) | Allows a designer to add to the set of properties that it exposes through a TypeDescriptor .
RaiseComponentChanged (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component has been changed.
RaiseComponentChanging (inherited from ComponentDesigner) | Notifies the IComponentChangeService that this component is about to be changed.

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


Dispose Method

Constable Authorization Engine 2.0 BETA

CommandManagerDesigner.Dispose Method

[This is preliminary documentation and subject to change.]

Overload List

Inherited from ComponentDesigner.

public void Dispose();

protected override void Dispose(bool);

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


CommandManagerDesigner.Dispose Method (Boolean)

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace | CommandManagerDesigner.Dispose Overload List


CommandManagerDesigner.Initialize Method

[Visual Basic]
Overrides Public Sub Initialize( _
ByVal component As IComponent _
) _
Implements IDesigner.Initialize
[C#]
public override void Initialize(
IComponent component
);

Implements

IDesigner.Initialize

See Also

CommandManagerDesigner Class | LaMarvin.Windows.Forms.CommandManagement.Design Namespace


LaMarvin.Windows.Forms.Design

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.Design Namespace

Namespace hierarchy

Classes

Class | Description
ControlLayoutRestorerDesigner | This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.


ControlLayoutRestorerDesigner Class

This class supports the LaMarvin Design Framework infrastructure and is not intended to be used directly from your code.

For a list of all members of this type, see ControlLayoutRestorerDesigner Members.

System.Object
System.ComponentModel.Design.ComponentDesigner
LaMarvin.Windows.Forms.Design.ControlLayoutRestorerDesigner

[Visual Basic]
NotInheritable Public Class ControlLayoutRestorerDesigner
Inherits ComponentDesigner
[C#]
public sealed class ControlLayoutRestorerDesigner : ComponentDesigner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: LaMarvin.Windows.Forms.Design

Assembly: LaMarvin.Design (in LaMarvin.Design.dll)

See Also

ControlLayoutRestorerDesigner Members | LaMarvin.Windows.Forms.Design Namespace


ControlLayoutRestorerDesigner Members

ControlLayoutRestorerDesigner overview

Public Instance Constructors

ControlLayoutRestorerDesigner Constructor Initializes a new instance of the ControlLayoutRestorerDesigner class.

Public Instance Properties

AssociatedComponents (inherited from ComponentDesigner) | Gets the collection of components associated with the component managed by the designer.
Component (inherited from ComponentDesigner) | Gets the component this designer is designing.
Verbs (inherited from ComponentDesigner) | Gets the design-time verbs supported by the component that is associated with the designer.

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from ComponentDesigner) | Prepares the designer to view, edit, and design the specified component.
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ControlLayoutRestorerDesigner Class | LaMarvin.Windows.Forms.Design Namespace


ControlLayoutRestorerDesigner Constructor

Initializes a new instance of the ControlLayoutRestorerDesigner class.

[Visual Basic]
Public Sub New()
[C#]
public ControlLayoutRestorerDesigner();

See Also

ControlLayoutRestorerDesigner Class | LaMarvin.Windows.Forms.Design Namespace


ControlLayoutRestorerDesigner Methods

The methods of the ControlLayoutRestorerDesigner class are listed below. For a complete list of ControlLayoutRestorerDesigner class members, see the ControlLayoutRestorerDesigner Members topic.

Public Instance Methods

Dispose (inherited from ComponentDesigner) | Releases all resources used by the ComponentDesigner .
DoDefaultAction (inherited from ComponentDesigner) | Creates a method signature in the source code file for the default event on the component and navigates the user's cursor to that location.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from ComponentDesigner) | Prepares the designer to view, edit, and design the specified component.
InitializeNonDefault (inherited from ComponentDesigner) | Initializes the settings for an imported component that is already initialized to settings other than the defaults.
OnSetComponentDefaults | Sets the default properties for the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ControlLayoutRestorerDesigner Class | LaMarvin.Windows.Forms.Design Namespace


ControlLayoutRestorerDesigner.OnSetComponentDefaults Method

Sets the default properties for the component.

[Visual Basic]
Overrides Public Sub OnSetComponentDefaults()
[C#]
public override void OnSetComponentDefaults();

See Also

ControlLayoutRestorerDesigner Class | LaMarvin.Windows.Forms.Design Namespace


LaMarvin.ComponentModelHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.ComponentModel Hierarchy

System.Object
LaMarvin.ComponentModel.CollectionUpdaterBase ---- LaMarvin.ComponentModel.ICollectionUpdater, LaMarvin.ComponentModel.IChangeableCollection
LaMarvin.ComponentModel.ChangeUndoManager ---- LaMarvin.ComponentModel.IUndoItem
LaMarvin.ComponentModel.CollectionChangeUndoManager
LaMarvin.ComponentModel.PropertyChangeUndoManager
LaMarvin.ComponentModel.ICollectionUpdater ---- LaMarvin.ComponentModel.IChangeableCollection
LaMarvin.ComponentModel.IChangeableCollection
LaMarvin.ComponentModel.IChangeEventObserver
LaMarvin.ComponentModel.IChangeEventPropagator
LaMarvin.ComponentModel.IChangeEventSource
LaMarvin.ComponentModel.IUndoItem
LaMarvin.ComponentModel.UndoEngine
LaMarvin.ComponentModel.UndoEngine.UndoGroup ---- System.IDisposable
LaMarvin.ComponentModel.UndoItemCollection ---- LaMarvin.ComponentModel.IUndoItem, System.Collections.IEnumerable
System.Attribute
LaMarvin.ComponentModel.ExpandablePropertyAttribute
LaMarvin.ComponentModel.OrdinalAttribute
LaMarvin.ComponentModel.TypeInfoAttribute
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
LaMarvin.ComponentModel.ChangeableCollectionBase ---- LaMarvin.ComponentModel.IChangeableCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
LaMarvin.ComponentModel.ChangeEventHandler
System.EventArgs
LaMarvin.ComponentModel.ChangeEventArgs
LaMarvin.ComponentModel.CollectionChangeEventArgs
LaMarvin.ComponentModel.PropertyChangeEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
LaMarvin.ComponentModel.UndoException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
LaMarvin.ComponentModel.CollectionChangeType

See Also

LaMarvin.ComponentModel Namespace


LaMarvin.Constable.Design.ClipboardHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Clipboard Hierarchy

System.Object
LaMarvin.Design.Clipboard.ClipboardHandler ---- LaMarvin.Design.Clipboard.IClipboardHandler
LaMarvin.Constable.Design.Clipboard.NamedObjectClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyClipboardHandler
LaMarvin.Constable.Design.Clipboard.RoleClipboardHandler
LaMarvin.Constable.Design.Clipboard.StateClipboardHandler
LaMarvin.Constable.Design.Clipboard.PolicyClipboardHandler
LaMarvin.Constable.Design.Clipboard.RuleBaseClipboardHandler
LaMarvin.Constable.Design.Clipboard.ActionRuleClipboardHandler
LaMarvin.Constable.Design.Clipboard.PropertyRuleRuleClipboardHandler

See Also

LaMarvin.Constable.Design.Clipboard Namespace


LaMarvin.Constable.Design.CloningHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Cloning Hierarchy

System.Object
LaMarvin.Constable.Design.Cloning.CloningNamedObjectHandler
LaMarvin.Constable.Design.Cloning.CloningActionHandler
LaMarvin.Constable.Design.Cloning.CloningPropertyHandler
LaMarvin.Constable.Design.Cloning.CloningRoleHandler
LaMarvin.Constable.Design.Cloning.CloningStateHandler

See Also

LaMarvin.Constable.Design.Cloning Namespace


LaMarvin.Constable.Design.ControlsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Controls Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
LaMarvin.Constable.Design.Controls.DefaultPolicySimulationViewControl ---- LaMarvin.Constable.Design.IPolicySimulationView
System.Windows.Forms.UserControl
LaMarvin.Constable.Design.Controls.PolicyDesignModelContextControl ---- LaMarvin.Constable.Design.IPolicyDesignContextControl, System.ComponentModel.ISupportInitialize
LaMarvin.Constable.Design.Controls.PolicyDesignSimulationContextControl ---- LaMarvin.Constable.Design.IPolicyDesignContextControl, System.ComponentModel.ISupportInitialize
LaMarvin.Constable.Design.Controls.PolicySimulationViewFormControl ---- LaMarvin.Constable.Design.IPolicySimulationView, System.ComponentModel.ISupportInitialize
LaMarvin.Constable.Design.Controls.RolesSelectorControl

See Also

LaMarvin.Constable.Design.Controls Namespace


LaMarvin.Constable.Design.ConvertersHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Converters Hierarchy

System.Object
System.ComponentModel.TypeConverter
LaMarvin.Constable.Design.Converters.CurrentStatePropertyConverter
LaMarvin.Constable.Design.Converters.RolesPropertyConverter
LaMarvin.Constable.Design.Converters.RuleBasePropertyConverter
LaMarvin.Constable.Design.Converters.ActionPropertyConverter
LaMarvin.Constable.Design.Converters.PropertyPropertyConverter
LaMarvin.Constable.Design.Converters.RolePropertyConverter
LaMarvin.Constable.Design.Converters.StatePropertyConverter
LaMarvin.Constable.Design.Converters.TargetStatePropertyConverter

See Also

LaMarvin.Constable.Design.Converters Namespace


LaMarvin.Constable.Design.EditorsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Editors Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
LaMarvin.Constable.Design.Editors.CurrentStatePropertyEditor
LaMarvin.Constable.Design.Editors.RolesPropertyEditor
LaMarvin.Constable.Design.Editors.RuleBasePropertyEditor
LaMarvin.Constable.Design.Editors.ActionPropertyEditor
LaMarvin.Constable.Design.Editors.PropertyPropertyEditor
LaMarvin.Constable.Design.Editors.RolePropertyEditor
LaMarvin.Constable.Design.Editors.StatePropertyEditor
LaMarvin.Constable.Design.Editors.TargetStatePropertyEditor

See Also

LaMarvin.Constable.Design.Editors Namespace


LaMarvin.Constable.Design.FallbackHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Fallback Hierarchy

System.Object
LaMarvin.Constable.Design.Fallback.FallbackTypeDescriptor ---- System.ComponentModel.ICustomTypeDescriptor
LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner
LaMarvin.Constable.Model.ObjectBase ---- LaMarvin.ComponentModel.IChangeEventPropagator
LaMarvin.Constable.Model.NamedObjectBase ---- System.IComparable
LaMarvin.Constable.AuthorizationPolicy ---- LaMarvin.ComponentModel.IChangeEventSource
LaMarvin.Constable.Design.Fallback.FallbackPolicy ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.Action
LaMarvin.Constable.Design.Fallback.FallbackAction ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.Property
LaMarvin.Constable.Design.Fallback.FallbackProperty ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Design.Fallback.FallbackRole ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.State
LaMarvin.Constable.Design.Fallback.FallbackState ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.ActionRule
LaMarvin.Constable.Design.Fallback.FallbackActionRule ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
LaMarvin.Constable.Model.PropertyRule
LaMarvin.Constable.Design.Fallback.FallbackPropertyRule ---- LaMarvin.Constable.Design.Fallback.IFallbackPropertyOwner, System.ComponentModel.ICustomTypeDescriptor, System.ComponentModel.ISupportInitialize, System.Runtime.Serialization.IDeserializationCallback
System.ComponentModel.MemberDescriptor
System.ComponentModel.PropertyDescriptor
LaMarvin.Constable.Design.Fallback.FallbackPropertyDescriptor

See Also

LaMarvin.Constable.Design.Fallback Namespace


LaMarvin.Constable.Design.FormsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Forms Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.Form
LaMarvin.Constable.Design.Forms.AssemblyFileSelectorForm
LaMarvin.Constable.Design.Forms.ClonePolicyObjectForm
LaMarvin.Constable.Design.Forms.ExceptionDetailsForm
LaMarvin.Constable.Design.Forms.PasteRuleForm
LaMarvin.Constable.Design.Forms.PolicyDesignForm ---- LaMarvin.Constable.Design.IPolicyDesignHost
LaMarvin.Constable.Design.Forms.PolicyStatisticsForm ---- LaMarvin.Constable.Design.IPolicyDesignExtension
LaMarvin.Constable.Design.Forms.ShowExceptionForm
LaMarvin.Constable.Design.Forms.TypeInfoSelectorForm

See Also

LaMarvin.Constable.Design.Forms Namespace


LaMarvin.Constable.Design.PersistenceHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Persistence Hierarchy

System.Object
LaMarvin.Constable.Design.Persistence.PolicyDocument
LaMarvin.Constable.Design.Persistence.PolicyLoader ---- LaMarvin.Constable.Design.IPolicyLoaderTypeResolver
LaMarvin.Constable.Design.Persistence.RecentPolicyDocumentEntry
LaMarvin.Constable.Design.Persistence.RecentPolicyDocumentList
LaMarvin.Design.Persistence.PersistentStore
LaMarvin.Constable.Design.Persistence.FilePolicyStore

See Also

LaMarvin.Constable.Design.Persistence Namespace


LaMarvin.Constable.Design.ShellHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Shell Hierarchy

System.Object
LaMarvin.Constable.Design.Shell.EntryPoint
System.MarshalByRefObject
LaMarvin.Constable.Design.Shell.InstanceConnector

See Also

LaMarvin.Constable.Design.Shell Namespace


CollectionBaseTypeInfo Hierarchy

System.Object
TypeInfo
CollectionBaseTypeInfo
ActionCollectionTypeInfo
ActionRuleCollectionTypeInfo
PropertyCollectionTypeInfo
PropertyRuleCollectionTypeInfo
RoleCollectionTypeInfo
StateCollectionTypeInfo

See Also

CollectionBaseTypeInfo Class | CollectionBaseTypeInfo Members | LaMarvin.Constable.Design.TypeInfos Namespace


LaMarvin.Constable.Design.TypeInfosHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.TypeInfos Hierarchy

System.Object
LaMarvin.Design.TypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionRuleTypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionTypeInfo
LaMarvin.Constable.Design.TypeInfos.AppDomainTypeInfo
LaMarvin.Constable.Design.TypeInfos.AssemblyTypeInfo
LaMarvin.Constable.Design.TypeInfos.CollectionBaseTypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.ActionRuleCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyRuleCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.RoleCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.StateCollectionTypeInfo
LaMarvin.Constable.Design.TypeInfos.ExceptionTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackActionRuleTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackActionTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPolicyTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPropertyRuleTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackPropertyTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackRoleTypeInfo
LaMarvin.Constable.Design.TypeInfos.FallbackStateTypeInfo
LaMarvin.Constable.Design.TypeInfos.PolicySimulationViewAdapterTypeInfo
LaMarvin.Constable.Design.TypeInfos.PolicyTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyRuleTypeInfo
LaMarvin.Constable.Design.TypeInfos.PropertyTypeInfo
LaMarvin.Constable.Design.TypeInfos.RoleTypeInfo
LaMarvin.Constable.Design.TypeInfos.StateTypeInfo

See Also

LaMarvin.Constable.Design.TypeInfos Namespace


PolicyViewAdapter Hierarchy

System.Object
PolicyViewAdapter
DefaultPolicyViewAdapter
GroupByActionPolicyViewAdapter
GroupByRolePolicyViewAdapter
GroupByRoleThenStatePolicyViewAdapter
GroupByStatePolicyViewAdapter
PolicySimulationViewAdapter

See Also

PolicyViewAdapter Class | PolicyViewAdapter Members | LaMarvin.Constable.Design.Views Namespace


LaMarvin.Constable.Design.ViewsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design.Views Hierarchy

System.Object
LaMarvin.Constable.Design.Views.PolicyViewAdapter ---- LaMarvin.ComponentModel.IChangeEventObserver, LaMarvin.ComponentModel.IChangeEventSource
LaMarvin.Constable.Design.Views.DefaultPolicyViewAdapter
LaMarvin.Constable.Design.Views.GroupByActionPolicyViewAdapter ---- System.Collections.IEnumerable
LaMarvin.Constable.Design.Views.GroupByRolePolicyViewAdapter ---- System.Collections.IEnumerable
LaMarvin.Constable.Design.Views.GroupByRoleThenStatePolicyViewAdapter ---- System.Collections.IEnumerable
LaMarvin.Constable.Design.Views.GroupByStatePolicyViewAdapter ---- System.Collections.IEnumerable
LaMarvin.Constable.Design.Views.PolicySimulationViewAdapter ---- System.Collections.IEnumerable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
LaMarvin.Constable.Design.Views.AuthorizationRuleType

See Also

LaMarvin.Constable.Design.Views Namespace


LaMarvin.Constable.DesignHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Design Hierarchy

System.Object
LaMarvin.Constable.Design.AuthorizationContextPropertyGridAdapter
LaMarvin.Constable.Design.DesignHelper
LaMarvin.Constable.Design.IPolicyDesignContextControl
LaMarvin.Constable.Design.IPolicyDesignExtension
LaMarvin.Constable.Design.IPolicyDesignHost
LaMarvin.Constable.Design.IPolicyLoaderContext
LaMarvin.Constable.Design.IPolicyLoaderTypeResolver
LaMarvin.Constable.Design.IPolicySimulationView
System.Attribute
LaMarvin.Constable.Design.PolicyDesignContextControlAttribute
LaMarvin.Constable.Design.SerializablePropertyAttribute
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
LaMarvin.Constable.Design.PolicyDesignHostMenuItem
System.Windows.Forms.ApplicationContext
LaMarvin.Constable.Design.PolicyDesignApplicationContext

See Also

LaMarvin.Constable.Design Namespace


LaMarvin.Constable.ModelHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Model Hierarchy

System.Object
LaMarvin.Constable.Model.ObjectBase ---- LaMarvin.ComponentModel.IChangeEventPropagator
LaMarvin.Constable.Model.NamedObjectBase ---- System.IComparable
LaMarvin.Constable.Model.Action
LaMarvin.Constable.Model.Property
LaMarvin.Constable.Model.Role
LaMarvin.Constable.Model.ComPlusRole
LaMarvin.Constable.Model.DynamicRole
LaMarvin.Constable.Model.WindowsRole
LaMarvin.Constable.Model.State
LaMarvin.Constable.Model.RuleBase
LaMarvin.Constable.Model.ActionRule
LaMarvin.Constable.Model.PropertyRule
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
LaMarvin.ComponentModel.ChangeableCollectionBase ---- LaMarvin.ComponentModel.IChangeableCollection
LaMarvin.Constable.Model.ObjectCollectionBase ---- LaMarvin.ComponentModel.IChangeEventPropagator
LaMarvin.Constable.Model.NamedObjectCollectionBase
LaMarvin.Constable.Model.ActionCollection
LaMarvin.Constable.Model.PropertyCollection
LaMarvin.Constable.Model.RoleCollection
LaMarvin.Constable.Model.StateCollection
LaMarvin.Constable.Model.RuleCollectionBase
LaMarvin.Constable.Model.ActionRuleCollection
LaMarvin.Constable.Model.PropertyRuleCollection

See Also

LaMarvin.Constable.Model Namespace


LaMarvin.Constable.PrincipalHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable.Principal Hierarchy

System.Object
LaMarvin.Constable.Principal.DynamicPrincipal ---- System.Security.Principal.IPrincipal
LaMarvin.Constable.Principal.ExtendedPrincipal ---- System.Security.Principal.IPrincipal

See Also

LaMarvin.Constable.Principal Namespace


LaMarvin.ConstableHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Constable Hierarchy

System.Object
LaMarvin.Constable.AuthorizationPolicyLoader
LaMarvin.Constable.AuthorizationPolicyLoader.XmlElementNames
LaMarvin.Constable.Model.ObjectBase ---- LaMarvin.ComponentModel.IChangeEventPropagator
LaMarvin.Constable.Model.NamedObjectBase ---- System.IComparable
LaMarvin.Constable.AuthorizationPolicy ---- LaMarvin.ComponentModel.IChangeEventSource
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
LaMarvin.Constable.ActionExecutionEventHandler
LaMarvin.Constable.ResolveRoleMembershipEventHandler
System.EventArgs
LaMarvin.Constable.ActionExecutionEventArgs
LaMarvin.Constable.ResolveRoleMembershipEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
LaMarvin.Constable.ConstableException
LaMarvin.Constable.DuplicateAuthorizationRuleException
LaMarvin.Constable.NonDeterministicModelException
LaMarvin.Constable.PermissionDeniedException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
LaMarvin.Constable.EnabledOption
LaMarvin.Constable.VisibleOption

See Also

LaMarvin.Constable Namespace


LaMarvin.DataHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Data Hierarchy

System.Object
LaMarvin.Data.DataHelper
System.MarshalByRefObject
LaMarvin.Data.DataBase ---- System.IDisposable

See Also

LaMarvin.Data Namespace


LaMarvin.Design.ClipboardHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Clipboard Hierarchy

System.Object
LaMarvin.Design.Clipboard.AppClipboard
LaMarvin.Design.Clipboard.ClipboardHandler ---- LaMarvin.Design.Clipboard.IClipboardHandler
LaMarvin.Design.Clipboard.IClipboardHandler

See Also

LaMarvin.Design.Clipboard Namespace


LaMarvin.Design.ControlsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Controls Hierarchy

System.Object
LaMarvin.Design.Controls.InstanceView.InstanceEntry
LaMarvin.Design.Controls.InstanceView.PropertyEntry
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IWin32Window
LaMarvin.Design.Controls.DesignerVerbsView
System.Windows.Forms.Label
System.Windows.Forms.LinkLabel ---- System.Windows.Forms.IButtonControl
LaMarvin.Design.Controls.AutoLinkLabel
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
LaMarvin.Design.Controls.KeyboardDrivenListBox
System.Windows.Forms.CheckedListBox
LaMarvin.Design.Controls.KeyboardDrivenCheckedListBox
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
LaMarvin.Design.Controls.DropDownPicker
LaMarvin.Design.Controls.InstanceView
System.Windows.Forms.TreeView
LaMarvin.Design.Controls.KeyboardDrivenTreeView

See Also

LaMarvin.Design.Controls Namespace


LaMarvin.Design.PersistenceHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Design.Persistence Hierarchy

System.Object
LaMarvin.Design.Persistence.PersistentMoniker
LaMarvin.Design.Persistence.FileMoniker
LaMarvin.Design.Persistence.PersistentStore

See Also

LaMarvin.Design.Persistence Namespace


TypeInfo Hierarchy

System.Object
TypeInfo
ActionRuleTypeInfo
ActionTypeInfo
AppDomainTypeInfo
AssemblyTypeInfo
CollectionBaseTypeInfo
ExceptionTypeInfo
FallbackActionRuleTypeInfo
FallbackActionTypeInfo
FallbackPolicyTypeInfo
FallbackPropertyRuleTypeInfo
FallbackPropertyTypeInfo
FallbackRoleTypeInfo
FallbackStateTypeInfo
PolicySimulationViewAdapterTypeInfo
PolicyTypeInfo
PropertyRuleTypeInfo
PropertyTypeInfo
RoleTypeInfo
StateTypeInfo

See Also

TypeInfo Class | TypeInfo Members | LaMarvin.Design Namespace


LaMarvin.DesignHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Design Hierarchy

System.Object
LaMarvin.Design.Context
LaMarvin.Design.Context.Registry
LaMarvin.Design.ICustomInstanceEntryDisplay
LaMarvin.Design.IDesignApplicationHost
LaMarvin.Design.TypeInfo
LaMarvin.Design.VisualInfo
System.ComponentModel.Design.MenuCommand
System.ComponentModel.Design.DesignerVerb
LaMarvin.Design.InstanceDesignerVerb
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
LaMarvin.Design.Context.AssemblyFilterDelegate
LaMarvin.Design.Context.TypeFilterDelegate
System.Exception ---- System.Runtime.Serialization.ISerializable
LaMarvin.Design.UserCancelledException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
LaMarvin.Design.InstanceEntryDisplayProperties

See Also

LaMarvin.Design Namespace


LaMarvin.RemotingHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Remoting Hierarchy

System.Object
LaMarvin.Remoting.IRemoteServer
LaMarvin.Remoting.ServerProxy ---- LaMarvin.Remoting.IRemoteServer
System.MarshalByRefObject
LaMarvin.Remoting.ServerBase ---- LaMarvin.Remoting.IRemoteServer
LaMarvin.Remoting.DataServerBase

See Also

LaMarvin.Remoting Namespace


LaMarvin.Windows.Forms.CommandManagement.DesignHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.CommandManagement.Design Hierarchy

System.Object
System.ComponentModel.Design.ComponentDesigner ---- System.ComponentModel.Design.IDesigner, System.ComponentModel.Design.IDesignerFilter, System.IDisposable
LaMarvin.Windows.Forms.CommandManagement.Design.CommandDesigner
LaMarvin.Windows.Forms.CommandManagement.Design.CommandManagerDesigner
System.Drawing.Design.UITypeEditor
System.ComponentModel.Design.CollectionEditor
LaMarvin.Windows.Forms.CommandManagement.Design.CommandCollectionEditor

See Also

LaMarvin.Windows.Forms.CommandManagement.Design Namespace


LaMarvin.Windows.Forms.CommandManagementHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.CommandManagement Hierarchy

System.Object
LaMarvin.Windows.Forms.CommandManagement.ButtonAdapter ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapter, System.IDisposable
LaMarvin.Windows.Forms.CommandManagement.ButtonAdapter.Factory ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapterFactory
LaMarvin.Windows.Forms.CommandManagement.IExecuteExceptionHandler
LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapter
LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapterFactory
LaMarvin.Windows.Forms.CommandManagement.MenuItemAdapter ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapter, System.IDisposable
LaMarvin.Windows.Forms.CommandManagement.MenuItemAdapter.Factory ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapterFactory
LaMarvin.Windows.Forms.CommandManagement.ToolbarButtonAdapter ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapter, System.ComponentModel.ISupportInitialize, System.IDisposable
LaMarvin.Windows.Forms.CommandManagement.ToolbarButtonAdapter.Factory ---- LaMarvin.Windows.Forms.CommandManagement.IUIElementAdapterFactory
LaMarvin.Windows.Forms.CommandManagement.UIAdapterServices
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
LaMarvin.Windows.Forms.CommandManagement.CommandCollection ---- LaMarvin.Windows.Forms.CommandManagement.IExecuteExceptionHandler
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
LaMarvin.Windows.Forms.CommandManagement.CommandEventHandler
LaMarvin.Windows.Forms.CommandManagement.ExecuteExceptionEventHandler
System.EventArgs
LaMarvin.Windows.Forms.CommandManagement.CommandEventArgs
LaMarvin.Windows.Forms.CommandManagement.ExecuteExceptionEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
LaMarvin.Windows.Forms.CommandManagement.Command
LaMarvin.Windows.Forms.CommandManagement.CommandManager ---- LaMarvin.Windows.Forms.CommandManagement.IExecuteExceptionHandler, System.ComponentModel.IExtenderProvider, System.ComponentModel.ISupportInitialize

See Also

LaMarvin.Windows.Forms.CommandManagement Namespace


LaMarvin.Windows.Forms.DesignHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms.Design Hierarchy

System.Object
System.ComponentModel.Design.ComponentDesigner ---- System.ComponentModel.Design.IDesigner, System.ComponentModel.Design.IDesignerFilter, System.IDisposable
LaMarvin.Windows.Forms.Design.ControlLayoutRestorerDesigner

See Also

LaMarvin.Windows.Forms.Design Namespace


LaMarvin.Windows.FormsHierarchy

Constable Authorization Engine 2.0 BETA

LaMarvin.Windows.Forms Hierarchy

System.Object
LaMarvin.Windows.Forms.DelayedEventDispatcher
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
LaMarvin.Windows.Forms.ControlLayoutRestorer ---- System.ComponentModel.IExtenderProvider, System.ComponentModel.ISupportInitialize

See Also

LaMarvin.Windows.Forms Namespace